]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- hardcode openssl path (make which dependency optional)
[packages/openssl.git] / openssl.spec
1 #
2 # TODO: consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform "make tests"
6 %bcond_with     purify  # Compile openssl with \-DPURIFY, useful when one wants to
7                         # use valgrind debugger against openssl-linked programs
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
11 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
12 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
13 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
14 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
15 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
16 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
17 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
18 Name:           openssl
19 Version:        1.0.0a
20 Release:        1
21 License:        Apache-like
22 Group:          Libraries
23 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
24 # Source0-md5:  e3873edfffc783624cfbdb65e2249cbd
25 Source2:        %{name}.1.pl
26 Source3:        %{name}-ssl-certificate.sh
27 Source4:        %{name}-c_rehash.sh
28 Patch0:         %{name}-alpha-ccc.patch
29 Patch1:         %{name}-optflags.patch
30 Patch2:         %{name}-globalCA.diff
31 Patch3:         %{name}-include.patch
32 Patch4:         %{name}-man-namespace.patch
33 Patch5:         %{name}-asflag.patch
34 Patch6:         %{name}-ca-certificates.patch
35 Patch7:         %{name}-ldflags.patch
36 URL:            http://www.openssl.org/
37 BuildRequires:  bc
38 BuildRequires:  perl-devel >= 1:5.6.1
39 BuildRequires:  rpm-perlprov >= 4.1-13
40 BuildRequires:  rpmbuild(macros) >= 1.213
41 BuildRequires:  sed >= 4.0
42 Requires:       ca-certificates >= 20080809-4
43 Requires:       rpm-whiteout >= 1.7
44 Obsoletes:      SSLeay
45 Obsoletes:      SSLeay-devel
46 Obsoletes:      SSLeay-perl
47 Obsoletes:      libopenssl0
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 The OpenSSL Project is a collaborative effort to develop a robust,
52 commercial-grade, full-featured, and Open Source toolkit implementing
53 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
54 v1) protocols with full-strength cryptography world-wide. The project
55 is managed by a worldwide community of volunteers that use the
56 Internet to communicate, plan, and develop the OpenSSL tookit and its
57 related documentation.
58
59 OpenSSL is based on the excellent SSLeay library developed by Eric A.
60 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
61 Apache-style licence, which basically means that you are free to get
62 and use it for commercial and non-commercial purposes subject to some
63 simple license conditions.
64
65 This package contains shared libraries only, install openssl-tools if
66 you want to use openssl cmdline tool.
67
68 %description -l de.UTF-8
69 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
70 libraries, die verschiedene Verschlüsselungs- und
71 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
72 zur Verfügung stellen.
73
74 %description -l es.UTF-8
75 Biblioteca C que suministra algoritmos y protocolos criptográficos.
76
77 %description -l fr.UTF-8
78 OpenSSL est un outiil de gestion des certificats et les librairies
79 partagees qui fournit plusieurs protocoles et algorithmes de
80 codage/decodage, incluant DES, RC4, RSA et SSL.
81
82 %description -l pl.UTF-8
83 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
84 v2/v3 oraz Transport Layer Security (TLS v1).
85
86 %description -l pt_BR.UTF-8
87 Uma biblioteca C que fornece vários algoritmos e protocolos
88 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
89 compartilhadas e utilitários.
90
91 %description -l ru.UTF-8
92 Программа openssl для работы с сертификатами и разделяемые библиотеки,
93 которые реализуют множетсво криптографических алгоритмов, включая DES,
94 RC4, RSA и SSL.
95
96 %description -l uk.UTF-8
97 Програма openssl для роботи з сертифікатами та бібліотеки спільного
98 користування, що реалізують велику кількість криптографічних
99 алгоритмів, включаючи DES, RC4, RSA та SSL.
100
101 %package engines
102 Summary:        OpenSSL optional crypto engines
103 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
104 Group:          Libraries
105 Requires:       %{name} = %{version}-%{release}
106
107 %description engines
108 With OpenSSL 0.9.6, a new component was added to support alternative
109 cryptography implementations, most commonly for interfacing with
110 external crypto devices (eg. accelerator cards). This component is
111 called ENGINE.
112
113 There are currently built-in ENGINE implementations for the following
114 crypto devices:
115
116 - CryptoSwift
117 - Compaq Atalla
118 - nCipher CHIL
119 - Nuron
120 - Broadcom uBSec
121
122 In addition, dynamic binding to external ENGINE implementations is now
123 provided by a special ENGINE called "dynamic". 
124
125 %description engines -l pl.UTF-8
126 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
127 wspierać alternatywne implementacje kryptografii, przeważnie
128 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
129 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM
130 (ang. ENGINE).
131
132 Obecnie istnieją wbudowane implementacje silników dla następujących
133 urządzeń kryptograficznych:
134 - CryptoSwift
135 - Compaq Atalla
136 - nCipher CHIL
137 - Nuron
138 - Broadcom uBSec
139
140 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
141 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
142
143 %package tools
144 Summary:        OpenSSL command line tool and utilities
145 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
146 Group:          Applications/Communications
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       which
149
150 %description tools
151 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
152
153 %description tools -l pl.UTF-8
154 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
155
156 %package tools-perl
157 Summary:        OpenSSL utilities written in Perl
158 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
159 Group:          Applications/Communications
160 Requires:       %{name} = %{version}-%{release}
161
162 %description tools-perl
163 OpenSSL Toolkit tools written in Perl.
164
165 %description tools-perl -l pl.UTF-8
166 Narzędzia OpenSSL napisane w perlu.
167
168 %package devel
169 Summary:        Development part of OpenSSL Toolkit libraries
170 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
171 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
172 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
173 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
174 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
175 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
176 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
177 Group:          Development/Libraries
178 Requires:       %{name} = %{version}-%{release}
179 Obsoletes:      libopenssl0-devel
180
181 %description devel
182 Development part of OpenSSL library.
183
184 %description devel -l es.UTF-8
185 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
186
187 %description devel -l pl.UTF-8
188 Część biblioteki OpenSSL przeznaczona dla programistów.
189
190 %description devel -l pt_BR.UTF-8
191 Uma biblioteca C que fornece vários algoritmos e protocolos
192 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
193 arquivos de inclusão para desenvolvimento.
194
195 %description devel -l ru.UTF-8
196 Программа openssl для работы с сертификатами и разделяемые библиотеки,
197 которые реализуют множетсво криптографических алгоритмов, включая DES,
198 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
199 с использованием SSL.
200
201 %description devel -l uk.UTF-8
202 Програма openssl для роботи з сертифікатами та бібліотеки спільного
203 користування, що реалізують велику кількість криптографічних
204 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
205 хедери для розробки програм з використанням SSL.
206
207 %package static
208 Summary:        Static OpenSSL libraries
209 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
210 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
211 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
212 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
213 Group:          Development/Libraries
214 Requires:       %{name}-devel = %{version}-%{release}
215
216 %description static
217 Static OpenSSL Toolkit libraries.
218
219 %description static -l pl.UTF-8
220 Statyczne wersje bibliotek z OpenSSL.
221
222 %description static -l pt_BR.UTF-8
223 Bibliotecas estáticas para desenvolvimento com openssl.
224
225 %description static -l ru.UTF-8
226 Программа openssl для работы с сертификатами и разделяемые библиотеки,
227 которые реализуют множетсво криптографических алгоритмов, включая DES,
228 RC4, RSA и SSL. Включает статические библиотеки для разработки
229 приложений с использованием OpenSSL.
230
231 %description static -l uk.UTF-8
232 Програма openssl для роботи з сертифікатами та бібліотеки спільного
233 користування, що реалізують велику кількість криптографічних
234 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
235 бібліотеки для розробки програм з використанням SSL.
236
237 %prep
238 %setup -q
239 %patch0 -p1
240 %patch1 -p1
241 %patch2 -p1
242 %patch3 -p1
243 %patch4 -p1
244 %patch5 -p1
245 %patch6 -p1
246 %patch7 -p1
247
248 %{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
249         `grep -l -r "%{_prefix}/local/bin/perl" *`
250
251 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
252
253 %build
254 touch Makefile.*
255
256 %{__perl} util/perlpath.pl %{__perl}
257
258 OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}" \
259 ./Configure \
260 %if "%{pld_release}" == "ti"
261         --openssldir=%{_var}/lib/%{name} \
262 %else
263         --openssldir=%{_sysconfdir}/%{name} \
264 %endif
265         --libdir=%{_lib} \
266         shared threads \
267         enable-tlsext \
268         enable-seed \
269         enable-rfc3779 \
270         enable-cms \
271         enable-idea \
272         enable-mdc2 \
273         enable-md2 \
274         enable-rc5 \
275 %ifarch %{ix86}
276 %ifarch i386
277         386 linux-elf
278 # ^- allow running on 80386 (default code uses bswapl available on i486+)
279 %else
280         linux-elf
281 %endif
282 %endif
283 %ifarch alpha
284         linux-alpha+bwx-gcc
285 %endif
286 %ifarch %{x8664}
287         linux-x86_64
288 %endif
289 %ifarch ia64
290         linux-ia64
291 %endif
292 %ifarch ppc
293         linux-ppc
294 %endif
295 %ifarch ppc64
296         linux-ppc64
297 %endif
298 %ifarch sparc
299         linux-sparcv8
300 %endif
301 %ifarch sparcv9
302         linux-sparcv9
303 %endif
304 %ifarch sparc64
305         linux64-sparcv9
306 %endif
307 %ifarch armv4 armv5 armv5t armv5te armv5tel
308         linux-armv4
309 %endif
310
311 %{__make} -j1 all rehash %{?with_tests:tests} \
312         CC="%{__cc}" \
313         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
314         INSTALLTOP=%{_prefix}
315
316 # Rename POD sources of man pages. "openssl_" prefix is added to each
317 # manpage to avoid potential conflicts with other packages.
318
319 for dir in doc/{apps,ssl,crypto}; do
320         cd $dir || exit 1;
321         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
322
323         for pod in !(openssl*).pod; do
324                 mv -f $pod openssl_$pod;
325         done
326         cd ../..
327 done
328
329 %install
330 rm -rf $RPM_BUILD_ROOT
331 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
332         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
333         $RPM_BUILD_ROOT/%{_lib}/engines \
334         $RPM_BUILD_ROOT%{_pkgconfigdir}
335
336 %{__make} install \
337         INSTALLTOP=%{_prefix} \
338         INSTALL_PREFIX=$RPM_BUILD_ROOT \
339         MANDIR=%{_mandir}
340
341 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
342 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
343 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
344 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
345
346 %if "%{pld_release}" == "ti"
347 ln -sf %{_var}/lib/%{name}/%{name}.cnf \
348         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/openssl.cnf
349 ln -sf %{_var}/lib/%{name}/certs \
350         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/certs
351 ln -sf %{_var}/lib/%{name}/private \
352         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/private
353 mv -f $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
354 rm -rf $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc
355 %else
356 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
357 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
358 %endif
359
360 # not installed as individual utilities (see openssl dgst instead)
361 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md2,md4,md5,mdc2,ripemd160,sha,sha1}.1
362
363 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
364 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
365 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
366
367 %clean
368 rm -rf $RPM_BUILD_ROOT
369
370 %post   -p /sbin/ldconfig
371 %postun -p /sbin/ldconfig
372
373 %triggerpostun -- %{name}-tools < 1.0.0-5
374 # the hashing format has changed in 1.0.0
375 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
376
377 %if "%{pld_release}" == "ti"
378 %triggerin -- %{name}-tools < 0.9.8i-2
379 if [ -L /var/lib/openssl/openssl.cnf ] ; then
380         echo "Saving old configuration as /var/lib/openssl/openssl.cnf.rpmsave"
381         rm /var/lib/openssl/openssl.cnf
382         mv %{_sysconfdir}/%{name}/openssl.cnf /var/lib/openssl/openssl.cnf.rpmsave 2>/dev/null || :
383 fi
384 %else
385 %triggerpostun -- %{name} < 0.9.8i-2
386 if [ -d /var/lib/openssl/certs ] ; then
387         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
388 fi
389 if [ -d /var/lib/openssl/private ] ; then
390         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
391 fi
392 if [ -d /var/lib/openssl ] ; then
393         for f in /var/lib/openssl/* ; do
394                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
395         done
396 fi
397 %endif
398
399 %files
400 %defattr(644,root,root,755)
401 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
402 %doc doc/openssl_button.gif doc/openssl_button.html
403 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
404 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
405 %if "%{pld_release}" == "ti"
406 %dir %{_var}/lib/%{name}
407 %dir %{_var}/lib/%{name}/certs
408 %dir %{_var}/lib/%{name}/private
409 %dir %{_sysconfdir}/%{name}
410 %attr(755,root,root) %{_sysconfdir}/%{name}/certs
411 %attr(755,root,root) %{_sysconfdir}/%{name}/private
412 %else
413 %dir %{_sysconfdir}/%{name}
414 %dir %{_sysconfdir}/%{name}/certs
415 %dir %{_sysconfdir}/%{name}/private
416 %endif
417 %dir %{_datadir}/ssl
418
419 %files engines
420 %dir /%{_lib}/engines
421 %attr(755,root,root) /%{_lib}/engines/*.so
422
423 %files tools
424 %defattr(644,root,root,755)
425 %if "%{pld_release}" == "ti"
426 %{_sysconfdir}/%{name}/openssl.cnf
427 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/%{name}/openssl.cnf
428 %else
429 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
430 %endif
431 %attr(755,root,root) %{_bindir}/c_rehash.sh
432 %attr(755,root,root) %{_bindir}/openssl
433 %attr(754,root,root) %{_bindir}/ssl-certificate
434
435 %dir %{_libdir}/%{name}
436 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
437 %attr(755,root,root) %{_libdir}/%{name}/c_hash
438 %attr(755,root,root) %{_libdir}/%{name}/c_info
439 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
440 %attr(755,root,root) %{_libdir}/%{name}/c_name
441 %attr(755,root,root) %{_libdir}/%{name}/tsget
442
443 %{_mandir}/man1/openssl.1*
444 %{_mandir}/man1/openssl_asn1parse.1*
445 %{_mandir}/man1/openssl_ca.1*
446 %{_mandir}/man1/openssl_ciphers.1*
447 %{_mandir}/man1/openssl_cms.1*
448 %{_mandir}/man1/openssl_crl.1*
449 %{_mandir}/man1/openssl_crl2pkcs7.1*
450 %{_mandir}/man1/openssl_dgst.1*
451 %{_mandir}/man1/openssl_dhparam.1*
452 %{_mandir}/man1/openssl_dsa.1*
453 %{_mandir}/man1/openssl_dsaparam.1*
454 %{_mandir}/man1/openssl_ec.1*
455 %{_mandir}/man1/openssl_ecparam.1*
456 %{_mandir}/man1/openssl_enc.1*
457 %{_mandir}/man1/openssl_errstr.1*
458 %{_mandir}/man1/openssl_gendsa.1*
459 %{_mandir}/man1/openssl_genpkey.1*
460 %{_mandir}/man1/openssl_genrsa.1*
461 %{_mandir}/man1/openssl_nseq.1*
462 %{_mandir}/man1/openssl_ocsp.1*
463 %{_mandir}/man1/openssl_passwd.1*
464 %{_mandir}/man1/openssl_pkcs12.1*
465 %{_mandir}/man1/openssl_pkcs7.1*
466 %{_mandir}/man1/openssl_pkcs8.1*
467 %{_mandir}/man1/openssl_pkey.1*
468 %{_mandir}/man1/openssl_pkeyparam.1*
469 %{_mandir}/man1/openssl_pkeyutl.1*
470 %{_mandir}/man1/openssl_rand.1*
471 %{_mandir}/man1/openssl_req.1*
472 %{_mandir}/man1/openssl_rsa.1*
473 %{_mandir}/man1/openssl_rsautl.1*
474 %{_mandir}/man1/openssl_s_client.1*
475 %{_mandir}/man1/openssl_s_server.1*
476 %{_mandir}/man1/openssl_s_time.1*
477 %{_mandir}/man1/openssl_sess_id.1*
478 %{_mandir}/man1/openssl_smime.1*
479 %{_mandir}/man1/openssl_speed.1*
480 %{_mandir}/man1/openssl_spkac.1*
481 %{_mandir}/man1/openssl_ts.1*
482 %{_mandir}/man1/openssl_tsget.1*
483 %{_mandir}/man1/openssl_verify.1*
484 %{_mandir}/man1/openssl_version.1*
485 %{_mandir}/man1/openssl_x509.1*
486 %{_mandir}/man5/openssl_config.5*
487 %{_mandir}/man5/openssl_x509v3_config.5*
488 %lang(pl) %{_mandir}/pl/man1/openssl.1*
489
490 %files tools-perl
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/c_rehash
493 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
494 %{_mandir}/man1/openssl_CA.pl.1*
495
496 %files devel
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_libdir}/libcrypto.so
499 %attr(755,root,root) %{_libdir}/libssl.so
500 %{_includedir}/%{name}
501 %{_pkgconfigdir}/libcrypto.pc
502 %{_pkgconfigdir}/libssl.pc
503 %{_pkgconfigdir}/openssl.pc
504 %{_mandir}/man3/openssl*.3*
505 %{_mandir}/man7/openssl_des_modes.7*
506
507 %files static
508 %defattr(644,root,root,755)
509 %{_libdir}/lib*.a
This page took 0.069521 seconds and 4 git commands to generate.