]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- added using %%{rpmcflags} macro.
[packages/openssl.git] / openssl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
3 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary
4 Summary(fr):    Utilitaires de communication SSL (Secure Sockets Layer)
5 Name:           openssl
6 Version:        0.9.6
7 Release:        6
8 Group:          Libraries
9 Group(de):      Libraries
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
13 Patch0:         %{name}-perl.patch
14 Patch1:         %{name}-alpha-ccc.patch
15 Vendor:         The OpenSSL Project
16 License:        Apache-style License
17 BuildRequires:  perl
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      SSLeay
20 Obsoletes:      SSLeay-devel
21 Obsoletes:      SSLeay-perl
22
23 %description
24 The OpenSSL Project is a collaborative effort to develop a robust,
25 commercial-grade, full-featured, and Open Source toolkit implementing
26 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
27 v1) protocols with full-strength cryptography world-wide. The project
28 is managed by a worldwide community of volunteers that use the
29 Internet to communicate, plan, and develop the OpenSSL tookit and its
30 related documentation.
31
32 OpenSSL is based on the excellent SSLeay library developed by Eric A.
33 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
34 Apache-style licence, which basically means that you are free to get
35 and use it for commercial and non-commercial purposes subject to some
36 simple license conditions.
37
38 This package contains shared libraries only, install openssl-tools if
39 you want to use openssl cmdline tool.
40
41 %description -l de
42 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
43 libraries, die verschiedene Verschlüsselungs- und
44 Entschlüsselungsalgorithmen und
45 - -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.
46
47 %description -l fr
48 OpenSSL est un outiil de gestion des certificats et les librairies
49 partagees qui fournit plusieurs protocoles et algorithmes de
50 codage/decodage, incluant DES, RC4, RSA et SSL.
51
52 %package tools
53 Summary:        OpenSSL command line tool and utilities
54 Group:          Applications/Communications
55 Group(de):      Applikationen/Kommunikation
56 Group(pl):      Aplikacje/Komunikacja
57 Requires:       %{name} = %{version}
58
59 %description tools
60 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
61
62 %package tools-perl
63 Summary:        OpenSSL utilities written in Perl
64 Group:          Applications/Communications
65 Group(de):      Applikationen/Kommunikation
66 Group(fr):      Utilitaires
67 Group(pl):      Aplikacje/Komunikacja
68 Requires:       %{name} = %{version}
69
70 %description tools-perl
71 OpenSSL Toolkit tools written in Perl.
72
73 %package devel
74 Summary:        Development part of OpenSSL Toolkit libraries
75 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header
76 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL
77 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
78 Group:          Development/Libraries
79 Group(de):      Entwicklung/Libraries
80 Group(fr):      Development/Librairies
81 Group(pl):      Programowanie/Biblioteki
82 Requires:       %{name} = %{version}
83
84 %description devel
85 Development part of OpenSSL library.
86
87 %description devel -l pl
88 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
89
90 %package static
91 Summary:        Static OpenSSL libraries
92 Summary(pl):    Statyczne wersje bibliotek z OpenSSL
93 Group:          Development/Libraries
94 Group(de):      Entwicklung/Libraries
95 Group(fr):      Development/Librairies
96 Group(pl):      Programowanie/Biblioteki
97 Requires:       %{name}-devel = %{version}
98
99 %description static
100 Static OpenSSL Toolkit libraries.
101
102 %description static -l pl
103 Statyczne wersje bibliotek z OpenSSL.
104
105 %prep
106 %setup -q 
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 for i in Configure Makefile.org ; do
112         perl -pi -e 's#-m486##g' $i
113         perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
114         perl -pi -e 's#-mcpu=ultrasparc#%{optflags}#g' $i
115 done
116 touch Makefile.*
117
118 perl util/perlpath.pl %{_bindir}/perl
119
120 %ifarch i386 i486
121 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
122 %endif
123 %ifarch i586 i686
124 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
125 %endif
126 %ifarch ppc
127 ./Configure --openssldir=%{_var}/lib/%{name} linux-ppc shared
128 %endif
129 %ifarch alpha
130 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-alpha+bwx-gcc
131 %endif
132
133 %{__make} OPT_FLAGS="%{rpmcflags} -DSSL_ALLOW_DH"
134 %{__make} INSTALLTOP=%{_prefix} \
135         OPT_FLAGS="%{rpmcflags}"
136 %ifarch alpha
137 %{__make} linux-shared
138 %endif
139 %{__make} rehash
140
141 # Conv PODs to man pages. "openssl_" prefix is added to each manpage 
142 # to avoid potential conflicts with others packages.
143 center="OpenSSL 0.9.6"
144 rel="OpenSSL 0.9.6"
145
146 cd doc/apps || exit 1 
147 perl -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
148
149 for pod in *.pod; do 
150     if [ $pod != "openssl.pod" ]; then
151         mv -f $pod openssl_$pod;
152         pod=openssl_$pod;
153     fi
154
155     sec=1
156     if [ $pod = "openssl_config.pod" ]; then
157         sec=5
158     fi
159
160     manpage=`basename $pod .pod`.$sec;      
161     pod2man --section="$sec" --release="$rel" --center="$center" \
162             $pod > $manpage;
163     echo "$manpage";
164 done
165 cd ..
166
167 sec=3
168 for dir in ssl crypto; do 
169         cd $dir || exit 1;
170         if [ $dir = "ssl" ]; then
171                 rel="OpenSSL SSL/TLS library"
172         elif [ $dir = "crypto" ]; then 
173                 rel="OpenSSL cryptographic library"
174         fi
175         
176         perl -p -i -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
177         
178         for pod in *.pod; do 
179             sec=`[ "$pod" = "des_modes.pod" ] && echo 7 || echo 3`;     
180             mv -f $pod openssl_$pod;
181             pod=openssl_$pod;
182             manpage=`basename $pod .pod`.$sec;
183             pod2man --section="$sec" --release="$rel" --center=" " $pod > $manpage;
184             echo "$manpage";
185         done
186         cd ..
187 done
188
189 #cd perl
190 #perl Makefile.PL
191 #make
192
193 %install
194 rm -rf $RPM_BUILD_ROOT
195 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
196            $RPM_BUILD_ROOT%{_mandir}/man{1,3,5,7}
197
198 %{__make} install \
199         INSTALLTOP=%{_prefix} \
200         INSTALL_PREFIX=$RPM_BUILD_ROOT
201
202 install libRSAglue.a libcrypto.a libssl.a       $RPM_BUILD_ROOT%{_libdir}
203 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
204 ln -sf libcrypto.so.*.* $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
205 ln -sf libssl.so.*.* $RPM_BUILD_ROOT%{_libdir}/libssl.so
206
207 #cd perl
208 #make install DESTDIR=$RPM_BUILD_ROOT
209 #cd ..
210
211 mv -f $RPM_BUILD_ROOT%{_var}/lib/%{name}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
212 ln -s ../../../%{_sysconfdir}/%{name}/openssl.cnf \
213         $RPM_BUILD_ROOT%{_var}/lib/%{name}/%{name}.cnf
214
215 mv -f $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc/*  $RPM_BUILD_ROOT%{_libdir}/%{name}
216 rm -rf $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc
217
218 mv -f $RPM_BUILD_ROOT%{_bindir}/c_rehash $RPM_BUILD_ROOT%{_libdir}/%{name}
219
220 find $RPM_BUILD_ROOT%{_mandir} -type f | xargs rm -f
221 install doc/apps/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
222 install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
223 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
224 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
225
226 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
227
228 %post   -p /sbin/ldconfig
229 %postun -p /sbin/ldconfig
230
231 %clean
232 rm -rf $RPM_BUILD_ROOT
233
234 %files
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/lib*.so.*.*
237 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
238 %doc doc/*.txt.gz doc/openssl_button.gif doc/openssl_button.html
239
240 %files tools
241 %defattr(644,root,root,755)
242 %dir %{_sysconfdir}/%{name}
243 %dir %{_var}/lib/%{name}
244 %dir %{_var}/lib/%{name}/private
245 %dir %{_var}/lib/%{name}/certs
246 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
247 %verify(not md5 size mtime) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
248
249 %attr(755,root,root) %{_bindir}/%{name}
250 %dir %{_libdir}/%{name}
251 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
252 %attr(755,root,root) %{_libdir}/%{name}/c_hash
253 %attr(755,root,root) %{_libdir}/%{name}/c_info
254 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
255 %attr(755,root,root) %{_libdir}/%{name}/c_name
256
257 %{_mandir}/man1/openssl.1*
258 %{_mandir}/man1/openssl_asn1parse.1*
259 %{_mandir}/man1/openssl_ca.1*
260 %{_mandir}/man1/openssl_ciphers.1*
261 %{_mandir}/man1/openssl_crl.1*
262 %{_mandir}/man1/openssl_crl2pkcs7.1*
263 %{_mandir}/man1/openssl_dgst.1*
264 %{_mandir}/man1/openssl_dhparam.1*
265 %{_mandir}/man1/openssl_dsa.1*
266 %{_mandir}/man1/openssl_dsaparam.1*
267 %{_mandir}/man1/openssl_enc.1*
268 %{_mandir}/man1/openssl_gendsa.1*
269 %{_mandir}/man1/openssl_genrsa.1*
270 %{_mandir}/man1/openssl_nseq.1*
271 %{_mandir}/man1/openssl_passwd.1*
272 %{_mandir}/man1/openssl_pkcs12.1*
273 %{_mandir}/man1/openssl_pkcs7.1*
274 %{_mandir}/man1/openssl_pkcs8.1*
275 %{_mandir}/man1/openssl_rand.1*
276 %{_mandir}/man1/openssl_req.1*
277 %{_mandir}/man1/openssl_rsa.1*
278 %{_mandir}/man1/openssl_s_client.1*
279 %{_mandir}/man1/openssl_s_server.1*
280 %{_mandir}/man1/openssl_sess_id.1*
281 %{_mandir}/man1/openssl_smime.1*
282 %{_mandir}/man1/openssl_speed.1*
283 %{_mandir}/man1/openssl_spkac.1*
284 %{_mandir}/man1/openssl_verify.1*
285 %{_mandir}/man1/openssl_version.1*
286 %{_mandir}/man1/openssl_x509.1*
287 %{_mandir}/man5/*.5*
288
289 %files tools-perl
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
292 %attr(755,root,root) %{_libdir}/%{name}/der_chop
293 %attr(755,root,root) %{_libdir}/%{name}/c_rehash
294 %{_mandir}/man1/openssl_CA.pl.1*
295
296 %files devel
297 %defattr(644,root,root,755)
298 %attr(755,root,root) %{_libdir}/lib*.so
299 %{_includedir}/%{name}
300 %{_mandir}/man3/*.3*
301
302 %files static
303 %defattr(644,root,root,755)
304 %{_libdir}/lib*.a
This page took 0.048554 seconds and 4 git commands to generate.