]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- up to 1.0.0b + fix that makes test suite pass
[packages/openssl.git] / openssl.spec
1 #
2 # TODO: consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform "make tests"
6 %bcond_with     purify  # Compile openssl with \-DPURIFY, useful when one wants to
7                         # use valgrind debugger against openssl-linked programs
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
11 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
12 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
13 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
14 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
15 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
16 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
17 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
18 Name:           openssl
19 Version:        1.0.0b
20 Release:        1
21 License:        Apache-like
22 Group:          Libraries
23 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
24 # Source0-md5:  104deb3b7e6820cae6de3f49ba0ff2b0
25 Source2:        %{name}.1.pl
26 Source3:        %{name}-ssl-certificate.sh
27 Source4:        %{name}-c_rehash.sh
28 Patch0:         %{name}-alpha-ccc.patch
29 Patch1:         %{name}-optflags.patch
30 Patch2:         %{name}-globalCA.diff
31 Patch3:         %{name}-include.patch
32 Patch4:         %{name}-man-namespace.patch
33 Patch5:         %{name}-asflag.patch
34 Patch6:         %{name}-ca-certificates.patch
35 Patch7:         %{name}-ldflags.patch
36 Patch8:         %{name}-tls.patch
37 URL:            http://www.openssl.org/
38 BuildRequires:  bc
39 BuildRequires:  perl-devel >= 1:5.6.1
40 BuildRequires:  rpm-perlprov >= 4.1-13
41 BuildRequires:  rpmbuild(macros) >= 1.213
42 BuildRequires:  sed >= 4.0
43 Requires:       ca-certificates >= 20080809-4
44 Requires:       rpm-whiteout >= 1.7
45 Obsoletes:      SSLeay
46 Obsoletes:      SSLeay-devel
47 Obsoletes:      SSLeay-perl
48 Obsoletes:      libopenssl0
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 The OpenSSL Project is a collaborative effort to develop a robust,
53 commercial-grade, full-featured, and Open Source toolkit implementing
54 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
55 v1) protocols with full-strength cryptography world-wide. The project
56 is managed by a worldwide community of volunteers that use the
57 Internet to communicate, plan, and develop the OpenSSL tookit and its
58 related documentation.
59
60 OpenSSL is based on the excellent SSLeay library developed by Eric A.
61 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
62 Apache-style licence, which basically means that you are free to get
63 and use it for commercial and non-commercial purposes subject to some
64 simple license conditions.
65
66 This package contains shared libraries only, install openssl-tools if
67 you want to use openssl cmdline tool.
68
69 %description -l de.UTF-8
70 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
71 libraries, die verschiedene Verschlüsselungs- und
72 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
73 zur Verfügung stellen.
74
75 %description -l es.UTF-8
76 Biblioteca C que suministra algoritmos y protocolos criptográficos.
77
78 %description -l fr.UTF-8
79 OpenSSL est un outiil de gestion des certificats et les librairies
80 partagees qui fournit plusieurs protocoles et algorithmes de
81 codage/decodage, incluant DES, RC4, RSA et SSL.
82
83 %description -l pl.UTF-8
84 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
85 v2/v3 oraz Transport Layer Security (TLS v1).
86
87 %description -l pt_BR.UTF-8
88 Uma biblioteca C que fornece vários algoritmos e protocolos
89 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
90 compartilhadas e utilitários.
91
92 %description -l ru.UTF-8
93 Программа openssl для работы с сертификатами и разделяемые библиотеки,
94 которые реализуют множетсво криптографических алгоритмов, включая DES,
95 RC4, RSA и SSL.
96
97 %description -l uk.UTF-8
98 Програма openssl для роботи з сертифікатами та бібліотеки спільного
99 користування, що реалізують велику кількість криптографічних
100 алгоритмів, включаючи DES, RC4, RSA та SSL.
101
102 %package engines
103 Summary:        OpenSSL optional crypto engines
104 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description engines
109 With OpenSSL 0.9.6, a new component was added to support alternative
110 cryptography implementations, most commonly for interfacing with
111 external crypto devices (eg. accelerator cards). This component is
112 called ENGINE.
113
114 There are currently built-in ENGINE implementations for the following
115 crypto devices:
116
117 - CryptoSwift
118 - Compaq Atalla
119 - nCipher CHIL
120 - Nuron
121 - Broadcom uBSec
122
123 In addition, dynamic binding to external ENGINE implementations is now
124 provided by a special ENGINE called "dynamic". 
125
126 %description engines -l pl.UTF-8
127 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
128 wspierać alternatywne implementacje kryptografii, przeważnie
129 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
130 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM
131 (ang. ENGINE).
132
133 Obecnie istnieją wbudowane implementacje silników dla następujących
134 urządzeń kryptograficznych:
135 - CryptoSwift
136 - Compaq Atalla
137 - nCipher CHIL
138 - Nuron
139 - Broadcom uBSec
140
141 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
142 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
143
144 %package tools
145 Summary:        OpenSSL command line tool and utilities
146 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
147 Group:          Applications/Communications
148 Requires:       %{name} = %{version}-%{release}
149 Requires:       which
150
151 %description tools
152 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
153
154 %description tools -l pl.UTF-8
155 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
156
157 %package tools-perl
158 Summary:        OpenSSL utilities written in Perl
159 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
160 Group:          Applications/Communications
161 Requires:       %{name} = %{version}-%{release}
162
163 %description tools-perl
164 OpenSSL Toolkit tools written in Perl.
165
166 %description tools-perl -l pl.UTF-8
167 Narzędzia OpenSSL napisane w perlu.
168
169 %package devel
170 Summary:        Development part of OpenSSL Toolkit libraries
171 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
172 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
173 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
174 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
175 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
176 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
177 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
178 Group:          Development/Libraries
179 Requires:       %{name} = %{version}-%{release}
180 Obsoletes:      libopenssl0-devel
181
182 %description devel
183 Development part of OpenSSL library.
184
185 %description devel -l es.UTF-8
186 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
187
188 %description devel -l pl.UTF-8
189 Część biblioteki OpenSSL przeznaczona dla programistów.
190
191 %description devel -l pt_BR.UTF-8
192 Uma biblioteca C que fornece vários algoritmos e protocolos
193 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
194 arquivos de inclusão para desenvolvimento.
195
196 %description devel -l ru.UTF-8
197 Программа openssl для работы с сертификатами и разделяемые библиотеки,
198 которые реализуют множетсво криптографических алгоритмов, включая DES,
199 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
200 с использованием SSL.
201
202 %description devel -l uk.UTF-8
203 Програма openssl для роботи з сертифікатами та бібліотеки спільного
204 користування, що реалізують велику кількість криптографічних
205 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
206 хедери для розробки програм з використанням SSL.
207
208 %package static
209 Summary:        Static OpenSSL libraries
210 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
211 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
212 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
213 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
214 Group:          Development/Libraries
215 Requires:       %{name}-devel = %{version}-%{release}
216
217 %description static
218 Static OpenSSL Toolkit libraries.
219
220 %description static -l pl.UTF-8
221 Statyczne wersje bibliotek z OpenSSL.
222
223 %description static -l pt_BR.UTF-8
224 Bibliotecas estáticas para desenvolvimento com openssl.
225
226 %description static -l ru.UTF-8
227 Программа openssl для работы с сертификатами и разделяемые библиотеки,
228 которые реализуют множетсво криптографических алгоритмов, включая DES,
229 RC4, RSA и SSL. Включает статические библиотеки для разработки
230 приложений с использованием OpenSSL.
231
232 %description static -l uk.UTF-8
233 Програма openssl для роботи з сертифікатами та бібліотеки спільного
234 користування, що реалізують велику кількість криптографічних
235 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
236 бібліотеки для розробки програм з використанням SSL.
237
238 %prep
239 %setup -q
240 %patch0 -p1
241 %patch1 -p1
242 %patch2 -p1
243 %patch3 -p1
244 %patch4 -p1
245 %patch5 -p1
246 %patch6 -p1
247 %patch7 -p1
248 %patch8 -p1
249
250 %{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
251         `grep -l -r "%{_prefix}/local/bin/perl" *`
252
253 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
254
255 %build
256 touch Makefile.*
257
258 %{__perl} util/perlpath.pl %{__perl}
259
260 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
261 ./Configure \
262 %if "%{pld_release}" == "ti"
263         --openssldir=%{_var}/lib/%{name} \
264 %else
265         --openssldir=%{_sysconfdir}/%{name} \
266 %endif
267         --libdir=%{_lib} \
268         shared threads \
269         enable-tlsext \
270         enable-seed \
271         enable-rfc3779 \
272         enable-cms \
273         enable-idea \
274         enable-mdc2 \
275         enable-md2 \
276         enable-rc5 \
277 %ifarch %{ix86}
278 %ifarch i386
279         386 linux-elf
280 # ^- allow running on 80386 (default code uses bswapl available on i486+)
281 %else
282         linux-elf
283 %endif
284 %endif
285 %ifarch alpha
286         linux-alpha+bwx-gcc
287 %endif
288 %ifarch %{x8664}
289         linux-x86_64
290 %endif
291 %ifarch ia64
292         linux-ia64
293 %endif
294 %ifarch ppc
295         linux-ppc
296 %endif
297 %ifarch ppc64
298         linux-ppc64
299 %endif
300 %ifarch sparc
301         linux-sparcv8
302 %endif
303 %ifarch sparcv9
304         linux-sparcv9
305 %endif
306 %ifarch sparc64
307         linux64-sparcv9
308 %endif
309 %ifarch armv4 armv5 armv5t armv5te armv5tel
310         linux-armv4
311 %endif
312
313 %{__make} -j1 all rehash %{?with_tests:tests} \
314         CC="%{__cc}" \
315         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
316         INSTALLTOP=%{_prefix}
317
318 # Rename POD sources of man pages. "openssl_" prefix is added to each
319 # manpage to avoid potential conflicts with other packages.
320
321 for dir in doc/{apps,ssl,crypto}; do
322         cd $dir || exit 1;
323         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
324
325         for pod in !(openssl*).pod; do
326                 mv -f $pod openssl_$pod;
327         done
328         cd ../..
329 done
330
331 %install
332 rm -rf $RPM_BUILD_ROOT
333 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
334         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
335         $RPM_BUILD_ROOT/%{_lib}/engines \
336         $RPM_BUILD_ROOT%{_pkgconfigdir}
337
338 %{__make} install \
339         INSTALLTOP=%{_prefix} \
340         INSTALL_PREFIX=$RPM_BUILD_ROOT \
341         MANDIR=%{_mandir}
342
343 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
344 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
345 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
346 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
347
348 %if "%{pld_release}" == "ti"
349 ln -sf %{_var}/lib/%{name}/%{name}.cnf \
350         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/openssl.cnf
351 ln -sf %{_var}/lib/%{name}/certs \
352         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/certs
353 ln -sf %{_var}/lib/%{name}/private \
354         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/private
355 mv -f $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
356 rm -rf $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc
357 %else
358 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
359 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
360 %endif
361
362 # not installed as individual utilities (see openssl dgst instead)
363 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md2,md4,md5,mdc2,ripemd160,sha,sha1}.1
364
365 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
366 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
367 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
368
369 %clean
370 rm -rf $RPM_BUILD_ROOT
371
372 %post   -p /sbin/ldconfig
373 %postun -p /sbin/ldconfig
374
375 %triggerpostun -- %{name}-tools < 1.0.0-5
376 # the hashing format has changed in 1.0.0
377 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
378
379 %if "%{pld_release}" == "ti"
380 %triggerin -- %{name}-tools < 0.9.8i-2
381 if [ -L /var/lib/openssl/openssl.cnf ] ; then
382         echo "Saving old configuration as /var/lib/openssl/openssl.cnf.rpmsave"
383         rm /var/lib/openssl/openssl.cnf
384         mv %{_sysconfdir}/%{name}/openssl.cnf /var/lib/openssl/openssl.cnf.rpmsave 2>/dev/null || :
385 fi
386 %else
387 %triggerpostun -- %{name} < 0.9.8i-2
388 if [ -d /var/lib/openssl/certs ] ; then
389         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
390 fi
391 if [ -d /var/lib/openssl/private ] ; then
392         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
393 fi
394 if [ -d /var/lib/openssl ] ; then
395         for f in /var/lib/openssl/* ; do
396                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
397         done
398 fi
399 %endif
400
401 %files
402 %defattr(644,root,root,755)
403 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
404 %doc doc/openssl_button.gif doc/openssl_button.html
405 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
406 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
407 %if "%{pld_release}" == "ti"
408 %dir %{_var}/lib/%{name}
409 %dir %{_var}/lib/%{name}/certs
410 %dir %{_var}/lib/%{name}/private
411 %dir %{_sysconfdir}/%{name}
412 %attr(755,root,root) %{_sysconfdir}/%{name}/certs
413 %attr(755,root,root) %{_sysconfdir}/%{name}/private
414 %else
415 %dir %{_sysconfdir}/%{name}
416 %dir %{_sysconfdir}/%{name}/certs
417 %dir %{_sysconfdir}/%{name}/private
418 %endif
419 %dir %{_datadir}/ssl
420
421 %files engines
422 %dir /%{_lib}/engines
423 %attr(755,root,root) /%{_lib}/engines/*.so
424
425 %files tools
426 %defattr(644,root,root,755)
427 %if "%{pld_release}" == "ti"
428 %{_sysconfdir}/%{name}/openssl.cnf
429 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/%{name}/openssl.cnf
430 %else
431 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
432 %endif
433 %attr(755,root,root) %{_bindir}/c_rehash.sh
434 %attr(755,root,root) %{_bindir}/openssl
435 %attr(754,root,root) %{_bindir}/ssl-certificate
436
437 %dir %{_libdir}/%{name}
438 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
439 %attr(755,root,root) %{_libdir}/%{name}/c_hash
440 %attr(755,root,root) %{_libdir}/%{name}/c_info
441 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
442 %attr(755,root,root) %{_libdir}/%{name}/c_name
443 %attr(755,root,root) %{_libdir}/%{name}/tsget
444
445 %{_mandir}/man1/openssl.1*
446 %{_mandir}/man1/openssl_asn1parse.1*
447 %{_mandir}/man1/openssl_ca.1*
448 %{_mandir}/man1/openssl_ciphers.1*
449 %{_mandir}/man1/openssl_cms.1*
450 %{_mandir}/man1/openssl_crl.1*
451 %{_mandir}/man1/openssl_crl2pkcs7.1*
452 %{_mandir}/man1/openssl_dgst.1*
453 %{_mandir}/man1/openssl_dhparam.1*
454 %{_mandir}/man1/openssl_dsa.1*
455 %{_mandir}/man1/openssl_dsaparam.1*
456 %{_mandir}/man1/openssl_ec.1*
457 %{_mandir}/man1/openssl_ecparam.1*
458 %{_mandir}/man1/openssl_enc.1*
459 %{_mandir}/man1/openssl_errstr.1*
460 %{_mandir}/man1/openssl_gendsa.1*
461 %{_mandir}/man1/openssl_genpkey.1*
462 %{_mandir}/man1/openssl_genrsa.1*
463 %{_mandir}/man1/openssl_nseq.1*
464 %{_mandir}/man1/openssl_ocsp.1*
465 %{_mandir}/man1/openssl_passwd.1*
466 %{_mandir}/man1/openssl_pkcs12.1*
467 %{_mandir}/man1/openssl_pkcs7.1*
468 %{_mandir}/man1/openssl_pkcs8.1*
469 %{_mandir}/man1/openssl_pkey.1*
470 %{_mandir}/man1/openssl_pkeyparam.1*
471 %{_mandir}/man1/openssl_pkeyutl.1*
472 %{_mandir}/man1/openssl_rand.1*
473 %{_mandir}/man1/openssl_req.1*
474 %{_mandir}/man1/openssl_rsa.1*
475 %{_mandir}/man1/openssl_rsautl.1*
476 %{_mandir}/man1/openssl_s_client.1*
477 %{_mandir}/man1/openssl_s_server.1*
478 %{_mandir}/man1/openssl_s_time.1*
479 %{_mandir}/man1/openssl_sess_id.1*
480 %{_mandir}/man1/openssl_smime.1*
481 %{_mandir}/man1/openssl_speed.1*
482 %{_mandir}/man1/openssl_spkac.1*
483 %{_mandir}/man1/openssl_ts.1*
484 %{_mandir}/man1/openssl_tsget.1*
485 %{_mandir}/man1/openssl_verify.1*
486 %{_mandir}/man1/openssl_version.1*
487 %{_mandir}/man1/openssl_x509.1*
488 %{_mandir}/man5/openssl_config.5*
489 %{_mandir}/man5/openssl_x509v3_config.5*
490 %lang(pl) %{_mandir}/pl/man1/openssl.1*
491
492 %files tools-perl
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/c_rehash
495 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
496 %{_mandir}/man1/openssl_CA.pl.1*
497
498 %files devel
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/libcrypto.so
501 %attr(755,root,root) %{_libdir}/libssl.so
502 %{_includedir}/%{name}
503 %{_pkgconfigdir}/libcrypto.pc
504 %{_pkgconfigdir}/libssl.pc
505 %{_pkgconfigdir}/openssl.pc
506 %{_mandir}/man3/openssl*.3*
507 %{_mandir}/man7/openssl_des_modes.7*
508
509 %files static
510 %defattr(644,root,root,755)
511 %{_libdir}/lib*.a
This page took 0.061278 seconds and 4 git commands to generate.