]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- added line on top spec file with cvs tags ($Revision:$ and $Date:$).
[packages/openssl.git] / openssl.spec
1 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
2 Name:           openssl
3 Version:        0.9.3
4 Release:        1
5 Group:          Libraries
6 Group(pl):      Biblioteki
7 Source:         ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
8 Patch0:         openssl-sslcrypto.patch
9 Patch1:         openssl-perl.patch
10 Vendor:         The OpenSSL Project
11 License:        Apache-style License
12 BuildPrereq:    perl
13 BuildRoot:      /tmp/%{name}-%{version}-root
14 Obsoletes:      SSLeay
15 Obsoletes:      SSLeay-devel
16 Obsoletes:      SSLeay-perl
17
18 %define         openssldir      /var/state/openssl
19 %define         _sysconfdir     /etc/%{name}
20 %define         _pkglibdir      %{_libdir}/%{name}
21 %define         _pkgincludedir  %{_includedir}/%{name}
22
23 %description
24 The OpenSSL Project is a collaborative effort to develop a robust,
25 commercial-grade, full-featured, and Open Source toolkit implementing
26 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
27 v1) protocols with full-strength cryptography world-wide. The project
28 is managed by a worldwide community of volunteers that use the
29 Internet to communicate, plan, and develop the OpenSSL tookit and its
30 related documentation.
31    
32 OpenSSL is based on the excellent SSLeay library developed by Eric A.
33 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
34 Apache-style licence, which basically means that you are free to get
35 and use it for commercial and non-commercial purposes subject to some
36 simple license conditions.
37
38 %package devel
39 Summary:        Development part of OpenSSL library
40 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
41 Group:          Development/Library
42 Group(pl):      Programownie/Biblioteki
43 Requires:       %{name} = %{version}
44
45 %description devel
46 Development part of OpenSSL library.
47
48 %description devel -l pl
49 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
50
51 %package static
52 Summary:        Static OpenSSL library
53 Summary(pl):    Statyczna wersja biblioteki OpenSSL
54 Group:          Development/Library
55 Group(pl):      Programowanie/Biblioteki
56 Requires:       %{name}-devel = %{version}
57
58 %description static
59 Static OpenSSL library.
60
61 %description static -l pl
62 Statyczna wersja biblioteki OpenSSL.
63
64 %prep
65 %setup  -q 
66 %patch0 -p1
67 %patch1 -p1
68
69 %build
70 for i in ` echo Configure Makefile.org `; do
71         sed -e 's#-m486##g' \
72                 -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
73                 <$i >$i.work
74         mv $i.work $i
75 done
76
77 perl util/perlpath.pl %{_bindir}
78
79 ln -s crypto sslcrypto
80
81 ./config --openssldir=%{openssldir}
82
83 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
84 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
85 make rehash
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
91
92 make install \
93         INSTALLTOP=%{_prefix} \
94         INSTALL_PREFIX=$RPM_BUILD_ROOT
95
96 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
97 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
98 mv      lib*.so         $RPM_BUILD_ROOT%{_libdir}
99
100
101 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
102 ln -s $RPM_BUILD_ROOT%{_sysconfdir}/openssl.cnf \
103         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
104 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
105
106 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
107 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
108
109 strip $RPM_BUILD_ROOT%{_bindir}/* || :
110 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
111
112 gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
113         doc/*.pod doc/*.txt
114
115 %post
116 %{_bindir}/c_rehash certs
117 /sbin/ldconfig
118
119 %postun -p /sbin/ldconfig
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
127 %doc doc/*.pod.gz doc/*.txt.gz
128 %doc doc/openssl_button.gif doc/openssl_button.html
129
130 %attr(755,root,root) %{_bindir}/*
131 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
132 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
133 %{openssldir}/certs
134 %{openssldir}/private
135 %dir %{_pkglibdir}
136 %attr(755,root,root) %{_pkglibdir}/*
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/lib*.so
142 %{_pkgincludedir}
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/lib*.a
147
148 %changelog
149 * Wed Apr 14 1999 Artur Frysiak <wiget@pld.org.pl>
150   [0.9.2c-2]
151 - rewrite for PLD
152 TODO: make shared libs and perl subpackage
This page took 0.103085 seconds and 4 git commands to generate.