]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
f73a8fe0750d6c00ffa6848e69c30f010ec398d8
[packages/openssl.git] / openssl.spec
1 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
2 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
3 Name:           openssl
4 Version:        0.9.4
5 Release:        2
6 Group:          Libraries
7 Group(pl):      Biblioteki
8 Source:         ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
9 Patch:          openssl-perl.patch
10 Vendor:         The OpenSSL Project
11 License:        Apache-style License
12 BuildRequires:  symlinks
13 BuildRequires:  perl
14 BuildRoot:      /tmp/%{name}-%{version}-root
15 Obsoletes:      SSLeay
16 Obsoletes:      SSLeay-devel
17 Obsoletes:      SSLeay-perl
18
19 %define         openssldir      /var/state/openssl
20 %define         _sysconfdir     /etc/%{name}
21 %define         _pkglibdir      %{_libdir}/%{name}
22 %define         _pkgincludedir  %{_includedir}/%{name}
23
24 %description
25 The OpenSSL Project is a collaborative effort to develop a robust,
26 commercial-grade, full-featured, and Open Source toolkit implementing
27 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
28 v1) protocols with full-strength cryptography world-wide. The project
29 is managed by a worldwide community of volunteers that use the
30 Internet to communicate, plan, and develop the OpenSSL tookit and its
31 related documentation.
32    
33 OpenSSL is based on the excellent SSLeay library developed by Eric A.
34 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
35 Apache-style licence, which basically means that you are free to get
36 and use it for commercial and non-commercial purposes subject to some
37 simple license conditions.
38
39 %description -l de
40 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared libraries,
41 die verschiedene Verschlüsselungs- und Entschlüsselungsalgorithmen und
42 -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.                                                 
43
44 %description -l fr
45 OpenSSL est un outiil de gestion des certificats et les librairies partagees
46 qui fournit plusieurs protocoles et algorithmes de codage/decodage, incluant
47 DES, RC4, RSA et SSL.
48
49 %package devel
50 Summary:        Development part of OpenSSL library
51 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
52 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
53 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
54 Group:          Development/Libraries
55 Group(pl):      Programowanie/Biblioteki
56 Requires:       %{name} = %{version}
57
58 %description devel
59 Development part of OpenSSL library.
60
61 %description devel -l pl
62 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
63
64 %package static
65 Summary:        Static OpenSSL library
66 Summary(pl):    Statyczna wersja biblioteki OpenSSL
67 Group:          Development/Libraries
68 Group(pl):      Programowanie/Biblioteki
69 Requires:       %{name}-devel = %{version}
70
71 %description static
72 Static OpenSSL library.
73
74 %description static -l pl
75 Statyczna wersja biblioteki OpenSSL.
76
77 %prep
78 %setup -q 
79 %patch -p1
80
81 %build
82 for i in ` echo Configure Makefile.org `; do
83         sed -e 's#-m486##g' \
84                 -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
85                 <$i >$i.work
86         mv $i.work $i
87 done
88
89 perl util/perlpath.pl %{_bindir}
90
91 ln -s crypto sslcrypto
92
93 ./config --openssldir=%{openssldir}
94
95 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
96 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
97 make rehash
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
103
104 make install \
105         INSTALLTOP=%{_prefix} \
106         INSTALL_PREFIX=$RPM_BUILD_ROOT
107
108 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
109 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
110 cp -d   lib*.so         $RPM_BUILD_ROOT%{_libdir}
111
112
113 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
114 ln -s %{_sysconfdir}/openssl.cnf \
115         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
116 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
117
118 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
119 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
120
121 strip $RPM_BUILD_ROOT%{_bindir}/* || :
122 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
123
124 gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
125         doc/*.pod doc/*.txt
126
127 %post
128 %{_bindir}/c_rehash certs
129 /sbin/ldconfig
130
131 %postun -p /sbin/ldconfig
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
139 %doc doc/*.pod.gz doc/*.txt.gz
140 %doc doc/openssl_button.gif doc/openssl_button.html
141
142 %attr(755,root,root) %{_bindir}/*
143 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
144 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
145 %{openssldir}/certs
146 %{openssldir}/private
147 %dir %{_pkglibdir}
148 %attr(755,root,root) %{_pkglibdir}/*
149 %attr(755,root,root) %{_libdir}/lib*.so.*.*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_pkgincludedir}
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
This page took 0.049466 seconds and 2 git commands to generate.