]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
dcf970b09516a8acab6d8ce18c6b826c9df79268
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_with     sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
6 %bcond_with     sslv3   # SSLv3: note - enables CVE-2014-3566 vulnerability
7 %bcond_with     snap    # use GitHub snapshot to build branch release
8
9 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
10 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
11 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
12 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
13 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
14 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
15 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
16 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
17 Name:           openssl
18 # Version 1.1.1 is LTS, supported until 2023-09-11.
19 # https://www.openssl.org/about/releasestrat.html
20 Version:        1.1.1i
21 Release:        1
22 License:        Apache-like
23 Group:          Libraries
24 %if %{without snap}
25 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
26 # Source0-md5:  53840c70434793127a3574433494e8d3
27 %else
28 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_1_1-stable/%{name}-%{version}-dev.tar.gz
29 %endif
30 Source2:        %{name}.1.pl
31 Source3:        %{name}-ssl-certificate.sh
32 Source4:        %{name}-c_rehash.sh
33 Patch1:         %{name}-optflags.patch
34
35 Patch3:         %{name}-man-namespace.patch
36 Patch5:         %{name}-ca-certificates.patch
37 Patch6:         %{name}-no-win32.patch
38 Patch7:         %{name}-find.patch
39 Patch8:         pic.patch
40
41 Patch11:        engines-dir.patch
42 URL:            http://www.openssl.org/
43 BuildRequires:  libsctp-devel
44 BuildRequires:  perl-devel >= 1:5.10.0
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpm-perlprov >= 4.1-13
47 BuildRequires:  rpmbuild(macros) >= 1.213
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  zlib-devel
50 Requires:       ca-certificates >= 20141019-3
51 Requires:       rpm-whiteout >= 1.7
52 Obsoletes:      SSLeay
53 Obsoletes:      SSLeay-devel
54 Obsoletes:      SSLeay-perl
55 Obsoletes:      libopenssl0
56 %if "%{pld_release}" == "ac"
57 Conflicts:      neon < 0.26.3-3
58 Conflicts:      ntpd < 4.2.4p8-10
59 Conflicts:      openssh-clients < 2:5.8p1-9
60 Conflicts:      openssh-server < 2:5.8p1-9
61 %else
62 Conflicts:      neon < 0.29.6-8
63 Conflicts:      openssh-clients < 2:6.2p2-3
64 Conflicts:      openssh-server < 2:6.2p2-3
65 %endif
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 The OpenSSL Project is a collaborative effort to develop a robust,
70 commercial-grade, full-featured, and Open Source toolkit implementing
71 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
72 v1) protocols with full-strength cryptography world-wide. The project
73 is managed by a worldwide community of volunteers that use the
74 Internet to communicate, plan, and develop the OpenSSL tookit and its
75 related documentation.
76
77 OpenSSL is based on the excellent SSLeay library developed by Eric A.
78 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
79 Apache-style licence, which basically means that you are free to get
80 and use it for commercial and non-commercial purposes subject to some
81 simple license conditions.
82
83 This package contains shared libraries only, install openssl-tools if
84 you want to use openssl cmdline tool.
85
86 %description -l de.UTF-8
87 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
88 libraries, die verschiedene Verschlüsselungs- und
89 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
90 zur Verfügung stellen.
91
92 %description -l es.UTF-8
93 Biblioteca C que suministra algoritmos y protocolos criptográficos.
94
95 %description -l fr.UTF-8
96 OpenSSL est un outiil de gestion des certificats et les librairies
97 partagees qui fournit plusieurs protocoles et algorithmes de
98 codage/decodage, incluant DES, RC4, RSA et SSL.
99
100 %description -l pl.UTF-8
101 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
102 v2/v3 oraz Transport Layer Security (TLS v1).
103
104 %description -l pt_BR.UTF-8
105 Uma biblioteca C que fornece vários algoritmos e protocolos
106 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
107 compartilhadas e utilitários.
108
109 %description -l ru.UTF-8
110 Программа openssl для работы с сертификатами и разделяемые библиотеки,
111 которые реализуют множетсво криптографических алгоритмов, включая DES,
112 RC4, RSA и SSL.
113
114 %description -l uk.UTF-8
115 Програма openssl для роботи з сертифікатами та бібліотеки спільного
116 користування, що реалізують велику кількість криптографічних
117 алгоритмів, включаючи DES, RC4, RSA та SSL.
118
119 %package engines
120 Summary:        OpenSSL optional crypto engines
121 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124
125 %description engines
126 With OpenSSL 0.9.6, a new component was added to support alternative
127 cryptography implementations, most commonly for interfacing with
128 external crypto devices (eg. accelerator cards). This component is
129 called ENGINE.
130
131 There are currently built-in ENGINE implementations for the following
132 crypto devices:
133
134 - CryptoSwift
135 - Compaq Atalla
136 - nCipher CHIL
137 - Nuron
138 - Broadcom uBSec
139
140 In addition, dynamic binding to external ENGINE implementations is now
141 provided by a special ENGINE called "dynamic".
142
143 %description engines -l pl.UTF-8
144 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
145 wspierać alternatywne implementacje kryptografii, przeważnie
146 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
147 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
148 ENGINE).
149
150 Obecnie istnieją wbudowane implementacje silników dla następujących
151 urządzeń kryptograficznych:
152 - CryptoSwift
153 - Compaq Atalla
154 - nCipher CHIL
155 - Nuron
156 - Broadcom uBSec
157
158 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
159 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
160
161 %package tools
162 Summary:        OpenSSL command line tool and utilities
163 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
164 Group:          Applications/Communications
165 Requires:       %{name} = %{version}-%{release}
166 Requires:       which
167
168 %description tools
169 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
170
171 %description tools -l pl.UTF-8
172 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
173
174 %package tools-perl
175 Summary:        OpenSSL utilities written in Perl
176 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
177 Group:          Applications/Communications
178 Requires:       %{name} = %{version}-%{release}
179
180 %description tools-perl
181 OpenSSL Toolkit tools written in Perl.
182
183 %description tools-perl -l pl.UTF-8
184 Narzędzia OpenSSL napisane w perlu.
185
186 %package devel
187 Summary:        Development part of OpenSSL Toolkit libraries
188 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
189 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
190 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
191 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
192 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
193 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
194 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
195 Group:          Development/Libraries
196 Requires:       %{name} = %{version}-%{release}
197 Obsoletes:      libopenssl0-devel
198
199 %description devel
200 Development part of OpenSSL library.
201
202 %description devel -l es.UTF-8
203 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
204
205 %description devel -l pl.UTF-8
206 Część biblioteki OpenSSL przeznaczona dla programistów.
207
208 %description devel -l pt_BR.UTF-8
209 Uma biblioteca C que fornece vários algoritmos e protocolos
210 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
211 arquivos de inclusão para desenvolvimento.
212
213 %description devel -l ru.UTF-8
214 Программа openssl для работы с сертификатами и разделяемые библиотеки,
215 которые реализуют множетсво криптографических алгоритмов, включая DES,
216 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
217 с использованием SSL.
218
219 %description devel -l uk.UTF-8
220 Програма openssl для роботи з сертифікатами та бібліотеки спільного
221 користування, що реалізують велику кількість криптографічних
222 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
223 хедери для розробки програм з використанням SSL.
224
225 %package static
226 Summary:        Static OpenSSL libraries
227 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
228 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
229 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
230 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
231 Group:          Development/Libraries
232 Requires:       %{name}-devel = %{version}-%{release}
233
234 %description static
235 Static OpenSSL Toolkit libraries.
236
237 %description static -l pl.UTF-8
238 Statyczne wersje bibliotek z OpenSSL.
239
240 %description static -l pt_BR.UTF-8
241 Bibliotecas estáticas para desenvolvimento com openssl.
242
243 %description static -l ru.UTF-8
244 Программа openssl для работы с сертификатами и разделяемые библиотеки,
245 которые реализуют множетсво криптографических алгоритмов, включая DES,
246 RC4, RSA и SSL. Включает статические библиотеки для разработки
247 приложений с использованием OpenSSL.
248
249 %description static -l uk.UTF-8
250 Програма openssl для роботи з сертифікатами та бібліотеки спільного
251 користування, що реалізують велику кількість криптографічних
252 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
253 бібліотеки для розробки програм з використанням SSL.
254
255 %prep
256 %if %{with snap}
257 %setup -qcT -a1
258 %{__mv} %{name}-OpenSSL_1_1_1-stable/* .
259 %else
260 %setup -q %{?subver:-n %{name}-%{version}-%{subver}}
261 %endif
262 %patch1 -p1
263
264 %patch3 -p1
265 %patch5 -p1
266 %patch6 -p1
267 %patch7 -p1
268 %patch8 -p1
269
270 %patch11 -p1
271
272 %build
273 touch Makefile.*
274
275 PERL="%{__perl}" \
276 %{__perl} ./Configure \
277         --prefix=%{_prefix} \
278         --openssldir=%{_sysconfdir}/%{name} \
279         --libdir=%{_lib} \
280         -Wa,--noexecstack \
281         shared \
282         threads \
283         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
284         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
285         %{!?with_zlib:no-}zlib \
286         enable-cms \
287         enable-idea \
288         enable-md2 \
289         enable-mdc2 \
290         enable-rc5 \
291         enable-rfc3779 \
292         enable-sctp \
293         enable-seed \
294 %ifarch %{x8664}
295         enable-ec_nistp_64_gcc_128 \
296 %endif
297 %ifarch %{ix86}
298 %ifarch i386
299         386 linux-elf
300 # ^- allow running on 80386 (default code uses bswapl available on i486+)
301 %else
302         linux-elf
303 %endif
304 %endif
305 %ifarch alpha
306         linux-alpha-gcc
307 %endif
308 %ifarch %{x8664}
309         linux-x86_64
310 %endif
311 %ifarch x32
312         linux-x32
313 %endif
314 %ifarch ia64
315         linux-ia64
316 %endif
317 %ifarch ppc
318         linux-ppc
319 %endif
320 %ifarch ppc64
321         linux-ppc64
322 %endif
323 %ifarch sparc
324         linux-sparcv8
325 %endif
326 %ifarch sparcv9
327         linux-sparcv9
328 %endif
329 %ifarch sparc64
330         linux64-sparcv9
331 %endif
332 %ifarch %{arm}
333         linux-armv4
334 %endif
335 %ifarch aarch64
336         linux-aarch64
337 %endif
338
339 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
340 test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
341
342 # fails with enable-sctp as of 1.1.1
343 %{__rm} test/recipes/80-test_ssl_new.t
344
345 %{__make} -j1 all %{?with_tests:tests} \
346         CC="%{__cc}" \
347         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
348         INSTALLTOP=%{_prefix}
349
350 # Rename POD sources of man pages. "openssl-" prefix is added to each
351 # manpage to avoid potential conflicts with other packages.
352 # openssl-man-namespace.patch mostly marks these pages with "openssl-" prefix.
353
354 for podfile in $(grep -rl '^openssl-' doc/man*); do
355         dir=$(dirname "$podfile")
356         base=$(basename "$podfile")
357         %{__mv} "$podfile" "$dir/openssl-$base"
358 done
359
360 %install
361 rm -rf $RPM_BUILD_ROOT
362 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
363         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
364         $RPM_BUILD_ROOT%{_pkgconfigdir}
365
366 %{__make} -j1 install \
367         CC="%{__cc}" \
368         DESTDIR=$RPM_BUILD_ROOT
369
370 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
371 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
372 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
373
374 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
375 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
376
377 # html version of man pages - not packaged
378 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
379
380 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
381 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
382 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
383
384 %clean
385 rm -rf $RPM_BUILD_ROOT
386
387 %post   -p /sbin/ldconfig
388 %postun -p /sbin/ldconfig
389
390 %triggerpostun -- %{name}-tools < 1.0.0-5
391 # the hashing format has changed in 1.0.0
392 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
393
394 %triggerpostun -- %{name} < 0.9.8i-2
395 # don't do anything on --downgrade
396 if [ $1 -le 1 ]; then
397         exit 0
398 fi
399 if [ -d /var/lib/openssl/certs ] ; then
400         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
401 fi
402 if [ -d /var/lib/openssl/private ] ; then
403         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
404 fi
405 if [ -d /var/lib/openssl ] ; then
406         for f in /var/lib/openssl/* ; do
407                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
408         done
409         rmdir /var/lib/openssl/* 2>/dev/null || :
410         rmdir /var/lib/openssl 2>/dev/null || :
411 fi
412
413 %files
414 %defattr(644,root,root,755)
415 %doc CHANGES LICENSE NEWS README doc/*.txt
416 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*
417 %attr(755,root,root) /%{_lib}/libssl.so.*.*
418 %dir %{_sysconfdir}/%{name}
419 %dir %{_sysconfdir}/%{name}/certs
420 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
421 %dir %{_datadir}/ssl
422
423 %files engines
424 %defattr(644,root,root,755)
425 %dir /%{_lib}/engines-1.1
426 %attr(755,root,root) /%{_lib}/engines-1.1/*.so
427
428 %files tools
429 %defattr(644,root,root,755)
430 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ct_log_list.cnf
431 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
432 %attr(755,root,root) %{_bindir}/c_rehash.sh
433 %attr(755,root,root) %{_bindir}/openssl
434 %attr(754,root,root) %{_bindir}/ssl-certificate
435 %{_mandir}/man1/openssl.1*
436 %{_mandir}/man1/openssl-asn1parse.1*
437 %{_mandir}/man1/openssl-ca.1*
438 %{_mandir}/man1/openssl-ciphers.1*
439 %{_mandir}/man1/openssl-cms.1*
440 %{_mandir}/man1/openssl-crl.1*
441 %{_mandir}/man1/openssl-crl2pkcs7.1*
442 %{_mandir}/man1/openssl-dgst.1*
443 %{_mandir}/man1/openssl-dhparam.1*
444 %{_mandir}/man1/openssl-dsa.1*
445 %{_mandir}/man1/openssl-dsaparam.1*
446 %{_mandir}/man1/openssl-ec.1*
447 %{_mandir}/man1/openssl-ecparam.1*
448 %{_mandir}/man1/openssl-enc.1*
449 %{_mandir}/man1/openssl-engine.1*
450 %{_mandir}/man1/openssl-errstr.1*
451 %{_mandir}/man1/openssl-gendsa.1*
452 %{_mandir}/man1/openssl-genpkey.1*
453 %{_mandir}/man1/openssl-genrsa.1*
454 %{_mandir}/man1/openssl-list.1*
455 %{_mandir}/man1/openssl-nseq.1*
456 %{_mandir}/man1/openssl-ocsp.1*
457 %{_mandir}/man1/openssl-passwd.1*
458 %{_mandir}/man1/openssl-pkcs12.1*
459 %{_mandir}/man1/openssl-pkcs7.1*
460 %{_mandir}/man1/openssl-pkcs8.1*
461 %{_mandir}/man1/openssl-pkey.1*
462 %{_mandir}/man1/openssl-pkeyparam.1*
463 %{_mandir}/man1/openssl-pkeyutl.1*
464 %{_mandir}/man1/openssl-prime.1*
465 %{_mandir}/man1/openssl-rand.1*
466 %{_mandir}/man1/openssl-rehash.1*
467 %{_mandir}/man1/openssl-req.1*
468 %{_mandir}/man1/openssl-rsa.1*
469 %{_mandir}/man1/openssl-rsautl.1*
470 %{_mandir}/man1/openssl-s_client.1*
471 %{_mandir}/man1/openssl-s_server.1*
472 %{_mandir}/man1/openssl-s_time.1*
473 %{_mandir}/man1/openssl-sess_id.1*
474 %{_mandir}/man1/openssl-smime.1*
475 %{_mandir}/man1/openssl-speed.1*
476 %{_mandir}/man1/openssl-spkac.1*
477 %{_mandir}/man1/openssl-srp.1*
478 %{_mandir}/man1/openssl-storeutl.1*
479 %{_mandir}/man1/openssl-ts.1*
480 %{_mandir}/man1/openssl-tsget.1*
481 %{_mandir}/man1/openssl-verify.1*
482 %{_mandir}/man1/openssl-version.1*
483 %{_mandir}/man1/openssl-x509.1*
484 %{_mandir}/man5/openssl-config.5*
485 %{_mandir}/man5/openssl-x509v3_config.5*
486 %lang(pl) %{_mandir}/pl/man1/openssl.1*
487
488 %files tools-perl
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_bindir}/c_rehash
491 %dir %{_libdir}/%{name}
492 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
493 %attr(755,root,root) %{_libdir}/%{name}/tsget
494 %attr(755,root,root) %{_libdir}/%{name}/tsget.pl
495 %{_mandir}/man1/CA.pl.1*
496 %{_mandir}/man1/c_rehash.1*
497
498 %files devel
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/libcrypto.so
501 %attr(755,root,root) %{_libdir}/libssl.so
502 %{_includedir}/%{name}
503 %{_pkgconfigdir}/libcrypto.pc
504 %{_pkgconfigdir}/libssl.pc
505 %{_pkgconfigdir}/openssl.pc
506 %{_mandir}/man3/ACCESS_DESCRIPTION_*.3*
507 %{_mandir}/man3/ADMISSION*.3*
508 %{_mandir}/man3/ASId*.3*
509 %{_mandir}/man3/ASRange_*.3*
510 %{_mandir}/man3/ASN1_*.3*
511 %{_mandir}/man3/ASYNC_*.3*
512 %{_mandir}/man3/AUTHORITY_*.3*
513 %{_mandir}/man3/BASIC_CONSTRAINTS_*.3*
514 %{_mandir}/man3/BF_*.3*
515 %{_mandir}/man3/BIO_*.3*
516 %{_mandir}/man3/BN_*.3*
517 %{_mandir}/man3/BUF_*.3*
518 %{_mandir}/man3/CERTIFICATEPOLICIES_*.3*
519 %{_mandir}/man3/CMS_*.3*
520 %{_mandir}/man3/CONF_*.3*
521 %{_mandir}/man3/CRL_DIST_POINTS_*.3*
522 %{_mandir}/man3/CRYPTO_*.3*
523 %{_mandir}/man3/CTLOG_*.3*
524 %{_mandir}/man3/CT_POLICY_*.3*
525 %{_mandir}/man3/DECLARE_*.3*
526 %{_mandir}/man3/DEFINE_*.3*
527 %{_mandir}/man3/DES_*.3*
528 %{_mandir}/man3/DH_*.3*
529 %{_mandir}/man3/DHparams_*.3*
530 %{_mandir}/man3/DIRECTORYSTRING_*.3*
531 %{_mandir}/man3/DISPLAYTEXT_*.3*
532 %{_mandir}/man3/DIST_POINT_*.3*
533 %{_mandir}/man3/DSA_*.3*
534 %{_mandir}/man3/DSAparams_*.3*
535 %{_mandir}/man3/DTLS_*.3*
536 %{_mandir}/man3/DTLSv1_*.3*
537 %{_mandir}/man3/ECDH_*.3*
538 %{_mandir}/man3/ECDSA_*.3*
539 %{_mandir}/man3/ECPARAMETERS_*.3*
540 %{_mandir}/man3/ECPKPARAMETERS_*.3*
541 %{_mandir}/man3/ECPKParameters_*.3*
542 %{_mandir}/man3/EC_*.3*
543 %{_mandir}/man3/EDIPARTYNAME_*.3*
544 %{_mandir}/man3/ENGINE_*.3*
545 %{_mandir}/man3/ERR_*.3*
546 %{_mandir}/man3/ESS_*.3*
547 %{_mandir}/man3/EVP_*.3*
548 %{_mandir}/man3/EXTENDED_KEY_USAGE_*.3*
549 %{_mandir}/man3/GENERAL_*.3*
550 %{_mandir}/man3/GEN_SESSION_CB.3*
551 %{_mandir}/man3/HMAC*.3*
552 %{_mandir}/man3/IMPLEMENT_*.3*
553 %{_mandir}/man3/IPAddress*.3*
554 %{_mandir}/man3/ISSUING_DIST_POINT_*.3*
555 %{_mandir}/man3/LHASH*.3*
556 %{_mandir}/man3/MD2*.3*
557 %{_mandir}/man3/MD4*.3*
558 %{_mandir}/man3/MD5*.3*
559 %{_mandir}/man3/MDC2*.3*
560 %{_mandir}/man3/NAME_CONSTRAINTS_*.3*
561 %{_mandir}/man3/NAMING_AUTHORITY*.3*
562 %{_mandir}/man3/NETSCAPE_*.3*
563 %{_mandir}/man3/NOTICEREF_*.3*
564 %{_mandir}/man3/OBJ_*.3*
565 %{_mandir}/man3/OCSP_*.3*
566 %{_mandir}/man3/OPENSSL_*.3*
567 %{_mandir}/man3/OSSL*.3*
568 %{_mandir}/man3/OTHERNAME_*.3*
569 %{_mandir}/man3/OpenSSL_*.3*
570 %{_mandir}/man3/PBE2PARAM_*.3*
571 %{_mandir}/man3/PBEPARAM_*.3*
572 %{_mandir}/man3/PBKDF2PARAM_*.3*
573 %{_mandir}/man3/PEM_*.3*
574 %{_mandir}/man3/PKCS12_*.3*
575 %{_mandir}/man3/PKCS5_*.3*
576 %{_mandir}/man3/PKCS7_*.3*
577 %{_mandir}/man3/PKCS8_*.3*
578 %{_mandir}/man3/PKEY_*.3*
579 %{_mandir}/man3/POLICYINFO_*.3*
580 %{_mandir}/man3/POLICYQUALINFO_*.3*
581 %{_mandir}/man3/POLICY_*.3*
582 %{_mandir}/man3/PROFESSION_INFO*.3*
583 %{_mandir}/man3/PROXY_*.3*
584 %{_mandir}/man3/RAND_*.3*
585 %{_mandir}/man3/RC4*.3*
586 %{_mandir}/man3/RIPEMD160*.3*
587 %{_mandir}/man3/RSAPrivateKey_*.3*
588 %{_mandir}/man3/RSAPublicKey_*.3*
589 %{_mandir}/man3/RSA_*.3*
590 %{_mandir}/man3/SCRYPT_PARAMS*.3*
591 %{_mandir}/man3/SCT_*.3*
592 %{_mandir}/man3/SHA1*.3*
593 %{_mandir}/man3/SHA224*.3*
594 %{_mandir}/man3/SHA256*.3*
595 %{_mandir}/man3/SHA384*.3*
596 %{_mandir}/man3/SHA512*.3*
597 %{_mandir}/man3/SMIME_*.3*
598 %{_mandir}/man3/SSL_*.3*
599 %{_mandir}/man3/SSLv23_*.3*
600 %{_mandir}/man3/SSLv3_*.3*
601 %{_mandir}/man3/SXNET_*.3*
602 %{_mandir}/man3/SXNETID_*.3*
603 %{_mandir}/man3/TLS_*.3*
604 %{_mandir}/man3/TLSv1_*.3*
605 %{_mandir}/man3/TS_*.3*
606 %{_mandir}/man3/UI*.3*
607 %{_mandir}/man3/USERNOTICE_*.3*
608 %{_mandir}/man3/X509_*.3*
609 %{_mandir}/man3/X509V3_*.3*
610 %{_mandir}/man3/X509v3_*.3*
611 %{_mandir}/man3/custom_ext_*.3*
612 %{_mandir}/man3/d2i_*.3*
613 %{_mandir}/man3/i2d_*.3*
614 %{_mandir}/man3/i2o_*.3*
615 %{_mandir}/man3/i2t_*.3*
616 %{_mandir}/man3/lh_TYPE_*.3*
617 %{_mandir}/man3/o2i_*.3*
618 %{_mandir}/man3/pem_password_cb.3*
619 %{_mandir}/man3/sk_TYPE_*.3*
620 %{_mandir}/man3/ssl_ct_validation_cb.3*
621 %{_mandir}/man7/openssl.7*
622 %{_mandir}/man7/openssl-bio.7*
623 %{_mandir}/man7/openssl-crypto.7*
624 %{_mandir}/man7/openssl-ct.7*
625 %{_mandir}/man7/openssl-des_modes.7*
626 %{_mandir}/man7/openssl-Ed25519.7*
627 %{_mandir}/man7/openssl-Ed448.7*
628 %{_mandir}/man7/openssl-evp.7*
629 %{_mandir}/man7/openssl-passphrase-encoding.7*
630 %{_mandir}/man7/openssl-RAND.7*
631 %{_mandir}/man7/openssl-RAND_DRBG.7*
632 %{_mandir}/man7/openssl-scrypt.7*
633 %{_mandir}/man7/openssl-SM2.7*
634 %{_mandir}/man7/openssl-ssl.7*
635 %{_mandir}/man7/openssl-X25519.7*
636 %{_mandir}/man7/openssl-X448.7*
637 %{_mandir}/man7/openssl-x509.7*
638 %{_mandir}/man7/ossl_store.7*
639 %{_mandir}/man7/ossl_store-file.7*
640 %{_mandir}/man7/proxy-certificates.7*
641 %{_mandir}/man7/RSA-PSS.7.gz
642
643 %files static
644 %defattr(644,root,root,755)
645 %{_libdir}/libcrypto.a
646 %{_libdir}/libssl.a
This page took 0.079286 seconds and 2 git commands to generate.