]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- updated to 0.9.4,
[packages/openssl.git] / openssl.spec
1 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
2 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
3 Name:           openssl
4 Version:        0.9.4
5 Release:        1
6 Group:          Libraries
7 Group(pl):      Biblioteki
8 Source:         ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
9 Patch0:         openssl-sslcrypto.patch
10 Patch1:         openssl-perl.patch
11 Vendor:         The OpenSSL Project
12 License:        Apache-style License
13 BuildRequires:  symlinks
14 BuildRequires:  perl
15 BuildRoot:      /tmp/%{name}-%{version}-root
16 Obsoletes:      SSLeay
17 Obsoletes:      SSLeay-devel
18 Obsoletes:      SSLeay-perl
19
20 %define         openssldir      /var/state/openssl
21 %define         _sysconfdir     /etc/%{name}
22 %define         _pkglibdir      %{_libdir}/%{name}
23 %define         _pkgincludedir  %{_includedir}/%{name}
24
25 %description
26 The OpenSSL Project is a collaborative effort to develop a robust,
27 commercial-grade, full-featured, and Open Source toolkit implementing
28 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
29 v1) protocols with full-strength cryptography world-wide. The project
30 is managed by a worldwide community of volunteers that use the
31 Internet to communicate, plan, and develop the OpenSSL tookit and its
32 related documentation.
33    
34 OpenSSL is based on the excellent SSLeay library developed by Eric A.
35 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
36 Apache-style licence, which basically means that you are free to get
37 and use it for commercial and non-commercial purposes subject to some
38 simple license conditions.
39
40 %description -l de
41 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared libraries,
42 die verschiedene Verschlüsselungs- und Entschlüsselungsalgorithmen und
43 -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.                                                 
44
45 %description -l fr
46 OpenSSL est un outiil de gestion des certificats et les librairies partagees
47 qui fournit plusieurs protocoles et algorithmes de codage/decodage, incluant
48 DES, RC4, RSA et SSL.
49
50 %package devel
51 Summary:        Development part of OpenSSL library
52 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
53 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
54 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
55 Group:          Development/Libraries
56 Group(pl):      Programowanie/Biblioteki
57 Requires:       %{name} = %{version}
58
59 %description devel
60 Development part of OpenSSL library.
61
62 %description devel -l pl
63 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
64
65 %package static
66 Summary:        Static OpenSSL library
67 Summary(pl):    Statyczna wersja biblioteki OpenSSL
68 Group:          Development/Libraries
69 Group(pl):      Programowanie/Biblioteki
70 Requires:       %{name}-devel = %{version}
71
72 %description static
73 Static OpenSSL library.
74
75 %description static -l pl
76 Statyczna wersja biblioteki OpenSSL.
77
78 %prep
79 %setup  -q 
80 %patch0 -p1
81 %patch1 -p1
82
83 %build
84 for i in ` echo Configure Makefile.org `; do
85         sed -e 's#-m486##g' \
86                 -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
87                 <$i >$i.work
88         mv $i.work $i
89 done
90
91 perl util/perlpath.pl %{_bindir}
92
93 ln -s crypto sslcrypto
94
95 ./config --openssldir=%{openssldir}
96
97 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
98 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
99 make rehash
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
105
106 make install \
107         INSTALLTOP=%{_prefix} \
108         INSTALL_PREFIX=$RPM_BUILD_ROOT
109
110 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
111 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
112 mv      lib*.so         $RPM_BUILD_ROOT%{_libdir}
113
114
115 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
116 ln -s %{_sysconfdir}/openssl.cnf \
117         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
118 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
119
120 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
121 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
122
123 strip $RPM_BUILD_ROOT%{_bindir}/* || :
124 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
125
126 gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
127         doc/*.pod doc/*.txt
128
129 %post
130 %{_bindir}/c_rehash certs
131 /sbin/ldconfig
132
133 %postun -p /sbin/ldconfig
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
141 %doc doc/*.pod.gz doc/*.txt.gz
142 %doc doc/openssl_button.gif doc/openssl_button.html
143
144 %attr(755,root,root) %{_bindir}/*
145 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
146 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
147 %{openssldir}/certs
148 %{openssldir}/private
149 %dir %{_pkglibdir}
150 %attr(755,root,root) %{_pkglibdir}/*
151 %attr(755,root,root) %{_libdir}/lib*.so.*.*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/lib*.so
156 %{_pkgincludedir}
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/lib*.a
This page took 0.040317 seconds and 3 git commands to generate.