]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
python3 rebuild
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 # - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
4 #
5 # Conditional build:
6 %bcond_without  tests   # don't perform "make tests"
7 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
8 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
9 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
10 %bcond_with     purify  # Compile openssl with "-DPURIFY", useful when one wants to
11                         # use valgrind debugger against openssl-linked programs
12 %bcond_with     snap    # use GitHub snapshot to build branch release
13
14 %include        /usr/lib/rpm/macros.perl
15 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
16 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
17 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
18 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
19 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
20 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
21 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
22 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
23 Name:           openssl
24 # 1.0.2 will be LTS release
25 # Version 1.0.2 will be supported until 2019-12-31.
26 # https://www.openssl.org/about/releasestrat.html
27 Version:        1.0.2g
28 Release:        6
29 License:        Apache-like
30 Group:          Libraries
31 %if %{without snap}
32 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
33 # Source0-md5:  f3c710c045cdee5fd114feb69feba7aa
34 %else
35 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
36 %endif
37 Source2:        %{name}.1.pl
38 Source3:        %{name}-ssl-certificate.sh
39 Source4:        %{name}-c_rehash.sh
40 Patch0:         %{name}-alpha-ccc.patch
41 Patch1:         %{name}-optflags.patch
42 Patch2:         %{name}-include.patch
43 Patch3:         %{name}-man-namespace.patch
44 Patch4:         %{name}-asflag.patch
45 Patch5:         %{name}-ca-certificates.patch
46 Patch6:         %{name}-ldflags.patch
47 Patch7:         %{name}-find.patch
48 Patch8:         pic.patch
49 Patch10:        %{name}_fix_for_x32.patch
50 URL:            http://www.openssl.org/
51 BuildRequires:  bc
52 BuildRequires:  perl-devel >= 1:5.6.1
53 BuildRequires:  rpm-perlprov >= 4.1-13
54 BuildRequires:  rpmbuild(macros) >= 1.213
55 BuildRequires:  sed >= 4.0
56 Requires:       ca-certificates >= 20120623-1.1
57 Requires:       rpm-whiteout >= 1.7
58 Obsoletes:      SSLeay
59 Obsoletes:      SSLeay-devel
60 Obsoletes:      SSLeay-perl
61 Obsoletes:      libopenssl0
62 %if "%{pld_release}" == "ac"
63 Conflicts:      neon < 0.26.3-3
64 Conflicts:      ntpd < 4.2.4p8-10
65 Conflicts:      openssh-clients < 2:5.8p1-9
66 Conflicts:      openssh-server < 2:5.8p1-9
67 %else
68 Conflicts:      apache-mod_ssl < 1:2.2.31-4
69 Conflicts:      curl-libs < 7.47.1-2
70 Conflicts:      neon < 0.29.6-8
71 Conflicts:      openssh-clients < 2:6.2p2-3
72 Conflicts:      openssh-server < 2:6.2p2-3
73 Conflicts:      php52-common < 4:5.2.17-20130717.17
74 Conflicts:      php53-common < 4:5.3.29-27
75 Conflicts:      php54-common < 4:5.4.45-5
76 Conflicts:      php55-common < 4:5.5.32-2
77 Conflicts:      php56-common < 4:5.6.18-3
78 Conflicts:      python-modules < 1:2.7.10-8
79 Conflicts:      python3-modules < 1:3.5.0-9
80 Conflicts:      ruby-modules < 1:2.0.0.648-2
81 %endif
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 The OpenSSL Project is a collaborative effort to develop a robust,
86 commercial-grade, full-featured, and Open Source toolkit implementing
87 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
88 v1) protocols with full-strength cryptography world-wide. The project
89 is managed by a worldwide community of volunteers that use the
90 Internet to communicate, plan, and develop the OpenSSL tookit and its
91 related documentation.
92
93 OpenSSL is based on the excellent SSLeay library developed by Eric A.
94 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
95 Apache-style licence, which basically means that you are free to get
96 and use it for commercial and non-commercial purposes subject to some
97 simple license conditions.
98
99 This package contains shared libraries only, install openssl-tools if
100 you want to use openssl cmdline tool.
101
102 %description -l de.UTF-8
103 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
104 libraries, die verschiedene Verschlüsselungs- und
105 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
106 zur Verfügung stellen.
107
108 %description -l es.UTF-8
109 Biblioteca C que suministra algoritmos y protocolos criptográficos.
110
111 %description -l fr.UTF-8
112 OpenSSL est un outiil de gestion des certificats et les librairies
113 partagees qui fournit plusieurs protocoles et algorithmes de
114 codage/decodage, incluant DES, RC4, RSA et SSL.
115
116 %description -l pl.UTF-8
117 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
118 v2/v3 oraz Transport Layer Security (TLS v1).
119
120 %description -l pt_BR.UTF-8
121 Uma biblioteca C que fornece vários algoritmos e protocolos
122 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
123 compartilhadas e utilitários.
124
125 %description -l ru.UTF-8
126 Программа openssl для работы с сертификатами и разделяемые библиотеки,
127 которые реализуют множетсво криптографических алгоритмов, включая DES,
128 RC4, RSA и SSL.
129
130 %description -l uk.UTF-8
131 Програма openssl для роботи з сертифікатами та бібліотеки спільного
132 користування, що реалізують велику кількість криптографічних
133 алгоритмів, включаючи DES, RC4, RSA та SSL.
134
135 %package engines
136 Summary:        OpenSSL optional crypto engines
137 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
138 Group:          Libraries
139 Requires:       %{name} = %{version}-%{release}
140
141 %description engines
142 With OpenSSL 0.9.6, a new component was added to support alternative
143 cryptography implementations, most commonly for interfacing with
144 external crypto devices (eg. accelerator cards). This component is
145 called ENGINE.
146
147 There are currently built-in ENGINE implementations for the following
148 crypto devices:
149
150 - CryptoSwift
151 - Compaq Atalla
152 - nCipher CHIL
153 - Nuron
154 - Broadcom uBSec
155
156 In addition, dynamic binding to external ENGINE implementations is now
157 provided by a special ENGINE called "dynamic".
158
159 %description engines -l pl.UTF-8
160 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
161 wspierać alternatywne implementacje kryptografii, przeważnie
162 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
163 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
164 ENGINE).
165
166 Obecnie istnieją wbudowane implementacje silników dla następujących
167 urządzeń kryptograficznych:
168 - CryptoSwift
169 - Compaq Atalla
170 - nCipher CHIL
171 - Nuron
172 - Broadcom uBSec
173
174 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
175 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
176
177 %package tools
178 Summary:        OpenSSL command line tool and utilities
179 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
180 Group:          Applications/Communications
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       which
183
184 %description tools
185 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
186
187 %description tools -l pl.UTF-8
188 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
189
190 %package tools-perl
191 Summary:        OpenSSL utilities written in Perl
192 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
193 Group:          Applications/Communications
194 Requires:       %{name} = %{version}-%{release}
195
196 %description tools-perl
197 OpenSSL Toolkit tools written in Perl.
198
199 %description tools-perl -l pl.UTF-8
200 Narzędzia OpenSSL napisane w perlu.
201
202 %package devel
203 Summary:        Development part of OpenSSL Toolkit libraries
204 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
205 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
206 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
207 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
208 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
209 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
210 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
211 Group:          Development/Libraries
212 Requires:       %{name} = %{version}-%{release}
213 Obsoletes:      libopenssl0-devel
214
215 %description devel
216 Development part of OpenSSL library.
217
218 %description devel -l es.UTF-8
219 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
220
221 %description devel -l pl.UTF-8
222 Część biblioteki OpenSSL przeznaczona dla programistów.
223
224 %description devel -l pt_BR.UTF-8
225 Uma biblioteca C que fornece vários algoritmos e protocolos
226 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
227 arquivos de inclusão para desenvolvimento.
228
229 %description devel -l ru.UTF-8
230 Программа openssl для работы с сертификатами и разделяемые библиотеки,
231 которые реализуют множетсво криптографических алгоритмов, включая DES,
232 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
233 с использованием SSL.
234
235 %description devel -l uk.UTF-8
236 Програма openssl для роботи з сертифікатами та бібліотеки спільного
237 користування, що реалізують велику кількість криптографічних
238 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
239 хедери для розробки програм з використанням SSL.
240
241 %package static
242 Summary:        Static OpenSSL libraries
243 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
244 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
245 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
246 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
247 Group:          Development/Libraries
248 Requires:       %{name}-devel = %{version}-%{release}
249
250 %description static
251 Static OpenSSL Toolkit libraries.
252
253 %description static -l pl.UTF-8
254 Statyczne wersje bibliotek z OpenSSL.
255
256 %description static -l pt_BR.UTF-8
257 Bibliotecas estáticas para desenvolvimento com openssl.
258
259 %description static -l ru.UTF-8
260 Программа openssl для работы с сертификатами и разделяемые библиотеки,
261 которые реализуют множетсво криптографических алгоритмов, включая DES,
262 RC4, RSA и SSL. Включает статические библиотеки для разработки
263 приложений с использованием OpenSSL.
264
265 %description static -l uk.UTF-8
266 Програма openssl для роботи з сертифікатами та бібліотеки спільного
267 користування, що реалізують велику кількість криптографічних
268 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
269 бібліотеки для розробки програм з використанням SSL.
270
271 %prep
272 %if %{with snap}
273 %setup -qcT -a1
274 mv %{name}-OpenSSL_1_0_2-stable/* .
275 %else
276 %setup -q
277 %endif
278 %patch0 -p1
279 %patch1 -p1
280 %patch2 -p1
281 %patch3 -p1
282 %patch4 -p1
283 %patch5 -p1
284 %patch6 -p1
285 %patch7 -p1
286 %patch8 -p1
287 %ifarch x32
288 %patch10 -p1
289 %endif
290
291 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
292
293 %build
294 touch Makefile.*
295
296 %{__perl} util/perlpath.pl %{__perl}
297
298 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
299 PERL="%{__perl}" \
300 %{__perl} ./Configure \
301         --openssldir=%{_sysconfdir}/%{name} \
302         --libdir=%{_lib} \
303         shared \
304         threads \
305         %{!?with_sslv2:no-ssl2} \
306         %{!?with_sslv3:no-ssl3} \
307         %{!?with_zlib:no-}zlib \
308         enable-camelia \
309         enable-cms \
310         enable-idea \
311         enable-md2 \
312         enable-mdc2 \
313         enable-rc5 \
314         enable-rfc3779 \
315         enable-seed \
316         enable-tlsext \
317 %ifarch %{x8664}
318         enable-ec_nistp_64_gcc_128 \
319 %endif
320 %ifarch %{ix86}
321 %ifarch i386
322         386 linux-elf
323 # ^- allow running on 80386 (default code uses bswapl available on i486+)
324 %else
325         linux-elf
326 %endif
327 %endif
328 %ifarch alpha
329         linux-alpha+bwx-gcc
330 %endif
331 %ifarch %{x8664}
332         linux-x86_64
333 %endif
334 %ifarch x32
335         linux-x32
336 %endif
337 %ifarch ia64
338         linux-ia64
339 %endif
340 %ifarch ppc
341         linux-ppc
342 %endif
343 %ifarch ppc64
344         linux-ppc64
345 %endif
346 %ifarch sparc
347         linux-sparcv8
348 %endif
349 %ifarch sparcv9
350         linux-sparcv9
351 %endif
352 %ifarch sparc64
353         linux64-sparcv9
354 %endif
355 %ifarch armv4 armv5 armv5t armv5te armv5tel
356         linux-armv4
357 %endif
358
359 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
360 test "$v" = %{version}%{?with_snap:-dev}
361
362 %{__make} -j1 all rehash %{?with_tests:tests} \
363         CC="%{__cc}" \
364         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
365         INSTALLTOP=%{_prefix}
366
367 # Rename POD sources of man pages. "openssl_" prefix is added to each
368 # manpage to avoid potential conflicts with other packages.
369
370 for dir in doc/{apps,ssl,crypto}; do
371         cd $dir || exit 1;
372         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
373
374         for pod in !(openssl*).pod; do
375                 mv -f $pod openssl_$pod;
376         done
377         cd ../..
378 done
379
380 %install
381 rm -rf $RPM_BUILD_ROOT
382 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
383         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
384         $RPM_BUILD_ROOT/%{_lib}/engines \
385         $RPM_BUILD_ROOT%{_pkgconfigdir}
386
387 %{__make} -j1 install \
388         INSTALLTOP=%{_prefix} \
389         INSTALL_PREFIX=$RPM_BUILD_ROOT \
390         MANDIR=%{_mandir}
391
392 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
393 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
394 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
395 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
396
397 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
398 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
399
400 # not installed as individual utilities (see openssl dgst instead)
401 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
402
403 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
404 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
405 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
406
407 %clean
408 rm -rf $RPM_BUILD_ROOT
409
410 %post   -p /sbin/ldconfig
411 %postun -p /sbin/ldconfig
412
413 %triggerpostun -- %{name}-tools < 1.0.0-5
414 # the hashing format has changed in 1.0.0
415 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
416
417 %triggerpostun -- %{name} < 0.9.8i-2
418 # don't do anything on --downgrade
419 if [ $1 -le 1 ]; then
420         exit 0
421 fi
422 if [ -d /var/lib/openssl/certs ] ; then
423         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
424 fi
425 if [ -d /var/lib/openssl/private ] ; then
426         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
427 fi
428 if [ -d /var/lib/openssl ] ; then
429         for f in /var/lib/openssl/* ; do
430                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
431         done
432         rmdir /var/lib/openssl/* 2>/dev/null || :
433         rmdir /var/lib/openssl 2>/dev/null || :
434 fi
435
436 %files
437 %defattr(644,root,root,755)
438 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
439 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
440 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
441 %dir %{_sysconfdir}/%{name}
442 %dir %{_sysconfdir}/%{name}/certs
443 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
444 %dir %{_datadir}/ssl
445
446 %files engines
447 %defattr(644,root,root,755)
448 %dir /%{_lib}/engines
449 %attr(755,root,root) /%{_lib}/engines/*.so
450
451 %files tools
452 %defattr(644,root,root,755)
453 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
454 %attr(755,root,root) %{_bindir}/c_rehash.sh
455 %attr(755,root,root) %{_bindir}/openssl
456 %attr(754,root,root) %{_bindir}/ssl-certificate
457
458 %dir %{_libdir}/%{name}
459 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
460 %attr(755,root,root) %{_libdir}/%{name}/c_hash
461 %attr(755,root,root) %{_libdir}/%{name}/c_info
462 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
463 %attr(755,root,root) %{_libdir}/%{name}/c_name
464
465 %{_mandir}/man1/openssl.1*
466 %{_mandir}/man1/openssl_asn1parse.1*
467 %{_mandir}/man1/openssl_ca.1*
468 %{_mandir}/man1/openssl_ciphers.1*
469 %{_mandir}/man1/openssl_cms.1*
470 %{_mandir}/man1/openssl_crl.1*
471 %{_mandir}/man1/openssl_crl2pkcs7.1*
472 %{_mandir}/man1/openssl_dgst.1*
473 %{_mandir}/man1/openssl_dhparam.1*
474 %{_mandir}/man1/openssl_dsa.1*
475 %{_mandir}/man1/openssl_dsaparam.1*
476 %{_mandir}/man1/openssl_ec.1*
477 %{_mandir}/man1/openssl_ecparam.1*
478 %{_mandir}/man1/openssl_enc.1*
479 %{_mandir}/man1/openssl_errstr.1*
480 %{_mandir}/man1/openssl_gendsa.1*
481 %{_mandir}/man1/openssl_genpkey.1*
482 %{_mandir}/man1/openssl_genrsa.1*
483 %{_mandir}/man1/openssl_nseq.1*
484 %{_mandir}/man1/openssl_ocsp.1*
485 %{_mandir}/man1/openssl_passwd.1*
486 %{_mandir}/man1/openssl_pkcs12.1*
487 %{_mandir}/man1/openssl_pkcs7.1*
488 %{_mandir}/man1/openssl_pkcs8.1*
489 %{_mandir}/man1/openssl_pkey.1*
490 %{_mandir}/man1/openssl_pkeyparam.1*
491 %{_mandir}/man1/openssl_pkeyutl.1*
492 %{_mandir}/man1/openssl_rand.1*
493 %{_mandir}/man1/openssl_req.1*
494 %{_mandir}/man1/openssl_rsa.1*
495 %{_mandir}/man1/openssl_rsautl.1*
496 %{_mandir}/man1/openssl_s_client.1*
497 %{_mandir}/man1/openssl_s_server.1*
498 %{_mandir}/man1/openssl_s_time.1*
499 %{_mandir}/man1/openssl_sess_id.1*
500 %{_mandir}/man1/openssl_smime.1*
501 %{_mandir}/man1/openssl_speed.1*
502 %{_mandir}/man1/openssl_spkac.1*
503 %{_mandir}/man1/openssl_ts.1*
504 %{_mandir}/man1/openssl_tsget.1*
505 %{_mandir}/man1/openssl_verify.1*
506 %{_mandir}/man1/openssl_version.1*
507 %{_mandir}/man1/openssl_x509.1*
508 %{_mandir}/man5/openssl_config.5*
509 %{_mandir}/man5/openssl_x509v3_config.5*
510 %lang(pl) %{_mandir}/pl/man1/openssl.1*
511
512 %files tools-perl
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/c_rehash
515 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
516 %attr(755,root,root) %{_libdir}/%{name}/tsget
517 %{_mandir}/man1/openssl_CA.pl.1*
518 %{_mandir}/man1/openssl_c_rehash.1*
519
520 %files devel
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_libdir}/libcrypto.so
523 %attr(755,root,root) %{_libdir}/libssl.so
524 %{_includedir}/%{name}
525 %{_pkgconfigdir}/libcrypto.pc
526 %{_pkgconfigdir}/libssl.pc
527 %{_pkgconfigdir}/openssl.pc
528 %{_mandir}/man3/openssl*.3*
529 %{_mandir}/man7/openssl_des_modes.7*
530
531 %files static
532 %defattr(644,root,root,755)
533 %{_libdir}/libcrypto.a
534 %{_libdir}/libssl.a
This page took 0.15301 seconds and 3 git commands to generate.