]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- x32 rebuild
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform "make tests"
6 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
7 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
8 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
9 %bcond_with     purify  # Compile openssl with \-DPURIFY, useful when one wants to
10                         # use valgrind debugger against openssl-linked programs
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
14 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
15 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
16 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
17 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
18 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
19 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
20 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
21 Name:           openssl
22 Version:        1.0.2
23 Release:        2
24 License:        Apache-like
25 Group:          Libraries
26 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
27 # Source0-md5:  38373013fc85c790aabf8837969c5eba
28 Source2:        %{name}.1.pl
29 Source3:        %{name}-ssl-certificate.sh
30 Source4:        %{name}-c_rehash.sh
31 Patch0:         %{name}-alpha-ccc.patch
32 Patch1:         %{name}-optflags.patch
33 Patch2:         %{name}-include.patch
34 Patch3:         %{name}-man-namespace.patch
35 Patch4:         %{name}-asflag.patch
36 Patch5:         %{name}-ca-certificates.patch
37 Patch6:         %{name}-ldflags.patch
38 Patch7:         %{name}-find.patch
39 Patch8:         pic.patch
40 Patch9:         stddef.patch
41 Patch10:        %{name}_fix_for_x32.patch
42 URL:            http://www.openssl.org/
43 BuildRequires:  bc
44 BuildRequires:  perl-devel >= 1:5.6.1
45 BuildRequires:  rpm-perlprov >= 4.1-13
46 BuildRequires:  rpmbuild(macros) >= 1.213
47 BuildRequires:  sed >= 4.0
48 Requires:       ca-certificates >= 20080809-4
49 Requires:       rpm-whiteout >= 1.7
50 Obsoletes:      SSLeay
51 Obsoletes:      SSLeay-devel
52 Obsoletes:      SSLeay-perl
53 Obsoletes:      libopenssl0
54 %if "%{pld_release}" != "ac"
55 Conflicts:      neon < 0.29.6-8
56 Conflicts:      openssh-clients < 2:6.2p2-3
57 Conflicts:      openssh-server < 2:6.2p2-3
58 %endif
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 The OpenSSL Project is a collaborative effort to develop a robust,
63 commercial-grade, full-featured, and Open Source toolkit implementing
64 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
65 v1) protocols with full-strength cryptography world-wide. The project
66 is managed by a worldwide community of volunteers that use the
67 Internet to communicate, plan, and develop the OpenSSL tookit and its
68 related documentation.
69
70 OpenSSL is based on the excellent SSLeay library developed by Eric A.
71 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
72 Apache-style licence, which basically means that you are free to get
73 and use it for commercial and non-commercial purposes subject to some
74 simple license conditions.
75
76 This package contains shared libraries only, install openssl-tools if
77 you want to use openssl cmdline tool.
78
79 %description -l de.UTF-8
80 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
81 libraries, die verschiedene Verschlüsselungs- und
82 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
83 zur Verfügung stellen.
84
85 %description -l es.UTF-8
86 Biblioteca C que suministra algoritmos y protocolos criptográficos.
87
88 %description -l fr.UTF-8
89 OpenSSL est un outiil de gestion des certificats et les librairies
90 partagees qui fournit plusieurs protocoles et algorithmes de
91 codage/decodage, incluant DES, RC4, RSA et SSL.
92
93 %description -l pl.UTF-8
94 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
95 v2/v3 oraz Transport Layer Security (TLS v1).
96
97 %description -l pt_BR.UTF-8
98 Uma biblioteca C que fornece vários algoritmos e protocolos
99 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
100 compartilhadas e utilitários.
101
102 %description -l ru.UTF-8
103 Программа openssl для работы с сертификатами и разделяемые библиотеки,
104 которые реализуют множетсво криптографических алгоритмов, включая DES,
105 RC4, RSA и SSL.
106
107 %description -l uk.UTF-8
108 Програма openssl для роботи з сертифікатами та бібліотеки спільного
109 користування, що реалізують велику кількість криптографічних
110 алгоритмів, включаючи DES, RC4, RSA та SSL.
111
112 %package engines
113 Summary:        OpenSSL optional crypto engines
114 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
115 Group:          Libraries
116 Requires:       %{name} = %{version}-%{release}
117
118 %description engines
119 With OpenSSL 0.9.6, a new component was added to support alternative
120 cryptography implementations, most commonly for interfacing with
121 external crypto devices (eg. accelerator cards). This component is
122 called ENGINE.
123
124 There are currently built-in ENGINE implementations for the following
125 crypto devices:
126
127 - CryptoSwift
128 - Compaq Atalla
129 - nCipher CHIL
130 - Nuron
131 - Broadcom uBSec
132
133 In addition, dynamic binding to external ENGINE implementations is now
134 provided by a special ENGINE called "dynamic".
135
136 %description engines -l pl.UTF-8
137 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
138 wspierać alternatywne implementacje kryptografii, przeważnie
139 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
140 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
141 ENGINE).
142
143 Obecnie istnieją wbudowane implementacje silników dla następujących
144 urządzeń kryptograficznych:
145 - CryptoSwift
146 - Compaq Atalla
147 - nCipher CHIL
148 - Nuron
149 - Broadcom uBSec
150
151 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
152 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
153
154 %package tools
155 Summary:        OpenSSL command line tool and utilities
156 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
157 Group:          Applications/Communications
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       which
160
161 %description tools
162 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
163
164 %description tools -l pl.UTF-8
165 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
166
167 %package tools-perl
168 Summary:        OpenSSL utilities written in Perl
169 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
170 Group:          Applications/Communications
171 Requires:       %{name} = %{version}-%{release}
172
173 %description tools-perl
174 OpenSSL Toolkit tools written in Perl.
175
176 %description tools-perl -l pl.UTF-8
177 Narzędzia OpenSSL napisane w perlu.
178
179 %package devel
180 Summary:        Development part of OpenSSL Toolkit libraries
181 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
182 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
183 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
184 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
185 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
186 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
187 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
188 Group:          Development/Libraries
189 Requires:       %{name} = %{version}-%{release}
190 Obsoletes:      libopenssl0-devel
191
192 %description devel
193 Development part of OpenSSL library.
194
195 %description devel -l es.UTF-8
196 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
197
198 %description devel -l pl.UTF-8
199 Część biblioteki OpenSSL przeznaczona dla programistów.
200
201 %description devel -l pt_BR.UTF-8
202 Uma biblioteca C que fornece vários algoritmos e protocolos
203 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
204 arquivos de inclusão para desenvolvimento.
205
206 %description devel -l ru.UTF-8
207 Программа openssl для работы с сертификатами и разделяемые библиотеки,
208 которые реализуют множетсво криптографических алгоритмов, включая DES,
209 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
210 с использованием SSL.
211
212 %description devel -l uk.UTF-8
213 Програма openssl для роботи з сертифікатами та бібліотеки спільного
214 користування, що реалізують велику кількість криптографічних
215 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
216 хедери для розробки програм з використанням SSL.
217
218 %package static
219 Summary:        Static OpenSSL libraries
220 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
221 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
222 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
223 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
224 Group:          Development/Libraries
225 Requires:       %{name}-devel = %{version}-%{release}
226
227 %description static
228 Static OpenSSL Toolkit libraries.
229
230 %description static -l pl.UTF-8
231 Statyczne wersje bibliotek z OpenSSL.
232
233 %description static -l pt_BR.UTF-8
234 Bibliotecas estáticas para desenvolvimento com openssl.
235
236 %description static -l ru.UTF-8
237 Программа openssl для работы с сертификатами и разделяемые библиотеки,
238 которые реализуют множетсво криптографических алгоритмов, включая DES,
239 RC4, RSA и SSL. Включает статические библиотеки для разработки
240 приложений с использованием OpenSSL.
241
242 %description static -l uk.UTF-8
243 Програма openssl для роботи з сертифікатами та бібліотеки спільного
244 користування, що реалізують велику кількість криптографічних
245 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
246 бібліотеки для розробки програм з використанням SSL.
247
248 %prep
249 %setup -q
250 %patch0 -p1
251 %patch1 -p1
252 %patch2 -p1
253 %patch3 -p1
254 %patch4 -p1
255 %patch5 -p1
256 %patch6 -p1
257 %patch7 -p1
258 %patch8 -p1
259 %patch9 -p1
260 %patch10 -p1
261
262 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
263
264 %build
265 touch Makefile.*
266
267 %{__perl} util/perlpath.pl %{__perl}
268
269 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
270 PERL="%{__perl}" \
271 %{__perl} ./Configure \
272         --openssldir=%{_sysconfdir}/%{name} \
273         --libdir=%{_lib} \
274         shared \
275         threads \
276         %{!?with_sslv2:no-ssl2} \
277         %{!?with_sslv3:no-ssl3} \
278         %{!?with_zlib:no-}zlib \
279         enable-camelia \
280         enable-cms \
281         enable-idea \
282         enable-md2 \
283         enable-mdc2 \
284         enable-rc5 \
285         enable-rfc3779 \
286         enable-seed \
287         enable-tlsext \
288 %ifarch %{x8664}
289         enable-ec_nistp_64_gcc_128 \
290 %endif
291 %ifarch %{ix86}
292 %ifarch i386
293         386 linux-elf
294 # ^- allow running on 80386 (default code uses bswapl available on i486+)
295 %else
296         linux-elf
297 %endif
298 %endif
299 %ifarch alpha
300         linux-alpha+bwx-gcc
301 %endif
302 %ifarch %{x8664}
303         linux-x86_64
304 %endif
305 %ifarch x32
306         linux-x32
307 %endif
308 %ifarch ia64
309         linux-ia64
310 %endif
311 %ifarch ppc
312         linux-ppc
313 %endif
314 %ifarch ppc64
315         linux-ppc64
316 %endif
317 %ifarch sparc
318         linux-sparcv8
319 %endif
320 %ifarch sparcv9
321         linux-sparcv9
322 %endif
323 %ifarch sparc64
324         linux64-sparcv9
325 %endif
326 %ifarch armv4 armv5 armv5t armv5te armv5tel
327         linux-armv4
328 %endif
329
330 %{__make} -j1 all rehash %{?with_tests:tests} \
331         CC="%{__cc}" \
332         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
333         INSTALLTOP=%{_prefix}
334
335 # Rename POD sources of man pages. "openssl_" prefix is added to each
336 # manpage to avoid potential conflicts with other packages.
337
338 for dir in doc/{apps,ssl,crypto}; do
339         cd $dir || exit 1;
340         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
341
342         for pod in !(openssl*).pod; do
343                 mv -f $pod openssl_$pod;
344         done
345         cd ../..
346 done
347
348 %install
349 rm -rf $RPM_BUILD_ROOT
350 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
351         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
352         $RPM_BUILD_ROOT/%{_lib}/engines \
353         $RPM_BUILD_ROOT%{_pkgconfigdir}
354
355 %{__make} -j1 install \
356         INSTALLTOP=%{_prefix} \
357         INSTALL_PREFIX=$RPM_BUILD_ROOT \
358         MANDIR=%{_mandir}
359
360 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
361 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
362 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
363 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
364
365 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
366 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
367
368 # not installed as individual utilities (see openssl dgst instead)
369 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
370
371 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
372 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
373 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
374
375 %clean
376 rm -rf $RPM_BUILD_ROOT
377
378 %post   -p /sbin/ldconfig
379 %postun -p /sbin/ldconfig
380
381 %triggerpostun -- %{name}-tools < 1.0.0-5
382 # the hashing format has changed in 1.0.0
383 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
384
385 %triggerpostun -- %{name} < 0.9.8i-2
386 # don't do anything on --downgrade
387 if [ $1 -le 1 ]; then
388         exit 0
389 fi
390 if [ -d /var/lib/openssl/certs ] ; then
391         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
392 fi
393 if [ -d /var/lib/openssl/private ] ; then
394         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
395 fi
396 if [ -d /var/lib/openssl ] ; then
397         for f in /var/lib/openssl/* ; do
398                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
399         done
400         rmdir /var/lib/openssl/* 2>/dev/null || :
401         rmdir /var/lib/openssl 2>/dev/null || :
402 fi
403
404 %files
405 %defattr(644,root,root,755)
406 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
407 %doc doc/openssl_button.gif doc/openssl_button.html
408 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
409 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
410 %dir %{_sysconfdir}/%{name}
411 %dir %{_sysconfdir}/%{name}/certs
412 %dir %{_sysconfdir}/%{name}/private
413 %dir %{_datadir}/ssl
414
415 %files engines
416 %defattr(644,root,root,755)
417 %dir /%{_lib}/engines
418 %attr(755,root,root) /%{_lib}/engines/*.so
419
420 %files tools
421 %defattr(644,root,root,755)
422 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
423 %attr(755,root,root) %{_bindir}/c_rehash.sh
424 %attr(755,root,root) %{_bindir}/openssl
425 %attr(754,root,root) %{_bindir}/ssl-certificate
426
427 %dir %{_libdir}/%{name}
428 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
429 %attr(755,root,root) %{_libdir}/%{name}/c_hash
430 %attr(755,root,root) %{_libdir}/%{name}/c_info
431 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
432 %attr(755,root,root) %{_libdir}/%{name}/c_name
433
434 %{_mandir}/man1/openssl.1*
435 %{_mandir}/man1/openssl_asn1parse.1*
436 %{_mandir}/man1/openssl_ca.1*
437 %{_mandir}/man1/openssl_ciphers.1*
438 %{_mandir}/man1/openssl_cms.1*
439 %{_mandir}/man1/openssl_crl.1*
440 %{_mandir}/man1/openssl_crl2pkcs7.1*
441 %{_mandir}/man1/openssl_dgst.1*
442 %{_mandir}/man1/openssl_dhparam.1*
443 %{_mandir}/man1/openssl_dsa.1*
444 %{_mandir}/man1/openssl_dsaparam.1*
445 %{_mandir}/man1/openssl_ec.1*
446 %{_mandir}/man1/openssl_ecparam.1*
447 %{_mandir}/man1/openssl_enc.1*
448 %{_mandir}/man1/openssl_errstr.1*
449 %{_mandir}/man1/openssl_gendsa.1*
450 %{_mandir}/man1/openssl_genpkey.1*
451 %{_mandir}/man1/openssl_genrsa.1*
452 %{_mandir}/man1/openssl_nseq.1*
453 %{_mandir}/man1/openssl_ocsp.1*
454 %{_mandir}/man1/openssl_passwd.1*
455 %{_mandir}/man1/openssl_pkcs12.1*
456 %{_mandir}/man1/openssl_pkcs7.1*
457 %{_mandir}/man1/openssl_pkcs8.1*
458 %{_mandir}/man1/openssl_pkey.1*
459 %{_mandir}/man1/openssl_pkeyparam.1*
460 %{_mandir}/man1/openssl_pkeyutl.1*
461 %{_mandir}/man1/openssl_rand.1*
462 %{_mandir}/man1/openssl_req.1*
463 %{_mandir}/man1/openssl_rsa.1*
464 %{_mandir}/man1/openssl_rsautl.1*
465 %{_mandir}/man1/openssl_s_client.1*
466 %{_mandir}/man1/openssl_s_server.1*
467 %{_mandir}/man1/openssl_s_time.1*
468 %{_mandir}/man1/openssl_sess_id.1*
469 %{_mandir}/man1/openssl_smime.1*
470 %{_mandir}/man1/openssl_speed.1*
471 %{_mandir}/man1/openssl_spkac.1*
472 %{_mandir}/man1/openssl_ts.1*
473 %{_mandir}/man1/openssl_tsget.1*
474 %{_mandir}/man1/openssl_verify.1*
475 %{_mandir}/man1/openssl_version.1*
476 %{_mandir}/man1/openssl_x509.1*
477 %{_mandir}/man5/openssl_config.5*
478 %{_mandir}/man5/openssl_x509v3_config.5*
479 %lang(pl) %{_mandir}/pl/man1/openssl.1*
480
481 %files tools-perl
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{_bindir}/c_rehash
484 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
485 %attr(755,root,root) %{_libdir}/%{name}/tsget
486 %{_mandir}/man1/openssl_CA.pl.1*
487 %{_mandir}/man1/openssl_c_rehash.1*
488
489 %files devel
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{_libdir}/libcrypto.so
492 %attr(755,root,root) %{_libdir}/libssl.so
493 %{_includedir}/%{name}
494 %{_pkgconfigdir}/libcrypto.pc
495 %{_pkgconfigdir}/libssl.pc
496 %{_pkgconfigdir}/openssl.pc
497 %{_mandir}/man3/openssl*.3*
498 %{_mandir}/man7/openssl_des_modes.7*
499
500 %files static
501 %defattr(644,root,root,755)
502 %{_libdir}/libcrypto.a
503 %{_libdir}/libssl.a
This page took 0.124674 seconds and 3 git commands to generate.