]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
a0c73ab66b0c33b69edcc57f7393d957f8373012
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_with     sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
6 %bcond_with     sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
7 %bcond_with     snap    # use GitHub snapshot to build branch release
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
11 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
12 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
13 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
14 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
15 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
16 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
17 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
18 Name:           openssl
19 # Version 1.1.0 will be supported until 2019-??-?? (one year after release of 1.1.1).
20 # https://www.openssl.org/about/releasestrat.html
21 Version:        1.1.1
22 Release:        1
23 License:        Apache-like
24 Group:          Libraries
25 %if %{without snap}
26 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
27 # Source0-md5:  7079eb017429e0ffb9efb42bf80ccb21
28 %else
29 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_1_0-stable/%{name}-%{version}-dev.tar.gz
30 %endif
31 Source2:        %{name}.1.pl
32 Source3:        %{name}-ssl-certificate.sh
33 Source4:        %{name}-c_rehash.sh
34 Patch1:         %{name}-optflags.patch
35
36 Patch3:         %{name}-man-namespace.patch
37
38 Patch5:         %{name}-ca-certificates.patch
39
40 Patch7:         %{name}-find.patch
41 Patch8:         pic.patch
42
43 Patch11:        engines-dir.patch
44 URL:            http://www.openssl.org/
45 BuildRequires:  perl-devel >= 1:5.10.0
46 BuildRequires:  pkgconfig
47 BuildRequires:  rpm-perlprov >= 4.1-13
48 BuildRequires:  rpmbuild(macros) >= 1.213
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  zlib-devel
51 Requires:       ca-certificates >= 20120623-1.1
52 Requires:       rpm-whiteout >= 1.7
53 Obsoletes:      SSLeay
54 Obsoletes:      SSLeay-devel
55 Obsoletes:      SSLeay-perl
56 Obsoletes:      libopenssl0
57 %if "%{pld_release}" == "ac"
58 Conflicts:      neon < 0.26.3-3
59 Conflicts:      ntpd < 4.2.4p8-10
60 Conflicts:      openssh-clients < 2:5.8p1-9
61 Conflicts:      openssh-server < 2:5.8p1-9
62 %else
63 Conflicts:      neon < 0.29.6-8
64 Conflicts:      openssh-clients < 2:6.2p2-3
65 Conflicts:      openssh-server < 2:6.2p2-3
66 %endif
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 The OpenSSL Project is a collaborative effort to develop a robust,
71 commercial-grade, full-featured, and Open Source toolkit implementing
72 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
73 v1) protocols with full-strength cryptography world-wide. The project
74 is managed by a worldwide community of volunteers that use the
75 Internet to communicate, plan, and develop the OpenSSL tookit and its
76 related documentation.
77
78 OpenSSL is based on the excellent SSLeay library developed by Eric A.
79 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
80 Apache-style licence, which basically means that you are free to get
81 and use it for commercial and non-commercial purposes subject to some
82 simple license conditions.
83
84 This package contains shared libraries only, install openssl-tools if
85 you want to use openssl cmdline tool.
86
87 %description -l de.UTF-8
88 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
89 libraries, die verschiedene Verschlüsselungs- und
90 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
91 zur Verfügung stellen.
92
93 %description -l es.UTF-8
94 Biblioteca C que suministra algoritmos y protocolos criptográficos.
95
96 %description -l fr.UTF-8
97 OpenSSL est un outiil de gestion des certificats et les librairies
98 partagees qui fournit plusieurs protocoles et algorithmes de
99 codage/decodage, incluant DES, RC4, RSA et SSL.
100
101 %description -l pl.UTF-8
102 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
103 v2/v3 oraz Transport Layer Security (TLS v1).
104
105 %description -l pt_BR.UTF-8
106 Uma biblioteca C que fornece vários algoritmos e protocolos
107 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
108 compartilhadas e utilitários.
109
110 %description -l ru.UTF-8
111 Программа openssl для работы с сертификатами и разделяемые библиотеки,
112 которые реализуют множетсво криптографических алгоритмов, включая DES,
113 RC4, RSA и SSL.
114
115 %description -l uk.UTF-8
116 Програма openssl для роботи з сертифікатами та бібліотеки спільного
117 користування, що реалізують велику кількість криптографічних
118 алгоритмів, включаючи DES, RC4, RSA та SSL.
119
120 %package engines
121 Summary:        OpenSSL optional crypto engines
122 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
123 Group:          Libraries
124 Requires:       %{name} = %{version}-%{release}
125
126 %description engines
127 With OpenSSL 0.9.6, a new component was added to support alternative
128 cryptography implementations, most commonly for interfacing with
129 external crypto devices (eg. accelerator cards). This component is
130 called ENGINE.
131
132 There are currently built-in ENGINE implementations for the following
133 crypto devices:
134
135 - CryptoSwift
136 - Compaq Atalla
137 - nCipher CHIL
138 - Nuron
139 - Broadcom uBSec
140
141 In addition, dynamic binding to external ENGINE implementations is now
142 provided by a special ENGINE called "dynamic".
143
144 %description engines -l pl.UTF-8
145 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
146 wspierać alternatywne implementacje kryptografii, przeważnie
147 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
148 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
149 ENGINE).
150
151 Obecnie istnieją wbudowane implementacje silników dla następujących
152 urządzeń kryptograficznych:
153 - CryptoSwift
154 - Compaq Atalla
155 - nCipher CHIL
156 - Nuron
157 - Broadcom uBSec
158
159 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
160 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
161
162 %package tools
163 Summary:        OpenSSL command line tool and utilities
164 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
165 Group:          Applications/Communications
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       which
168
169 %description tools
170 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
171
172 %description tools -l pl.UTF-8
173 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
174
175 %package tools-perl
176 Summary:        OpenSSL utilities written in Perl
177 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
178 Group:          Applications/Communications
179 Requires:       %{name} = %{version}-%{release}
180
181 %description tools-perl
182 OpenSSL Toolkit tools written in Perl.
183
184 %description tools-perl -l pl.UTF-8
185 Narzędzia OpenSSL napisane w perlu.
186
187 %package devel
188 Summary:        Development part of OpenSSL Toolkit libraries
189 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
190 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
191 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
192 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
193 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
194 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
195 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
196 Group:          Development/Libraries
197 Requires:       %{name} = %{version}-%{release}
198 Obsoletes:      libopenssl0-devel
199
200 %description devel
201 Development part of OpenSSL library.
202
203 %description devel -l es.UTF-8
204 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
205
206 %description devel -l pl.UTF-8
207 Część biblioteki OpenSSL przeznaczona dla programistów.
208
209 %description devel -l pt_BR.UTF-8
210 Uma biblioteca C que fornece vários algoritmos e protocolos
211 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
212 arquivos de inclusão para desenvolvimento.
213
214 %description devel -l ru.UTF-8
215 Программа openssl для работы с сертификатами и разделяемые библиотеки,
216 которые реализуют множетсво криптографических алгоритмов, включая DES,
217 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
218 с использованием SSL.
219
220 %description devel -l uk.UTF-8
221 Програма openssl для роботи з сертифікатами та бібліотеки спільного
222 користування, що реалізують велику кількість криптографічних
223 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
224 хедери для розробки програм з використанням SSL.
225
226 %package static
227 Summary:        Static OpenSSL libraries
228 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
229 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
230 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
231 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
232 Group:          Development/Libraries
233 Requires:       %{name}-devel = %{version}-%{release}
234
235 %description static
236 Static OpenSSL Toolkit libraries.
237
238 %description static -l pl.UTF-8
239 Statyczne wersje bibliotek z OpenSSL.
240
241 %description static -l pt_BR.UTF-8
242 Bibliotecas estáticas para desenvolvimento com openssl.
243
244 %description static -l ru.UTF-8
245 Программа openssl для работы с сертификатами и разделяемые библиотеки,
246 которые реализуют множетсво криптографических алгоритмов, включая DES,
247 RC4, RSA и SSL. Включает статические библиотеки для разработки
248 приложений с использованием OpenSSL.
249
250 %description static -l uk.UTF-8
251 Програма openssl для роботи з сертифікатами та бібліотеки спільного
252 користування, що реалізують велику кількість криптографічних
253 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
254 бібліотеки для розробки програм з використанням SSL.
255
256 %prep
257 %if %{with snap}
258 %setup -qcT -a1
259 %{__mv} %{name}-OpenSSL_1_1_0-stable/* .
260 %else
261 %setup -q %{?subver:-n %{name}-%{version}-%{subver}}
262 %endif
263
264 %patch1 -p1
265
266 %patch3 -p1
267
268 %patch5 -p1
269
270 %patch7 -p1
271 %patch8 -p1
272
273 %patch11 -p1
274
275 %build
276 touch Makefile.*
277
278 PERL="%{__perl}" \
279 %{__perl} ./Configure \
280         --prefix=%{_prefix} \
281         --openssldir=%{_sysconfdir}/%{name} \
282         --libdir=%{_lib} \
283         -Wa,--noexecstack \
284         shared \
285         threads \
286         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
287         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
288         %{!?with_zlib:no-}zlib \
289         enable-cms \
290         enable-idea \
291         enable-md2 \
292         enable-mdc2 \
293         enable-rc5 \
294         enable-rfc3779 \
295         enable-seed \
296 %ifarch %{x8664}
297         enable-ec_nistp_64_gcc_128 \
298 %endif
299 %ifarch %{ix86}
300 %ifarch i386
301         386 linux-elf
302 # ^- allow running on 80386 (default code uses bswapl available on i486+)
303 %else
304         linux-elf
305 %endif
306 %endif
307 %ifarch alpha
308         linux-alpha-gcc
309 %endif
310 %ifarch %{x8664}
311         linux-x86_64
312 %endif
313 %ifarch x32
314         linux-x32
315 %endif
316 %ifarch ia64
317         linux-ia64
318 %endif
319 %ifarch ppc
320         linux-ppc
321 %endif
322 %ifarch ppc64
323         linux-ppc64
324 %endif
325 %ifarch sparc
326         linux-sparcv8
327 %endif
328 %ifarch sparcv9
329         linux-sparcv9
330 %endif
331 %ifarch sparc64
332         linux64-sparcv9
333 %endif
334 %ifarch %{arm}
335         linux-armv4
336 %endif
337 %ifarch aarch64
338         linux-aarch64
339 %endif
340
341 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
342 test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
343
344 %{__make} -j1 all %{?with_tests:tests} \
345         CC="%{__cc}" \
346         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
347         INSTALLTOP=%{_prefix}
348
349 # Rename POD sources of man pages. "openssl-" prefix is added to each
350 # manpage to avoid potential conflicts with other packages. 
351 # openssl-man-namespace.patch mostly marks these pages with "openssl-" prefix.
352
353 for podfile in $(grep -rl '^openssl-' doc/man*); do
354         dir=$(dirname "$podfile")
355         base=$(basename "$podfile")
356         %{__mv} "$podfile" "$dir/openssl-$base"
357 done
358
359 %install
360 rm -rf $RPM_BUILD_ROOT
361 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
362         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
363         $RPM_BUILD_ROOT%{_pkgconfigdir}
364
365 %{__make} -j1 install \
366         CC="%{__cc}" \
367         DESTDIR=$RPM_BUILD_ROOT
368
369 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
370 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
371 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
372
373 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
374 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
375
376 # html version of man pages - not packaged
377 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
378
379 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
380 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
381 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
382
383 %clean
384 rm -rf $RPM_BUILD_ROOT
385
386 %post   -p /sbin/ldconfig
387 %postun -p /sbin/ldconfig
388
389 %triggerpostun -- %{name}-tools < 1.0.0-5
390 # the hashing format has changed in 1.0.0
391 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
392
393 %triggerpostun -- %{name} < 0.9.8i-2
394 # don't do anything on --downgrade
395 if [ $1 -le 1 ]; then
396         exit 0
397 fi
398 if [ -d /var/lib/openssl/certs ] ; then
399         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
400 fi
401 if [ -d /var/lib/openssl/private ] ; then
402         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
403 fi
404 if [ -d /var/lib/openssl ] ; then
405         for f in /var/lib/openssl/* ; do
406                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
407         done
408         rmdir /var/lib/openssl/* 2>/dev/null || :
409         rmdir /var/lib/openssl 2>/dev/null || :
410 fi
411
412 %files
413 %defattr(644,root,root,755)
414 %doc CHANGES LICENSE NEWS README doc/*.txt
415 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*
416 %attr(755,root,root) /%{_lib}/libssl.so.*.*
417 %dir %{_sysconfdir}/%{name}
418 %dir %{_sysconfdir}/%{name}/certs
419 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
420 %dir %{_datadir}/ssl
421
422 %files engines
423 %defattr(644,root,root,755)
424 %dir /%{_lib}/engines-1.1
425 %attr(755,root,root) /%{_lib}/engines-1.1/*.so
426
427 %files tools
428 %defattr(644,root,root,755)
429 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ct_log_list.cnf
430 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
431 %attr(755,root,root) %{_bindir}/c_rehash.sh
432 %attr(755,root,root) %{_bindir}/openssl
433 %attr(754,root,root) %{_bindir}/ssl-certificate
434 %{_mandir}/man1/openssl.1*
435 %{_mandir}/man1/openssl-asn1parse.1*
436 %{_mandir}/man1/openssl-ca.1*
437 %{_mandir}/man1/openssl-ciphers.1*
438 %{_mandir}/man1/openssl-cms.1*
439 %{_mandir}/man1/openssl-crl.1*
440 %{_mandir}/man1/openssl-crl2pkcs7.1*
441 %{_mandir}/man1/openssl-dgst.1*
442 %{_mandir}/man1/openssl-dhparam.1*
443 %{_mandir}/man1/openssl-dsa.1*
444 %{_mandir}/man1/openssl-dsaparam.1*
445 %{_mandir}/man1/openssl-ec.1*
446 %{_mandir}/man1/openssl-ecparam.1*
447 %{_mandir}/man1/openssl-enc.1*
448 %{_mandir}/man1/openssl-engine.1*
449 %{_mandir}/man1/openssl-errstr.1*
450 %{_mandir}/man1/openssl-gendsa.1*
451 %{_mandir}/man1/openssl-genpkey.1*
452 %{_mandir}/man1/openssl-genrsa.1*
453 %{_mandir}/man1/openssl-list.1*
454 %{_mandir}/man1/openssl-nseq.1*
455 %{_mandir}/man1/openssl-ocsp.1*
456 %{_mandir}/man1/openssl-passwd.1*
457 %{_mandir}/man1/openssl-pkcs12.1*
458 %{_mandir}/man1/openssl-pkcs7.1*
459 %{_mandir}/man1/openssl-pkcs8.1*
460 %{_mandir}/man1/openssl-pkey.1*
461 %{_mandir}/man1/openssl-pkeyparam.1*
462 %{_mandir}/man1/openssl-pkeyutl.1*
463 %{_mandir}/man1/openssl-prime.1*
464 %{_mandir}/man1/openssl-rand.1*
465 %{_mandir}/man1/openssl-rehash.1*
466 %{_mandir}/man1/openssl-req.1*
467 %{_mandir}/man1/openssl-rsa.1*
468 %{_mandir}/man1/openssl-rsautl.1*
469 %{_mandir}/man1/openssl-s_client.1*
470 %{_mandir}/man1/openssl-sess_id.1*
471 %{_mandir}/man1/openssl-smime.1*
472 %{_mandir}/man1/openssl-speed.1*
473 %{_mandir}/man1/openssl-spkac.1*
474 %{_mandir}/man1/openssl-srp.1*
475 %{_mandir}/man1/openssl-s_server.1*
476 %{_mandir}/man1/openssl-s_time.1*
477 %{_mandir}/man1/openssl-storeutl.1*
478 %{_mandir}/man1/openssl-ts.1*
479 %{_mandir}/man1/openssl-tsget.1*
480 %{_mandir}/man1/openssl-verify.1*
481 %{_mandir}/man1/openssl-version.1*
482 %{_mandir}/man1/openssl-x509.1*
483 %{_mandir}/man5/openssl-config.5*
484 %{_mandir}/man5/openssl-x509v3_config.5*
485 %lang(pl) %{_mandir}/pl/man1/openssl.1*
486
487 %files tools-perl
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_bindir}/c_rehash
490 %dir %{_libdir}/%{name}
491 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
492 %attr(755,root,root) %{_libdir}/%{name}/tsget
493 %attr(755,root,root) %{_libdir}/%{name}/tsget.pl
494 %{_mandir}/man1/CA.pl.1*
495 %{_mandir}/man1/c_rehash.1*
496
497 %files devel
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_libdir}/libcrypto.so
500 %attr(755,root,root) %{_libdir}/libssl.so
501 %{_includedir}/%{name}
502 %{_pkgconfigdir}/libcrypto.pc
503 %{_pkgconfigdir}/libssl.pc
504 %{_pkgconfigdir}/openssl.pc
505 %{_mandir}/man3/ACCESS_DESCRIPTION_*.3*
506 %{_mandir}/man3/ADMISSION*.3*
507 %{_mandir}/man3/ASId*.3*
508 %{_mandir}/man3/ASRange_*.3*
509 %{_mandir}/man3/ASN1_*.3*
510 %{_mandir}/man3/ASYNC_*.3*
511 %{_mandir}/man3/AUTHORITY_*.3*
512 %{_mandir}/man3/BASIC_CONSTRAINTS_*.3*
513 %{_mandir}/man3/BF_*.3*
514 %{_mandir}/man3/BIO_*.3*
515 %{_mandir}/man3/BN_*.3*
516 %{_mandir}/man3/BUF_*.3*
517 %{_mandir}/man3/CERTIFICATEPOLICIES_*.3*
518 %{_mandir}/man3/CMS_*.3*
519 %{_mandir}/man3/CONF_*.3*
520 %{_mandir}/man3/CRL_DIST_POINTS_*.3*
521 %{_mandir}/man3/CRYPTO_*.3*
522 %{_mandir}/man3/CTLOG_*.3*
523 %{_mandir}/man3/CT_POLICY_*.3*
524 %{_mandir}/man3/DECLARE_*.3*
525 %{_mandir}/man3/DEFINE_*.3*
526 %{_mandir}/man3/DES_*.3*
527 %{_mandir}/man3/DH_*.3*
528 %{_mandir}/man3/DHparams_*.3*
529 %{_mandir}/man3/DIRECTORYSTRING_*.3*
530 %{_mandir}/man3/DISPLAYTEXT_*.3*
531 %{_mandir}/man3/DIST_POINT_*.3*
532 %{_mandir}/man3/DSA_*.3*
533 %{_mandir}/man3/DSAparams_*.3*
534 %{_mandir}/man3/DTLS_*.3*
535 %{_mandir}/man3/DTLSv1_*.3*
536 %{_mandir}/man3/ECDH_*.3*
537 %{_mandir}/man3/ECDSA_*.3*
538 %{_mandir}/man3/ECPARAMETERS_*.3*
539 %{_mandir}/man3/ECPKPARAMETERS_*.3*
540 %{_mandir}/man3/ECPKParameters_*.3*
541 %{_mandir}/man3/EC_*.3*
542 %{_mandir}/man3/EDIPARTYNAME_*.3*
543 %{_mandir}/man3/ENGINE_*.3*
544 %{_mandir}/man3/ERR_*.3*
545 %{_mandir}/man3/ESS_*.3*
546 %{_mandir}/man3/EVP_*.3*
547 %{_mandir}/man3/EXTENDED_KEY_USAGE_*.3*
548 %{_mandir}/man3/GENERAL_*.3*
549 %{_mandir}/man3/GEN_SESSION_CB.3*
550 %{_mandir}/man3/HMAC*.3*
551 %{_mandir}/man3/IMPLEMENT_*.3*
552 %{_mandir}/man3/IPAddress*.3*
553 %{_mandir}/man3/ISSUING_DIST_POINT_*.3*
554 %{_mandir}/man3/LHASH*.3*
555 %{_mandir}/man3/MD2*.3*
556 %{_mandir}/man3/MD4*.3*
557 %{_mandir}/man3/MD5*.3*
558 %{_mandir}/man3/MDC2*.3*
559 %{_mandir}/man3/NAME_CONSTRAINTS_*.3*
560 %{_mandir}/man3/NAMING_AUTHORITY*.3*
561 %{_mandir}/man3/NETSCAPE_*.3*
562 %{_mandir}/man3/NOTICEREF_*.3*
563 %{_mandir}/man3/OBJ_*.3*
564 %{_mandir}/man3/OCSP_*.3*
565 %{_mandir}/man3/OPENSSL_*.3*
566 %{_mandir}/man3/OSSL*.3*
567 %{_mandir}/man3/OTHERNAME_*.3*
568 %{_mandir}/man3/OpenSSL_*.3*
569 %{_mandir}/man3/PBE2PARAM_*.3*
570 %{_mandir}/man3/PBEPARAM_*.3*
571 %{_mandir}/man3/PBKDF2PARAM_*.3*
572 %{_mandir}/man3/PEM_*.3*
573 %{_mandir}/man3/PKCS12_*.3*
574 %{_mandir}/man3/PKCS5_*.3*
575 %{_mandir}/man3/PKCS7_*.3*
576 %{_mandir}/man3/PKCS8_*.3*
577 %{_mandir}/man3/PKEY_*.3*
578 %{_mandir}/man3/POLICYINFO_*.3*
579 %{_mandir}/man3/POLICYQUALINFO_*.3*
580 %{_mandir}/man3/POLICY_*.3*
581 %{_mandir}/man3/PROFESSION_INFO*.3*
582 %{_mandir}/man3/PROXY_*.3*
583 %{_mandir}/man3/RAND_*.3*
584 %{_mandir}/man3/RC4*.3*
585 %{_mandir}/man3/RIPEMD160*.3*
586 %{_mandir}/man3/RSAPrivateKey_*.3*
587 %{_mandir}/man3/RSAPublicKey_*.3*
588 %{_mandir}/man3/RSA_*.3*
589 %{_mandir}/man3/SCRYPT_PARAMS*.3*
590 %{_mandir}/man3/SCT_*.3*
591 %{_mandir}/man3/SHA1*.3*
592 %{_mandir}/man3/SHA224*.3*
593 %{_mandir}/man3/SHA256*.3*
594 %{_mandir}/man3/SHA384*.3*
595 %{_mandir}/man3/SHA512*.3*
596 %{_mandir}/man3/SMIME_*.3*
597 %{_mandir}/man3/SSL_*.3*
598 %{_mandir}/man3/SSLv23_*.3*
599 %{_mandir}/man3/SSLv3_*.3*
600 %{_mandir}/man3/SXNET_*.3*
601 %{_mandir}/man3/SXNETID_*.3*
602 %{_mandir}/man3/TLS_*.3*
603 %{_mandir}/man3/TLSv1_*.3*
604 %{_mandir}/man3/TS_*.3*
605 %{_mandir}/man3/UI*.3*
606 %{_mandir}/man3/USERNOTICE_*.3*
607 %{_mandir}/man3/X509_*.3*
608 %{_mandir}/man3/X509V3_*.3*
609 %{_mandir}/man3/X509v3_*.3*
610 %{_mandir}/man3/custom_ext_*.3*
611 %{_mandir}/man3/d2i_*.3*
612 %{_mandir}/man3/i2d_*.3*
613 %{_mandir}/man3/i2o_*.3*
614 %{_mandir}/man3/i2t_*.3*
615 %{_mandir}/man3/lh_TYPE_*.3*
616 %{_mandir}/man3/o2i_*.3*
617 %{_mandir}/man3/pem_password_cb.3*
618 %{_mandir}/man3/sk_TYPE_*.3*
619 %{_mandir}/man3/ssl_ct_validation_cb.3*
620 %{_mandir}/man7/openssl.7*
621 %{_mandir}/man7/openssl-bio.7*
622 %{_mandir}/man7/openssl-crypto.7*
623 %{_mandir}/man7/openssl-ct.7*
624 %{_mandir}/man7/openssl-des_modes.7*
625 %{_mandir}/man7/openssl-Ed25519.7*
626 %{_mandir}/man7/openssl-Ed448.7*
627 %{_mandir}/man7/openssl-evp.7*
628 %{_mandir}/man7/openssl-passphrase-encoding.7*
629 %{_mandir}/man7/openssl-RAND.7*
630 %{_mandir}/man7/openssl-RAND_DRBG.7*
631 %{_mandir}/man7/openssl-scrypt.7*
632 %{_mandir}/man7/openssl-SM2.7*
633 %{_mandir}/man7/openssl-ssl.7*
634 %{_mandir}/man7/openssl-X25519.7*
635 %{_mandir}/man7/openssl-X448.7*
636 %{_mandir}/man7/openssl-x509.7*
637 %{_mandir}/man7/ossl_store.7*
638 %{_mandir}/man7/ossl_store-file.7*
639 %{_mandir}/man7/RSA-PSS.7.gz
640
641 %files static
642 %defattr(644,root,root,755)
643 %{_libdir}/libcrypto.a
644 %{_libdir}/libssl.a
This page took 0.112509 seconds and 2 git commands to generate.