]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
9bca39169978093ce5a517b07cc1528311beb94f
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform "make tests"
6 %bcond_with     purify  # Compile openssl with \-DPURIFY, useful when one wants to
7                         # use valgrind debugger against openssl-linked programs
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
11 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
12 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
13 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
14 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
15 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
16 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
17 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
18 Name:           openssl
19 Version:        1.0.1j
20 Release:        2
21 License:        Apache-like
22 Group:          Libraries
23 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
24 # Source0-md5:  f7175c9cd3c39bb1907ac8bba9df8ed3
25 Source2:        %{name}.1.pl
26 Source3:        %{name}-ssl-certificate.sh
27 Source4:        %{name}-c_rehash.sh
28 Patch0:         %{name}-alpha-ccc.patch
29 Patch1:         %{name}-optflags.patch
30 Patch2:         %{name}-globalCA.diff
31 Patch3:         %{name}-include.patch
32 Patch4:         %{name}-man-namespace.patch
33 Patch5:         %{name}-asflag.patch
34 Patch6:         %{name}-ca-certificates.patch
35 Patch7:         %{name}-ldflags.patch
36 Patch8:         %{name}-find.patch
37 # from debian
38 Patch10:        default_bits.patch
39 Patch11:        pic.patch
40 Patch12:        stddef.patch
41 URL:            http://www.openssl.org/
42 BuildRequires:  bc
43 BuildRequires:  perl-devel >= 1:5.6.1
44 BuildRequires:  rpm-perlprov >= 4.1-13
45 BuildRequires:  rpmbuild(macros) >= 1.213
46 BuildRequires:  sed >= 4.0
47 Requires:       ca-certificates >= 20080809-4
48 Requires:       rpm-whiteout >= 1.7
49 Obsoletes:      SSLeay
50 Obsoletes:      SSLeay-devel
51 Obsoletes:      SSLeay-perl
52 Obsoletes:      libopenssl0
53 Conflicts:      neon < 0.29.6-8
54 Conflicts:      openssh-clients < 2:6.2p2-3
55 Conflicts:      openssh-server < 2:6.2p2-3
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 The OpenSSL Project is a collaborative effort to develop a robust,
60 commercial-grade, full-featured, and Open Source toolkit implementing
61 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
62 v1) protocols with full-strength cryptography world-wide. The project
63 is managed by a worldwide community of volunteers that use the
64 Internet to communicate, plan, and develop the OpenSSL tookit and its
65 related documentation.
66
67 OpenSSL is based on the excellent SSLeay library developed by Eric A.
68 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
69 Apache-style licence, which basically means that you are free to get
70 and use it for commercial and non-commercial purposes subject to some
71 simple license conditions.
72
73 This package contains shared libraries only, install openssl-tools if
74 you want to use openssl cmdline tool.
75
76 %description -l de.UTF-8
77 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
78 libraries, die verschiedene Verschlüsselungs- und
79 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
80 zur Verfügung stellen.
81
82 %description -l es.UTF-8
83 Biblioteca C que suministra algoritmos y protocolos criptográficos.
84
85 %description -l fr.UTF-8
86 OpenSSL est un outiil de gestion des certificats et les librairies
87 partagees qui fournit plusieurs protocoles et algorithmes de
88 codage/decodage, incluant DES, RC4, RSA et SSL.
89
90 %description -l pl.UTF-8
91 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
92 v2/v3 oraz Transport Layer Security (TLS v1).
93
94 %description -l pt_BR.UTF-8
95 Uma biblioteca C que fornece vários algoritmos e protocolos
96 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
97 compartilhadas e utilitários.
98
99 %description -l ru.UTF-8
100 Программа openssl для работы с сертификатами и разделяемые библиотеки,
101 которые реализуют множетсво криптографических алгоритмов, включая DES,
102 RC4, RSA и SSL.
103
104 %description -l uk.UTF-8
105 Програма openssl для роботи з сертифікатами та бібліотеки спільного
106 користування, що реалізують велику кількість криптографічних
107 алгоритмів, включаючи DES, RC4, RSA та SSL.
108
109 %package engines
110 Summary:        OpenSSL optional crypto engines
111 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
112 Group:          Libraries
113 Requires:       %{name} = %{version}-%{release}
114
115 %description engines
116 With OpenSSL 0.9.6, a new component was added to support alternative
117 cryptography implementations, most commonly for interfacing with
118 external crypto devices (eg. accelerator cards). This component is
119 called ENGINE.
120
121 There are currently built-in ENGINE implementations for the following
122 crypto devices:
123
124 - CryptoSwift
125 - Compaq Atalla
126 - nCipher CHIL
127 - Nuron
128 - Broadcom uBSec
129
130 In addition, dynamic binding to external ENGINE implementations is now
131 provided by a special ENGINE called "dynamic".
132
133 %description engines -l pl.UTF-8
134 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
135 wspierać alternatywne implementacje kryptografii, przeważnie
136 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
137 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
138 ENGINE).
139
140 Obecnie istnieją wbudowane implementacje silników dla następujących
141 urządzeń kryptograficznych:
142 - CryptoSwift
143 - Compaq Atalla
144 - nCipher CHIL
145 - Nuron
146 - Broadcom uBSec
147
148 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
149 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
150
151 %package tools
152 Summary:        OpenSSL command line tool and utilities
153 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
154 Group:          Applications/Communications
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       which
157
158 %description tools
159 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
160
161 %description tools -l pl.UTF-8
162 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
163
164 %package tools-perl
165 Summary:        OpenSSL utilities written in Perl
166 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
167 Group:          Applications/Communications
168 Requires:       %{name} = %{version}-%{release}
169
170 %description tools-perl
171 OpenSSL Toolkit tools written in Perl.
172
173 %description tools-perl -l pl.UTF-8
174 Narzędzia OpenSSL napisane w perlu.
175
176 %package devel
177 Summary:        Development part of OpenSSL Toolkit libraries
178 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
179 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
180 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
181 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
182 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
183 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
184 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
185 Group:          Development/Libraries
186 Requires:       %{name} = %{version}-%{release}
187 Obsoletes:      libopenssl0-devel
188
189 %description devel
190 Development part of OpenSSL library.
191
192 %description devel -l es.UTF-8
193 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
194
195 %description devel -l pl.UTF-8
196 Część biblioteki OpenSSL przeznaczona dla programistów.
197
198 %description devel -l pt_BR.UTF-8
199 Uma biblioteca C que fornece vários algoritmos e protocolos
200 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
201 arquivos de inclusão para desenvolvimento.
202
203 %description devel -l ru.UTF-8
204 Программа openssl для работы с сертификатами и разделяемые библиотеки,
205 которые реализуют множетсво криптографических алгоритмов, включая DES,
206 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
207 с использованием SSL.
208
209 %description devel -l uk.UTF-8
210 Програма openssl для роботи з сертифікатами та бібліотеки спільного
211 користування, що реалізують велику кількість криптографічних
212 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
213 хедери для розробки програм з використанням SSL.
214
215 %package static
216 Summary:        Static OpenSSL libraries
217 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
218 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
219 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
220 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
221 Group:          Development/Libraries
222 Requires:       %{name}-devel = %{version}-%{release}
223
224 %description static
225 Static OpenSSL Toolkit libraries.
226
227 %description static -l pl.UTF-8
228 Statyczne wersje bibliotek z OpenSSL.
229
230 %description static -l pt_BR.UTF-8
231 Bibliotecas estáticas para desenvolvimento com openssl.
232
233 %description static -l ru.UTF-8
234 Программа openssl для работы с сертификатами и разделяемые библиотеки,
235 которые реализуют множетсво криптографических алгоритмов, включая DES,
236 RC4, RSA и SSL. Включает статические библиотеки для разработки
237 приложений с использованием OpenSSL.
238
239 %description static -l uk.UTF-8
240 Програма openssl для роботи з сертифікатами та бібліотеки спільного
241 користування, що реалізують велику кількість криптографічних
242 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
243 бібліотеки для розробки програм з використанням SSL.
244
245 %prep
246 %setup -q
247 %patch0 -p1
248 %patch1 -p1
249 %patch2 -p1
250 %patch3 -p1
251 %patch4 -p1
252 %patch5 -p1
253 %patch6 -p1
254 %patch7 -p1
255 %patch8 -p1
256 %patch10 -p1
257 %patch11 -p1
258 %patch12 -p1
259
260 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
261
262 %build
263 touch Makefile.*
264
265 %{__perl} util/perlpath.pl %{__perl}
266
267 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
268 PERL="%{__perl}" \
269 %{__perl} ./Configure \
270         --openssldir=%{_sysconfdir}/%{name} \
271         --libdir=%{_lib} \
272         shared \
273         threads \
274         no-ssl2 \
275         no-ssl3 \
276         no-zlib \
277         enable-camelia \
278         enable-cms \
279         enable-idea \
280         enable-md2 \
281         enable-mdc2 \
282         enable-rc5 \
283         enable-rfc3779 \
284         enable-seed \
285         enable-tlsext \
286 %ifarch %{x8664}
287         enable-ec_nistp_64_gcc_128 \
288 %endif
289 %ifarch %{ix86}
290 %ifarch i386
291         386 linux-elf
292 # ^- allow running on 80386 (default code uses bswapl available on i486+)
293 %else
294         linux-elf
295 %endif
296 %endif
297 %ifarch alpha
298         linux-alpha+bwx-gcc
299 %endif
300 %ifarch %{x8664}
301         linux-x86_64
302 %endif
303 %ifarch ia64
304         linux-ia64
305 %endif
306 %ifarch ppc
307         linux-ppc
308 %endif
309 %ifarch ppc64
310         linux-ppc64
311 %endif
312 %ifarch sparc
313         linux-sparcv8
314 %endif
315 %ifarch sparcv9
316         linux-sparcv9
317 %endif
318 %ifarch sparc64
319         linux64-sparcv9
320 %endif
321 %ifarch armv4 armv5 armv5t armv5te armv5tel
322         linux-armv4
323 %endif
324
325 %{__make} -j1 all rehash %{?with_tests:tests} \
326         CC="%{__cc}" \
327         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
328         INSTALLTOP=%{_prefix}
329
330 # Rename POD sources of man pages. "openssl_" prefix is added to each
331 # manpage to avoid potential conflicts with other packages.
332
333 for dir in doc/{apps,ssl,crypto}; do
334         cd $dir || exit 1;
335         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
336
337         for pod in !(openssl*).pod; do
338                 mv -f $pod openssl_$pod;
339         done
340         cd ../..
341 done
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
346         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
347         $RPM_BUILD_ROOT/%{_lib}/engines \
348         $RPM_BUILD_ROOT%{_pkgconfigdir}
349
350 %{__make} -j1 install \
351         INSTALLTOP=%{_prefix} \
352         INSTALL_PREFIX=$RPM_BUILD_ROOT \
353         MANDIR=%{_mandir}
354
355 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
356 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
357 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
358 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
359
360 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
361 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
362
363 # not installed as individual utilities (see openssl dgst instead)
364 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
365
366 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
367 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
368 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
369
370 %clean
371 rm -rf $RPM_BUILD_ROOT
372
373 %post   -p /sbin/ldconfig
374 %postun -p /sbin/ldconfig
375
376 %triggerpostun -- %{name}-tools < 1.0.0-5
377 # the hashing format has changed in 1.0.0
378 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
379
380 %triggerpostun -- %{name} < 0.9.8i-2
381 # don't do anything on --downgrade
382 if [ $1 -le 1 ]; then
383         exit 0
384 fi
385 if [ -d /var/lib/openssl/certs ] ; then
386         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
387 fi
388 if [ -d /var/lib/openssl/private ] ; then
389         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
390 fi
391 if [ -d /var/lib/openssl ] ; then
392         for f in /var/lib/openssl/* ; do
393                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
394         done
395         rmdir /var/lib/openssl/* 2>/dev/null || :
396         rmdir /var/lib/openssl 2>/dev/null || :
397 fi
398
399 %files
400 %defattr(644,root,root,755)
401 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
402 %doc doc/openssl_button.gif doc/openssl_button.html
403 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
404 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
405 %dir %{_sysconfdir}/%{name}
406 %dir %{_sysconfdir}/%{name}/certs
407 %dir %{_sysconfdir}/%{name}/private
408 %dir %{_datadir}/ssl
409
410 %files engines
411 %defattr(644,root,root,755)
412 %dir /%{_lib}/engines
413 %attr(755,root,root) /%{_lib}/engines/*.so
414
415 %files tools
416 %defattr(644,root,root,755)
417 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
418 %attr(755,root,root) %{_bindir}/c_rehash.sh
419 %attr(755,root,root) %{_bindir}/openssl
420 %attr(754,root,root) %{_bindir}/ssl-certificate
421
422 %dir %{_libdir}/%{name}
423 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
424 %attr(755,root,root) %{_libdir}/%{name}/c_hash
425 %attr(755,root,root) %{_libdir}/%{name}/c_info
426 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
427 %attr(755,root,root) %{_libdir}/%{name}/c_name
428
429 %{_mandir}/man1/openssl.1*
430 %{_mandir}/man1/openssl_asn1parse.1*
431 %{_mandir}/man1/openssl_ca.1*
432 %{_mandir}/man1/openssl_ciphers.1*
433 %{_mandir}/man1/openssl_cms.1*
434 %{_mandir}/man1/openssl_crl.1*
435 %{_mandir}/man1/openssl_crl2pkcs7.1*
436 %{_mandir}/man1/openssl_dgst.1*
437 %{_mandir}/man1/openssl_dhparam.1*
438 %{_mandir}/man1/openssl_dsa.1*
439 %{_mandir}/man1/openssl_dsaparam.1*
440 %{_mandir}/man1/openssl_ec.1*
441 %{_mandir}/man1/openssl_ecparam.1*
442 %{_mandir}/man1/openssl_enc.1*
443 %{_mandir}/man1/openssl_errstr.1*
444 %{_mandir}/man1/openssl_gendsa.1*
445 %{_mandir}/man1/openssl_genpkey.1*
446 %{_mandir}/man1/openssl_genrsa.1*
447 %{_mandir}/man1/openssl_nseq.1*
448 %{_mandir}/man1/openssl_ocsp.1*
449 %{_mandir}/man1/openssl_passwd.1*
450 %{_mandir}/man1/openssl_pkcs12.1*
451 %{_mandir}/man1/openssl_pkcs7.1*
452 %{_mandir}/man1/openssl_pkcs8.1*
453 %{_mandir}/man1/openssl_pkey.1*
454 %{_mandir}/man1/openssl_pkeyparam.1*
455 %{_mandir}/man1/openssl_pkeyutl.1*
456 %{_mandir}/man1/openssl_rand.1*
457 %{_mandir}/man1/openssl_req.1*
458 %{_mandir}/man1/openssl_rsa.1*
459 %{_mandir}/man1/openssl_rsautl.1*
460 %{_mandir}/man1/openssl_s_client.1*
461 %{_mandir}/man1/openssl_s_server.1*
462 %{_mandir}/man1/openssl_s_time.1*
463 %{_mandir}/man1/openssl_sess_id.1*
464 %{_mandir}/man1/openssl_smime.1*
465 %{_mandir}/man1/openssl_speed.1*
466 %{_mandir}/man1/openssl_spkac.1*
467 %{_mandir}/man1/openssl_ts.1*
468 %{_mandir}/man1/openssl_tsget.1*
469 %{_mandir}/man1/openssl_verify.1*
470 %{_mandir}/man1/openssl_version.1*
471 %{_mandir}/man1/openssl_x509.1*
472 %{_mandir}/man5/openssl_config.5*
473 %{_mandir}/man5/openssl_x509v3_config.5*
474 %lang(pl) %{_mandir}/pl/man1/openssl.1*
475
476 %files tools-perl
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_bindir}/c_rehash
479 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
480 %attr(755,root,root) %{_libdir}/%{name}/tsget
481 %{_mandir}/man1/openssl_CA.pl.1*
482 %{_mandir}/man1/openssl_c_rehash.1*
483
484 %files devel
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_libdir}/libcrypto.so
487 %attr(755,root,root) %{_libdir}/libssl.so
488 %{_includedir}/%{name}
489 %{_pkgconfigdir}/libcrypto.pc
490 %{_pkgconfigdir}/libssl.pc
491 %{_pkgconfigdir}/openssl.pc
492 %{_mandir}/man3/openssl*.3*
493 %{_mandir}/man7/openssl_des_modes.7*
494
495 %files static
496 %defattr(644,root,root,755)
497 %{_libdir}/libcrypto.a
498 %{_libdir}/libssl.a
This page took 0.053394 seconds and 2 git commands to generate.