]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
93ecf6680c7db71f4da0fe8a8a9c92c36be77f4e
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_with     sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
6 %bcond_with     sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
7 %bcond_with     snap    # use GitHub snapshot to build branch release
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
11 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
12 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
13 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
14 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
15 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
16 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
17 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
18 Name:           openssl
19 # Version 1.1.0 will be supported until 2019-??-?? (one year after release of 1.1.1).
20 # https://www.openssl.org/about/releasestrat.html
21 Version:        1.1.1
22 Release:        1
23 License:        Apache-like
24 Group:          Libraries
25 %if %{without snap}
26 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
27 # Source0-md5:  7079eb017429e0ffb9efb42bf80ccb21
28 %else
29 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_1_0-stable/%{name}-%{version}-dev.tar.gz
30 %endif
31 Source2:        %{name}.1.pl
32 Source3:        %{name}-ssl-certificate.sh
33 Source4:        %{name}-c_rehash.sh
34 Patch1:         %{name}-optflags.patch
35
36 Patch3:         %{name}-man-namespace.patch
37
38 Patch5:         %{name}-ca-certificates.patch
39
40 Patch7:         %{name}-find.patch
41 Patch8:         pic.patch
42
43 Patch10:        %{name}_fix_for_x32.patch
44 Patch11:        engines-dir.patch
45 URL:            http://www.openssl.org/
46 BuildRequires:  perl-devel >= 1:5.10.0
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpm-perlprov >= 4.1-13
49 BuildRequires:  rpmbuild(macros) >= 1.213
50 BuildRequires:  sed >= 4.0
51 BuildRequires:  zlib-devel
52 Requires:       ca-certificates >= 20120623-1.1
53 Requires:       rpm-whiteout >= 1.7
54 Obsoletes:      SSLeay
55 Obsoletes:      SSLeay-devel
56 Obsoletes:      SSLeay-perl
57 Obsoletes:      libopenssl0
58 %if "%{pld_release}" == "ac"
59 Conflicts:      neon < 0.26.3-3
60 Conflicts:      ntpd < 4.2.4p8-10
61 Conflicts:      openssh-clients < 2:5.8p1-9
62 Conflicts:      openssh-server < 2:5.8p1-9
63 %else
64 Conflicts:      neon < 0.29.6-8
65 Conflicts:      openssh-clients < 2:6.2p2-3
66 Conflicts:      openssh-server < 2:6.2p2-3
67 %endif
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 The OpenSSL Project is a collaborative effort to develop a robust,
72 commercial-grade, full-featured, and Open Source toolkit implementing
73 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
74 v1) protocols with full-strength cryptography world-wide. The project
75 is managed by a worldwide community of volunteers that use the
76 Internet to communicate, plan, and develop the OpenSSL tookit and its
77 related documentation.
78
79 OpenSSL is based on the excellent SSLeay library developed by Eric A.
80 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
81 Apache-style licence, which basically means that you are free to get
82 and use it for commercial and non-commercial purposes subject to some
83 simple license conditions.
84
85 This package contains shared libraries only, install openssl-tools if
86 you want to use openssl cmdline tool.
87
88 %description -l de.UTF-8
89 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
90 libraries, die verschiedene Verschlüsselungs- und
91 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
92 zur Verfügung stellen.
93
94 %description -l es.UTF-8
95 Biblioteca C que suministra algoritmos y protocolos criptográficos.
96
97 %description -l fr.UTF-8
98 OpenSSL est un outiil de gestion des certificats et les librairies
99 partagees qui fournit plusieurs protocoles et algorithmes de
100 codage/decodage, incluant DES, RC4, RSA et SSL.
101
102 %description -l pl.UTF-8
103 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
104 v2/v3 oraz Transport Layer Security (TLS v1).
105
106 %description -l pt_BR.UTF-8
107 Uma biblioteca C que fornece vários algoritmos e protocolos
108 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
109 compartilhadas e utilitários.
110
111 %description -l ru.UTF-8
112 Программа openssl для работы с сертификатами и разделяемые библиотеки,
113 которые реализуют множетсво криптографических алгоритмов, включая DES,
114 RC4, RSA и SSL.
115
116 %description -l uk.UTF-8
117 Програма openssl для роботи з сертифікатами та бібліотеки спільного
118 користування, що реалізують велику кількість криптографічних
119 алгоритмів, включаючи DES, RC4, RSA та SSL.
120
121 %package engines
122 Summary:        OpenSSL optional crypto engines
123 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
124 Group:          Libraries
125 Requires:       %{name} = %{version}-%{release}
126
127 %description engines
128 With OpenSSL 0.9.6, a new component was added to support alternative
129 cryptography implementations, most commonly for interfacing with
130 external crypto devices (eg. accelerator cards). This component is
131 called ENGINE.
132
133 There are currently built-in ENGINE implementations for the following
134 crypto devices:
135
136 - CryptoSwift
137 - Compaq Atalla
138 - nCipher CHIL
139 - Nuron
140 - Broadcom uBSec
141
142 In addition, dynamic binding to external ENGINE implementations is now
143 provided by a special ENGINE called "dynamic".
144
145 %description engines -l pl.UTF-8
146 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
147 wspierać alternatywne implementacje kryptografii, przeważnie
148 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
149 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
150 ENGINE).
151
152 Obecnie istnieją wbudowane implementacje silników dla następujących
153 urządzeń kryptograficznych:
154 - CryptoSwift
155 - Compaq Atalla
156 - nCipher CHIL
157 - Nuron
158 - Broadcom uBSec
159
160 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
161 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
162
163 %package tools
164 Summary:        OpenSSL command line tool and utilities
165 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
166 Group:          Applications/Communications
167 Requires:       %{name} = %{version}-%{release}
168 Requires:       which
169
170 %description tools
171 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
172
173 %description tools -l pl.UTF-8
174 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
175
176 %package tools-perl
177 Summary:        OpenSSL utilities written in Perl
178 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
179 Group:          Applications/Communications
180 Requires:       %{name} = %{version}-%{release}
181
182 %description tools-perl
183 OpenSSL Toolkit tools written in Perl.
184
185 %description tools-perl -l pl.UTF-8
186 Narzędzia OpenSSL napisane w perlu.
187
188 %package devel
189 Summary:        Development part of OpenSSL Toolkit libraries
190 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
191 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
192 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
193 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
194 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
195 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
196 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
197 Group:          Development/Libraries
198 Requires:       %{name} = %{version}-%{release}
199 Obsoletes:      libopenssl0-devel
200
201 %description devel
202 Development part of OpenSSL library.
203
204 %description devel -l es.UTF-8
205 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
206
207 %description devel -l pl.UTF-8
208 Część biblioteki OpenSSL przeznaczona dla programistów.
209
210 %description devel -l pt_BR.UTF-8
211 Uma biblioteca C que fornece vários algoritmos e protocolos
212 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
213 arquivos de inclusão para desenvolvimento.
214
215 %description devel -l ru.UTF-8
216 Программа openssl для работы с сертификатами и разделяемые библиотеки,
217 которые реализуют множетсво криптографических алгоритмов, включая DES,
218 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
219 с использованием SSL.
220
221 %description devel -l uk.UTF-8
222 Програма openssl для роботи з сертифікатами та бібліотеки спільного
223 користування, що реалізують велику кількість криптографічних
224 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
225 хедери для розробки програм з використанням SSL.
226
227 %package static
228 Summary:        Static OpenSSL libraries
229 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
230 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
231 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
232 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
233 Group:          Development/Libraries
234 Requires:       %{name}-devel = %{version}-%{release}
235
236 %description static
237 Static OpenSSL Toolkit libraries.
238
239 %description static -l pl.UTF-8
240 Statyczne wersje bibliotek z OpenSSL.
241
242 %description static -l pt_BR.UTF-8
243 Bibliotecas estáticas para desenvolvimento com openssl.
244
245 %description static -l ru.UTF-8
246 Программа openssl для работы с сертификатами и разделяемые библиотеки,
247 которые реализуют множетсво криптографических алгоритмов, включая DES,
248 RC4, RSA и SSL. Включает статические библиотеки для разработки
249 приложений с использованием OpenSSL.
250
251 %description static -l uk.UTF-8
252 Програма openssl для роботи з сертифікатами та бібліотеки спільного
253 користування, що реалізують велику кількість криптографічних
254 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
255 бібліотеки для розробки програм з використанням SSL.
256
257 %prep
258 %if %{with snap}
259 %setup -qcT -a1
260 %{__mv} %{name}-OpenSSL_1_1_0-stable/* .
261 %else
262 %setup -q %{?subver:-n %{name}-%{version}-%{subver}}
263 %endif
264
265 %patch1 -p1
266
267 %patch3 -p1
268
269 %patch5 -p1
270
271 %patch7 -p1
272 %patch8 -p1
273
274 %ifarch x32
275 %patch10 -p1
276 %endif
277 %patch11 -p1
278
279 %build
280 touch Makefile.*
281
282 PERL="%{__perl}" \
283 %{__perl} ./Configure \
284         --prefix=%{_prefix} \
285         --openssldir=%{_sysconfdir}/%{name} \
286         --libdir=%{_lib} \
287         -Wa,--noexecstack \
288         shared \
289         threads \
290         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
291         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
292         %{!?with_zlib:no-}zlib \
293         enable-cms \
294         enable-idea \
295         enable-md2 \
296         enable-mdc2 \
297         enable-rc5 \
298         enable-rfc3779 \
299         enable-seed \
300 %ifarch %{x8664}
301         enable-ec_nistp_64_gcc_128 \
302 %endif
303 %ifarch %{ix86}
304 %ifarch i386
305         386 linux-elf
306 # ^- allow running on 80386 (default code uses bswapl available on i486+)
307 %else
308         linux-elf
309 %endif
310 %endif
311 %ifarch alpha
312         linux-alpha-gcc
313 %endif
314 %ifarch %{x8664}
315         linux-x86_64
316 %endif
317 %ifarch x32
318         linux-x32
319 %endif
320 %ifarch ia64
321         linux-ia64
322 %endif
323 %ifarch ppc
324         linux-ppc
325 %endif
326 %ifarch ppc64
327         linux-ppc64
328 %endif
329 %ifarch sparc
330         linux-sparcv8
331 %endif
332 %ifarch sparcv9
333         linux-sparcv9
334 %endif
335 %ifarch sparc64
336         linux64-sparcv9
337 %endif
338 %ifarch %{arm}
339         linux-armv4
340 %endif
341 %ifarch aarch64
342         linux-aarch64
343 %endif
344
345 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
346 test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
347
348 %{__make} -j1 all %{?with_tests:tests} \
349         CC="%{__cc}" \
350         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
351         INSTALLTOP=%{_prefix}
352
353 # Rename POD sources of man pages. "openssl-" prefix is added to each
354 # manpage to avoid potential conflicts with other packages. 
355 # openssl-man-namespace.patch mostly marks these pages with "openssl-" prefix.
356
357 for podfile in $(grep -rl '^openssl-' doc/man*); do
358         dir=$(dirname "$podfile")
359         base=$(basename "$podfile")
360         %{__mv} "$podfile" "$dir/openssl-$base"
361 done
362
363 %install
364 rm -rf $RPM_BUILD_ROOT
365 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
366         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
367         $RPM_BUILD_ROOT%{_pkgconfigdir}
368
369 %{__make} -j1 install \
370         CC="%{__cc}" \
371         DESTDIR=$RPM_BUILD_ROOT
372
373 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
374 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
375 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
376
377 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
378 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
379
380 # html version of man pages - not packaged
381 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
382
383 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
384 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
385 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
386
387 %clean
388 rm -rf $RPM_BUILD_ROOT
389
390 %post   -p /sbin/ldconfig
391 %postun -p /sbin/ldconfig
392
393 %triggerpostun -- %{name}-tools < 1.0.0-5
394 # the hashing format has changed in 1.0.0
395 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
396
397 %triggerpostun -- %{name} < 0.9.8i-2
398 # don't do anything on --downgrade
399 if [ $1 -le 1 ]; then
400         exit 0
401 fi
402 if [ -d /var/lib/openssl/certs ] ; then
403         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
404 fi
405 if [ -d /var/lib/openssl/private ] ; then
406         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
407 fi
408 if [ -d /var/lib/openssl ] ; then
409         for f in /var/lib/openssl/* ; do
410                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
411         done
412         rmdir /var/lib/openssl/* 2>/dev/null || :
413         rmdir /var/lib/openssl 2>/dev/null || :
414 fi
415
416 %files
417 %defattr(644,root,root,755)
418 %doc CHANGES LICENSE NEWS README doc/*.txt
419 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*
420 %attr(755,root,root) /%{_lib}/libssl.so.*.*
421 %dir %{_sysconfdir}/%{name}
422 %dir %{_sysconfdir}/%{name}/certs
423 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
424 %dir %{_datadir}/ssl
425
426 %files engines
427 %defattr(644,root,root,755)
428 %dir /%{_lib}/engines-1.1
429 %attr(755,root,root) /%{_lib}/engines-1.1/*.so
430
431 %files tools
432 %defattr(644,root,root,755)
433 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ct_log_list.cnf
434 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
435 %attr(755,root,root) %{_bindir}/c_rehash.sh
436 %attr(755,root,root) %{_bindir}/openssl
437 %attr(754,root,root) %{_bindir}/ssl-certificate
438 %{_mandir}/man1/openssl.1*
439 %{_mandir}/man1/openssl-asn1parse.1*
440 %{_mandir}/man1/openssl-ca.1*
441 %{_mandir}/man1/openssl-ciphers.1*
442 %{_mandir}/man1/openssl-cms.1*
443 %{_mandir}/man1/openssl-crl.1*
444 %{_mandir}/man1/openssl-crl2pkcs7.1*
445 %{_mandir}/man1/openssl-dgst.1*
446 %{_mandir}/man1/openssl-dhparam.1*
447 %{_mandir}/man1/openssl-dsa.1*
448 %{_mandir}/man1/openssl-dsaparam.1*
449 %{_mandir}/man1/openssl-ec.1*
450 %{_mandir}/man1/openssl-ecparam.1*
451 %{_mandir}/man1/openssl-enc.1*
452 %{_mandir}/man1/openssl-engine.1*
453 %{_mandir}/man1/openssl-errstr.1*
454 %{_mandir}/man1/openssl-gendsa.1*
455 %{_mandir}/man1/openssl-genpkey.1*
456 %{_mandir}/man1/openssl-genrsa.1*
457 %{_mandir}/man1/openssl-list.1*
458 %{_mandir}/man1/openssl-nseq.1*
459 %{_mandir}/man1/openssl-ocsp.1*
460 %{_mandir}/man1/openssl-passwd.1*
461 %{_mandir}/man1/openssl-pkcs12.1*
462 %{_mandir}/man1/openssl-pkcs7.1*
463 %{_mandir}/man1/openssl-pkcs8.1*
464 %{_mandir}/man1/openssl-pkey.1*
465 %{_mandir}/man1/openssl-pkeyparam.1*
466 %{_mandir}/man1/openssl-pkeyutl.1*
467 %{_mandir}/man1/openssl-prime.1*
468 %{_mandir}/man1/openssl-rand.1*
469 %{_mandir}/man1/openssl-rehash.1*
470 %{_mandir}/man1/openssl-req.1*
471 %{_mandir}/man1/openssl-rsa.1*
472 %{_mandir}/man1/openssl-rsautl.1*
473 %{_mandir}/man1/openssl-s_client.1*
474 %{_mandir}/man1/openssl-sess_id.1*
475 %{_mandir}/man1/openssl-smime.1*
476 %{_mandir}/man1/openssl-speed.1*
477 %{_mandir}/man1/openssl-spkac.1*
478 %{_mandir}/man1/openssl-srp.1*
479 %{_mandir}/man1/openssl-s_server.1*
480 %{_mandir}/man1/openssl-s_time.1*
481 %{_mandir}/man1/openssl-storeutl.1*
482 %{_mandir}/man1/openssl-ts.1*
483 %{_mandir}/man1/openssl-tsget.1*
484 %{_mandir}/man1/openssl-verify.1*
485 %{_mandir}/man1/openssl-version.1*
486 %{_mandir}/man1/openssl-x509.1*
487 %{_mandir}/man5/openssl-config.5*
488 %{_mandir}/man5/openssl-x509v3_config.5*
489 %lang(pl) %{_mandir}/pl/man1/openssl.1*
490
491 %files tools-perl
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_bindir}/c_rehash
494 %dir %{_libdir}/%{name}
495 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
496 %attr(755,root,root) %{_libdir}/%{name}/tsget
497 %attr(755,root,root) %{_libdir}/%{name}/tsget.pl
498 %{_mandir}/man1/CA.pl.1*
499 %{_mandir}/man1/c_rehash.1*
500
501 %files devel
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_libdir}/libcrypto.so
504 %attr(755,root,root) %{_libdir}/libssl.so
505 %{_includedir}/%{name}
506 %{_pkgconfigdir}/libcrypto.pc
507 %{_pkgconfigdir}/libssl.pc
508 %{_pkgconfigdir}/openssl.pc
509 %{_mandir}/man3/ACCESS_DESCRIPTION_*.3*
510 %{_mandir}/man3/ADMISSION*.3*
511 %{_mandir}/man3/ASId*.3*
512 %{_mandir}/man3/ASRange_*.3*
513 %{_mandir}/man3/ASN1_*.3*
514 %{_mandir}/man3/ASYNC_*.3*
515 %{_mandir}/man3/AUTHORITY_*.3*
516 %{_mandir}/man3/BASIC_CONSTRAINTS_*.3*
517 %{_mandir}/man3/BF_*.3*
518 %{_mandir}/man3/BIO_*.3*
519 %{_mandir}/man3/BN_*.3*
520 %{_mandir}/man3/BUF_*.3*
521 %{_mandir}/man3/CERTIFICATEPOLICIES_*.3*
522 %{_mandir}/man3/CMS_*.3*
523 %{_mandir}/man3/CONF_*.3*
524 %{_mandir}/man3/CRL_DIST_POINTS_*.3*
525 %{_mandir}/man3/CRYPTO_*.3*
526 %{_mandir}/man3/CTLOG_*.3*
527 %{_mandir}/man3/CT_POLICY_*.3*
528 %{_mandir}/man3/DECLARE_*.3*
529 %{_mandir}/man3/DEFINE_*.3*
530 %{_mandir}/man3/DES_*.3*
531 %{_mandir}/man3/DH_*.3*
532 %{_mandir}/man3/DHparams_*.3*
533 %{_mandir}/man3/DIRECTORYSTRING_*.3*
534 %{_mandir}/man3/DISPLAYTEXT_*.3*
535 %{_mandir}/man3/DIST_POINT_*.3*
536 %{_mandir}/man3/DSA_*.3*
537 %{_mandir}/man3/DSAparams_*.3*
538 %{_mandir}/man3/DTLS_*.3*
539 %{_mandir}/man3/DTLSv1_*.3*
540 %{_mandir}/man3/ECDH_*.3*
541 %{_mandir}/man3/ECDSA_*.3*
542 %{_mandir}/man3/ECPARAMETERS_*.3*
543 %{_mandir}/man3/ECPKPARAMETERS_*.3*
544 %{_mandir}/man3/ECPKParameters_*.3*
545 %{_mandir}/man3/EC_*.3*
546 %{_mandir}/man3/EDIPARTYNAME_*.3*
547 %{_mandir}/man3/ENGINE_*.3*
548 %{_mandir}/man3/ERR_*.3*
549 %{_mandir}/man3/ESS_*.3*
550 %{_mandir}/man3/EVP_*.3*
551 %{_mandir}/man3/EXTENDED_KEY_USAGE_*.3*
552 %{_mandir}/man3/GENERAL_*.3*
553 %{_mandir}/man3/GEN_SESSION_CB.3*
554 %{_mandir}/man3/HMAC*.3*
555 %{_mandir}/man3/IMPLEMENT_*.3*
556 %{_mandir}/man3/IPAddress*.3*
557 %{_mandir}/man3/ISSUING_DIST_POINT_*.3*
558 %{_mandir}/man3/LHASH*.3*
559 %{_mandir}/man3/MD2*.3*
560 %{_mandir}/man3/MD4*.3*
561 %{_mandir}/man3/MD5*.3*
562 %{_mandir}/man3/MDC2*.3*
563 %{_mandir}/man3/NAME_CONSTRAINTS_*.3*
564 %{_mandir}/man3/NAMING_AUTHORITY*.3*
565 %{_mandir}/man3/NETSCAPE_*.3*
566 %{_mandir}/man3/NOTICEREF_*.3*
567 %{_mandir}/man3/OBJ_*.3*
568 %{_mandir}/man3/OCSP_*.3*
569 %{_mandir}/man3/OPENSSL_*.3*
570 %{_mandir}/man3/OSSL*.3*
571 %{_mandir}/man3/OTHERNAME_*.3*
572 %{_mandir}/man3/OpenSSL_*.3*
573 %{_mandir}/man3/PBE2PARAM_*.3*
574 %{_mandir}/man3/PBEPARAM_*.3*
575 %{_mandir}/man3/PBKDF2PARAM_*.3*
576 %{_mandir}/man3/PEM_*.3*
577 %{_mandir}/man3/PKCS12_*.3*
578 %{_mandir}/man3/PKCS5_*.3*
579 %{_mandir}/man3/PKCS7_*.3*
580 %{_mandir}/man3/PKCS8_*.3*
581 %{_mandir}/man3/PKEY_*.3*
582 %{_mandir}/man3/POLICYINFO_*.3*
583 %{_mandir}/man3/POLICYQUALINFO_*.3*
584 %{_mandir}/man3/POLICY_*.3*
585 %{_mandir}/man3/PROFESSION_INFO*.3*
586 %{_mandir}/man3/PROXY_*.3*
587 %{_mandir}/man3/RAND_*.3*
588 %{_mandir}/man3/RC4*.3*
589 %{_mandir}/man3/RIPEMD160*.3*
590 %{_mandir}/man3/RSAPrivateKey_*.3*
591 %{_mandir}/man3/RSAPublicKey_*.3*
592 %{_mandir}/man3/RSA_*.3*
593 %{_mandir}/man3/SCRYPT_PARAMS*.3*
594 %{_mandir}/man3/SCT_*.3*
595 %{_mandir}/man3/SHA1*.3*
596 %{_mandir}/man3/SHA224*.3*
597 %{_mandir}/man3/SHA256*.3*
598 %{_mandir}/man3/SHA384*.3*
599 %{_mandir}/man3/SHA512*.3*
600 %{_mandir}/man3/SMIME_*.3*
601 %{_mandir}/man3/SSL_*.3*
602 %{_mandir}/man3/SSLv23_*.3*
603 %{_mandir}/man3/SSLv3_*.3*
604 %{_mandir}/man3/SXNET_*.3*
605 %{_mandir}/man3/SXNETID_*.3*
606 %{_mandir}/man3/TLS_*.3*
607 %{_mandir}/man3/TLSv1_*.3*
608 %{_mandir}/man3/TS_*.3*
609 %{_mandir}/man3/UI*.3*
610 %{_mandir}/man3/USERNOTICE_*.3*
611 %{_mandir}/man3/X509_*.3*
612 %{_mandir}/man3/X509V3_*.3*
613 %{_mandir}/man3/X509v3_*.3*
614 %{_mandir}/man3/custom_ext_*.3*
615 %{_mandir}/man3/d2i_*.3*
616 %{_mandir}/man3/i2d_*.3*
617 %{_mandir}/man3/i2o_*.3*
618 %{_mandir}/man3/i2t_*.3*
619 %{_mandir}/man3/lh_TYPE_*.3*
620 %{_mandir}/man3/o2i_*.3*
621 %{_mandir}/man3/pem_password_cb.3*
622 %{_mandir}/man3/sk_TYPE_*.3*
623 %{_mandir}/man3/ssl_ct_validation_cb.3*
624 %{_mandir}/man7/openssl.7*
625 %{_mandir}/man7/openssl-bio.7*
626 %{_mandir}/man7/openssl-crypto.7*
627 %{_mandir}/man7/openssl-ct.7*
628 %{_mandir}/man7/openssl-des_modes.7*
629 %{_mandir}/man7/openssl-Ed25519.7*
630 %{_mandir}/man7/openssl-Ed448.7*
631 %{_mandir}/man7/openssl-evp.7*
632 %{_mandir}/man7/openssl-passphrase-encoding.7*
633 %{_mandir}/man7/openssl-RAND.7*
634 %{_mandir}/man7/openssl-RAND_DRBG.7*
635 %{_mandir}/man7/openssl-scrypt.7*
636 %{_mandir}/man7/openssl-SM2.7*
637 %{_mandir}/man7/openssl-ssl.7*
638 %{_mandir}/man7/openssl-X25519.7*
639 %{_mandir}/man7/openssl-X448.7*
640 %{_mandir}/man7/openssl-x509.7*
641 %{_mandir}/man7/ossl_store.7*
642 %{_mandir}/man7/ossl_store-file.7*
643 %{_mandir}/man7/RSA-PSS.7.gz
644
645 %files static
646 %defattr(644,root,root,755)
647 %{_libdir}/libcrypto.a
648 %{_libdir}/libssl.a
This page took 0.079162 seconds and 2 git commands to generate.