]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- adjusted man prefix to match upstream (openssl- instead of openssl_)
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 # - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
4 #
5 # Conditional build:
6 %bcond_without  tests   # don't perform "make tests"
7 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
8 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
9 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
10 %bcond_with     purify  # Compile openssl with "-DPURIFY", useful when one wants to
11                         # use valgrind debugger against openssl-linked programs
12 %bcond_with     snap    # use GitHub snapshot to build branch release
13
14 %include        /usr/lib/rpm/macros.perl
15 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
16 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
17 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
18 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
19 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
20 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
21 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
22 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
23 Name:           openssl
24 # 1.0.2 will be LTS release
25 # Version 1.0.2 will be supported until 2019-12-31.
26 # https://www.openssl.org/about/releasestrat.html
27 Version:        1.0.2m
28 Release:        1
29 License:        Apache-like
30 Group:          Libraries
31 %if %{without snap}
32 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
33 # Source0-md5:  10e9e37f492094b9ef296f68f24a7666
34 %else
35 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
36 # Source1-md5:  6b846f8a4f55f5ddfa1e0d335241840a
37 %endif
38 Source2:        %{name}.1.pl
39 Source3:        %{name}-ssl-certificate.sh
40 Source4:        %{name}-c_rehash.sh
41 Patch0:         %{name}-alpha-ccc.patch
42 Patch1:         %{name}-optflags.patch
43 Patch2:         %{name}-include.patch
44 Patch3:         %{name}-man-namespace.patch
45 Patch4:         %{name}-asflag.patch
46 Patch5:         %{name}-ca-certificates.patch
47 Patch6:         %{name}-ldflags.patch
48 Patch7:         %{name}-find.patch
49 Patch8:         pic.patch
50 Patch10:        %{name}_fix_for_x32.patch
51 URL:            http://www.openssl.org/
52 BuildRequires:  bc
53 BuildRequires:  perl-devel >= 1:5.6.1
54 BuildRequires:  pkgconfig
55 BuildRequires:  rpm-perlprov >= 4.1-13
56 BuildRequires:  rpmbuild(macros) >= 1.213
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  zlib-devel
59 Requires:       ca-certificates >= 20120623-1.1
60 Requires:       rpm-whiteout >= 1.7
61 Obsoletes:      SSLeay
62 Obsoletes:      SSLeay-devel
63 Obsoletes:      SSLeay-perl
64 Obsoletes:      libopenssl0
65 %if "%{pld_release}" == "ac"
66 Conflicts:      neon < 0.26.3-3
67 Conflicts:      ntpd < 4.2.4p8-10
68 Conflicts:      openssh-clients < 2:5.8p1-9
69 Conflicts:      openssh-server < 2:5.8p1-9
70 %else
71 Conflicts:      neon < 0.29.6-8
72 Conflicts:      openssh-clients < 2:6.2p2-3
73 Conflicts:      openssh-server < 2:6.2p2-3
74 %endif
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 The OpenSSL Project is a collaborative effort to develop a robust,
79 commercial-grade, full-featured, and Open Source toolkit implementing
80 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
81 v1) protocols with full-strength cryptography world-wide. The project
82 is managed by a worldwide community of volunteers that use the
83 Internet to communicate, plan, and develop the OpenSSL tookit and its
84 related documentation.
85
86 OpenSSL is based on the excellent SSLeay library developed by Eric A.
87 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
88 Apache-style licence, which basically means that you are free to get
89 and use it for commercial and non-commercial purposes subject to some
90 simple license conditions.
91
92 This package contains shared libraries only, install openssl-tools if
93 you want to use openssl cmdline tool.
94
95 %description -l de.UTF-8
96 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
97 libraries, die verschiedene Verschlüsselungs- und
98 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
99 zur Verfügung stellen.
100
101 %description -l es.UTF-8
102 Biblioteca C que suministra algoritmos y protocolos criptográficos.
103
104 %description -l fr.UTF-8
105 OpenSSL est un outiil de gestion des certificats et les librairies
106 partagees qui fournit plusieurs protocoles et algorithmes de
107 codage/decodage, incluant DES, RC4, RSA et SSL.
108
109 %description -l pl.UTF-8
110 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
111 v2/v3 oraz Transport Layer Security (TLS v1).
112
113 %description -l pt_BR.UTF-8
114 Uma biblioteca C que fornece vários algoritmos e protocolos
115 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
116 compartilhadas e utilitários.
117
118 %description -l ru.UTF-8
119 Программа openssl для работы с сертификатами и разделяемые библиотеки,
120 которые реализуют множетсво криптографических алгоритмов, включая DES,
121 RC4, RSA и SSL.
122
123 %description -l uk.UTF-8
124 Програма openssl для роботи з сертифікатами та бібліотеки спільного
125 користування, що реалізують велику кількість криптографічних
126 алгоритмів, включаючи DES, RC4, RSA та SSL.
127
128 %package engines
129 Summary:        OpenSSL optional crypto engines
130 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
131 Group:          Libraries
132 Requires:       %{name} = %{version}-%{release}
133
134 %description engines
135 With OpenSSL 0.9.6, a new component was added to support alternative
136 cryptography implementations, most commonly for interfacing with
137 external crypto devices (eg. accelerator cards). This component is
138 called ENGINE.
139
140 There are currently built-in ENGINE implementations for the following
141 crypto devices:
142
143 - CryptoSwift
144 - Compaq Atalla
145 - nCipher CHIL
146 - Nuron
147 - Broadcom uBSec
148
149 In addition, dynamic binding to external ENGINE implementations is now
150 provided by a special ENGINE called "dynamic".
151
152 %description engines -l pl.UTF-8
153 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
154 wspierać alternatywne implementacje kryptografii, przeważnie
155 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
156 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
157 ENGINE).
158
159 Obecnie istnieją wbudowane implementacje silników dla następujących
160 urządzeń kryptograficznych:
161 - CryptoSwift
162 - Compaq Atalla
163 - nCipher CHIL
164 - Nuron
165 - Broadcom uBSec
166
167 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
168 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
169
170 %package tools
171 Summary:        OpenSSL command line tool and utilities
172 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
173 Group:          Applications/Communications
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       which
176
177 %description tools
178 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
179
180 %description tools -l pl.UTF-8
181 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
182
183 %package tools-perl
184 Summary:        OpenSSL utilities written in Perl
185 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
186 Group:          Applications/Communications
187 Requires:       %{name} = %{version}-%{release}
188
189 %description tools-perl
190 OpenSSL Toolkit tools written in Perl.
191
192 %description tools-perl -l pl.UTF-8
193 Narzędzia OpenSSL napisane w perlu.
194
195 %package devel
196 Summary:        Development part of OpenSSL Toolkit libraries
197 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
198 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
199 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
200 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
201 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
202 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
203 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
204 Group:          Development/Libraries
205 Requires:       %{name} = %{version}-%{release}
206 Obsoletes:      libopenssl0-devel
207
208 %description devel
209 Development part of OpenSSL library.
210
211 %description devel -l es.UTF-8
212 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
213
214 %description devel -l pl.UTF-8
215 Część biblioteki OpenSSL przeznaczona dla programistów.
216
217 %description devel -l pt_BR.UTF-8
218 Uma biblioteca C que fornece vários algoritmos e protocolos
219 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
220 arquivos de inclusão para desenvolvimento.
221
222 %description devel -l ru.UTF-8
223 Программа openssl для работы с сертификатами и разделяемые библиотеки,
224 которые реализуют множетсво криптографических алгоритмов, включая DES,
225 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
226 с использованием SSL.
227
228 %description devel -l uk.UTF-8
229 Програма openssl для роботи з сертифікатами та бібліотеки спільного
230 користування, що реалізують велику кількість криптографічних
231 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
232 хедери для розробки програм з використанням SSL.
233
234 %package static
235 Summary:        Static OpenSSL libraries
236 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
237 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
238 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
239 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
240 Group:          Development/Libraries
241 Requires:       %{name}-devel = %{version}-%{release}
242
243 %description static
244 Static OpenSSL Toolkit libraries.
245
246 %description static -l pl.UTF-8
247 Statyczne wersje bibliotek z OpenSSL.
248
249 %description static -l pt_BR.UTF-8
250 Bibliotecas estáticas para desenvolvimento com openssl.
251
252 %description static -l ru.UTF-8
253 Программа openssl для работы с сертификатами и разделяемые библиотеки,
254 которые реализуют множетсво криптографических алгоритмов, включая DES,
255 RC4, RSA и SSL. Включает статические библиотеки для разработки
256 приложений с использованием OpenSSL.
257
258 %description static -l uk.UTF-8
259 Програма openssl для роботи з сертифікатами та бібліотеки спільного
260 користування, що реалізують велику кількість криптографічних
261 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
262 бібліотеки для розробки програм з використанням SSL.
263
264 %prep
265 %if %{with snap}
266 %setup -qcT -a1
267 mv %{name}-OpenSSL_1_0_2-stable/* .
268 %else
269 %setup -q
270 %endif
271 %patch0 -p1
272 %patch1 -p1
273 %patch2 -p1
274 %patch3 -p1
275 %patch4 -p1
276 %patch5 -p1
277 %patch6 -p1
278 %patch7 -p1
279 %patch8 -p1
280 %ifarch x32
281 %patch10 -p1
282 %endif
283
284 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
285
286 %build
287 touch Makefile.*
288
289 PERL5LIB=$(pwd) %{__perl} util/perlpath.pl %{__perl}
290
291 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
292 PERL="%{__perl}" \
293 %{__perl} ./Configure \
294         --openssldir=%{_sysconfdir}/%{name} \
295         --libdir=%{_lib} \
296         shared \
297         threads \
298         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
299         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
300         %{!?with_zlib:no-}zlib \
301         enable-camelia \
302         enable-cms \
303         enable-idea \
304         enable-md2 \
305         enable-mdc2 \
306         enable-rc5 \
307         enable-rfc3779 \
308         enable-seed \
309         enable-tlsext \
310 %ifarch %{x8664}
311         enable-ec_nistp_64_gcc_128 \
312 %endif
313 %ifarch %{ix86}
314 %ifarch i386
315         386 linux-elf
316 # ^- allow running on 80386 (default code uses bswapl available on i486+)
317 %else
318         linux-elf
319 %endif
320 %endif
321 %ifarch alpha
322         linux-alpha+bwx-gcc
323 %endif
324 %ifarch %{x8664}
325         linux-x86_64
326 %endif
327 %ifarch x32
328         linux-x32
329 %endif
330 %ifarch ia64
331         linux-ia64
332 %endif
333 %ifarch ppc
334         linux-ppc
335 %endif
336 %ifarch ppc64
337         linux-ppc64
338 %endif
339 %ifarch sparc
340         linux-sparcv8
341 %endif
342 %ifarch sparcv9
343         linux-sparcv9
344 %endif
345 %ifarch sparc64
346         linux64-sparcv9
347 %endif
348 %ifarch armv4 armv5 armv5t armv5te armv5tel
349         linux-armv4
350 %endif
351
352 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
353 test "$v" = %{version}%{?with_snap:-dev}
354
355 %{__make} -j1 all rehash %{?with_tests:tests} \
356         CC="%{__cc}" \
357         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
358         INSTALLTOP=%{_prefix}
359
360 # Rename POD sources of man pages. "openssl-" prefix is added to each
361 # manpage to avoid potential conflicts with other packages.
362
363 for dir in doc/{apps,ssl,crypto}; do
364         cd $dir || exit 1;
365         %{__perl} -pi -e 's/(\W)((?<!openssl-)\w+)(\(\d\))/$1openssl-$2$3/g; s/openssl-openssl/openssl/g;' *.pod;
366
367         for pod in !(openssl*).pod; do
368                 %{__mv} $pod openssl-$pod;
369         done
370         cd ../..
371 done
372
373 %install
374 rm -rf $RPM_BUILD_ROOT
375 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
376         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
377         $RPM_BUILD_ROOT/%{_lib}/engines \
378         $RPM_BUILD_ROOT%{_pkgconfigdir}
379
380 %{__make} -j1 install \
381         INSTALLTOP=%{_prefix} \
382         INSTALL_PREFIX=$RPM_BUILD_ROOT \
383         MANDIR=%{_mandir}
384
385 %{__mv} $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
386 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
387 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
388 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
389
390 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
391 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
392
393 # not installed as individual utilities (see openssl dgst instead)
394 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
395
396 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
397 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
398 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
399
400 %clean
401 rm -rf $RPM_BUILD_ROOT
402
403 %post   -p /sbin/ldconfig
404 %postun -p /sbin/ldconfig
405
406 %triggerpostun -- %{name}-tools < 1.0.0-5
407 # the hashing format has changed in 1.0.0
408 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
409
410 %triggerpostun -- %{name} < 0.9.8i-2
411 # don't do anything on --downgrade
412 if [ $1 -le 1 ]; then
413         exit 0
414 fi
415 if [ -d /var/lib/openssl/certs ] ; then
416         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
417 fi
418 if [ -d /var/lib/openssl/private ] ; then
419         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
420 fi
421 if [ -d /var/lib/openssl ] ; then
422         for f in /var/lib/openssl/* ; do
423                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
424         done
425         rmdir /var/lib/openssl/* 2>/dev/null || :
426         rmdir /var/lib/openssl 2>/dev/null || :
427 fi
428
429 %files
430 %defattr(644,root,root,755)
431 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
432 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
433 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
434 %dir %{_sysconfdir}/%{name}
435 %dir %{_sysconfdir}/%{name}/certs
436 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
437 %dir %{_datadir}/ssl
438
439 %files engines
440 %defattr(644,root,root,755)
441 %dir /%{_lib}/engines
442 %attr(755,root,root) /%{_lib}/engines/*.so
443
444 %files tools
445 %defattr(644,root,root,755)
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
447 %attr(755,root,root) %{_bindir}/c_rehash.sh
448 %attr(755,root,root) %{_bindir}/openssl
449 %attr(754,root,root) %{_bindir}/ssl-certificate
450
451 %dir %{_libdir}/%{name}
452 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
453 %attr(755,root,root) %{_libdir}/%{name}/c_hash
454 %attr(755,root,root) %{_libdir}/%{name}/c_info
455 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
456 %attr(755,root,root) %{_libdir}/%{name}/c_name
457
458 %{_mandir}/man1/openssl.1*
459 %{_mandir}/man1/openssl-asn1parse.1*
460 %{_mandir}/man1/openssl-ca.1*
461 %{_mandir}/man1/openssl-ciphers.1*
462 %{_mandir}/man1/openssl-cms.1*
463 %{_mandir}/man1/openssl-crl.1*
464 %{_mandir}/man1/openssl-crl2pkcs7.1*
465 %{_mandir}/man1/openssl-dgst.1*
466 %{_mandir}/man1/openssl-dhparam.1*
467 %{_mandir}/man1/openssl-dsa.1*
468 %{_mandir}/man1/openssl-dsaparam.1*
469 %{_mandir}/man1/openssl-ec.1*
470 %{_mandir}/man1/openssl-ecparam.1*
471 %{_mandir}/man1/openssl-enc.1*
472 %{_mandir}/man1/openssl-errstr.1*
473 %{_mandir}/man1/openssl-gendsa.1*
474 %{_mandir}/man1/openssl-genpkey.1*
475 %{_mandir}/man1/openssl-genrsa.1*
476 %{_mandir}/man1/openssl-nseq.1*
477 %{_mandir}/man1/openssl-ocsp.1*
478 %{_mandir}/man1/openssl-passwd.1*
479 %{_mandir}/man1/openssl-pkcs12.1*
480 %{_mandir}/man1/openssl-pkcs7.1*
481 %{_mandir}/man1/openssl-pkcs8.1*
482 %{_mandir}/man1/openssl-pkey.1*
483 %{_mandir}/man1/openssl-pkeyparam.1*
484 %{_mandir}/man1/openssl-pkeyutl.1*
485 %{_mandir}/man1/openssl-rand.1*
486 %{_mandir}/man1/openssl-req.1*
487 %{_mandir}/man1/openssl-rsa.1*
488 %{_mandir}/man1/openssl-rsautl.1*
489 %{_mandir}/man1/openssl-s_client.1*
490 %{_mandir}/man1/openssl-s_server.1*
491 %{_mandir}/man1/openssl-s_time.1*
492 %{_mandir}/man1/openssl-sess_id.1*
493 %{_mandir}/man1/openssl-smime.1*
494 %{_mandir}/man1/openssl-speed.1*
495 %{_mandir}/man1/openssl-spkac.1*
496 %{_mandir}/man1/openssl-ts.1*
497 %{_mandir}/man1/openssl-tsget.1*
498 %{_mandir}/man1/openssl-verify.1*
499 %{_mandir}/man1/openssl-version.1*
500 %{_mandir}/man1/openssl-x509.1*
501 %{_mandir}/man5/openssl-config.5*
502 %{_mandir}/man5/openssl-x509v3_config.5*
503 %lang(pl) %{_mandir}/pl/man1/openssl.1*
504
505 %files tools-perl
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_bindir}/c_rehash
508 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
509 %attr(755,root,root) %{_libdir}/%{name}/tsget
510 %{_mandir}/man1/openssl-CA.pl.1*
511 %{_mandir}/man1/openssl-c_rehash.1*
512
513 %files devel
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_libdir}/libcrypto.so
516 %attr(755,root,root) %{_libdir}/libssl.so
517 %{_includedir}/%{name}
518 %{_pkgconfigdir}/libcrypto.pc
519 %{_pkgconfigdir}/libssl.pc
520 %{_pkgconfigdir}/openssl.pc
521 %{_mandir}/man3/openssl-*.3*
522 %{_mandir}/man7/openssl-des_modes.7*
523
524 %files static
525 %defattr(644,root,root,755)
526 %{_libdir}/libcrypto.a
527 %{_libdir}/libssl.a
This page took 0.188706 seconds and 3 git commands to generate.