]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
bconds were fixed in 2a82d45
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 # - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
4 #
5 # Conditional build:
6 %bcond_without  tests   # don't perform "make tests"
7 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
8 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
9 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
10 %bcond_with     purify  # Compile openssl with "-DPURIFY", useful when one wants to
11                         # use valgrind debugger against openssl-linked programs
12 %bcond_with     snap    # use GitHub snapshot to build branch release
13
14 %include        /usr/lib/rpm/macros.perl
15 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
16 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
17 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
18 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
19 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
20 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
21 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
22 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
23 Name:           openssl
24 # 1.0.2 will be LTS release
25 # Version 1.0.2 will be supported until 2019-12-31.
26 # https://www.openssl.org/about/releasestrat.html
27 Version:        1.0.2g
28 Release:        6
29 License:        Apache-like
30 Group:          Libraries
31 %if %{without snap}
32 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
33 # Source0-md5:  f3c710c045cdee5fd114feb69feba7aa
34 %else
35 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
36 %endif
37 Source2:        %{name}.1.pl
38 Source3:        %{name}-ssl-certificate.sh
39 Source4:        %{name}-c_rehash.sh
40 Patch0:         %{name}-alpha-ccc.patch
41 Patch1:         %{name}-optflags.patch
42 Patch2:         %{name}-include.patch
43 Patch3:         %{name}-man-namespace.patch
44 Patch4:         %{name}-asflag.patch
45 Patch5:         %{name}-ca-certificates.patch
46 Patch6:         %{name}-ldflags.patch
47 Patch7:         %{name}-find.patch
48 Patch8:         pic.patch
49 Patch10:        %{name}_fix_for_x32.patch
50 URL:            http://www.openssl.org/
51 BuildRequires:  bc
52 BuildRequires:  perl-devel >= 1:5.6.1
53 BuildRequires:  rpm-perlprov >= 4.1-13
54 BuildRequires:  rpmbuild(macros) >= 1.213
55 BuildRequires:  sed >= 4.0
56 Requires:       ca-certificates >= 20120623-1.1
57 Requires:       rpm-whiteout >= 1.7
58 Obsoletes:      SSLeay
59 Obsoletes:      SSLeay-devel
60 Obsoletes:      SSLeay-perl
61 Obsoletes:      libopenssl0
62 %if "%{pld_release}" == "ac"
63 Conflicts:      neon < 0.26.3-3
64 Conflicts:      ntpd < 4.2.4p8-10
65 Conflicts:      openssh-clients < 2:5.8p1-9
66 Conflicts:      openssh-server < 2:5.8p1-9
67 %else
68 Conflicts:      QtNetwork < 4.8.7-8
69 Conflicts:      apache-mod_ssl < 1:2.2.31-4
70 Conflicts:      curl-libs < 7.47.1-2
71 Conflicts:      neon < 0.29.6-8
72 Conflicts:      openssh-clients < 2:6.2p2-3
73 Conflicts:      openssh-server < 2:6.2p2-3
74 Conflicts:      php52-common < 4:5.2.17-20130717.17
75 Conflicts:      php53-common < 4:5.3.29-27
76 Conflicts:      php54-common < 4:5.4.45-5
77 Conflicts:      php55-common < 4:5.5.32-2
78 Conflicts:      php56-common < 4:5.6.18-3
79 Conflicts:      python-modules < 1:2.7.10-8
80 Conflicts:      python3-modules < 1:3.5.0-9
81 Conflicts:      ruby-modules < 1:2.0.0.648-2
82 %endif
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %description
86 The OpenSSL Project is a collaborative effort to develop a robust,
87 commercial-grade, full-featured, and Open Source toolkit implementing
88 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
89 v1) protocols with full-strength cryptography world-wide. The project
90 is managed by a worldwide community of volunteers that use the
91 Internet to communicate, plan, and develop the OpenSSL tookit and its
92 related documentation.
93
94 OpenSSL is based on the excellent SSLeay library developed by Eric A.
95 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
96 Apache-style licence, which basically means that you are free to get
97 and use it for commercial and non-commercial purposes subject to some
98 simple license conditions.
99
100 This package contains shared libraries only, install openssl-tools if
101 you want to use openssl cmdline tool.
102
103 %description -l de.UTF-8
104 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
105 libraries, die verschiedene Verschlüsselungs- und
106 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
107 zur Verfügung stellen.
108
109 %description -l es.UTF-8
110 Biblioteca C que suministra algoritmos y protocolos criptográficos.
111
112 %description -l fr.UTF-8
113 OpenSSL est un outiil de gestion des certificats et les librairies
114 partagees qui fournit plusieurs protocoles et algorithmes de
115 codage/decodage, incluant DES, RC4, RSA et SSL.
116
117 %description -l pl.UTF-8
118 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
119 v2/v3 oraz Transport Layer Security (TLS v1).
120
121 %description -l pt_BR.UTF-8
122 Uma biblioteca C que fornece vários algoritmos e protocolos
123 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
124 compartilhadas e utilitários.
125
126 %description -l ru.UTF-8
127 Программа openssl для работы с сертификатами и разделяемые библиотеки,
128 которые реализуют множетсво криптографических алгоритмов, включая DES,
129 RC4, RSA и SSL.
130
131 %description -l uk.UTF-8
132 Програма openssl для роботи з сертифікатами та бібліотеки спільного
133 користування, що реалізують велику кількість криптографічних
134 алгоритмів, включаючи DES, RC4, RSA та SSL.
135
136 %package engines
137 Summary:        OpenSSL optional crypto engines
138 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141
142 %description engines
143 With OpenSSL 0.9.6, a new component was added to support alternative
144 cryptography implementations, most commonly for interfacing with
145 external crypto devices (eg. accelerator cards). This component is
146 called ENGINE.
147
148 There are currently built-in ENGINE implementations for the following
149 crypto devices:
150
151 - CryptoSwift
152 - Compaq Atalla
153 - nCipher CHIL
154 - Nuron
155 - Broadcom uBSec
156
157 In addition, dynamic binding to external ENGINE implementations is now
158 provided by a special ENGINE called "dynamic".
159
160 %description engines -l pl.UTF-8
161 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
162 wspierać alternatywne implementacje kryptografii, przeważnie
163 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
164 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
165 ENGINE).
166
167 Obecnie istnieją wbudowane implementacje silników dla następujących
168 urządzeń kryptograficznych:
169 - CryptoSwift
170 - Compaq Atalla
171 - nCipher CHIL
172 - Nuron
173 - Broadcom uBSec
174
175 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
176 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
177
178 %package tools
179 Summary:        OpenSSL command line tool and utilities
180 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
181 Group:          Applications/Communications
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       which
184
185 %description tools
186 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
187
188 %description tools -l pl.UTF-8
189 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
190
191 %package tools-perl
192 Summary:        OpenSSL utilities written in Perl
193 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
194 Group:          Applications/Communications
195 Requires:       %{name} = %{version}-%{release}
196
197 %description tools-perl
198 OpenSSL Toolkit tools written in Perl.
199
200 %description tools-perl -l pl.UTF-8
201 Narzędzia OpenSSL napisane w perlu.
202
203 %package devel
204 Summary:        Development part of OpenSSL Toolkit libraries
205 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
206 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
207 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
208 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
209 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
210 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
211 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
212 Group:          Development/Libraries
213 Requires:       %{name} = %{version}-%{release}
214 Obsoletes:      libopenssl0-devel
215
216 %description devel
217 Development part of OpenSSL library.
218
219 %description devel -l es.UTF-8
220 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
221
222 %description devel -l pl.UTF-8
223 Część biblioteki OpenSSL przeznaczona dla programistów.
224
225 %description devel -l pt_BR.UTF-8
226 Uma biblioteca C que fornece vários algoritmos e protocolos
227 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
228 arquivos de inclusão para desenvolvimento.
229
230 %description devel -l ru.UTF-8
231 Программа openssl для работы с сертификатами и разделяемые библиотеки,
232 которые реализуют множетсво криптографических алгоритмов, включая DES,
233 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
234 с использованием SSL.
235
236 %description devel -l uk.UTF-8
237 Програма openssl для роботи з сертифікатами та бібліотеки спільного
238 користування, що реалізують велику кількість криптографічних
239 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
240 хедери для розробки програм з використанням SSL.
241
242 %package static
243 Summary:        Static OpenSSL libraries
244 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
245 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
246 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
247 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
248 Group:          Development/Libraries
249 Requires:       %{name}-devel = %{version}-%{release}
250
251 %description static
252 Static OpenSSL Toolkit libraries.
253
254 %description static -l pl.UTF-8
255 Statyczne wersje bibliotek z OpenSSL.
256
257 %description static -l pt_BR.UTF-8
258 Bibliotecas estáticas para desenvolvimento com openssl.
259
260 %description static -l ru.UTF-8
261 Программа openssl для работы с сертификатами и разделяемые библиотеки,
262 которые реализуют множетсво криптографических алгоритмов, включая DES,
263 RC4, RSA и SSL. Включает статические библиотеки для разработки
264 приложений с использованием OpenSSL.
265
266 %description static -l uk.UTF-8
267 Програма openssl для роботи з сертифікатами та бібліотеки спільного
268 користування, що реалізують велику кількість криптографічних
269 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
270 бібліотеки для розробки програм з використанням SSL.
271
272 %prep
273 %if %{with snap}
274 %setup -qcT -a1
275 mv %{name}-OpenSSL_1_0_2-stable/* .
276 %else
277 %setup -q
278 %endif
279 %patch0 -p1
280 %patch1 -p1
281 %patch2 -p1
282 %patch3 -p1
283 %patch4 -p1
284 %patch5 -p1
285 %patch6 -p1
286 %patch7 -p1
287 %patch8 -p1
288 %ifarch x32
289 %patch10 -p1
290 %endif
291
292 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
293
294 %build
295 touch Makefile.*
296
297 %{__perl} util/perlpath.pl %{__perl}
298
299 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
300 PERL="%{__perl}" \
301 %{__perl} ./Configure \
302         --openssldir=%{_sysconfdir}/%{name} \
303         --libdir=%{_lib} \
304         shared \
305         threads \
306         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
307         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
308         %{!?with_zlib:no-}zlib \
309         enable-camelia \
310         enable-cms \
311         enable-idea \
312         enable-md2 \
313         enable-mdc2 \
314         enable-rc5 \
315         enable-rfc3779 \
316         enable-seed \
317         enable-tlsext \
318 %ifarch %{x8664}
319         enable-ec_nistp_64_gcc_128 \
320 %endif
321 %ifarch %{ix86}
322 %ifarch i386
323         386 linux-elf
324 # ^- allow running on 80386 (default code uses bswapl available on i486+)
325 %else
326         linux-elf
327 %endif
328 %endif
329 %ifarch alpha
330         linux-alpha+bwx-gcc
331 %endif
332 %ifarch %{x8664}
333         linux-x86_64
334 %endif
335 %ifarch x32
336         linux-x32
337 %endif
338 %ifarch ia64
339         linux-ia64
340 %endif
341 %ifarch ppc
342         linux-ppc
343 %endif
344 %ifarch ppc64
345         linux-ppc64
346 %endif
347 %ifarch sparc
348         linux-sparcv8
349 %endif
350 %ifarch sparcv9
351         linux-sparcv9
352 %endif
353 %ifarch sparc64
354         linux64-sparcv9
355 %endif
356 %ifarch armv4 armv5 armv5t armv5te armv5tel
357         linux-armv4
358 %endif
359
360 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
361 test "$v" = %{version}%{?with_snap:-dev}
362
363 %{__make} -j1 all rehash %{?with_tests:tests} \
364         CC="%{__cc}" \
365         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
366         INSTALLTOP=%{_prefix}
367
368 # Rename POD sources of man pages. "openssl_" prefix is added to each
369 # manpage to avoid potential conflicts with other packages.
370
371 for dir in doc/{apps,ssl,crypto}; do
372         cd $dir || exit 1;
373         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
374
375         for pod in !(openssl*).pod; do
376                 mv -f $pod openssl_$pod;
377         done
378         cd ../..
379 done
380
381 %install
382 rm -rf $RPM_BUILD_ROOT
383 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
384         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
385         $RPM_BUILD_ROOT/%{_lib}/engines \
386         $RPM_BUILD_ROOT%{_pkgconfigdir}
387
388 %{__make} -j1 install \
389         INSTALLTOP=%{_prefix} \
390         INSTALL_PREFIX=$RPM_BUILD_ROOT \
391         MANDIR=%{_mandir}
392
393 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
394 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
395 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
396 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
397
398 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
399 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
400
401 # not installed as individual utilities (see openssl dgst instead)
402 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
403
404 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
405 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
406 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %post   -p /sbin/ldconfig
412 %postun -p /sbin/ldconfig
413
414 %triggerpostun -- %{name}-tools < 1.0.0-5
415 # the hashing format has changed in 1.0.0
416 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
417
418 %triggerpostun -- %{name} < 0.9.8i-2
419 # don't do anything on --downgrade
420 if [ $1 -le 1 ]; then
421         exit 0
422 fi
423 if [ -d /var/lib/openssl/certs ] ; then
424         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
425 fi
426 if [ -d /var/lib/openssl/private ] ; then
427         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
428 fi
429 if [ -d /var/lib/openssl ] ; then
430         for f in /var/lib/openssl/* ; do
431                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
432         done
433         rmdir /var/lib/openssl/* 2>/dev/null || :
434         rmdir /var/lib/openssl 2>/dev/null || :
435 fi
436
437 %files
438 %defattr(644,root,root,755)
439 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
440 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
441 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
442 %dir %{_sysconfdir}/%{name}
443 %dir %{_sysconfdir}/%{name}/certs
444 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
445 %dir %{_datadir}/ssl
446
447 %files engines
448 %defattr(644,root,root,755)
449 %dir /%{_lib}/engines
450 %attr(755,root,root) /%{_lib}/engines/*.so
451
452 %files tools
453 %defattr(644,root,root,755)
454 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
455 %attr(755,root,root) %{_bindir}/c_rehash.sh
456 %attr(755,root,root) %{_bindir}/openssl
457 %attr(754,root,root) %{_bindir}/ssl-certificate
458
459 %dir %{_libdir}/%{name}
460 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
461 %attr(755,root,root) %{_libdir}/%{name}/c_hash
462 %attr(755,root,root) %{_libdir}/%{name}/c_info
463 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
464 %attr(755,root,root) %{_libdir}/%{name}/c_name
465
466 %{_mandir}/man1/openssl.1*
467 %{_mandir}/man1/openssl_asn1parse.1*
468 %{_mandir}/man1/openssl_ca.1*
469 %{_mandir}/man1/openssl_ciphers.1*
470 %{_mandir}/man1/openssl_cms.1*
471 %{_mandir}/man1/openssl_crl.1*
472 %{_mandir}/man1/openssl_crl2pkcs7.1*
473 %{_mandir}/man1/openssl_dgst.1*
474 %{_mandir}/man1/openssl_dhparam.1*
475 %{_mandir}/man1/openssl_dsa.1*
476 %{_mandir}/man1/openssl_dsaparam.1*
477 %{_mandir}/man1/openssl_ec.1*
478 %{_mandir}/man1/openssl_ecparam.1*
479 %{_mandir}/man1/openssl_enc.1*
480 %{_mandir}/man1/openssl_errstr.1*
481 %{_mandir}/man1/openssl_gendsa.1*
482 %{_mandir}/man1/openssl_genpkey.1*
483 %{_mandir}/man1/openssl_genrsa.1*
484 %{_mandir}/man1/openssl_nseq.1*
485 %{_mandir}/man1/openssl_ocsp.1*
486 %{_mandir}/man1/openssl_passwd.1*
487 %{_mandir}/man1/openssl_pkcs12.1*
488 %{_mandir}/man1/openssl_pkcs7.1*
489 %{_mandir}/man1/openssl_pkcs8.1*
490 %{_mandir}/man1/openssl_pkey.1*
491 %{_mandir}/man1/openssl_pkeyparam.1*
492 %{_mandir}/man1/openssl_pkeyutl.1*
493 %{_mandir}/man1/openssl_rand.1*
494 %{_mandir}/man1/openssl_req.1*
495 %{_mandir}/man1/openssl_rsa.1*
496 %{_mandir}/man1/openssl_rsautl.1*
497 %{_mandir}/man1/openssl_s_client.1*
498 %{_mandir}/man1/openssl_s_server.1*
499 %{_mandir}/man1/openssl_s_time.1*
500 %{_mandir}/man1/openssl_sess_id.1*
501 %{_mandir}/man1/openssl_smime.1*
502 %{_mandir}/man1/openssl_speed.1*
503 %{_mandir}/man1/openssl_spkac.1*
504 %{_mandir}/man1/openssl_ts.1*
505 %{_mandir}/man1/openssl_tsget.1*
506 %{_mandir}/man1/openssl_verify.1*
507 %{_mandir}/man1/openssl_version.1*
508 %{_mandir}/man1/openssl_x509.1*
509 %{_mandir}/man5/openssl_config.5*
510 %{_mandir}/man5/openssl_x509v3_config.5*
511 %lang(pl) %{_mandir}/pl/man1/openssl.1*
512
513 %files tools-perl
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_bindir}/c_rehash
516 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
517 %attr(755,root,root) %{_libdir}/%{name}/tsget
518 %{_mandir}/man1/openssl_CA.pl.1*
519 %{_mandir}/man1/openssl_c_rehash.1*
520
521 %files devel
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/libcrypto.so
524 %attr(755,root,root) %{_libdir}/libssl.so
525 %{_includedir}/%{name}
526 %{_pkgconfigdir}/libcrypto.pc
527 %{_pkgconfigdir}/libssl.pc
528 %{_pkgconfigdir}/openssl.pc
529 %{_mandir}/man3/openssl*.3*
530 %{_mandir}/man7/openssl_des_modes.7*
531
532 %files static
533 %defattr(644,root,root,755)
534 %{_libdir}/libcrypto.a
535 %{_libdir}/libssl.a
This page took 0.089384 seconds and 3 git commands to generate.