]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- added ldconfig to %post and %postun
[packages/openssl.git] / openssl.spec
1 %define         date    19990520
2 %define         time    2130
3 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
4 Name:           openssl
5 Version:        0.9.3
6 Release:        0.%{date}
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 Source:         ftp://ftp.openssl.org/source/%{name}-SNAP-%{date}-%{time}.tar.gz
10 Patch0:         openssl-sslcrypto.patch
11 Patch1:         openssl-perl.patch
12 Vendor:         The OpenSSL Project
13 License:        Apache-style License
14 BuildPrereq:    perl
15 BuildRoot:      /tmp/%{name}-%{version}-root
16 Obsoletes:      SSLeay
17 Obsoletes:      SSLeay-devel
18 Obsoletes:      SSLeay-perl
19
20 %define         openssldir      /var/state/openssl
21 %define         _sysconfdir     /etc/%{name}
22 %define         _pkglibdir      %{_libdir}/%{name}
23 %define         _pkgincludedir  %{_includedir}/%{name}
24
25 %description
26 The OpenSSL Project is a collaborative effort to develop a robust,
27 commercial-grade, full-featured, and Open Source toolkit implementing
28 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
29 v1) protocols with full-strength cryptography world-wide. The project
30 is managed by a worldwide community of volunteers that use the
31 Internet to communicate, plan, and develop the OpenSSL tookit and its
32 related documentation.
33    
34 OpenSSL is based on the excellent SSLeay library developed by Eric A.
35 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
36 Apache-style licence, which basically means that you are free to get
37 and use it for commercial and non-commercial purposes subject to some
38 simple license conditions.
39
40 %package devel
41 Summary:        Development part of OpenSSL library
42 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
43 Group:          Development/Library
44 Group(pl):      Programownie/Biblioteki
45 Requires:       %{name} = %{version}
46
47 %description devel
48 Development part of OpenSSL library.
49
50 %description devel -l pl
51 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
52
53 %package static
54 Summary:        Static OpenSSL library
55 Summary(pl):    Statyczna wersja biblioteki OpenSSL
56 Group:          Development/Library
57 Group(pl):      Programowanie/Biblioteki
58 Requires:       %{name}-devel = %{version}
59
60 %description static
61 Static OpenSSL library.
62
63 %description static -l pl
64 Statyczna wersja biblioteki OpenSSL.
65
66 %prep
67 %setup  -q -n %{name}-SNAP-%{date}-%{time}
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 for i in ` echo Configure Makefile.org `; do
73         sed -e 's#-m486##g' \
74                 -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
75                 <$i >$i.work
76         mv $i.work $i
77 done
78
79 perl util/perlpath.pl %{_bindir}
80
81 ln -s crypto sslcrypto
82
83 ./config --openssldir=%{openssldir}
84
85 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
86 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
87 make rehash
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
93
94 make install \
95         INSTALLTOP=%{_prefix} \
96         INSTALL_PREFIX=$RPM_BUILD_ROOT
97
98 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
99 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
100 mv      lib*.so         $RPM_BUILD_ROOT%{_libdir}
101
102
103 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
104 ln -s $RPM_BUILD_ROOT%{_sysconfdir}/openssl.cnf \
105         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
106 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
107
108 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
109 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
110
111 strip $RPM_BUILD_ROOT%{_bindir}/* || :
112 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
113
114 gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
115         doc/*.pod doc/*.txt
116
117 %post
118 %{_bindir}/c_rehash certs
119 /sbin/ldconfig
120
121 %postun -p /sbin/ldconfig
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
129 %doc doc/*.pod.gz doc/*.txt.gz
130 %doc doc/openssl_button.gif doc/openssl_button.html
131
132 %attr(755,root,root) %{_bindir}/*
133 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
134 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
135 %{openssldir}/certs
136 %{openssldir}/private
137 %dir %{_pkglibdir}
138 %attr(755,root,root) %{_pkglibdir}/*
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/lib*.so
144 %{_pkgincludedir}
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/lib*.a
149
150 %changelog
151 * Wed Apr 14 1999 Artur Frysiak <wiget@pld.org.pl>
152   [0.9.2c-2]
153 - rewrite for PLD
154 TODO: make shared libs and perl subpackage
This page took 0.043141 seconds and 3 git commands to generate.