]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
347483862069cf4fdd856b1abab2a0d8f148f3e9
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
6 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
7 %bcond_with     snap    # use GitHub snapshot to build branch release
8
9 %define         rel             0.1
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
12 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
13 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
14 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
15 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
16 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
17 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
18 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
19 Name:           openssl
20 # Version 1.1.0 will be supported until 2018-08-31.
21 # https://www.openssl.org/about/releasestrat.html
22 Version:        1.1.0g
23 Release:        1
24 License:        Apache-like
25 Group:          Libraries
26 %if %{without snap}
27 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
28 # Source0-md5:  ba5f1b8b835b88cadbce9b35ed9531a6
29 %else
30 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_1_0-stable/%{name}-%{version}-dev.tar.gz
31 %endif
32 Source2:        %{name}.1.pl
33 Source3:        %{name}-ssl-certificate.sh
34 Source4:        %{name}-c_rehash.sh
35 Patch1:         %{name}-optflags.patch
36 Patch3:         %{name}-man-namespace.patch
37 Patch4:         %{name}-asflag.patch
38 Patch5:         %{name}-ca-certificates.patch
39 Patch7:         %{name}-find.patch
40 Patch8:         pic.patch
41 Patch10:        %{name}_fix_for_x32.patch
42 Patch11:        engines-dir.patch
43 URL:            http://www.openssl.org/
44 BuildRequires:  perl-devel >= 1:5.10.0
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpm-perlprov >= 4.1-13
47 BuildRequires:  rpmbuild(macros) >= 1.213
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  zlib-devel
50 Requires:       ca-certificates >= 20120623-1.1
51 Requires:       rpm-whiteout >= 1.7
52 Obsoletes:      SSLeay
53 Obsoletes:      SSLeay-devel
54 Obsoletes:      SSLeay-perl
55 Obsoletes:      libopenssl0
56 %if "%{pld_release}" == "ac"
57 Conflicts:      neon < 0.26.3-3
58 Conflicts:      ntpd < 4.2.4p8-10
59 Conflicts:      openssh-clients < 2:5.8p1-9
60 Conflicts:      openssh-server < 2:5.8p1-9
61 %else
62 Conflicts:      neon < 0.29.6-8
63 Conflicts:      openssh-clients < 2:6.2p2-3
64 Conflicts:      openssh-server < 2:6.2p2-3
65 %endif
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 The OpenSSL Project is a collaborative effort to develop a robust,
70 commercial-grade, full-featured, and Open Source toolkit implementing
71 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
72 v1) protocols with full-strength cryptography world-wide. The project
73 is managed by a worldwide community of volunteers that use the
74 Internet to communicate, plan, and develop the OpenSSL tookit and its
75 related documentation.
76
77 OpenSSL is based on the excellent SSLeay library developed by Eric A.
78 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
79 Apache-style licence, which basically means that you are free to get
80 and use it for commercial and non-commercial purposes subject to some
81 simple license conditions.
82
83 This package contains shared libraries only, install openssl-tools if
84 you want to use openssl cmdline tool.
85
86 %description -l de.UTF-8
87 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
88 libraries, die verschiedene Verschlüsselungs- und
89 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
90 zur Verfügung stellen.
91
92 %description -l es.UTF-8
93 Biblioteca C que suministra algoritmos y protocolos criptográficos.
94
95 %description -l fr.UTF-8
96 OpenSSL est un outiil de gestion des certificats et les librairies
97 partagees qui fournit plusieurs protocoles et algorithmes de
98 codage/decodage, incluant DES, RC4, RSA et SSL.
99
100 %description -l pl.UTF-8
101 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
102 v2/v3 oraz Transport Layer Security (TLS v1).
103
104 %description -l pt_BR.UTF-8
105 Uma biblioteca C que fornece vários algoritmos e protocolos
106 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
107 compartilhadas e utilitários.
108
109 %description -l ru.UTF-8
110 Программа openssl для работы с сертификатами и разделяемые библиотеки,
111 которые реализуют множетсво криптографических алгоритмов, включая DES,
112 RC4, RSA и SSL.
113
114 %description -l uk.UTF-8
115 Програма openssl для роботи з сертифікатами та бібліотеки спільного
116 користування, що реалізують велику кількість криптографічних
117 алгоритмів, включаючи DES, RC4, RSA та SSL.
118
119 %package engines
120 Summary:        OpenSSL optional crypto engines
121 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124
125 %description engines
126 With OpenSSL 0.9.6, a new component was added to support alternative
127 cryptography implementations, most commonly for interfacing with
128 external crypto devices (eg. accelerator cards). This component is
129 called ENGINE.
130
131 There are currently built-in ENGINE implementations for the following
132 crypto devices:
133
134 - CryptoSwift
135 - Compaq Atalla
136 - nCipher CHIL
137 - Nuron
138 - Broadcom uBSec
139
140 In addition, dynamic binding to external ENGINE implementations is now
141 provided by a special ENGINE called "dynamic".
142
143 %description engines -l pl.UTF-8
144 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
145 wspierać alternatywne implementacje kryptografii, przeważnie
146 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
147 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
148 ENGINE).
149
150 Obecnie istnieją wbudowane implementacje silników dla następujących
151 urządzeń kryptograficznych:
152 - CryptoSwift
153 - Compaq Atalla
154 - nCipher CHIL
155 - Nuron
156 - Broadcom uBSec
157
158 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
159 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
160
161 %package tools
162 Summary:        OpenSSL command line tool and utilities
163 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
164 Group:          Applications/Communications
165 Requires:       %{name} = %{version}-%{release}
166 Requires:       which
167
168 %description tools
169 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
170
171 %description tools -l pl.UTF-8
172 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
173
174 %package tools-perl
175 Summary:        OpenSSL utilities written in Perl
176 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
177 Group:          Applications/Communications
178 Requires:       %{name} = %{version}-%{release}
179
180 %description tools-perl
181 OpenSSL Toolkit tools written in Perl.
182
183 %description tools-perl -l pl.UTF-8
184 Narzędzia OpenSSL napisane w perlu.
185
186 %package devel
187 Summary:        Development part of OpenSSL Toolkit libraries
188 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
189 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
190 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
191 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
192 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
193 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
194 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
195 Group:          Development/Libraries
196 Requires:       %{name} = %{version}-%{release}
197 Obsoletes:      libopenssl0-devel
198
199 %description devel
200 Development part of OpenSSL library.
201
202 %description devel -l es.UTF-8
203 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
204
205 %description devel -l pl.UTF-8
206 Część biblioteki OpenSSL przeznaczona dla programistów.
207
208 %description devel -l pt_BR.UTF-8
209 Uma biblioteca C que fornece vários algoritmos e protocolos
210 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
211 arquivos de inclusão para desenvolvimento.
212
213 %description devel -l ru.UTF-8
214 Программа openssl для работы с сертификатами и разделяемые библиотеки,
215 которые реализуют множетсво криптографических алгоритмов, включая DES,
216 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
217 с использованием SSL.
218
219 %description devel -l uk.UTF-8
220 Програма openssl для роботи з сертифікатами та бібліотеки спільного
221 користування, що реалізують велику кількість криптографічних
222 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
223 хедери для розробки програм з використанням SSL.
224
225 %package static
226 Summary:        Static OpenSSL libraries
227 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
228 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
229 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
230 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
231 Group:          Development/Libraries
232 Requires:       %{name}-devel = %{version}-%{release}
233
234 %description static
235 Static OpenSSL Toolkit libraries.
236
237 %description static -l pl.UTF-8
238 Statyczne wersje bibliotek z OpenSSL.
239
240 %description static -l pt_BR.UTF-8
241 Bibliotecas estáticas para desenvolvimento com openssl.
242
243 %description static -l ru.UTF-8
244 Программа openssl для работы с сертификатами и разделяемые библиотеки,
245 которые реализуют множетсво криптографических алгоритмов, включая DES,
246 RC4, RSA и SSL. Включает статические библиотеки для разработки
247 приложений с использованием OpenSSL.
248
249 %description static -l uk.UTF-8
250 Програма openssl для роботи з сертифікатами та бібліотеки спільного
251 користування, що реалізують велику кількість криптографічних
252 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
253 бібліотеки для розробки програм з використанням SSL.
254
255 %prep
256 %if %{with snap}
257 %setup -qcT -a1
258 %{__mv} %{name}-OpenSSL_1_1_0-stable/* .
259 %else
260 %setup -q %{?subver:-n %{name}-%{version}-%{subver}}
261 %endif
262 %patch1 -p1
263 %patch3 -p1
264 %patch4 -p1
265 %patch5 -p1
266 %patch7 -p1
267 %patch8 -p1
268 %ifarch x32
269 %patch10 -p1
270 %endif
271 %patch11 -p1
272
273 %build
274 touch Makefile.*
275
276 PERL="%{__perl}" \
277 %{__perl} ./Configure \
278         --prefix=%{_prefix} \
279         --openssldir=%{_sysconfdir}/%{name} \
280         --libdir=%{_lib} \
281         shared \
282         threads \
283         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
284         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
285         %{!?with_zlib:no-}zlib \
286         enable-cms \
287         enable-idea \
288         enable-md2 \
289         enable-mdc2 \
290         enable-rc5 \
291         enable-rfc3779 \
292         enable-seed \
293 %ifarch %{x8664}
294         enable-ec_nistp_64_gcc_128 \
295 %endif
296 %ifarch %{ix86}
297 %ifarch i386
298         386 linux-elf
299 # ^- allow running on 80386 (default code uses bswapl available on i486+)
300 %else
301         linux-elf
302 %endif
303 %endif
304 %ifarch alpha
305         linux-alpha-gcc
306 %endif
307 %ifarch %{x8664}
308         linux-x86_64
309 %endif
310 %ifarch x32
311         linux-x32
312 %endif
313 %ifarch ia64
314         linux-ia64
315 %endif
316 %ifarch ppc
317         linux-ppc
318 %endif
319 %ifarch ppc64
320         linux-ppc64
321 %endif
322 %ifarch sparc
323         linux-sparcv8
324 %endif
325 %ifarch sparcv9
326         linux-sparcv9
327 %endif
328 %ifarch sparc64
329         linux64-sparcv9
330 %endif
331 %ifarch %{arm}
332         linux-armv4
333 %endif
334 %ifarch aarch64
335         linux-aarch64
336 %endif
337
338 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
339 test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
340
341 %{__make} -j1 all %{?with_tests:tests} \
342         CC="%{__cc}" \
343         ASFLAG="-Wa,--noexecstack" \
344         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
345         INSTALLTOP=%{_prefix}
346
347 # Rename POD sources of man pages. "openssl-" prefix is added to each
348 # manpage to avoid potential conflicts with other packages.
349 # (libcrypto/libssl function names are not affected)
350
351 %{__perl} -pi -e 's/(\W)((?<!openssl-)\w+)(\([157]\))/$1openssl-$2$3/g; s/openssl-openssl/openssl/g;' {apps,ssl,crypto}/*.pod;
352 for podfile in doc/apps/!(CA.pl|openssl*).pod doc/crypto/{bio,crypto,ct,des_modes,evp,x509}.pod  doc/ssl/ssl.pod ; do
353         dir=$(dirname "$podfile")
354         base=$(basename "$podfile")
355         %{__mv} "$podfile" "$dir/openssl-$base"
356 done
357
358 %install
359 rm -rf $RPM_BUILD_ROOT
360 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
361         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
362         $RPM_BUILD_ROOT%{_pkgconfigdir}
363
364 %{__make} -j1 install \
365         CC="%{__cc}" \
366         ASFLAG="-Wa,--noexecstack" \
367         DESTDIR=$RPM_BUILD_ROOT \
368
369 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
370 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
371 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
372
373 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
374 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
375
376 # html version of man pages - not packaged
377 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
378
379 # not installed as individual utilities (see openssl dgst instead)
380 #%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
381
382 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
383 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
384 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
385
386 %clean
387 rm -rf $RPM_BUILD_ROOT
388
389 %post   -p /sbin/ldconfig
390 %postun -p /sbin/ldconfig
391
392 %triggerpostun -- %{name}-tools < 1.0.0-5
393 # the hashing format has changed in 1.0.0
394 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
395
396 %triggerpostun -- %{name} < 0.9.8i-2
397 # don't do anything on --downgrade
398 if [ $1 -le 1 ]; then
399         exit 0
400 fi
401 if [ -d /var/lib/openssl/certs ] ; then
402         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
403 fi
404 if [ -d /var/lib/openssl/private ] ; then
405         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
406 fi
407 if [ -d /var/lib/openssl ] ; then
408         for f in /var/lib/openssl/* ; do
409                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
410         done
411         rmdir /var/lib/openssl/* 2>/dev/null || :
412         rmdir /var/lib/openssl 2>/dev/null || :
413 fi
414
415 %files
416 %defattr(644,root,root,755)
417 %doc CHANGES LICENSE NEWS README doc/*.txt
418 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*
419 %attr(755,root,root) /%{_lib}/libssl.so.*.*
420 %dir %{_sysconfdir}/%{name}
421 %dir %{_sysconfdir}/%{name}/certs
422 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
423 %dir %{_datadir}/ssl
424
425 %files engines
426 %defattr(644,root,root,755)
427 %dir /%{_lib}/engines-1.1
428 %attr(755,root,root) /%{_lib}/engines-1.1/*.so
429
430 %files tools
431 %defattr(644,root,root,755)
432 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
433 %attr(755,root,root) %{_bindir}/c_rehash.sh
434 %attr(755,root,root) %{_bindir}/openssl
435 %attr(754,root,root) %{_bindir}/ssl-certificate
436
437 %dir %{_libdir}/%{name}
438 #%attr(755,root,root) %{_libdir}/%{name}/CA.sh
439 #%attr(755,root,root) %{_libdir}/%{name}/c_hash
440 #%attr(755,root,root) %{_libdir}/%{name}/c_info
441 #%attr(755,root,root) %{_libdir}/%{name}/c_issuer
442 #%attr(755,root,root) %{_libdir}/%{name}/c_name
443
444 %{_mandir}/man1/openssl.1*
445 %{_mandir}/man1/openssl-asn1parse.1*
446 %{_mandir}/man1/openssl-blake2b.1*
447 %{_mandir}/man1/openssl-blake2s.1*
448 %{_mandir}/man1/openssl-ca.1*
449 %{_mandir}/man1/openssl-ciphers.1*
450 %{_mandir}/man1/openssl-cms.1*
451 %{_mandir}/man1/openssl-crl.1*
452 %{_mandir}/man1/openssl-crl2pkcs7.1*
453 %{_mandir}/man1/openssl-dgst.1*
454 %{_mandir}/man1/openssl-dhparam.1*
455 %{_mandir}/man1/openssl-dsa.1*
456 %{_mandir}/man1/openssl-dsaparam.1*
457 %{_mandir}/man1/openssl-ec.1*
458 %{_mandir}/man1/openssl-ecparam.1*
459 %{_mandir}/man1/openssl-enc.1*
460 %{_mandir}/man1/openssl-engine.1*
461 %{_mandir}/man1/openssl-errstr.1*
462 %{_mandir}/man1/openssl-gendsa.1*
463 %{_mandir}/man1/openssl-genpkey.1*
464 %{_mandir}/man1/openssl-genrsa.1*
465 %{_mandir}/man1/openssl-list.1*
466 %{_mandir}/man1/openssl-md4.1*
467 %{_mandir}/man1/openssl-md5.1*
468 %{_mandir}/man1/openssl-mdc2.1*
469 %{_mandir}/man1/openssl-nseq.1*
470 %{_mandir}/man1/openssl-ocsp.1*
471 %{_mandir}/man1/openssl-passwd.1*
472 %{_mandir}/man1/openssl-pkcs12.1*
473 %{_mandir}/man1/openssl-pkcs7.1*
474 %{_mandir}/man1/openssl-pkcs8.1*
475 %{_mandir}/man1/openssl-pkey.1*
476 %{_mandir}/man1/openssl-pkeyparam.1*
477 %{_mandir}/man1/openssl-pkeyutl.1*
478 %{_mandir}/man1/openssl-rand.1*
479 %{_mandir}/man1/openssl-rehash.1*
480 %{_mandir}/man1/openssl-req.1*
481 %{_mandir}/man1/openssl-ripemd160.1*
482 %{_mandir}/man1/openssl-rsa.1*
483 %{_mandir}/man1/openssl-rsautl.1*
484 %{_mandir}/man1/openssl-s_client.1*
485 %{_mandir}/man1/openssl-s_server.1*
486 %{_mandir}/man1/openssl-s_time.1*
487 %{_mandir}/man1/openssl-sess_id.1*
488 %{_mandir}/man1/openssl-sha.1*
489 %{_mandir}/man1/openssl-sha1.1*
490 %{_mandir}/man1/openssl-sha224.1*
491 %{_mandir}/man1/openssl-sha256.1*
492 %{_mandir}/man1/openssl-sha384.1*
493 %{_mandir}/man1/openssl-sha512.1*
494 %{_mandir}/man1/openssl-smime.1*
495 %{_mandir}/man1/openssl-speed.1*
496 %{_mandir}/man1/openssl-spkac.1*
497 %{_mandir}/man1/openssl-ts.1*
498 %{_mandir}/man1/openssl-tsget.1*
499 %{_mandir}/man1/openssl-verify.1*
500 %{_mandir}/man1/openssl-version.1*
501 %{_mandir}/man1/openssl-x509.1*
502 %{_mandir}/man5/openssl-config.5*
503 %{_mandir}/man5/openssl-x509v3_config.5*
504 %lang(pl) %{_mandir}/pl/man1/openssl.1*
505
506 %files tools-perl
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/c_rehash
509 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
510 %attr(755,root,root) %{_libdir}/%{name}/tsget
511 %{_mandir}/man1/CA.pl.1*
512 %{_mandir}/man1/c_rehash.1*
513 %{_mandir}/man1/openssl-c_rehash.1*
514
515 %files devel
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/libcrypto.so
518 %attr(755,root,root) %{_libdir}/libssl.so
519 %{_includedir}/%{name}
520 %{_pkgconfigdir}/libcrypto.pc
521 %{_pkgconfigdir}/libssl.pc
522 %{_pkgconfigdir}/openssl.pc
523 %{_mandir}/man3/ACCESS_DESCRIPTION_*.3*
524 %{_mandir}/man3/ASId*.3*
525 %{_mandir}/man3/ASRange_*.3*
526 %{_mandir}/man3/ASN1_*.3*
527 %{_mandir}/man3/ASYNC_*.3*
528 %{_mandir}/man3/AUTHORITY_*.3*
529 %{_mandir}/man3/BASIC_CONSTRAINTS_*.3*
530 %{_mandir}/man3/BF_*.3*
531 %{_mandir}/man3/BIO_*.3*
532 %{_mandir}/man3/BN_*.3*
533 %{_mandir}/man3/BUF_*.3*
534 %{_mandir}/man3/CERTIFICATEPOLICIES_*.3*
535 %{_mandir}/man3/CMS_*.3*
536 %{_mandir}/man3/CONF_*.3*
537 %{_mandir}/man3/CRL_DIST_POINTS_*.3*
538 %{_mandir}/man3/CRYPTO_*.3*
539 %{_mandir}/man3/CTLOG_*.3*
540 %{_mandir}/man3/CT_POLICY_*.3*
541 %{_mandir}/man3/DECLARE_*.3*
542 %{_mandir}/man3/DEFINE_*.3*
543 %{_mandir}/man3/DES_*.3*
544 %{_mandir}/man3/DH_*.3*
545 %{_mandir}/man3/DHparams_*.3*
546 %{_mandir}/man3/DIRECTORYSTRING_*.3*
547 %{_mandir}/man3/DISPLAYTEXT_*.3*
548 %{_mandir}/man3/DIST_POINT_*.3*
549 %{_mandir}/man3/DSA_*.3*
550 %{_mandir}/man3/DSAparams_*.3*
551 %{_mandir}/man3/DTLS_*.3*
552 %{_mandir}/man3/DTLSv1_*.3*
553 %{_mandir}/man3/ECDH_*.3*
554 %{_mandir}/man3/ECDSA_*.3*
555 %{_mandir}/man3/ECPARAMETERS_*.3*
556 %{_mandir}/man3/ECPKPARAMETERS_*.3*
557 %{_mandir}/man3/ECPKParameters_*.3*
558 %{_mandir}/man3/EC_*.3*
559 %{_mandir}/man3/EDIPARTYNAME_*.3*
560 %{_mandir}/man3/ENGINE_*.3*
561 %{_mandir}/man3/ERR_*.3*
562 %{_mandir}/man3/ESS_*.3*
563 %{_mandir}/man3/EVP_*.3*
564 %{_mandir}/man3/EXTENDED_KEY_USAGE_*.3*
565 %{_mandir}/man3/GENERAL_*.3*
566 %{_mandir}/man3/GEN_SESSION_CB.3*
567 %{_mandir}/man3/HMAC*.3*
568 %{_mandir}/man3/IMPLEMENT_*.3*
569 %{_mandir}/man3/IPAddress*.3*
570 %{_mandir}/man3/ISSUING_DIST_POINT_*.3*
571 %{_mandir}/man3/LHASH_*.3*
572 %{_mandir}/man3/MD2*.3*
573 %{_mandir}/man3/MD4*.3*
574 %{_mandir}/man3/MD5*.3*
575 %{_mandir}/man3/MDC2*.3*
576 %{_mandir}/man3/NAME_CONSTRAINTS_*.3*
577 %{_mandir}/man3/NETSCAPE_*.3*
578 %{_mandir}/man3/NOTICEREF_*.3*
579 %{_mandir}/man3/OBJ_*.3*
580 %{_mandir}/man3/OCSP_*.3*
581 %{_mandir}/man3/OPENSSL_*.3*
582 %{_mandir}/man3/OTHERNAME_*.3*
583 %{_mandir}/man3/OpenSSL_*.3*
584 %{_mandir}/man3/PBE2PARAM_*.3*
585 %{_mandir}/man3/PBEPARAM_*.3*
586 %{_mandir}/man3/PBKDF2PARAM_*.3*
587 %{_mandir}/man3/PEM_*.3*
588 %{_mandir}/man3/PKCS12_*.3*
589 %{_mandir}/man3/PKCS5_*.3*
590 %{_mandir}/man3/PKCS7_*.3*
591 %{_mandir}/man3/PKCS8_*.3*
592 %{_mandir}/man3/PKEY_*.3*
593 %{_mandir}/man3/POLICYINFO_*.3*
594 %{_mandir}/man3/POLICYQUALINFO_*.3*
595 %{_mandir}/man3/POLICY_*.3*
596 %{_mandir}/man3/PROXY_*.3*
597 %{_mandir}/man3/RAND_*.3*
598 %{_mandir}/man3/RC4*.3*
599 %{_mandir}/man3/RIPEMD160*.3*
600 %{_mandir}/man3/RSAPrivateKey_*.3*
601 %{_mandir}/man3/RSAPublicKey_*.3*
602 %{_mandir}/man3/RSA_*.3*
603 %{_mandir}/man3/SCT_*.3*
604 %{_mandir}/man3/SHA1*.3*
605 %{_mandir}/man3/SHA224*.3*
606 %{_mandir}/man3/SHA256*.3*
607 %{_mandir}/man3/SHA384*.3*
608 %{_mandir}/man3/SHA512*.3*
609 %{_mandir}/man3/SMIME_*.3*
610 %{_mandir}/man3/SSL_*.3*
611 %{_mandir}/man3/SSLv23_*.3*
612 %{_mandir}/man3/SSLv3_*.3*
613 %{_mandir}/man3/SXNET_*.3*
614 %{_mandir}/man3/SXNETID_*.3*
615 %{_mandir}/man3/TLS_*.3*
616 %{_mandir}/man3/TLSv1_*.3*
617 %{_mandir}/man3/TS_*.3*
618 %{_mandir}/man3/UI*.3*
619 %{_mandir}/man3/USERNOTICE_*.3*
620 %{_mandir}/man3/X509_*.3*
621 %{_mandir}/man3/X509V3_*.3*
622 %{_mandir}/man3/X509v3_*.3*
623 %{_mandir}/man3/bio_info_cb.3*
624 %{_mandir}/man3/custom_ext_*.3*
625 %{_mandir}/man3/d2i_*.3*
626 %{_mandir}/man3/i2d_*.3*
627 %{_mandir}/man3/i2o_*.3*
628 %{_mandir}/man3/i2t_*.3*
629 %{_mandir}/man3/lh_TYPE_*.3*
630 %{_mandir}/man3/o2i_*.3*
631 %{_mandir}/man3/pem_password_cb.3*
632 %{_mandir}/man3/sk_TYPE_*.3*
633 %{_mandir}/man3/ssl_ct_validation_cb.3*
634 %{_mandir}/man7/openssl-bio.7*
635 %{_mandir}/man7/openssl-crypto.7*
636 %{_mandir}/man7/openssl-ct.7*
637 %{_mandir}/man7/openssl-des_modes.7*
638 %{_mandir}/man7/openssl-evp.7*
639 %{_mandir}/man7/openssl-ssl.7*
640 %{_mandir}/man7/openssl-x509.7*
641
642 %files static
643 %defattr(644,root,root,755)
644 %{_libdir}/libcrypto.a
645 %{_libdir}/libssl.a
This page took 0.060918 seconds and 2 git commands to generate.