]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- openssl package splited to openssl (with scripts and binaries) and
[packages/openssl.git] / openssl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Toolkit for the "Secure Sockets Layer" (SSL v2/v3)
3 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
4 Summary(fr):    Utilitaires de communication SSL (Secure Sockets Layer)
5 Name:           openssl
6 Version:        0.9.5a
7 Release:        3
8 Group:          Libraries
9 Group(fr):      Librairies
10 Group(pl):      Biblioteki
11 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
12 Patch0:         openssl-perl.patch
13 Vendor:         The OpenSSL Project
14 License:        Apache-style License
15 BuildRequires:  symlinks
16 BuildRequires:  perl
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Prereq:         fileutils
19 Prereq:         sed
20 Prereq:         %{name}-libs = %{version}
21 Obsoletes:      SSLeay
22 Obsoletes:      SSLeay-devel
23 Obsoletes:      SSLeay-perl
24
25 %define         openssldir      /var/lib/openssl
26 %define         _sysconfdir     /etc/%{name}
27 %define         _pkglibdir      %{_libdir}/%{name}
28 %define         _pkgincludedir  %{_includedir}/%{name}
29
30 %description
31 The OpenSSL Project is a collaborative effort to develop a robust,
32 commercial-grade, full-featured, and Open Source toolkit implementing
33 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
34 v1) protocols with full-strength cryptography world-wide. The project
35 is managed by a worldwide community of volunteers that use the
36 Internet to communicate, plan, and develop the OpenSSL tookit and its
37 related documentation.
38
39 OpenSSL is based on the excellent SSLeay library developed by Eric A.
40 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
41 Apache-style licence, which basically means that you are free to get
42 and use it for commercial and non-commercial purposes subject to some
43 simple license conditions.
44
45 %description -l de
46 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
47 libraries, die verschiedene Verschlüsselungs- und
48 Entschlüsselungsalgorithmen und
49 - -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.
50
51 %description -l fr
52 OpenSSL est un outiil de gestion des certificats et les librairies
53 partagees qui fournit plusieurs protocoles et algorithmes de
54 codage/decodage, incluant DES, RC4, RSA et SSL.
55
56 %package libs
57 Summary:        The OpenSSL shared libraries
58 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
59 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
60 Summary(pl):    Biblioteki dzilelone OpenSSL
61 Group:          Libraries
62 Group(fr):      Librairies
63 Group(pl):      Biblioteki
64
65 %description libs
66 The OpenSSL shared libraries
67
68 %package devel
69 Summary:        Development part of OpenSSL library
70 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
71 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
72 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
73 Group:          Development/Libraries
74 Group(fr):      Development/Librairies
75 Group(pl):      Programowanie/Biblioteki
76 Requires:       %{name}-libs = %{version}
77
78 %description devel
79 Development part of OpenSSL library.
80
81 %description devel -l pl
82 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
83
84 %package static
85 Summary:        Static OpenSSL library
86 Summary(pl):    Statyczna wersja biblioteki OpenSSL
87 Group:          Development/Libraries
88 Group(fr):      Development/Librairies
89 Group(pl):      Programowanie/Biblioteki
90 Requires:       %{name}-devel = %{version}
91
92 %description static
93 Static OpenSSL library.
94
95 %description static -l pl
96 Statyczna wersja biblioteki OpenSSL.
97
98 %prep
99 %setup -q 
100 %patch -p1
101
102 %build
103 for i in Configure Makefile.org ; do
104         perl -pi -e 's#-m486##g' $i
105         perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
106 done
107
108 perl util/perlpath.pl %{_bindir}
109
110 ./config --openssldir=%{openssldir}
111
112 %{__make} OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
113 %{__make} INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
114 %{__make} rehash
115 #cd perl
116 #perl Makefile.PL
117 #make
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
123
124 %{__make} install \
125         INSTALLTOP=%{_prefix} \
126         INSTALL_PREFIX=$RPM_BUILD_ROOT
127
128 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
129 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
130 cp -d   lib*.so         $RPM_BUILD_ROOT%{_libdir}
131
132 #cd perl
133 #make install DESTDIR=$RPM_BUILD_ROOT
134 #cd ..
135
136 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
137 ln -s %{_sysconfdir}/openssl.cnf \
138         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
139 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
140
141 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
142 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
143
144 strip $RPM_BUILD_ROOT%{_bindir}/* || :
145 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
146
147 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README \
148         doc/*.txt doc/*/*pod
149
150 %post
151 %{_bindir}/c_rehash certs
152
153 %post libs
154 /sbin/ldconfig
155
156 %postun libs
157 /sbin/ldconfig
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %files
163 %defattr(644,root,root,755)
164 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
165 %doc doc/*.txt.gz doc/apps 
166 %doc doc/openssl_button.gif doc/openssl_button.html
167
168 %attr(755,root,root) %{_bindir}/*
169 %dir %{_sysconfdir}
170 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
171 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
172 %{openssldir}/certs
173 %{openssldir}/private
174 %dir %{_pkglibdir}
175 %attr(755,root,root) %{_pkglibdir}/*
176
177 %files libs
178 %attr(755,root,root) %{_libdir}/lib*.so.*.*
179
180 %files devel
181 %defattr(644,root,root,755)
182 %doc doc/ssl doc/crypto
183 %attr(755,root,root) %{_libdir}/lib*.so
184 %{_pkgincludedir}
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/lib*.a
This page took 0.043167 seconds and 3 git commands to generate.