]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
159da5c35feb9471ac100ec467554b11a07b8cfd
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 # - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
4 #
5 # Conditional build:
6 %bcond_without  tests   # don't perform "make tests"
7 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
8 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
9 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
10 %bcond_with     purify  # Compile openssl with "-DPURIFY", useful when one wants to
11                         # use valgrind debugger against openssl-linked programs
12 %bcond_with     snap    # use GitHub snapshot to build branch release
13
14 %include        /usr/lib/rpm/macros.perl
15 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
16 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
17 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
18 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
19 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
20 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
21 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
22 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
23 Name:           openssl
24 # 1.0.2 will be LTS release
25 # Version 1.0.2 will be supported until 2019-12-31.
26 # https://www.openssl.org/about/releasestrat.html
27 Version:        1.0.2g
28 Release:        2
29 License:        Apache-like
30 Group:          Libraries
31 %if %{without snap}
32 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
33 # Source0-md5:  f3c710c045cdee5fd114feb69feba7aa
34 %else
35 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
36 %endif
37 Source2:        %{name}.1.pl
38 Source3:        %{name}-ssl-certificate.sh
39 Source4:        %{name}-c_rehash.sh
40 Patch0:         %{name}-alpha-ccc.patch
41 Patch1:         %{name}-optflags.patch
42 Patch2:         %{name}-include.patch
43 Patch3:         %{name}-man-namespace.patch
44 Patch4:         %{name}-asflag.patch
45 Patch5:         %{name}-ca-certificates.patch
46 Patch6:         %{name}-ldflags.patch
47 Patch7:         %{name}-find.patch
48 Patch8:         pic.patch
49 Patch10:        %{name}_fix_for_x32.patch
50 URL:            http://www.openssl.org/
51 BuildRequires:  bc
52 BuildRequires:  perl-devel >= 1:5.6.1
53 BuildRequires:  rpm-perlprov >= 4.1-13
54 BuildRequires:  rpmbuild(macros) >= 1.213
55 BuildRequires:  sed >= 4.0
56 Requires:       ca-certificates >= 20120623-1.1
57 Requires:       rpm-whiteout >= 1.7
58 Obsoletes:      SSLeay
59 Obsoletes:      SSLeay-devel
60 Obsoletes:      SSLeay-perl
61 Obsoletes:      libopenssl0
62 %if "%{pld_release}" == "ac"
63 Conflicts:      neon < 0.26.3-3
64 Conflicts:      ntpd < 4.2.4p8-10
65 Conflicts:      openssh-clients < 2:5.8p1-9
66 Conflicts:      openssh-server < 2:5.8p1-9
67 %else
68 Conflicts:      neon < 0.29.6-8
69 Conflicts:      openssh-clients < 2:6.2p2-3
70 Conflicts:      openssh-server < 2:6.2p2-3
71 Conflicts:      ruby-modules < 1:2.0.0.648-2
72 %endif
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 The OpenSSL Project is a collaborative effort to develop a robust,
77 commercial-grade, full-featured, and Open Source toolkit implementing
78 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
79 v1) protocols with full-strength cryptography world-wide. The project
80 is managed by a worldwide community of volunteers that use the
81 Internet to communicate, plan, and develop the OpenSSL tookit and its
82 related documentation.
83
84 OpenSSL is based on the excellent SSLeay library developed by Eric A.
85 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
86 Apache-style licence, which basically means that you are free to get
87 and use it for commercial and non-commercial purposes subject to some
88 simple license conditions.
89
90 This package contains shared libraries only, install openssl-tools if
91 you want to use openssl cmdline tool.
92
93 %description -l de.UTF-8
94 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
95 libraries, die verschiedene Verschlüsselungs- und
96 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
97 zur Verfügung stellen.
98
99 %description -l es.UTF-8
100 Biblioteca C que suministra algoritmos y protocolos criptográficos.
101
102 %description -l fr.UTF-8
103 OpenSSL est un outiil de gestion des certificats et les librairies
104 partagees qui fournit plusieurs protocoles et algorithmes de
105 codage/decodage, incluant DES, RC4, RSA et SSL.
106
107 %description -l pl.UTF-8
108 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
109 v2/v3 oraz Transport Layer Security (TLS v1).
110
111 %description -l pt_BR.UTF-8
112 Uma biblioteca C que fornece vários algoritmos e protocolos
113 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
114 compartilhadas e utilitários.
115
116 %description -l ru.UTF-8
117 Программа openssl для работы с сертификатами и разделяемые библиотеки,
118 которые реализуют множетсво криптографических алгоритмов, включая DES,
119 RC4, RSA и SSL.
120
121 %description -l uk.UTF-8
122 Програма openssl для роботи з сертифікатами та бібліотеки спільного
123 користування, що реалізують велику кількість криптографічних
124 алгоритмів, включаючи DES, RC4, RSA та SSL.
125
126 %package engines
127 Summary:        OpenSSL optional crypto engines
128 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
129 Group:          Libraries
130 Requires:       %{name} = %{version}-%{release}
131
132 %description engines
133 With OpenSSL 0.9.6, a new component was added to support alternative
134 cryptography implementations, most commonly for interfacing with
135 external crypto devices (eg. accelerator cards). This component is
136 called ENGINE.
137
138 There are currently built-in ENGINE implementations for the following
139 crypto devices:
140
141 - CryptoSwift
142 - Compaq Atalla
143 - nCipher CHIL
144 - Nuron
145 - Broadcom uBSec
146
147 In addition, dynamic binding to external ENGINE implementations is now
148 provided by a special ENGINE called "dynamic".
149
150 %description engines -l pl.UTF-8
151 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
152 wspierać alternatywne implementacje kryptografii, przeważnie
153 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
154 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
155 ENGINE).
156
157 Obecnie istnieją wbudowane implementacje silników dla następujących
158 urządzeń kryptograficznych:
159 - CryptoSwift
160 - Compaq Atalla
161 - nCipher CHIL
162 - Nuron
163 - Broadcom uBSec
164
165 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
166 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
167
168 %package tools
169 Summary:        OpenSSL command line tool and utilities
170 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
171 Group:          Applications/Communications
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       which
174
175 %description tools
176 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
177
178 %description tools -l pl.UTF-8
179 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
180
181 %package tools-perl
182 Summary:        OpenSSL utilities written in Perl
183 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
184 Group:          Applications/Communications
185 Requires:       %{name} = %{version}-%{release}
186
187 %description tools-perl
188 OpenSSL Toolkit tools written in Perl.
189
190 %description tools-perl -l pl.UTF-8
191 Narzędzia OpenSSL napisane w perlu.
192
193 %package devel
194 Summary:        Development part of OpenSSL Toolkit libraries
195 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
196 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
197 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
198 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
199 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
200 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
201 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
202 Group:          Development/Libraries
203 Requires:       %{name} = %{version}-%{release}
204 Obsoletes:      libopenssl0-devel
205
206 %description devel
207 Development part of OpenSSL library.
208
209 %description devel -l es.UTF-8
210 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
211
212 %description devel -l pl.UTF-8
213 Część biblioteki OpenSSL przeznaczona dla programistów.
214
215 %description devel -l pt_BR.UTF-8
216 Uma biblioteca C que fornece vários algoritmos e protocolos
217 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
218 arquivos de inclusão para desenvolvimento.
219
220 %description devel -l ru.UTF-8
221 Программа openssl для работы с сертификатами и разделяемые библиотеки,
222 которые реализуют множетсво криптографических алгоритмов, включая DES,
223 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
224 с использованием SSL.
225
226 %description devel -l uk.UTF-8
227 Програма openssl для роботи з сертифікатами та бібліотеки спільного
228 користування, що реалізують велику кількість криптографічних
229 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
230 хедери для розробки програм з використанням SSL.
231
232 %package static
233 Summary:        Static OpenSSL libraries
234 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
235 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
236 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
237 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
238 Group:          Development/Libraries
239 Requires:       %{name}-devel = %{version}-%{release}
240
241 %description static
242 Static OpenSSL Toolkit libraries.
243
244 %description static -l pl.UTF-8
245 Statyczne wersje bibliotek z OpenSSL.
246
247 %description static -l pt_BR.UTF-8
248 Bibliotecas estáticas para desenvolvimento com openssl.
249
250 %description static -l ru.UTF-8
251 Программа openssl для работы с сертификатами и разделяемые библиотеки,
252 которые реализуют множетсво криптографических алгоритмов, включая DES,
253 RC4, RSA и SSL. Включает статические библиотеки для разработки
254 приложений с использованием OpenSSL.
255
256 %description static -l uk.UTF-8
257 Програма openssl для роботи з сертифікатами та бібліотеки спільного
258 користування, що реалізують велику кількість криптографічних
259 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
260 бібліотеки для розробки програм з використанням SSL.
261
262 %prep
263 %if %{with snap}
264 %setup -qcT -a1
265 mv %{name}-OpenSSL_1_0_2-stable/* .
266 %else
267 %setup -q
268 %endif
269 %patch0 -p1
270 %patch1 -p1
271 %patch2 -p1
272 %patch3 -p1
273 %patch4 -p1
274 %patch5 -p1
275 %patch6 -p1
276 %patch7 -p1
277 %patch8 -p1
278 %ifarch x32
279 %patch10 -p1
280 %endif
281
282 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
283
284 %build
285 touch Makefile.*
286
287 %{__perl} util/perlpath.pl %{__perl}
288
289 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
290 PERL="%{__perl}" \
291 %{__perl} ./Configure \
292         --openssldir=%{_sysconfdir}/%{name} \
293         --libdir=%{_lib} \
294         shared \
295         threads \
296         %{!?with_sslv2:no-ssl2} \
297         %{!?with_sslv3:no-ssl3} \
298         %{!?with_zlib:no-}zlib \
299         enable-camelia \
300         enable-cms \
301         enable-idea \
302         enable-md2 \
303         enable-mdc2 \
304         enable-rc5 \
305         enable-rfc3779 \
306         enable-seed \
307         enable-tlsext \
308 %ifarch %{x8664}
309         enable-ec_nistp_64_gcc_128 \
310 %endif
311 %ifarch %{ix86}
312 %ifarch i386
313         386 linux-elf
314 # ^- allow running on 80386 (default code uses bswapl available on i486+)
315 %else
316         linux-elf
317 %endif
318 %endif
319 %ifarch alpha
320         linux-alpha+bwx-gcc
321 %endif
322 %ifarch %{x8664}
323         linux-x86_64
324 %endif
325 %ifarch x32
326         linux-x32
327 %endif
328 %ifarch ia64
329         linux-ia64
330 %endif
331 %ifarch ppc
332         linux-ppc
333 %endif
334 %ifarch ppc64
335         linux-ppc64
336 %endif
337 %ifarch sparc
338         linux-sparcv8
339 %endif
340 %ifarch sparcv9
341         linux-sparcv9
342 %endif
343 %ifarch sparc64
344         linux64-sparcv9
345 %endif
346 %ifarch armv4 armv5 armv5t armv5te armv5tel
347         linux-armv4
348 %endif
349
350 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
351 test "$v" = %{version}%{?with_snap:-dev}
352
353 %{__make} -j1 all rehash %{?with_tests:tests} \
354         CC="%{__cc}" \
355         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
356         INSTALLTOP=%{_prefix}
357
358 # Rename POD sources of man pages. "openssl_" prefix is added to each
359 # manpage to avoid potential conflicts with other packages.
360
361 for dir in doc/{apps,ssl,crypto}; do
362         cd $dir || exit 1;
363         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
364
365         for pod in !(openssl*).pod; do
366                 mv -f $pod openssl_$pod;
367         done
368         cd ../..
369 done
370
371 %install
372 rm -rf $RPM_BUILD_ROOT
373 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
374         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
375         $RPM_BUILD_ROOT/%{_lib}/engines \
376         $RPM_BUILD_ROOT%{_pkgconfigdir}
377
378 %{__make} -j1 install \
379         INSTALLTOP=%{_prefix} \
380         INSTALL_PREFIX=$RPM_BUILD_ROOT \
381         MANDIR=%{_mandir}
382
383 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
384 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
385 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
386 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
387
388 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
389 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
390
391 # not installed as individual utilities (see openssl dgst instead)
392 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
393
394 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
395 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
396 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
397
398 %clean
399 rm -rf $RPM_BUILD_ROOT
400
401 %post   -p /sbin/ldconfig
402 %postun -p /sbin/ldconfig
403
404 %triggerpostun -- %{name}-tools < 1.0.0-5
405 # the hashing format has changed in 1.0.0
406 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
407
408 %triggerpostun -- %{name} < 0.9.8i-2
409 # don't do anything on --downgrade
410 if [ $1 -le 1 ]; then
411         exit 0
412 fi
413 if [ -d /var/lib/openssl/certs ] ; then
414         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
415 fi
416 if [ -d /var/lib/openssl/private ] ; then
417         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
418 fi
419 if [ -d /var/lib/openssl ] ; then
420         for f in /var/lib/openssl/* ; do
421                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
422         done
423         rmdir /var/lib/openssl/* 2>/dev/null || :
424         rmdir /var/lib/openssl 2>/dev/null || :
425 fi
426
427 %files
428 %defattr(644,root,root,755)
429 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
430 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
431 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
432 %dir %{_sysconfdir}/%{name}
433 %dir %{_sysconfdir}/%{name}/certs
434 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
435 %dir %{_datadir}/ssl
436
437 %files engines
438 %defattr(644,root,root,755)
439 %dir /%{_lib}/engines
440 %attr(755,root,root) /%{_lib}/engines/*.so
441
442 %files tools
443 %defattr(644,root,root,755)
444 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
445 %attr(755,root,root) %{_bindir}/c_rehash.sh
446 %attr(755,root,root) %{_bindir}/openssl
447 %attr(754,root,root) %{_bindir}/ssl-certificate
448
449 %dir %{_libdir}/%{name}
450 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
451 %attr(755,root,root) %{_libdir}/%{name}/c_hash
452 %attr(755,root,root) %{_libdir}/%{name}/c_info
453 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
454 %attr(755,root,root) %{_libdir}/%{name}/c_name
455
456 %{_mandir}/man1/openssl.1*
457 %{_mandir}/man1/openssl_asn1parse.1*
458 %{_mandir}/man1/openssl_ca.1*
459 %{_mandir}/man1/openssl_ciphers.1*
460 %{_mandir}/man1/openssl_cms.1*
461 %{_mandir}/man1/openssl_crl.1*
462 %{_mandir}/man1/openssl_crl2pkcs7.1*
463 %{_mandir}/man1/openssl_dgst.1*
464 %{_mandir}/man1/openssl_dhparam.1*
465 %{_mandir}/man1/openssl_dsa.1*
466 %{_mandir}/man1/openssl_dsaparam.1*
467 %{_mandir}/man1/openssl_ec.1*
468 %{_mandir}/man1/openssl_ecparam.1*
469 %{_mandir}/man1/openssl_enc.1*
470 %{_mandir}/man1/openssl_errstr.1*
471 %{_mandir}/man1/openssl_gendsa.1*
472 %{_mandir}/man1/openssl_genpkey.1*
473 %{_mandir}/man1/openssl_genrsa.1*
474 %{_mandir}/man1/openssl_nseq.1*
475 %{_mandir}/man1/openssl_ocsp.1*
476 %{_mandir}/man1/openssl_passwd.1*
477 %{_mandir}/man1/openssl_pkcs12.1*
478 %{_mandir}/man1/openssl_pkcs7.1*
479 %{_mandir}/man1/openssl_pkcs8.1*
480 %{_mandir}/man1/openssl_pkey.1*
481 %{_mandir}/man1/openssl_pkeyparam.1*
482 %{_mandir}/man1/openssl_pkeyutl.1*
483 %{_mandir}/man1/openssl_rand.1*
484 %{_mandir}/man1/openssl_req.1*
485 %{_mandir}/man1/openssl_rsa.1*
486 %{_mandir}/man1/openssl_rsautl.1*
487 %{_mandir}/man1/openssl_s_client.1*
488 %{_mandir}/man1/openssl_s_server.1*
489 %{_mandir}/man1/openssl_s_time.1*
490 %{_mandir}/man1/openssl_sess_id.1*
491 %{_mandir}/man1/openssl_smime.1*
492 %{_mandir}/man1/openssl_speed.1*
493 %{_mandir}/man1/openssl_spkac.1*
494 %{_mandir}/man1/openssl_ts.1*
495 %{_mandir}/man1/openssl_tsget.1*
496 %{_mandir}/man1/openssl_verify.1*
497 %{_mandir}/man1/openssl_version.1*
498 %{_mandir}/man1/openssl_x509.1*
499 %{_mandir}/man5/openssl_config.5*
500 %{_mandir}/man5/openssl_x509v3_config.5*
501 %lang(pl) %{_mandir}/pl/man1/openssl.1*
502
503 %files tools-perl
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_bindir}/c_rehash
506 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
507 %attr(755,root,root) %{_libdir}/%{name}/tsget
508 %{_mandir}/man1/openssl_CA.pl.1*
509 %{_mandir}/man1/openssl_c_rehash.1*
510
511 %files devel
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/libcrypto.so
514 %attr(755,root,root) %{_libdir}/libssl.so
515 %{_includedir}/%{name}
516 %{_pkgconfigdir}/libcrypto.pc
517 %{_pkgconfigdir}/libssl.pc
518 %{_pkgconfigdir}/openssl.pc
519 %{_mandir}/man3/openssl*.3*
520 %{_mandir}/man7/openssl_des_modes.7*
521
522 %files static
523 %defattr(644,root,root,755)
524 %{_libdir}/libcrypto.a
525 %{_libdir}/libssl.a
This page took 0.098714 seconds and 2 git commands to generate.