]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
135489724cf793eb16aaef7f5e20269aa43f2bde
[packages/openssl.git] / openssl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
3 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
4 Summary(fr):    Utilitaires et librairies de communication SSL (Secure Sockets Layer)
5 Name:           openssl
6 Version:        0.9.5a
7 Release:        1
8 Group:          Libraries
9 Group(fr):      Librairies
10 Group(pl):      Biblioteki
11 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
12 Patch0:         openssl-perl.patch
13 Vendor:         The OpenSSL Project
14 License:        Apache-style License
15 BuildRequires:  symlinks
16 BuildRequires:  perl
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Obsoletes:      SSLeay
19 Obsoletes:      SSLeay-devel
20 Obsoletes:      SSLeay-perl
21
22 %define         openssldir      /var/lib/openssl
23 %define         _sysconfdir     /etc/%{name}
24 %define         _pkglibdir      %{_libdir}/%{name}
25 %define         _pkgincludedir  %{_includedir}/%{name}
26
27 %description
28 The OpenSSL Project is a collaborative effort to develop a robust,
29 commercial-grade, full-featured, and Open Source toolkit implementing the
30 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
31 protocols with full-strength cryptography world-wide. The project is
32 managed by a worldwide community of volunteers that use the Internet to
33 communicate, plan, and develop the OpenSSL tookit and its related
34 documentation.
35
36 OpenSSL is based on the excellent SSLeay library developed by Eric A. Young
37 and Tim J. Hudson. The OpenSSL toolkit is licensed under an Apache-style
38 licence, which basically means that you are free to get and use it for
39 commercial and non-commercial purposes subject to some simple license
40 conditions.
41
42 %description -l de
43 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared libraries,
44 die verschiedene Verschlüsselungs- und Entschlüsselungsalgorithmen und
45 - -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.
46
47 %description -l fr
48 OpenSSL est un outiil de gestion des certificats et les librairies
49 partagees qui fournit plusieurs protocoles et algorithmes de
50 codage/decodage, incluant DES, RC4, RSA et SSL.
51
52 %package devel
53 Summary:        Development part of OpenSSL library
54 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
55 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
56 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
57 Group:          Development/Libraries
58 Group(fr):      Development/Librairies
59 Group(pl):      Programowanie/Biblioteki
60 Requires:       %{name} = %{version}
61
62 %description devel
63 Development part of OpenSSL library.
64
65 %description devel -l pl
66 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
67
68 %package static
69 Summary:        Static OpenSSL library
70 Summary(pl):    Statyczna wersja biblioteki OpenSSL
71 Group:          Development/Libraries
72 Group(fr):      Development/Librairies
73 Group(pl):      Programowanie/Biblioteki
74 Requires:       %{name}-devel = %{version}
75
76 %description static
77 Static OpenSSL library.
78
79 %description static -l pl
80 Statyczna wersja biblioteki OpenSSL.
81
82 %prep
83 %setup -q 
84 %patch -p1
85
86 %build
87 for i in Configure Makefile.org ; do
88         perl -pi -e 's#-m486##g' $i
89         perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
90 done
91
92 perl util/perlpath.pl %{_bindir}
93
94 ./config --openssldir=%{openssldir}
95
96 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
97 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
98 make rehash
99 #cd perl
100 #perl Makefile.PL
101 #make
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
107
108 make install \
109         INSTALLTOP=%{_prefix} \
110         INSTALL_PREFIX=$RPM_BUILD_ROOT
111
112 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
113 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
114 cp -d   lib*.so         $RPM_BUILD_ROOT%{_libdir}
115
116 #cd perl
117 #make install DESTDIR=$RPM_BUILD_ROOT
118 #cd ..
119
120 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
121 ln -s %{_sysconfdir}/openssl.cnf \
122         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
123 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
124
125 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
126 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
127
128 strip $RPM_BUILD_ROOT%{_bindir}/* || :
129 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
130
131 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README \
132         doc/*.txt doc/*/*pod
133
134 %post
135 %{_bindir}/c_rehash certs
136 /sbin/ldconfig
137
138 %postun -p /sbin/ldconfig
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
146 %doc doc/*.txt.gz doc/apps 
147 %doc doc/openssl_button.gif doc/openssl_button.html
148
149 %attr(755,root,root) %{_bindir}/*
150 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
151 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
152 %{openssldir}/certs
153 %{openssldir}/private
154 %dir %{_pkglibdir}
155 %attr(755,root,root) %{_pkglibdir}/*
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %doc doc/ssl doc/crypto
161 %attr(755,root,root) %{_libdir}/lib*.so
162 %{_pkgincludedir}
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/lib*.a
This page took 0.04218 seconds and 3 git commands to generate.