]> git.pld-linux.org Git - packages/openssl.git/blame - openssl.spec
openssl patches
[packages/openssl.git] / openssl.spec
CommitLineData
04a5ad1f
AF
1Summary: Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
2Name: openssl
3Version: 0.9.2b
4Release: 2
5Group: Libraries
6Group(pl): Biblioteki
7Source: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
8Patch0: openssl-sslcrypto.patch
9Patch1: openssl-perl.patch
10Patch2: openssl-shlib.patch
11Vendor: The OpenSSL Project
12License: Apache-style License
13Packager: PLD Bug tracking <pld@pld.org.pl>
14BuildRoot: /tmp/%{name}-%{version}-root
15Obsoletes: SSLeay
16Obsoletes: SSLeay-devel
17Obsoletes: SSLeay-perl
21ac4f86
AF
18
19%description
20The OpenSSL Project is a collaborative effort to develop a robust,
21commercial-grade, full-featured, and Open Source toolkit implementing
22the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
23v1) protocols with full-strength cryptography world-wide. The project
24is managed by a worldwide community of volunteers that use the
25Internet to communicate, plan, and develop the OpenSSL tookit and its
26related documentation.
27
28OpenSSL is based on the excellent SSLeay library developed by Eric A.
29Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
30Apache-style licence, which basically means that you are free to get
31and use it for commercial and non-commercial purposes subject to some
32simple license conditions.
33
34%prep
04a5ad1f
AF
35%setup -q
36%patch0 -p1
37%patch1 -p1
38%patch2 -p1
21ac4f86
AF
39
40%build
04a5ad1f
AF
41for i in ` echo Configure Makefile.org Makefile.ssl `; do
42 sed -e 's#-m486##g' \
43 -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
44 <$i >$i.work
45 mv $i.work $i
46done
47
48perl util/perlpath.pl /usr/bin
49perl util/ssldir.pl /var/lib/ssl
50
51./config
52make INSTALLTOP=/usr OPT_FLAGS="$RPM_OPT_FLAGS"
21ac4f86
AF
53make rehash
54
55%install
04a5ad1f
AF
56rm -rf $RPM_BUILD_ROOT
57
58install -d $RPM_BUILD_ROOT/{etc,usr/include/ssl,var/lib/ssl/{certs,private}}
59
60make INSTALLTOP=$RPM_BUILD_ROOT/usr install
61
62install libRSAglue.a $RPM_BUILD_ROOT/usr/lib
63
64mv $RPM_BUILD_ROOT/usr/include/*.h $RPM_BUILD_ROOT/usr/include/ssl
65
66mv $RPM_BUILD_ROOT/usr/lib/openssl.cnf $RPM_BUILD_ROOT/etc
67ln -s ../../etc/openssl.cnf $RPM_BUILD_ROOT/usr/lib/openssl.cnf
68
69gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
70 doc/*.pod doc/*.txt
71
72%post
73/usr/bin/c_rehash certs
74
75%clean
76#rm -rf $RPM_BUILD_ROOT
21ac4f86
AF
77
78%files
04a5ad1f
AF
79%defattr(644,root,root,755)
80%doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
81%doc doc/*.pod.gz doc/*.txt.gz
82%doc doc/openssl_button.gif doc/openssl_button.html
83
84%attr(755,root,root) /usr/bin/*
85%verify(not md5 size mtime) %config(noreplace) /etc/openssl.cnf
86%verify(not md5 size mtime) %config(noreplace) /usr/lib/openssl.cnf
87/usr/lib/lib*.a
88/usr/include/ssl/*.h
89/var/lib/ssl
90
91%changelog
92* Wed Apr 14 1999 Artur Frysiak <wiget@pld.org.pl>
93 [0.9.2c-2]
94- rewrite for PLD
95TODO: make shared libs and perl subpackage
This page took 0.048183 seconds and 4 git commands to generate.