]> git.pld-linux.org Git - packages/openssh.git/commitdiff
- up to 7.6p1 auto/th/openssh-7.6p1-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 6 Oct 2017 06:54:50 +0000 (08:54 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 6 Oct 2017 06:54:50 +0000 (08:54 +0200)
openssh-bind.patch
openssh-config.patch
openssh-ldns.patch
openssh-sigpipe.patch
openssh.spec

index 718caa6673327ff4527c3e42ffee899c32d96930..ba77d7e188b381ab77bebd67496123bff7a13848 100644 (file)
@@ -1,11 +1,13 @@
---- openssh-5.9p1/channels.c~  2011-06-23 00:31:57.000000000 +0200
-+++ openssh-5.9p1/channels.c   2011-11-12 11:37:15.242015675 +0100
-@@ -3301,6 +3301,8 @@
-                       if (bind(sock, ai->ai_addr, ai->ai_addrlen) < 0) {
-                               debug2("bind port %d: %.100s", port, strerror(errno));
+--- a/channels.c~      2017-10-02 21:34:26.000000000 +0200
++++ b/channels.c       2017-10-06 08:39:25.072904075 +0200
+@@ -4444,6 +4444,9 @@ x11_create_display_inet(struct ssh *ssh,
+                               debug2("%s: bind port %d: %.100s", __func__,
+                                   port, strerror(errno));
                                close(sock);
++                              // vserver hack
 +                              if (errno == EADDRNOTAVAIL)
 +                                      continue;
-                               for (n = 0; n < num_socks; n++) {
+                               for (n = 0; n < num_socks; n++)
                                        close(socks[n]);
+                               num_socks = 0;
+
index 4bc53c37c2f0b2f02de01beed8f9fb503a63241a..915d1d76d7b0a04e481446edb7380db2a3ca7597 100644 (file)
  #     X11Forwarding no
 --- openssh-4.6p1/ssh_config~  2006-06-13 05:01:10.000000000 +0200
 +++ openssh-4.6p1/ssh_config   2007-10-13 02:00:16.000000000 +0200
-@@ -20,12 +20,15 @@
+@@ -20,10 +20,13 @@
  # Host *
  #   ForwardAgent no
  #   ForwardX11 no
 +#   ForwardX11Trusted no
- #   RhostsRSAAuthentication no
- #   RSAAuthentication yes
  #   PasswordAuthentication yes
  #   HostbasedAuthentication no
  #   GSSAPIAuthentication no
index a15c7dd5fec1f1413dfef64c593cc2e6c71c4554..367c5e8847de8b163427ba53229a8b09faf6f5b7 100644 (file)
@@ -1,6 +1,6 @@
---- openssh-7.5p1/configure.ac.orig    2017-04-17 10:38:47.458291317 +0200
-+++ openssh-7.5p1/configure.ac 2017-04-17 11:03:41.491607590 +0200
-@@ -1479,15 +1479,15 @@
+--- a/configure.ac~    2017-10-02 21:34:26.000000000 +0200
++++ b/configure.ac     2017-10-06 08:35:16.756080761 +0200
+@@ -1487,7 +1487,7 @@ AC_ARG_WITH(ldns,
        ldns=""
        if test "x$withval" = "xyes" ; then
                AC_PATH_TOOL([LDNSCONFIG], [ldns-config], [no])
@@ -9,12 +9,4 @@
                        CPPFLAGS="$CPPFLAGS -I${withval}/include"
                        LDFLAGS="$LDFLAGS -L${withval}/lib"
                        LIBS="-lldns $LIBS"
--                      ldns=yes
-               else
-                       LIBS="$LIBS `$LDNSCONFIG --libs`"
-                       CPPFLAGS="$CPPFLAGS `$LDNSCONFIG --cflags`"
-               fi
-+              ldns=yes
-       elif test "x$withval" != "xno" ; then
-                       CPPFLAGS="$CPPFLAGS -I${withval}/include"
-                       LDFLAGS="$LDFLAGS -L${withval}/lib"
+
index fccaf42de18a66bc53e12730b70c76f416c6139e..742640c871b296eec316b6acfc8407f58187bbe7 100644 (file)
@@ -33,12 +33,12 @@ diff -urN openssh-3.9p1.org/ssh.0 openssh-3.9p1/ssh.0
       -b bind_address
 --- openssh-5.6p1/ssh.1~       2010-08-24 14:05:48.000000000 +0300
 +++ openssh-5.6p1/ssh.1        2010-08-24 14:06:57.879253682 +0300
-@@ -44,7 +44,7 @@
+@@ -43,7 +43,7 @@
  .Sh SYNOPSIS
  .Nm ssh
  .Bk -words
--.Op Fl 1246AaCfGgKkMNnqsTtVvXxYy
-+.Op Fl 1246AaBCfGgKkMNnqsTtVvXxYy
+-.Op Fl 46AaCfGgKkMNnqsTtVvXxYy
++.Op Fl 46AaBCfGgKkMNnqsTtVvXxYy
  .Op Fl b Ar bind_address
  .Op Fl c Ar cipher_spec
  .Op Fl D Oo Ar bind_address : Oc Ns Ar port
@@ -66,15 +66,15 @@ diff -urN openssh-3.9p1.org/ssh.0 openssh-3.9p1/ssh.0
  /* # of replies received for global requests */
  static int client_global_request_id = 0;
  
-@@ -199,7 +199,7 @@ static void
+@@ -200,7 +200,7 @@ static void
  usage(void)
  {
        fprintf(stderr,
--"usage: ssh [-1246AaCfGgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]\n"
-+"usage: ssh [-1246AaBCfGgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]\n"
+-"usage: ssh [-46AaCfGgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]\n"
++"usage: ssh [-46AaBCfGgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]\n"
  "           [-D [bind_address:]port] [-E log_file] [-e escape_char]\n"
  "           [-F configfile] [-I pkcs11] [-i identity_file]\n"
- "           [-L [bind_address:]port:host:hostport] [-Q protocol_feature]\n"
+ "           [-J [user@]host[:port]] [-L address] [-l login_name] [-m mac_spec]\n"
 @@ -330,7 +330,7 @@ main(int ac, char **av)
  
   again:
index 36c103e18b9d7342884bb642b8136afa3becdd3e..3c2df1dc9687b926d1d8cd3393663f3267d19b19 100644 (file)
@@ -46,13 +46,13 @@ Summary(pt_BR.UTF-8):       Implementação livre do SSH
 Summary(ru.UTF-8):     OpenSSH - свободная реализация протокола Secure Shell (SSH)
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
-Version:       7.5p1
-Release:       2
+Version:       7.6p1
+Release:       1
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
-# Source0-md5: 652fdc7d8392f112bef11cacf7e69e23
+# Source0-md5: 06a88699018e5fef13d4655abfed1f63
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 66943d481cc422512b537bcc2c7400d1
 Source2:       %{name}d.init
This page took 0.216801 seconds and 4 git commands to generate.