]> git.pld-linux.org Git - packages/openssh.git/blobdiff - opensshd.init
- added some de,fr,it,pt translations from contrib/caldera/openssh.spec
[packages/openssh.git] / opensshd.init
index 7361f156a7f1663faee31a6596b475dc4cfc4824..c71085b33cd9f656c1a8a032c15d6204c16ea3d0 100644 (file)
@@ -20,7 +20,7 @@
 
 # Check that networking is up.
 if is_no "${NETWORKING}"; then
-        msg_Network_Down OpenSSH
+        msg_network_down OpenSSH
         exit 1
 fi
                        
@@ -28,19 +28,35 @@ fi
 # See how we were called.
 case "$1" in
   start)
-       # Check if the service is already running?
+       # generate new keys with empty passwords if they do not exist
+       if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
+           /usr/bin/ssh-keygen -t rsa1 -f /etc/ssh/ssh_host_key -N '' 1>&2
+           chmod 600 /etc/ssh/ssh_host_key
+       fi
+       if [ ! -f /etc/ssh/ssh_host_rsa_key -o ! -s /etc/ssh/ssh_host_rsa_key ]; then
+           /usr/bin/ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key -N '' 1>&2
+           chmod 600 /etc/ssh/ssh_host_rsa_key
+       fi
+       if [ ! -f /etc/ssh/ssh_host_dsa_key -o ! -s /etc/ssh/ssh_host_dsa_key ]; then
+           /usr/bin/ssh-keygen -t dsa -f /etc/ssh/ssh_host_dsa_key -N '' 1>&2
+           chmod 600 /etc/ssh/ssh_host_dsa_key
+       fi
+
        if [ ! -f /etc/ssh/ssh_host_key ]; then
-               msg_Not_Running OpenSSH
+               msg_not_running OpenSSH
                nls "No SSH host key found! You must run \"$0 init\" first."
                exit 1
        fi
+
+       # Check if the service is already running?
        if [ ! -f /var/lock/subsys/sshd ]; then
                msg_starting OpenSSH
+               ULIMIT_C="-S -c 0"
                daemon /usr/sbin/sshd 
                RETVAL=$?
                [ $RETVAL -eq 0 ] && touch /var/lock/subsys/sshd                
        else
-               msg_Already_Running OpenSSH
+               msg_already_running OpenSSH
        fi
        ;;
   stop)
@@ -49,7 +65,7 @@ case "$1" in
                killproc sshd
                rm -f /var/run/sshd.pid /var/lock/subsys/sshd >/dev/null 2>&1
        else
-               msg_Not_Running OpenSSH
+               msg_not_running OpenSSH
                exit 1
        fi      
        ;;
@@ -65,9 +81,11 @@ case "$1" in
        echo "Now the SSH host key will be generated. Please note, that if you"
        echo "will use password for the key, you will need to type it on each"
        echo "reboot."
-       /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key
+       /usr/bin/ssh-keygen -t rsa1 -f /etc/ssh/ssh_host_key
        chmod 600 /etc/ssh/ssh_host_key
-        /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key
+       /usr/bin/ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key
+       chmod 600 /etc/ssh/ssh_host_rsa_key
+        /usr/bin/ssh-keygen -t dsa -f /etc/ssh/ssh_host_dsa_key
        chmod 600 /etc/ssh/ssh_host_dsa_key
        exit $?
        ;;
@@ -76,7 +94,7 @@ case "$1" in
        killproc sshd -HUP
        ;;
   *)
-       msg_Usage "$0 {start|stop|init|status|restart|reload}"
+       msg_usage "$0 {start|stop|init|status|restart|reload}"
        exit 1
 esac
 
This page took 0.119075 seconds and 4 git commands to generate.