]> git.pld-linux.org Git - packages/openssh.git/blobdiff - openssh.spec
- sorry, forgotten one thing ;)
[packages/openssh.git] / openssh.spec
index 7951c10bb5079a11e4001b860fc68f15cc5b3e5b..e7484ad4a0c7c9de6422b98748992b3f50daba13 100644 (file)
@@ -1,9 +1,13 @@
 #
 # Conditional build:
-# _without_gnome - without gnome-askpass utility
-# _without_gtk  - without gtk (2.x)
+# _without_gnome       - without gnome-askpass utility
+# _without_gtk         - without gtk (2.x)
+# _with_ldap           - with ldap support
 #
 # default to gtk2-based gnome-askpass
+
+%define                orig_ver        3.6.1p2
+
 %{!?_without_gtk:%define _without_gnome 1}
 Summary:       OpenSSH free Secure Shell (SSH) implementation
 Summary(de):   OpenSSH - freie Implementation der Secure Shell (SSH)
@@ -16,12 +20,13 @@ Summary(pt_BR):     Implementa
 Summary(ru):   OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
 Summary(uk):   OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
 Name:          openssh
-Version:       3.6.1p2
-Release:       0.1
+Version:       3.6.1p2%{?_with_ldap:ldap}
+Release:       3.2
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
-Source0:       ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
+Source0:       ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{orig_ver}.tar.gz
+# Source0-md5: f3879270bffe479e1bd057aa36258696
 Source1:       %{name}d.conf
 Source2:       %{name}.conf
 Source3:       %{name}d.init
@@ -34,6 +39,8 @@ Patch0:               %{name}-no_libnsl.patch
 Patch2:                %{name}-linux-ipv6.patch
 Patch3:                %{name}-pam_misc.patch
 Patch4:                %{name}-sigpipe.patch
+# http://ldappubkey.gcu-squad.org/
+Patch5:                ldappubkey-ossh3.6-v2.patch
 URL:           http://www.openssh.com/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -41,8 +48,9 @@ BuildRequires:        automake
 %{!?_without_gtk:BuildRequires:        gtk+2-devel}
 BuildRequires: libwrap-devel
 BuildRequires: openssl-devel >= 0.9.7b
+%{?_with_ldap:BuildRequires:   openldap-devel}
 BuildRequires: pam-devel
-BuildRequires: perl
+BuildRequires: %{__perl}
 %{!?_without_gtk:BuildRequires:        pkgconfig}
 BuildRequires: zlib-devel
 PreReq:                openssl >= 0.9.7
@@ -180,7 +188,7 @@ Summary(pt_BR):     Clientes do OpenSSH
 Summary(ru):   OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
 Summary(uk):   OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
 Group:         Applications/Networking
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}
 Obsoletes:     ssh-clients
 
 %description clients
@@ -239,7 +247,7 @@ Summary(pt_BR):     Servidor OpenSSH para comunica
 Summary(ru):   OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
 Summary(uk):   OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
 Group:         Networking/Daemons
-PreReq:                %{name} = %{version}
+PreReq:                %{name} = %{epoch}:%{version}
 PreReq:                rc-scripts >= 0.3.1-3
 Requires(pre): /bin/id
 Requires(pre): /usr/sbin/useradd
@@ -325,7 +333,7 @@ Summary(pt_BR):     Di
 Summary(ru):   OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
 Summary(uk):   OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
 Group:         Applications/Networking
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}
 Obsoletes:     ssh-extras
 Obsoletes:     ssh-askpass
 Obsoletes:     openssh-askpass
@@ -374,17 +382,19 @@ Ssh (Secure Shell) - 
 GNOME.
 
 %prep
-%setup  -q
+%setup  -q -n %{name}-%{orig_ver}
 %patch0 -p1
 %patch2 -p1
 %patch3 -p1
 #%patch4 -p1
+%{?_with_ldap:%patch5 -p1}
 
 %build
 %{__aclocal}
 %{__autoconf}
 
 %configure \
+       PERL=%{__perl} \
        --with-pam \
        --with-mantype=man \
        --with-md5-passwords \
@@ -392,6 +402,8 @@ GNOME.
        --with-4in6 \
        --disable-suid-ssh \
        --with-tcp-wrappers \
+       %{?_with_ldap:--with-libs="-lldap -llber"} \
+       %{?_with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
        --with-privsep-path=%{_privsepdir} \
        --with-pid-dir=%{_localstatedir}/run \
        --with-xauth=/usr/X11R6/bin/xauth
@@ -501,6 +513,10 @@ fi
 %{_mandir}/man1/ssh-add.1*
 %{_mandir}/man5/ssh_config.5*
 
+# for host-based auth (suid required for accessing private host key)
+#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
+#%{_mandir}/man8/ssh-keysign.8*
+
 %files server
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/sshd
This page took 0.031427 seconds and 4 git commands to generate.