]> git.pld-linux.org Git - packages/openssh.git/blobdiff - openssh.spec
- rel 3
[packages/openssh.git] / openssh.spec
index 637807869510628fcbdabda53d3a88dc42cc2263..8e07b5c9f503a6a1c672cf2bb443afba511e8fb0 100644 (file)
@@ -1,8 +1,7 @@
-#
 # Conditional build:
 %bcond_with    gnome           # with gnome-askpass (GNOME 1.x) utility
 %bcond_without gtk             # without GTK+ (2.x)
-%bcond_with    ldap            # with ldap support
+%bcond_without ldap            # with ldap support
 %bcond_without libedit         # without libedit (editline/history support in sftp client)
 %bcond_without kerberos5       # without kerberos5 support
 %bcond_without selinux         # build without SELinux support
@@ -22,13 +21,13 @@ Summary(pt_BR.UTF-8):       Implementação livre do SSH
 Summary(ru.UTF-8):     OpenSSH - свободная реализация протокола Secure Shell (SSH)
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
-Version:       5.0p1
-Release:       4
+Version:       5.2p1
+Release:       3
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
-# Source0-md5: 1f1dfaa775f33dd3328169de9bdc292a
+# Source0-md5: ada79c7328a8551bdf55c95e631e7dad
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 66943d481cc422512b537bcc2c7400d1
 Source2:       %{name}d.init
@@ -36,12 +35,12 @@ Source3:    %{name}d.pamd
 Source4:       %{name}.sysconfig
 Source5:       ssh-agent.sh
 Source6:       ssh-agent.conf
+Source7:       %{name}-lpk.schema
 Patch0:                %{name}-no_libnsl.patch
-Patch1:                %{name}-linux-ipv6.patch
 Patch2:                %{name}-pam_misc.patch
 Patch3:                %{name}-sigpipe.patch
-# http://www.opendarwin.org/projects/openssh-lpk/
-Patch4:                %{name}-lpk-4.3p1-0.3.7.patch
+# http://code.google.com/p/openssh-lpk/
+Patch4:                %{name}-lpk.patch
 Patch5:                %{name}-config.patch
 Patch7:                %{name}-selinux.patch
 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
@@ -49,6 +48,7 @@ Patch7:               %{name}-selinux.patch
 Patch9:                %{name}-5.0p1-hpn13v4.diff
 Patch10:       %{name}-include.patch
 Patch11:       %{name}-chroot.patch
+Patch12:       http://people.debian.org/~cjwatson/%{name}-blacklist.diff
 URL:           http://www.openssh.com/
 BuildRequires: %{__perl}
 BuildRequires: autoconf
@@ -67,12 +67,15 @@ BuildRequires:      rpmbuild(macros) >= 1.318
 BuildRequires: zlib-devel
 Requires:      filesystem >= 3.0-11
 Requires:      pam >= 0.99.7.1
+Suggests:      openssh-blacklist
+Suggests:      xorg-app-xauth
 Obsoletes:     ssh
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/ssh
 %define                _libexecdir     %{_libdir}/%{name}
 %define                _privsepdir     /usr/share/empty
+%define                schemadir       /usr/share/openldap/schema
 
 %description
 Ssh (Secure Shell) a program for logging into a remote machine and for
@@ -454,10 +457,23 @@ Ssh (Secure Shell) - це програма для "заходу" (login) до в
 Цей пакет містить діалог вводу ключової фрази для використання під
 GNOME.
 
+%package -n openldap-schema-openssh-lpk
+Summary:       OpenSSH LDAP Public Key schema
+Summary(pl.UTF-8):     Schemat klucza publicznego LDAP dla OpenSSH
+Group:         Networking/Daemons
+Requires(post,postun): sed >= 4.0
+Requires:      openldap-servers
+
+%description -n openldap-schema-openssh-lpk
+This package contains OpenSSH LDAP Public Key schema for openldap.
+
+%description -n openldap-schema-openssh-lpk -l pl.UTF-8
+Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH
+dla openldap-a.
+
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %{?with_ldap:%patch4 -p1}
@@ -466,6 +482,7 @@ GNOME.
 %{?with_hpn:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 %build
 cp /usr/share/automake/config.sub .
@@ -509,7 +526,7 @@ cd contrib
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
-       $RPM_BUILD_ROOT%{_libexecdir}/ssh
+       $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
 
 %{__make} install \
@@ -523,6 +540,7 @@ install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
 ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
+install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
 
 %if %{with gnome}
 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
@@ -540,6 +558,9 @@ EOF
 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
 %endif
 
+install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
+install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
+
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
 
@@ -589,11 +610,23 @@ if [ "$1" = "0" ]; then
        %userremove sshd
 fi
 
+%post -n openldap-schema-openssh-lpk
+%openldap_schema_register %{schemadir}/openssh-lpk.schema
+%service -q ldap restart
+
+%postun -n openldap-schema-openssh-lpk
+if [ "$1" = "0" ]; then
+       %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
+       %service -q ldap restart
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc *.RNG TODO README OVERVIEW CREDITS Change*
 %attr(755,root,root) %{_bindir}/ssh-key*
+%attr(755,root,root) %{_bindir}/ssh-vulnkey*
 %{_mandir}/man1/ssh-key*.1*
+%{_mandir}/man1/ssh-vulnkey*.1*
 %dir %{_sysconfdir}
 %dir %{_libexecdir}
 
@@ -604,6 +637,7 @@ fi
 %attr(755,root,root) %{_bindir}/sftp
 %attr(755,root,root) %{_bindir}/ssh-agent
 %attr(755,root,root) %{_bindir}/ssh-add
+%attr(755,root,root) %{_bindir}/ssh-copy-id
 %attr(755,root,root) %{_bindir}/scp
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
@@ -613,6 +647,7 @@ fi
 %{_mandir}/man1/sftp.1*
 %{_mandir}/man1/ssh-agent.1*
 %{_mandir}/man1/ssh-add.1*
+%{_mandir}/man1/ssh-copy-id.1*
 %{_mandir}/man5/ssh_config.5*
 %lang(it) %{_mandir}/it/man1/ssh.1*
 %lang(it) %{_mandir}/it/man5/ssh_config.5*
@@ -641,6 +676,7 @@ fi
 %{_mandir}/man8/sftp-server.8*
 %{_mandir}/man8/ssh-keysign.8*
 %{_mandir}/man5/sshd_config.5*
+%{_mandir}/man5/moduli.5*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
 %attr(640,root,root) %{_sysconfdir}/moduli
@@ -656,3 +692,9 @@ fi
 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
 %attr(755,root,root) %{_libexecdir}/ssh-askpass
 %endif
+
+%if %{with ldap}
+%files -n openldap-schema-openssh-lpk
+%defattr(644,root,root,755)
+%{schemadir}/openssh-lpk.schema
+%endif
This page took 0.045518 seconds and 4 git commands to generate.