]> git.pld-linux.org Git - packages/openssh.git/blobdiff - openssh.spec
same problem with server too:
[packages/openssh.git] / openssh.spec
index 1c70c2ec2eda992176a681c35a95c5090d58b57c..37548d19495f66457a2c33285f042e676b801b0b 100644 (file)
@@ -1,6 +1,10 @@
+# TODO:
+# - add trigger to enable this:
+#  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
+#   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
 #
 # Conditional build:
-%bcond_with    audit           # sshd audit support
+%bcond_without audit           # sshd audit support
 %bcond_with    gnome           # with gnome-askpass (GNOME 1.x) utility
 %bcond_without gtk             # without GTK+ (2.x)
 %bcond_without ldap            # with ldap support
@@ -8,6 +12,7 @@
 %bcond_without kerberos5       # without kerberos5 support
 %bcond_without selinux         # build without SELinux support
 %bcond_with    hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
+%bcond_without tests
 
 # gtk2-based gnome-askpass means no gnome1-based
 %{?with_gtk:%undefine with_gnome}
@@ -15,7 +20,7 @@
 %if "%{pld_release}" == "ac"
 %define                pam_ver 0.79.0
 %else
-%define                pam_ver 0.99.7.1
+%define                pam_ver 1:1.1.5-5
 %endif
 
 Summary:       OpenSSH free Secure Shell (SSH) implementation
@@ -29,13 +34,13 @@ Summary(pt_BR.UTF-8):       Implementação livre do SSH
 Summary(ru.UTF-8):     OpenSSH - свободная реализация протокола Secure Shell (SSH)
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
-Version:       5.9p1
-Release:       4
+Version:       6.2p2
+Release:       3
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
-# Source0-md5: b50a499fa02616a47984b1920848b565
+# Source0-md5: be46174dcbb77ebb4ea88ef140685de1
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 66943d481cc422512b537bcc2c7400d1
 Source2:       %{name}d.init
@@ -45,6 +50,10 @@ Source5:     ssh-agent.sh
 Source6:       ssh-agent.conf
 Source7:       %{name}-lpk.schema
 Source8:       %{name}d.upstart
+Source9:       sshd.service
+Source10:      sshd-keygen
+Source11:      sshd.socket
+Source12:      sshd@.service
 Patch100:      %{name}-heimdal.patch
 Patch0:                %{name}-no_libnsl.patch
 Patch2:                %{name}-pam_misc.patch
@@ -54,8 +63,7 @@ Patch4:               %{name}-5.9p1-ldap.patch
 Patch5:                %{name}-5.9p1-ldap-fixes.patch
 Patch8:                ldap.conf.patch
 Patch6:                %{name}-config.patch
-# https://bugzilla.mindrot.org/show_bug.cgi?id=1663
-Patch7:                authorized-keys-command.patch
+
 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
 Patch9:                %{name}-5.2p1-hpn13v6.diff
@@ -64,8 +72,11 @@ Patch11:     %{name}-chroot.patch
 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
 Patch12:       %{name}-blacklist.diff
 Patch13:       %{name}-kuserok.patch
+Patch14:       %{name}-bind.patch
+Patch15:       %{name}-disable_ldap.patch
 URL:           http://www.openssh.com/portable.html
 BuildRequires: %{__perl}
+%{?with_tests:BuildRequires:   %{name}-server}
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -80,9 +91,10 @@ BuildRequires:       openssl-devel >= 0.9.7d
 BuildRequires: pam-devel
 %{?with_gtk:BuildRequires:     pkgconfig}
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.318
+BuildRequires: rpmbuild(macros) >= 1.627
 BuildRequires: sed >= 4.0
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.2.3
+Requires:      zlib >= 1.2.3
 %if "%{pld_release}" == "ac"
 Requires:      filesystem >= 2.0-1
 Requires:      pam >= 0.79.0
@@ -246,6 +258,7 @@ Group:              Applications/Networking
 Requires:      %{name}
 Provides:      ssh-clients
 Obsoletes:     ssh-clients
+%requires_eq_to        openssl openssl-devel
 
 %description clients
 Ssh (Secure Shell) a program for logging into a remote machine and for
@@ -334,15 +347,19 @@ Requires(post,preun):     /sbin/chkconfig
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
 Requires(pre): /usr/sbin/useradd
+Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 # remove in 6.0, kept for flawless upgrade
-Requires:      %{name}-server-ldap = %{epoch}:%{version}-%{release}
+%{?with_ldap:Requires: %{name}-server-ldap = %{epoch}:%{version}-%{release}}
 Requires:      pam >= %{pam_ver}
 Requires:      rc-scripts >= 0.4.3.0
+Requires:      systemd-units >= 38
 Requires:      util-linux
 Suggests:      /bin/login
+Suggests:      xorg-app-xauth
 Provides:      ssh-server
 Provides:      user(sshd)
+%requires_eq_to        openssl openssl-devel
 
 %description server
 Ssh (Secure Shell) a program for logging into a remote machine and for
@@ -408,13 +425,18 @@ Ssh (Secure Shell) - це програма для "заходу" (login) до в
 
 %package server-ldap
 Summary:       A LDAP support for open source SSH server daemon
+Summary(pl.UTF-8):     Wsparcie LDAP dla serwera OpenSSH
 Group:         Daemons
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description server-ldap
 OpenSSH LDAP backend is a way how to distribute the authorized tokens
 among the servers in the network.
 
+%description server-ldap -l pl.UTF-8
+Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
+tokenów między serwerami w sieci.
+
 %package server-upstart
 Summary:       Upstart job description for OpenSSH server
 Summary(pl.UTF-8):     Opis zadania Upstart dla serwera OpenSSH
@@ -513,24 +535,18 @@ openldap-a.
 %patch5 -p1
 %patch8 -p1
 %patch6 -p1
-%patch7 -p1
+
 %{?with_hpn:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-
-cp -p %{SOURCE3} sshd.pam
-install -p %{SOURCE2} sshd.init
+%patch14 -p1
+%{!?with_ldap:%patch15 -p1}
 
 %if "%{pld_release}" == "ac"
 # fix for missing x11.pc
 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
-# not present in ac, no point searching it
-%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
-
-# openssl on ac does not have OPENSSL_HAS_ECC
-%{__sed} -i -e '/ecdsa/d' sshd.init
 %endif
 
 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
@@ -559,9 +575,9 @@ CPPFLAGS="-DCHROOT"
        --with-mantype=man \
        --with-md5-passwords \
        --with-pam \
-       --with-authorized-keys-command \
        --with-pid-dir=%{_localstatedir}/run \
        --with-privsep-path=%{_privsepdir} \
+       --with-sandbox=seccomp_filter \
        %{?with_selinux:--with-selinux} \
        --with-tcp-wrappers \
 %if "%{pld_release}" == "ac"
@@ -574,6 +590,8 @@ echo '#define LOGIN_PROGRAM            "/bin/login"' >>config.h
 
 %{__make}
 
+%{?with_tests:%{__make} tests}
+
 cd contrib
 %if %{with gnome}
 %{__make} gnome-ssh-askpass1 \
@@ -587,7 +605,7 @@ cd contrib
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
-       $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
+       $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
 
 %{__make} install \
@@ -595,6 +613,21 @@ install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
+cp -p %{SOURCE3} sshd.pam
+install -p %{SOURCE2} sshd.init
+
+%if "%{pld_release}" == "ac"
+# not present in ac, no point searching it
+%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
+# openssl on ac does not have OPENSSL_HAS_ECC
+%{__sed} -i -e '/ecdsa/d' sshd.init
+%endif
+
+%if %{without audit}
+# remove recording user's login uid to the process attribute
+%{__sed} -i -e '/pam_loginuid.so/d' sshd.pam
+%endif
+
 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
@@ -604,6 +637,12 @@ cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
 
+%{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
+cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
+
+cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
+cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
+
 %if %{with gnome}
 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
 %endif
@@ -633,7 +672,7 @@ cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
 EOF
 
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
-%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
+%{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -656,23 +695,27 @@ rm -rf $RPM_BUILD_ROOT
 %post server
 /sbin/chkconfig --add sshd
 %service sshd reload "OpenSSH Daemon"
-if ! grep -qs ssh /etc/security/passwd.conf ; then
-       umask 022
-       echo "ssh" >> /etc/security/passwd.conf
-fi
+NORESTART=1
+%systemd_post sshd.service
 
 %preun server
 if [ "$1" = "0" ]; then
        %service sshd stop
        /sbin/chkconfig --del sshd
 fi
+%systemd_preun sshd.service
 
 %postun server
 if [ "$1" = "0" ]; then
        %userremove sshd
 fi
+%systemd_reload
+
+%triggerpostun server -- %{name}-server < 6.2p1-1
+cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
+sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
 
-%triggerpostun server -- %{name}-server < 2:5.9p1-1
+%triggerpostun server -- %{name}-server < 2:5.9p1-8
 # lpk.patch to ldap.patch
 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
        echo >&2 "Migrating LPK patch to LDAP patch"
@@ -680,12 +723,26 @@ if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
        %{__sed} -i -e '
                # disable old configs
                # just UseLPK/LkpLdapConf supported for now
-               s/^UseLPK/## Obsolete &/
-               s/^Lpk/## Obsolete &/
+               s/^\s*UseLPK/## Obsolete &/
+               s/^\s*Lpk/## Obsolete &/
                # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
                /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
        ' %{_sysconfdir}/sshd_config
-       %service -q sshd reload
+       if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
+               /bin/systemctl try-restart sshd.service || :
+       else
+               %service -q sshd reload
+       fi
+fi
+%systemd_trigger sshd.service
+if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
+%banner %{name}-server -e << EOF
+!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
+! Native systemd support for sshd has been installed.   !
+! Restarting sshd.service with systemctl WILL kill all  !
+! active ssh sessions (daemon as such will be started). !
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+EOF
 fi
 
 %post server-upstart
@@ -757,6 +814,7 @@ fi
 %attr(755,root,root) %{_libexecdir}/sftp-server
 %attr(755,root,root) %{_libexecdir}/ssh-keysign
 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
+%attr(755,root,root) %{_libexecdir}/sshd-keygen
 %{_mandir}/man8/sshd.8*
 %{_mandir}/man8/sftp-server.8*
 %{_mandir}/man8/ssh-keysign.8*
@@ -769,6 +827,9 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/sshd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
+%{systemdunitdir}/sshd.service
+%{systemdunitdir}/sshd.socket
+%{systemdunitdir}/sshd@.service
 
 %if %{with ldap}
 %files server-ldap
This page took 0.084496 seconds and 4 git commands to generate.