]> git.pld-linux.org Git - packages/openssh.git/blobdiff - openssh.spec
- release 2 (by relup.sh)
[packages/openssh.git] / openssh.spec
index 9910979e1e15184288b599da57a4d3835bca2475..0f350c3d05b62dc3b46ce8f9d4b7d2f8d1afe1cf 100644 (file)
@@ -15,6 +15,7 @@
 %bcond_without libseccomp      # use libseccomp for seccomp privsep (requires 3.5 kernel)
 %bcond_with    hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
 %bcond_without tests           # test suite
+%bcond_with    tests_conch     # run conch interoperability tests
 
 # gtk2-based gnome-askpass means no gnome1-based
 %{?with_gtk:%undefine with_gnome}
@@ -35,13 +36,13 @@ Summary(pt_BR.UTF-8):       Implementação livre do SSH
 Summary(ru.UTF-8):     OpenSSH - свободная реализация протокола Secure Shell (SSH)
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
-Version:       8.1p1
+Version:       8.2p1
 Release:       2
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
-# Source0-md5: 513694343631a99841e815306806edf0
+# Source0-md5: 3076e6413e8dbe56d33848c1054ac091
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 66943d481cc422512b537bcc2c7400d1
 Source2:       %{name}d.init
@@ -54,6 +55,7 @@ Source9:      sshd.service
 Source10:      sshd-keygen
 Source11:      sshd.socket
 Source12:      sshd@.service
+Patch0:                %{name}-no-pty-tests.patch
 Patch1:                %{name}-tests-reuseport.patch
 Patch2:                %{name}-pam_misc.patch
 Patch3:                %{name}-sigpipe.patch
@@ -66,10 +68,10 @@ Patch8:             ldap-helper-sigpipe.patch
 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
 Patch9:                %{name}-5.2p1-hpn13v6.diff
-Patch10:       %{name}-include.patch
+
 Patch11:       %{name}-chroot.patch
 Patch12:       openssh-bug-2905.patch
-
+Patch13:       %{name}-skip-interop-tests.patch
 Patch14:       %{name}-bind.patch
 Patch15:       %{name}-disable_ldap.patch
 URL:           http://www.openssh.com/portable.html
@@ -82,12 +84,16 @@ BuildRequires:      automake
 %{?with_kerberos5:BuildRequires:       heimdal-devel >= 0.7}
 %{?with_ldns:BuildRequires:    ldns-devel}
 %{?with_libedit:BuildRequires: libedit-devel}
+BuildRequires: libfido2-devel
 BuildRequires: libseccomp-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: openssl-devel >= 1.1.0g
 BuildRequires: pam-devel
 %{?with_gtk:BuildRequires:     pkgconfig}
+%if %{with tests} && %{with tests_conch}
+BuildRequires: python-TwistedConch
+%endif
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.627
 BuildRequires: sed >= 4.0
@@ -521,6 +527,7 @@ openldap-a.
 
 %prep
 %setup -q
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -531,9 +538,10 @@ openldap-a.
 %patch8 -p1
 
 %{?with_hpn:%patch9 -p1}
-%patch10 -p1
+
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
 
 %patch14 -p1
 %{!?with_ldap:%patch15 -p1}
@@ -576,6 +584,7 @@ CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
        --with-pid-dir=%{_localstatedir}/run \
        --with-privsep-path=%{_privsepdir} \
        --with-privsep-user=sshd \
+       --with-security-key-builtin \
        %{?with_selinux:--with-selinux} \
 %if "%{pld_release}" == "ac"
        --with-xauth=/usr/X11R6/bin/xauth
@@ -591,7 +600,10 @@ echo '#define LOGIN_PROGRAM                   "/bin/login"' >>config.h
 %if %{with tests}
 %{__make} -j1 tests \
        TEST_SSH_PORT=$((4242 + ${RANDOM:-$$} % 1000)) \
-       TEST_SSH_TRACE="yes"
+       TEST_SSH_TRACE="yes" \
+%if %{without tests_conch}
+       SKIP_LTESTS="conch-ciphers"
+%endif
 %endif
 
 cd contrib
@@ -781,6 +793,7 @@ fi
 %attr(755,root,root) %{_bindir}/ssh-add
 %attr(755,root,root) %{_bindir}/ssh-copy-id
 %attr(755,root,root) %{_bindir}/scp
+%attr(755,root,root) %{_libexecdir}/ssh-sk-helper
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
 %{_mandir}/man1/scp.1*
@@ -790,6 +803,7 @@ fi
 %{_mandir}/man1/ssh-add.1*
 %{_mandir}/man1/ssh-copy-id.1*
 %{_mandir}/man5/ssh_config.5*
+%{_mandir}/man8/ssh-sk-helper.8*
 %lang(it) %{_mandir}/it/man1/ssh.1*
 %lang(it) %{_mandir}/it/man5/ssh_config.5*
 %lang(pl) %{_mandir}/pl/man1/scp.1*
This page took 0.152322 seconds and 4 git commands to generate.