]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- sandbox macro is always defined
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_without  libseccomp      # use libseccomp for seccomp privsep (requires 3.5 kernel)
15 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
16 %bcond_without  tests
17
18 # gtk2-based gnome-askpass means no gnome1-based
19 %{?with_gtk:%undefine with_gnome}
20
21 %if "%{pld_release}" != "ac"
22 %define sandbox %{?with_libseccomp:lib}seccomp_filter
23 %endif
24
25 %if "%{pld_release}" == "ac"
26 %define         pam_ver 0.79.0
27 %else
28 %define         pam_ver 1:1.1.8-5
29 %endif
30 Summary:        OpenSSH free Secure Shell (SSH) implementation
31 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
32 Summary(es.UTF-8):      Implementación libre de SSH
33 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
34 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
35 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
36 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
37 Summary(pt_BR.UTF-8):   Implementação livre do SSH
38 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
39 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
40 Name:           openssh
41 Version:        6.8p1
42 Release:        6
43 Epoch:          2
44 License:        BSD
45 Group:          Applications/Networking
46 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
47 # Source0-md5:  08f72de6751acfbd0892b5f003922701
48 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
49 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
50 Source2:        %{name}d.init
51 Source3:        %{name}d.pamd
52 Source4:        %{name}.sysconfig
53 Source5:        ssh-agent.sh
54 Source6:        ssh-agent.conf
55 Source7:        %{name}-lpk.schema
56 Source9:        sshd.service
57 Source10:       sshd-keygen
58 Source11:       sshd.socket
59 Source12:       sshd@.service
60 Patch0:         %{name}-no_libnsl.patch
61 Patch2:         %{name}-pam_misc.patch
62 Patch3:         %{name}-sigpipe.patch
63 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
64 Patch4:         %{name}-ldap.patch
65 Patch5:         %{name}-ldap-fixes.patch
66 Patch6:         ldap.conf.patch
67 Patch7:         %{name}-config.patch
68 Patch8:         ldap-helper-sigpipe.patch
69 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
70 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
71 Patch9:         %{name}-5.2p1-hpn13v6.diff
72 Patch10:        %{name}-include.patch
73 Patch11:        %{name}-chroot.patch
74
75 Patch14:        %{name}-bind.patch
76 Patch15:        %{name}-disable_ldap.patch
77 Patch16:        libseccomp-sandbox.patch
78 URL:            http://www.openssh.com/portable.html
79 BuildRequires:  %{__perl}
80 %{?with_audit:BuildRequires:    audit-libs-devel}
81 BuildRequires:  autoconf >= 2.50
82 BuildRequires:  automake
83 %{?with_gnome:BuildRequires:    gnome-libs-devel}
84 %{?with_gtk:BuildRequires:      gtk+2-devel}
85 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
86 %{?with_libedit:BuildRequires:  libedit-devel}
87 BuildRequires:  libseccomp-devel
88 %{?with_selinux:BuildRequires:  libselinux-devel}
89 %{?with_ldap:BuildRequires:     openldap-devel}
90 BuildRequires:  openssl-devel >= 0.9.8f
91 BuildRequires:  pam-devel
92 %{?with_gtk:BuildRequires:      pkgconfig}
93 BuildRequires:  rpm >= 4.4.9-56
94 BuildRequires:  rpmbuild(macros) >= 1.627
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  zlib-devel >= 1.2.3
97 %if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
98 BuildRequires:  %{name}-server
99 %endif
100 %if %{with tests} && %{with libseccomp}
101 # libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
102 BuildRequires:  uname(release) >= 3.5
103 %endif
104 Requires:       zlib >= 1.2.3
105 %if "%{pld_release}" == "ac"
106 Requires:       filesystem >= 2.0-1
107 Requires:       pam >= 0.79.0
108 %else
109 Requires:       filesystem >= 3.0-11
110 Requires:       pam >= %{pam_ver}
111 Suggests:       xorg-app-xauth
112 %endif
113 %{?with_libseccomp:Requires:    uname(release) >= 3.5}
114 Obsoletes:      ssh
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %define         _sysconfdir     /etc/ssh
118 %define         _libexecdir     %{_libdir}/%{name}
119 %define         _privsepdir     /usr/share/empty
120 %define         schemadir       /usr/share/openldap/schema
121
122 %description
123 Ssh (Secure Shell) a program for logging into a remote machine and for
124 executing commands in a remote machine. It is intended to replace
125 rlogin and rsh, and provide secure encrypted communications between
126 two untrusted hosts over an insecure network. X11 connections and
127 arbitrary TCP/IP ports can also be forwarded over the secure channel.
128
129 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
130 it up to date in terms of security and features, as well as removing
131 all patented algorithms to seperate libraries (OpenSSL).
132
133 This package includes the core files necessary for both the OpenSSH
134 client and server. To make this package useful, you should also
135 install openssh-clients, openssh-server, or both.
136
137 %if %{with hpn}
138 This release includes High Performance SSH/SCP patches from
139 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
140 increase throughput on fast connections with high RTT (20-150 msec).
141 See the website for '-w' values for your connection and /proc/sys TCP
142 values. BTW. in a LAN you have got generally RTT < 1 msec.
143 %endif
144
145 %description -l de.UTF-8
146 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
147 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
148 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
149 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
150 andere TCP/IP Ports können ebenso über den sicheren Channel
151 weitergeleitet werden.
152
153 %description -l es.UTF-8
154 SSH es un programa para accesar y ejecutar órdenes en computadores
155 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
156 seguro entre dos servidores en una red insegura. Conexiones X11 y
157 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
158 seguro.
159
160 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
161 continuar la última versión gratuita de SSH, actualizándolo en
162 términos de seguridad y recursos,así también eliminando todos los
163 algoritmos patentados y colocándolos en bibliotecas separadas
164 (OpenSSL).
165
166 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
167 también el paquete openssh-clients u openssh-server o ambos.
168
169 %description -l fr.UTF-8
170 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
171 remplace telnet, rlogin, rexec et rsh, tout en assurant des
172 communications cryptées securisées entre deux hôtes non fiabilisés sur
173 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
174 arbitraires peuvent également être transmis sur le canal sécurisé.
175
176 %description -l it.UTF-8
177 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
178 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
179 sicure e crittate tra due host non fidati su una rete non sicura. Le
180 connessioni X11 ad una porta TCP/IP arbitraria possono essere
181 inoltrate attraverso un canale sicuro.
182
183 %description -l pl.UTF-8
184 Ssh (Secure Shell) to program służący do logowania się na zdalną
185 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
186 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
187 pomiędzy dwoma hostami.
188
189 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
190 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
191 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
192
193 %if %{with hpn}
194 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
195 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
196 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
197 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
198 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
199 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
200 %endif
201
202 %description -l pt.UTF-8
203 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
204 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
205 cifradas entre duas máquinas sem confiança mútua sobre uma rede
206 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
207 reenviados pelo canal seguro.
208
209 %description -l pt_BR.UTF-8
210 SSH é um programa para acessar e executar comandos em máquinas
211 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
212 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
213 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
214
215 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
216 última versão gratuita do SSH, atualizando-o em termos de segurança e
217 recursos, assim como removendo todos os algoritmos patenteados e
218 colocando-os em bibliotecas separadas (OpenSSL).
219
220 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
221 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
222
223 %description -l ru.UTF-8
224 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
225 машину и для выполнения команд на удаленной машине. Она предназначена
226 для замены rlogin и rsh и обеспечивает безопасную шифрованную
227 коммуникацию между двумя хостами в сети, являющейся небезопасной.
228 Соединения X11 и любые порты TCP/IP могут также быть проведены через
229 безопасный канал.
230
231 OpenSSH - это переделка командой разработчиков OpenBSD последней
232 свободной версии SSH, доведенная до современного состояния в терминах
233 уровня безопасности и поддерживаемых возможностей. Все патентованные
234 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
235
236 Этот пакет содержит файлы, необходимые как для клиента, так и для
237 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
238 openssh-server, или оба пакета.
239
240 %description -l uk.UTF-8
241 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
242 машини та для виконання команд на віддаленій машині. Вона призначена
243 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
244 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
245 довільні порти TCP/IP можуть також бути проведені через безпечний
246 канал.
247
248 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
249 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
250 підтримуваних можливостей. Всі патентовані алгоритми винесені до
251 окремих бібліотек (OpenSSL).
252
253 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
254 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
255 openssh-server, чи обидва пакети.
256
257 %package clients
258 Summary:        OpenSSH Secure Shell protocol clients
259 Summary(es.UTF-8):      Clientes de OpenSSH
260 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
261 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
262 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
263 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
264 Group:          Applications/Networking
265 Requires:       %{name}
266 Provides:       ssh-clients
267 Obsoletes:      ssh-clients
268 %requires_eq_to openssl openssl-devel
269
270 %description clients
271 Ssh (Secure Shell) a program for logging into a remote machine and for
272 executing commands in a remote machine. It is intended to replace
273 rlogin and rsh, and provide secure encrypted communications between
274 two untrusted hosts over an insecure network. X11 connections and
275 arbitrary TCP/IP ports can also be forwarded over the secure channel.
276
277 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
278 it up to date in terms of security and features, as well as removing
279 all patented algorithms to seperate libraries (OpenSSL).
280
281 This package includes the clients necessary to make encrypted
282 connections to SSH servers.
283
284 %description clients -l es.UTF-8
285 Este paquete incluye los clientes que se necesitan para hacer
286 conexiones codificadas con servidores SSH.
287
288 %description clients -l pl.UTF-8
289 Ssh (Secure Shell) to program służący do logowania się na zdalną
290 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
291 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
292 pomiędzy dwoma hostami.
293
294 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
295
296 %description clients -l pt_BR.UTF-8
297 Esse pacote inclui os clientes necessários para fazer conexões
298 encriptadas com servidores SSH.
299
300 %description clients -l ru.UTF-8
301 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
302 машину и для выполнения команд на удаленной машине.
303
304 Этот пакет содержит программы-клиенты, необходимые для установления
305 зашифрованных соединений с серверами SSH.
306
307 %description clients -l uk.UTF-8
308 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
309 машини та для виконання команд на віддаленій машині.
310
311 Цей пакет містить програми-клієнти, необхідні для встановлення
312 зашифрованих з'єднань з серверами SSH.
313
314 %package clients-agent-profile_d
315 Summary:        OpenSSH Secure Shell agent init script
316 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
317 Group:          Applications/Networking
318 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
319
320 %description clients-agent-profile_d
321 profile.d scripts for starting SSH agent.
322
323 %description clients-agent-profile_d -l pl.UTF-8
324 Skrypty profile.d do uruchamiania agenta SSH.
325
326 %package clients-agent-xinitrc
327 Summary:        OpenSSH Secure Shell agent init script
328 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
329 Group:          Applications/Networking
330 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
331 Requires:       xinitrc
332
333 %description clients-agent-xinitrc
334 xinitrc scripts for starting SSH agent.
335
336 %description clients-agent-xinitrc -l pl.UTF-8
337 Skrypty xinitrc do uruchamiania agenta SSH.
338
339 %package server
340 Summary:        OpenSSH Secure Shell protocol server (sshd)
341 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
342 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
343 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
344 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
345 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
346 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
347 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
348 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
349 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
350 Group:          Networking/Daemons
351 Requires(post): /sbin/chkconfig
352 Requires(post): grep
353 Requires(post,preun):   /sbin/chkconfig
354 Requires(postun):       /usr/sbin/userdel
355 Requires(pre):  /bin/id
356 Requires(pre):  /usr/sbin/useradd
357 Requires(post,preun,postun):    systemd-units >= 38
358 Requires:       %{name} = %{epoch}:%{version}-%{release}
359 Requires:       pam >= %{pam_ver}
360 Requires:       rc-scripts >= 0.4.3.0
361 Requires:       systemd-units >= 38
362 Requires:       util-linux
363 %{?with_ldap:Suggests:  %{name}-server-ldap}
364 Suggests:       /bin/login
365 Suggests:       xorg-app-xauth
366 Provides:       ssh-server
367 Provides:       user(sshd)
368 %requires_eq_to openssl openssl-devel
369
370 %description server
371 Ssh (Secure Shell) a program for logging into a remote machine and for
372 executing commands in a remote machine. It is intended to replace
373 rlogin and rsh, and provide secure encrypted communications between
374 two untrusted hosts over an insecure network. X11 connections and
375 arbitrary TCP/IP ports can also be forwarded over the secure channel.
376
377 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
378 it up to date in terms of security and features, as well as removing
379 all patented algorithms to seperate libraries (OpenSSL).
380
381 This package contains the secure shell daemon. The sshd is the server
382 part of the secure shell protocol and allows ssh clients to connect to
383 your host.
384
385 %description server -l de.UTF-8
386 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
387
388 %description server -l es.UTF-8
389 Este paquete contiene el servidor SSH. sshd es la parte servidor del
390 protocolo secure shell y permite que clientes ssh se conecten a su
391 servidor.
392
393 %description server -l fr.UTF-8
394 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
395
396 %description server -l it.UTF-8
397 Questo pacchetto installa sshd, il server di OpenSSH.
398
399 %description server -l pl.UTF-8
400 Ssh (Secure Shell) to program służący do logowania się na zdalną
401 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
402 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
403 pomiędzy dwoma hostami.
404
405 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
406 ssh).
407
408 %description server -l pt.UTF-8
409 Este pacote intala o sshd, o servidor do OpenSSH.
410
411 %description server -l pt_BR.UTF-8
412 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
413 protocolo secure shell e permite que clientes ssh se conectem ao seu
414 host.
415
416 %description server -l ru.UTF-8
417 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
418 машину и для выполнения команд на удаленной машине.
419
420 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
421 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
422 вашим хостом.
423
424 %description server -l uk.UTF-8
425 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
426 машини та для виконання команд на віддаленій машині.
427
428 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
429 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
430 з вашим хостом.
431
432 %package server-ldap
433 Summary:        A LDAP support for open source SSH server daemon
434 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
435 Group:          Daemons
436 Requires:       %{name} = %{epoch}:%{version}-%{release}
437 Requires:       openldap-nss-config
438
439 %description server-ldap
440 OpenSSH LDAP backend is a way how to distribute the authorized tokens
441 among the servers in the network.
442
443 %description server-ldap -l pl.UTF-8
444 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
445 tokenów między serwerami w sieci.
446
447 %package gnome-askpass
448 Summary:        OpenSSH GNOME passphrase dialog
449 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
450 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
451 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
452 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
453 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
454 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
455 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
456 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
457 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
458 Group:          Applications/Networking
459 Requires:       %{name} = %{epoch}:%{version}-%{release}
460 Obsoletes:      openssh-askpass
461 Obsoletes:      ssh-askpass
462 Obsoletes:      ssh-extras
463
464 %description gnome-askpass
465 Ssh (Secure Shell) a program for logging into a remote machine and for
466 executing commands in a remote machine. It is intended to replace
467 rlogin and rsh, and provide secure encrypted communications between
468 two untrusted hosts over an insecure network. X11 connections and
469 arbitrary TCP/IP ports can also be forwarded over the secure channel.
470
471 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
472 it up to date in terms of security and features, as well as removing
473 all patented algorithms to seperate libraries (OpenSSL).
474
475 This package contains the GNOME passphrase dialog.
476
477 %description gnome-askpass -l es.UTF-8
478 Este paquete contiene un programa que abre una caja de diálogo para
479 entrada de passphrase en GNOME.
480
481 %description gnome-askpass -l pl.UTF-8
482 Ssh (Secure Shell) to program służący do logowania się na zdalną
483 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
484 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
485 pomiędzy dwoma hostami.
486
487 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
488
489 %description gnome-askpass -l pt_BR.UTF-8
490 Esse pacote contém um programa que abre uma caixa de diálogo para
491 entrada de passphrase no GNOME.
492
493 %description gnome-askpass -l ru.UTF-8
494 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
495 машину и для выполнения команд на удаленной машине.
496
497 Этот пакет содержит диалог ввода ключевой фразы для использования под
498 GNOME.
499
500 %description gnome-askpass -l uk.UTF-8
501 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
502 машини та для виконання команд на віддаленій машині.
503
504 Цей пакет містить діалог вводу ключової фрази для використання під
505 GNOME.
506
507 %package -n openldap-schema-openssh-lpk
508 Summary:        OpenSSH LDAP Public Key schema
509 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
510 Group:          Networking/Daemons
511 Requires(post,postun):  sed >= 4.0
512 Requires:       openldap-servers
513 %if "%{_rpmversion}" >= "5"
514 BuildArch:      noarch
515 %endif
516
517 %description -n openldap-schema-openssh-lpk
518 This package contains OpenSSH LDAP Public Key schema for openldap.
519
520 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
521 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
522 openldap-a.
523
524 %prep
525 %setup -q
526 %patch0 -p1
527 %patch2 -p1
528 %patch3 -p1
529 %patch4 -p1
530 %patch5 -p1
531 %patch6 -p1
532 %patch7 -p1
533 %patch8 -p1
534
535 %{?with_hpn:%patch9 -p1}
536 %patch10 -p1
537 %patch11 -p1
538
539 %patch14 -p1
540 %{!?with_ldap:%patch15 -p1}
541 %{?with_libseccomp:%patch16 -p1}
542
543 %if "%{pld_release}" == "ac"
544 # fix for missing x11.pc
545 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
546 %endif
547
548 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
549 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
550
551 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
552 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
553
554 # prevent being ovewritten by aclocal calls
555 mv aclocal.m4 acinclude.m4
556
557 %build
558 cp /usr/share/automake/config.sub .
559 %{__aclocal}
560 %{__autoconf}
561 %{__autoheader}
562 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
563 %configure \
564         PERL=%{__perl} \
565         --disable-strip \
566         --enable-utmpx \
567         --enable-wtmpx \
568         --with-4in6 \
569         %{?with_audit:--with-audit=linux} \
570         --with-ipaddr-display \
571         %{?with_kerberos5:--with-kerberos5=/usr} \
572         --with-ldap%{!?with_ldap:=no} \
573         %{?with_libedit:--with-libedit} \
574         --with-mantype=man \
575         --with-md5-passwords \
576         --with-pam \
577         --with-pid-dir=%{_localstatedir}/run \
578         --with-privsep-path=%{_privsepdir} \
579         --with-privsep-user=sshd \
580         --with-sandbox=%{sandbox} \
581         %{?with_selinux:--with-selinux} \
582 %if "%{pld_release}" == "ac"
583         --with-xauth=/usr/X11R6/bin/xauth
584 %else
585         --with-xauth=%{_bindir}/xauth
586 %endif
587
588 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
589
590 %{__make}
591
592 %{?with_tests:%{__make} tests}
593
594 cd contrib
595 %if %{with gnome}
596 %{__make} gnome-ssh-askpass1 \
597         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
598 %endif
599 %if %{with gtk}
600 %{__make} gnome-ssh-askpass2 \
601         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
602 %endif
603
604 %install
605 rm -rf $RPM_BUILD_ROOT
606 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
607         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
608 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
609
610 %{__make} install \
611         DESTDIR=$RPM_BUILD_ROOT
612
613 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
614
615 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
616 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
617 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
618 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
619 ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
620 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
621 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
622
623 cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
624 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
625
626 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
627         $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
628         $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
629
630 %if %{with gnome}
631 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
632 %endif
633 %if %{with gtk}
634 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
635 %endif
636 %if %{with gnome} || %{with gtk}
637 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
638 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
639 EOF
640 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
641 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
642 EOF
643 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
644 %endif
645
646 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
647 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
648
649 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
650 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
651
652 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
653
654 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
655 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
656 EOF
657
658 %if "%{pld_release}" == "ac"
659 # not present in ac, no point searching it
660 %{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
661 # openssl on ac does not have OPENSSL_HAS_ECC
662 %{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
663 %endif
664
665 %if %{without audit}
666 # remove recording user's login uid to the process attribute
667 %{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
668 %endif
669
670 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
671 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
672
673 %clean
674 rm -rf $RPM_BUILD_ROOT
675
676 %post clients
677 %env_update
678
679 %postun clients
680 %env_update
681
682 %post gnome-askpass
683 %env_update
684
685 %postun gnome-askpass
686 %env_update
687
688 %pre server
689 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
690
691 %post server
692 /sbin/chkconfig --add sshd
693 %service sshd reload "OpenSSH Daemon"
694 NORESTART=1
695 %systemd_post sshd.service
696
697 %preun server
698 if [ "$1" = "0" ]; then
699         %service sshd stop
700         /sbin/chkconfig --del sshd
701 fi
702 %systemd_preun sshd.service
703
704 %postun server
705 if [ "$1" = "0" ]; then
706         %userremove sshd
707 fi
708 %systemd_reload
709
710 %triggerpostun server -- %{name}-server < 6.2p1-1
711 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
712 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
713
714 %triggerpostun server -- %{name}-server < 2:5.9p1-8
715 # lpk.patch to ldap.patch
716 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
717         echo >&2 "Migrating LPK patch to LDAP patch"
718         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
719         %{__sed} -i -e '
720                 # disable old configs
721                 # just UseLPK/LkpLdapConf supported for now
722                 s/^\s*UseLPK/## Obsolete &/
723                 s/^\s*Lpk/## Obsolete &/
724                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
725                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
726         ' %{_sysconfdir}/sshd_config
727         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
728                 /bin/systemctl try-restart sshd.service || :
729         else
730                 %service -q sshd reload
731         fi
732 fi
733 %systemd_trigger sshd.service
734 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
735 %banner %{name}-server -e << EOF
736 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
737 ! Native systemd support for sshd has been installed.   !
738 ! Restarting sshd.service with systemctl WILL kill all  !
739 ! active ssh sessions (daemon as such will be started). !
740 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
741 EOF
742 fi
743
744 %post -n openldap-schema-openssh-lpk
745 %openldap_schema_register %{schemadir}/openssh-lpk.schema
746 %service -q ldap restart
747
748 %postun -n openldap-schema-openssh-lpk
749 if [ "$1" = "0" ]; then
750         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
751         %service -q ldap restart
752 fi
753
754 %files
755 %defattr(644,root,root,755)
756 %doc TODO README OVERVIEW CREDITS Change*
757 %attr(755,root,root) %{_bindir}/ssh-key*
758 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
759 %{_mandir}/man1/ssh-key*.1*
760 #%{_mandir}/man1/ssh-vulnkey*.1*
761 %dir %{_sysconfdir}
762 %dir %{_libexecdir}
763
764 %files clients
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_bindir}/ssh
767 %attr(755,root,root) %{_bindir}/slogin
768 %attr(755,root,root) %{_bindir}/sftp
769 %attr(755,root,root) %{_bindir}/ssh-agent
770 %attr(755,root,root) %{_bindir}/ssh-add
771 %attr(755,root,root) %{_bindir}/ssh-copy-id
772 %attr(755,root,root) %{_bindir}/scp
773 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
774 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
775 %{_mandir}/man1/scp.1*
776 %{_mandir}/man1/ssh.1*
777 %{_mandir}/man1/slogin.1*
778 %{_mandir}/man1/sftp.1*
779 %{_mandir}/man1/ssh-agent.1*
780 %{_mandir}/man1/ssh-add.1*
781 %{_mandir}/man1/ssh-copy-id.1*
782 %{_mandir}/man5/ssh_config.5*
783 %lang(it) %{_mandir}/it/man1/ssh.1*
784 %lang(it) %{_mandir}/it/man5/ssh_config.5*
785 %lang(pl) %{_mandir}/pl/man1/scp.1*
786 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
787
788 # for host-based auth (suid required for accessing private host key)
789 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
790 #%{_mandir}/man8/ssh-keysign.8*
791
792 %files clients-agent-profile_d
793 %defattr(644,root,root,755)
794 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
795 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
796
797 %files clients-agent-xinitrc
798 %defattr(644,root,root,755)
799 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
800
801 %files server
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_sbindir}/sshd
804 %attr(755,root,root) %{_libexecdir}/sftp-server
805 %attr(755,root,root) %{_libexecdir}/ssh-keysign
806 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
807 %attr(755,root,root) %{_libexecdir}/sshd-keygen
808 %{_mandir}/man8/sshd.8*
809 %{_mandir}/man8/sftp-server.8*
810 %{_mandir}/man8/ssh-keysign.8*
811 %{_mandir}/man8/ssh-pkcs11-helper.8*
812 %{_mandir}/man5/sshd_config.5*
813 %{_mandir}/man5/moduli.5*
814 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
815 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
816 %attr(640,root,root) %{_sysconfdir}/moduli
817 %attr(754,root,root) /etc/rc.d/init.d/sshd
818 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
819 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
820 %{systemdunitdir}/sshd.service
821 %{systemdunitdir}/sshd.socket
822 %{systemdunitdir}/sshd@.service
823
824 %if %{with ldap}
825 %files server-ldap
826 %defattr(644,root,root,755)
827 %doc HOWTO.ldap-keys ldap.conf
828 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
829 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
830 %{_mandir}/man5/ssh-ldap.conf.5*
831 %{_mandir}/man8/ssh-ldap-helper.8*
832 %endif
833
834 %if %{with gnome} || %{with gtk}
835 %files gnome-askpass
836 %defattr(644,root,root,755)
837 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
838 %dir %{_libexecdir}/ssh
839 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
840 %attr(755,root,root) %{_libexecdir}/ssh-askpass
841 %endif
842
843 %if %{with ldap}
844 %files -n openldap-schema-openssh-lpk
845 %defattr(644,root,root,755)
846 %{schemadir}/openssh-lpk.schema
847 %endif
This page took 0.114049 seconds and 4 git commands to generate.