]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- x32 rebuild
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15 %bcond_without  tests
16
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19
20 %if "%{pld_release}" == "ac"
21 %define         pam_ver 0.79.0
22 %else
23 %define         pam_ver 1:1.1.8-5
24 %endif
25 Summary:        OpenSSH free Secure Shell (SSH) implementation
26 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
27 Summary(es.UTF-8):      Implementación libre de SSH
28 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
29 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
30 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
31 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
32 Summary(pt_BR.UTF-8):   Implementação livre do SSH
33 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
34 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
35 Name:           openssh
36 Version:        6.7p1
37 Release:        5
38 Epoch:          2
39 License:        BSD
40 Group:          Applications/Networking
41 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
42 # Source0-md5:  3246aa79317b1d23cae783a3bf8275d6
43 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
44 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
45 Source2:        %{name}d.init
46 Source3:        %{name}d.pamd
47 Source4:        %{name}.sysconfig
48 Source5:        ssh-agent.sh
49 Source6:        ssh-agent.conf
50 Source7:        %{name}-lpk.schema
51 Source8:        %{name}d.upstart
52 Source9:        sshd.service
53 Source10:       sshd-keygen
54 Source11:       sshd.socket
55 Source12:       sshd@.service
56 Patch0:         %{name}-no_libnsl.patch
57 Patch2:         %{name}-pam_misc.patch
58 Patch3:         %{name}-sigpipe.patch
59 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
60 Patch4:         %{name}-ldap.patch
61 Patch5:         %{name}-ldap-fixes.patch
62 Patch6:         ldap.conf.patch
63 Patch7:         %{name}-config.patch
64 Patch8:         ldap-helper-sigpipe.patch
65 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
66 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
67 Patch9:         %{name}-5.2p1-hpn13v6.diff
68 Patch10:        %{name}-include.patch
69 Patch11:        %{name}-chroot.patch
70
71 Patch14:        %{name}-bind.patch
72 Patch15:        %{name}-disable_ldap.patch
73 URL:            http://www.openssh.com/portable.html
74 BuildRequires:  %{__perl}
75 %{?with_tests:BuildRequires:    %{name}-server}
76 %{?with_audit:BuildRequires:    audit-libs-devel}
77 BuildRequires:  autoconf >= 2.50
78 BuildRequires:  automake
79 %{?with_gnome:BuildRequires:    gnome-libs-devel}
80 %{?with_gtk:BuildRequires:      gtk+2-devel}
81 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
82 %{?with_libedit:BuildRequires:  libedit-devel}
83 %{?with_selinux:BuildRequires:  libselinux-devel}
84 %{?with_ldap:BuildRequires:     openldap-devel}
85 BuildRequires:  openssl-devel >= 0.9.8f
86 BuildRequires:  pam-devel
87 %{?with_gtk:BuildRequires:      pkgconfig}
88 BuildRequires:  rpm >= 4.4.9-56
89 BuildRequires:  rpmbuild(macros) >= 1.627
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  zlib-devel >= 1.2.3
92 Requires:       zlib >= 1.2.3
93 %if "%{pld_release}" == "ac"
94 Requires:       filesystem >= 2.0-1
95 Requires:       pam >= 0.79.0
96 %else
97 Requires:       filesystem >= 3.0-11
98 Requires:       pam >= %{pam_ver}
99 Suggests:       xorg-app-xauth
100 %endif
101 Obsoletes:      ssh
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _sysconfdir     /etc/ssh
105 %define         _libexecdir     %{_libdir}/%{name}
106 %define         _privsepdir     /usr/share/empty
107 %define         schemadir       /usr/share/openldap/schema
108
109 %description
110 Ssh (Secure Shell) a program for logging into a remote machine and for
111 executing commands in a remote machine. It is intended to replace
112 rlogin and rsh, and provide secure encrypted communications between
113 two untrusted hosts over an insecure network. X11 connections and
114 arbitrary TCP/IP ports can also be forwarded over the secure channel.
115
116 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
117 it up to date in terms of security and features, as well as removing
118 all patented algorithms to seperate libraries (OpenSSL).
119
120 This package includes the core files necessary for both the OpenSSH
121 client and server. To make this package useful, you should also
122 install openssh-clients, openssh-server, or both.
123
124 %if %{with hpn}
125 This release includes High Performance SSH/SCP patches from
126 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
127 increase throughput on fast connections with high RTT (20-150 msec).
128 See the website for '-w' values for your connection and /proc/sys TCP
129 values. BTW. in a LAN you have got generally RTT < 1 msec.
130 %endif
131
132 %description -l de.UTF-8
133 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
134 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
135 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
136 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
137 andere TCP/IP Ports können ebenso über den sicheren Channel
138 weitergeleitet werden.
139
140 %description -l es.UTF-8
141 SSH es un programa para accesar y ejecutar órdenes en computadores
142 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
143 seguro entre dos servidores en una red insegura. Conexiones X11 y
144 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
145 seguro.
146
147 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
148 continuar la última versión gratuita de SSH, actualizándolo en
149 términos de seguridad y recursos,así también eliminando todos los
150 algoritmos patentados y colocándolos en bibliotecas separadas
151 (OpenSSL).
152
153 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
154 también el paquete openssh-clients u openssh-server o ambos.
155
156 %description -l fr.UTF-8
157 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
158 remplace telnet, rlogin, rexec et rsh, tout en assurant des
159 communications cryptées securisées entre deux hôtes non fiabilisés sur
160 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
161 arbitraires peuvent également être transmis sur le canal sécurisé.
162
163 %description -l it.UTF-8
164 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
165 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
166 sicure e crittate tra due host non fidati su una rete non sicura. Le
167 connessioni X11 ad una porta TCP/IP arbitraria possono essere
168 inoltrate attraverso un canale sicuro.
169
170 %description -l pl.UTF-8
171 Ssh (Secure Shell) to program służący do logowania się na zdalną
172 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
173 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
174 pomiędzy dwoma hostami.
175
176 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
177 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
178 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
179
180 %if %{with hpn}
181 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
182 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
183 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
184 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
185 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
186 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
187 %endif
188
189 %description -l pt.UTF-8
190 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
191 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
192 cifradas entre duas máquinas sem confiança mútua sobre uma rede
193 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
194 reenviados pelo canal seguro.
195
196 %description -l pt_BR.UTF-8
197 SSH é um programa para acessar e executar comandos em máquinas
198 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
199 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
200 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
201
202 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
203 última versão gratuita do SSH, atualizando-o em termos de segurança e
204 recursos, assim como removendo todos os algoritmos patenteados e
205 colocando-os em bibliotecas separadas (OpenSSL).
206
207 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
208 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
209
210 %description -l ru.UTF-8
211 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
212 машину и для выполнения команд на удаленной машине. Она предназначена
213 для замены rlogin и rsh и обеспечивает безопасную шифрованную
214 коммуникацию между двумя хостами в сети, являющейся небезопасной.
215 Соединения X11 и любые порты TCP/IP могут также быть проведены через
216 безопасный канал.
217
218 OpenSSH - это переделка командой разработчиков OpenBSD последней
219 свободной версии SSH, доведенная до современного состояния в терминах
220 уровня безопасности и поддерживаемых возможностей. Все патентованные
221 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
222
223 Этот пакет содержит файлы, необходимые как для клиента, так и для
224 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
225 openssh-server, или оба пакета.
226
227 %description -l uk.UTF-8
228 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
229 машини та для виконання команд на віддаленій машині. Вона призначена
230 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
231 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
232 довільні порти TCP/IP можуть також бути проведені через безпечний
233 канал.
234
235 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
236 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
237 підтримуваних можливостей. Всі патентовані алгоритми винесені до
238 окремих бібліотек (OpenSSL).
239
240 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
241 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
242 openssh-server, чи обидва пакети.
243
244 %package clients
245 Summary:        OpenSSH Secure Shell protocol clients
246 Summary(es.UTF-8):      Clientes de OpenSSH
247 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
248 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
249 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
250 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
251 Group:          Applications/Networking
252 Requires:       %{name}
253 Provides:       ssh-clients
254 Obsoletes:      ssh-clients
255 %requires_eq_to openssl openssl-devel
256
257 %description clients
258 Ssh (Secure Shell) a program for logging into a remote machine and for
259 executing commands in a remote machine. It is intended to replace
260 rlogin and rsh, and provide secure encrypted communications between
261 two untrusted hosts over an insecure network. X11 connections and
262 arbitrary TCP/IP ports can also be forwarded over the secure channel.
263
264 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
265 it up to date in terms of security and features, as well as removing
266 all patented algorithms to seperate libraries (OpenSSL).
267
268 This package includes the clients necessary to make encrypted
269 connections to SSH servers.
270
271 %description clients -l es.UTF-8
272 Este paquete incluye los clientes que se necesitan para hacer
273 conexiones codificadas con servidores SSH.
274
275 %description clients -l pl.UTF-8
276 Ssh (Secure Shell) to program służący do logowania się na zdalną
277 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
278 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
279 pomiędzy dwoma hostami.
280
281 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
282
283 %description clients -l pt_BR.UTF-8
284 Esse pacote inclui os clientes necessários para fazer conexões
285 encriptadas com servidores SSH.
286
287 %description clients -l ru.UTF-8
288 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
289 машину и для выполнения команд на удаленной машине.
290
291 Этот пакет содержит программы-клиенты, необходимые для установления
292 зашифрованных соединений с серверами SSH.
293
294 %description clients -l uk.UTF-8
295 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
296 машини та для виконання команд на віддаленій машині.
297
298 Цей пакет містить програми-клієнти, необхідні для встановлення
299 зашифрованих з'єднань з серверами SSH.
300
301 %package clients-agent-profile_d
302 Summary:        OpenSSH Secure Shell agent init script
303 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
304 Group:          Applications/Networking
305 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
306
307 %description clients-agent-profile_d
308 profile.d scripts for starting SSH agent.
309
310 %description clients-agent-profile_d -l pl.UTF-8
311 Skrypty profile.d do uruchamiania agenta SSH.
312
313 %package clients-agent-xinitrc
314 Summary:        OpenSSH Secure Shell agent init script
315 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
316 Group:          Applications/Networking
317 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
318 Requires:       xinitrc
319
320 %description clients-agent-xinitrc
321 xinitrc scripts for starting SSH agent.
322
323 %description clients-agent-xinitrc -l pl.UTF-8
324 Skrypty xinitrc do uruchamiania agenta SSH.
325
326 %package server
327 Summary:        OpenSSH Secure Shell protocol server (sshd)
328 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
329 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
330 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
331 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
332 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
333 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
334 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
335 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
336 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
337 Group:          Networking/Daemons
338 Requires(post): /sbin/chkconfig
339 Requires(post): grep
340 Requires(post,preun):   /sbin/chkconfig
341 Requires(postun):       /usr/sbin/userdel
342 Requires(pre):  /bin/id
343 Requires(pre):  /usr/sbin/useradd
344 Requires(post,preun,postun):    systemd-units >= 38
345 Requires:       %{name} = %{epoch}:%{version}-%{release}
346 Requires:       pam >= %{pam_ver}
347 Requires:       rc-scripts >= 0.4.3.0
348 Requires:       systemd-units >= 38
349 Requires:       util-linux
350 %{?with_ldap:Suggests:  %{name}-server-ldap}
351 Suggests:       /bin/login
352 Suggests:       xorg-app-xauth
353 Provides:       ssh-server
354 Provides:       user(sshd)
355 %requires_eq_to openssl openssl-devel
356
357 %description server
358 Ssh (Secure Shell) a program for logging into a remote machine and for
359 executing commands in a remote machine. It is intended to replace
360 rlogin and rsh, and provide secure encrypted communications between
361 two untrusted hosts over an insecure network. X11 connections and
362 arbitrary TCP/IP ports can also be forwarded over the secure channel.
363
364 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
365 it up to date in terms of security and features, as well as removing
366 all patented algorithms to seperate libraries (OpenSSL).
367
368 This package contains the secure shell daemon. The sshd is the server
369 part of the secure shell protocol and allows ssh clients to connect to
370 your host.
371
372 %description server -l de.UTF-8
373 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
374
375 %description server -l es.UTF-8
376 Este paquete contiene el servidor SSH. sshd es la parte servidor del
377 protocolo secure shell y permite que clientes ssh se conecten a su
378 servidor.
379
380 %description server -l fr.UTF-8
381 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
382
383 %description server -l it.UTF-8
384 Questo pacchetto installa sshd, il server di OpenSSH.
385
386 %description server -l pl.UTF-8
387 Ssh (Secure Shell) to program służący do logowania się na zdalną
388 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
389 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
390 pomiędzy dwoma hostami.
391
392 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
393 ssh).
394
395 %description server -l pt.UTF-8
396 Este pacote intala o sshd, o servidor do OpenSSH.
397
398 %description server -l pt_BR.UTF-8
399 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
400 protocolo secure shell e permite que clientes ssh se conectem ao seu
401 host.
402
403 %description server -l ru.UTF-8
404 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
405 машину и для выполнения команд на удаленной машине.
406
407 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
408 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
409 вашим хостом.
410
411 %description server -l uk.UTF-8
412 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
413 машини та для виконання команд на віддаленій машині.
414
415 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
416 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
417 з вашим хостом.
418
419 %package server-ldap
420 Summary:        A LDAP support for open source SSH server daemon
421 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
422 Group:          Daemons
423 Requires:       %{name} = %{epoch}:%{version}-%{release}
424 Requires:       openldap-nss-config
425
426 %description server-ldap
427 OpenSSH LDAP backend is a way how to distribute the authorized tokens
428 among the servers in the network.
429
430 %description server-ldap -l pl.UTF-8
431 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
432 tokenów między serwerami w sieci.
433
434 %package server-upstart
435 Summary:        Upstart job description for OpenSSH server
436 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
437 Group:          Daemons
438 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
439 Requires:       upstart >= 0.6
440 Conflicts:      syslog-ng < 3.2.4-1
441
442 %description server-upstart
443 Upstart job description for OpenSSH.
444
445 %description server-upstart -l pl.UTF-8
446 Opis zadania Upstart dla OpenSSH.
447
448 %package gnome-askpass
449 Summary:        OpenSSH GNOME passphrase dialog
450 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
451 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
452 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
453 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
454 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
455 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
456 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
457 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
458 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
459 Group:          Applications/Networking
460 Requires:       %{name} = %{epoch}:%{version}-%{release}
461 Obsoletes:      openssh-askpass
462 Obsoletes:      ssh-askpass
463 Obsoletes:      ssh-extras
464
465 %description gnome-askpass
466 Ssh (Secure Shell) a program for logging into a remote machine and for
467 executing commands in a remote machine. It is intended to replace
468 rlogin and rsh, and provide secure encrypted communications between
469 two untrusted hosts over an insecure network. X11 connections and
470 arbitrary TCP/IP ports can also be forwarded over the secure channel.
471
472 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
473 it up to date in terms of security and features, as well as removing
474 all patented algorithms to seperate libraries (OpenSSL).
475
476 This package contains the GNOME passphrase dialog.
477
478 %description gnome-askpass -l es.UTF-8
479 Este paquete contiene un programa que abre una caja de diálogo para
480 entrada de passphrase en GNOME.
481
482 %description gnome-askpass -l pl.UTF-8
483 Ssh (Secure Shell) to program służący do logowania się na zdalną
484 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
485 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
486 pomiędzy dwoma hostami.
487
488 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
489
490 %description gnome-askpass -l pt_BR.UTF-8
491 Esse pacote contém um programa que abre uma caixa de diálogo para
492 entrada de passphrase no GNOME.
493
494 %description gnome-askpass -l ru.UTF-8
495 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
496 машину и для выполнения команд на удаленной машине.
497
498 Этот пакет содержит диалог ввода ключевой фразы для использования под
499 GNOME.
500
501 %description gnome-askpass -l uk.UTF-8
502 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
503 машини та для виконання команд на віддаленій машині.
504
505 Цей пакет містить діалог вводу ключової фрази для використання під
506 GNOME.
507
508 %package -n openldap-schema-openssh-lpk
509 Summary:        OpenSSH LDAP Public Key schema
510 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
511 Group:          Networking/Daemons
512 Requires(post,postun):  sed >= 4.0
513 Requires:       openldap-servers
514 %if "%{_rpmversion}" >= "5"
515 BuildArch:      noarch
516 %endif
517
518 %description -n openldap-schema-openssh-lpk
519 This package contains OpenSSH LDAP Public Key schema for openldap.
520
521 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
522 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
523 openldap-a.
524
525 %prep
526 %setup -q
527 %patch0 -p1
528 %patch2 -p1
529 %patch3 -p1
530 %patch4 -p1
531 %patch5 -p1
532 %patch6 -p1
533 %patch7 -p1
534 %patch8 -p1
535
536 %{?with_hpn:%patch9 -p1}
537 %patch10 -p1
538 %patch11 -p1
539
540 %patch14 -p1
541 %{!?with_ldap:%patch15 -p1}
542
543 %if "%{pld_release}" == "ac"
544 # fix for missing x11.pc
545 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
546 %endif
547
548 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
549 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
550
551 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
552 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
553
554 %build
555 cp /usr/share/automake/config.sub .
556 %{__aclocal}
557 %{__autoconf}
558 %{__autoheader}
559 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
560 %configure \
561         PERL=%{__perl} \
562         --disable-strip \
563         --enable-utmpx \
564         --enable-wtmpx \
565         --with-4in6 \
566         %{?with_audit:--with-audit=linux} \
567         --with-ipaddr-display \
568         %{?with_kerberos5:--with-kerberos5=/usr} \
569         --with-ldap%{!?with_ldap:=no} \
570         %{?with_libedit:--with-libedit} \
571         --with-mantype=man \
572         --with-md5-passwords \
573         --with-pam \
574         --with-pid-dir=%{_localstatedir}/run \
575         --with-privsep-path=%{_privsepdir} \
576 %if "%{pld_release}" != "ac"
577         --with-sandbox=seccomp_filter \
578 %endif
579         %{?with_selinux:--with-selinux} \
580 %if "%{pld_release}" == "ac"
581         --with-xauth=/usr/X11R6/bin/xauth
582 %else
583         --with-xauth=%{_bindir}/xauth
584 %endif
585
586 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
587
588 %{__make}
589
590 %{?with_tests:%{__make} tests}
591
592 cd contrib
593 %if %{with gnome}
594 %{__make} gnome-ssh-askpass1 \
595         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
596 %endif
597 %if %{with gtk}
598 %{__make} gnome-ssh-askpass2 \
599         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
600 %endif
601
602 %install
603 rm -rf $RPM_BUILD_ROOT
604 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
605         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
606 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
607
608 %{__make} install \
609         DESTDIR=$RPM_BUILD_ROOT
610
611 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
612
613 cp -p %{SOURCE3} sshd.pam
614 install -p %{SOURCE2} sshd.init
615
616 %if "%{pld_release}" == "ac"
617 # not present in ac, no point searching it
618 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
619 # openssl on ac does not have OPENSSL_HAS_ECC
620 %{__sed} -i -e '/ecdsa/d' sshd.init
621 %endif
622
623 %if %{without audit}
624 # remove recording user's login uid to the process attribute
625 %{__sed} -i -e '/pam_loginuid.so/d' sshd.pam
626 %endif
627
628 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
629 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
630 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
631 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
632 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
633 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
634 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
635 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
636
637 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
638 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
639
640 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
641 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
642
643 %if %{with gnome}
644 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
645 %endif
646 %if %{with gtk}
647 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
648 %endif
649 %if %{with gnome} || %{with gtk}
650 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
651 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
652 EOF
653 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
654 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
655 EOF
656 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
657 %endif
658
659 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
660 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
661
662 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
663 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
664
665 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
666
667 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
668 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
669 EOF
670
671 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
672 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
673
674 %clean
675 rm -rf $RPM_BUILD_ROOT
676
677 %post clients
678 %env_update
679
680 %postun clients
681 %env_update
682
683 %post gnome-askpass
684 %env_update
685
686 %postun gnome-askpass
687 %env_update
688
689 %pre server
690 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
691
692 %post server
693 /sbin/chkconfig --add sshd
694 %service sshd reload "OpenSSH Daemon"
695 NORESTART=1
696 %systemd_post sshd.service
697
698 %preun server
699 if [ "$1" = "0" ]; then
700         %service sshd stop
701         /sbin/chkconfig --del sshd
702 fi
703 %systemd_preun sshd.service
704
705 %postun server
706 if [ "$1" = "0" ]; then
707         %userremove sshd
708 fi
709 %systemd_reload
710
711 %triggerpostun server -- %{name}-server < 6.2p1-1
712 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
713 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
714
715 %triggerpostun server -- %{name}-server < 2:5.9p1-8
716 # lpk.patch to ldap.patch
717 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
718         echo >&2 "Migrating LPK patch to LDAP patch"
719         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
720         %{__sed} -i -e '
721                 # disable old configs
722                 # just UseLPK/LkpLdapConf supported for now
723                 s/^\s*UseLPK/## Obsolete &/
724                 s/^\s*Lpk/## Obsolete &/
725                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
726                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
727         ' %{_sysconfdir}/sshd_config
728         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
729                 /bin/systemctl try-restart sshd.service || :
730         else
731                 %service -q sshd reload
732         fi
733 fi
734 %systemd_trigger sshd.service
735 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
736 %banner %{name}-server -e << EOF
737 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
738 ! Native systemd support for sshd has been installed.   !
739 ! Restarting sshd.service with systemctl WILL kill all  !
740 ! active ssh sessions (daemon as such will be started). !
741 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
742 EOF
743 fi
744
745 %post server-upstart
746 %upstart_post sshd
747
748 %postun server-upstart
749 %upstart_postun sshd
750
751 %post -n openldap-schema-openssh-lpk
752 %openldap_schema_register %{schemadir}/openssh-lpk.schema
753 %service -q ldap restart
754
755 %postun -n openldap-schema-openssh-lpk
756 if [ "$1" = "0" ]; then
757         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
758         %service -q ldap restart
759 fi
760
761 %files
762 %defattr(644,root,root,755)
763 %doc TODO README OVERVIEW CREDITS Change*
764 %attr(755,root,root) %{_bindir}/ssh-key*
765 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
766 %{_mandir}/man1/ssh-key*.1*
767 #%{_mandir}/man1/ssh-vulnkey*.1*
768 %dir %{_sysconfdir}
769 %dir %{_libexecdir}
770
771 %files clients
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_bindir}/ssh
774 %attr(755,root,root) %{_bindir}/slogin
775 %attr(755,root,root) %{_bindir}/sftp
776 %attr(755,root,root) %{_bindir}/ssh-agent
777 %attr(755,root,root) %{_bindir}/ssh-add
778 %attr(755,root,root) %{_bindir}/ssh-copy-id
779 %attr(755,root,root) %{_bindir}/scp
780 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
781 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
782 %{_mandir}/man1/scp.1*
783 %{_mandir}/man1/ssh.1*
784 %{_mandir}/man1/slogin.1*
785 %{_mandir}/man1/sftp.1*
786 %{_mandir}/man1/ssh-agent.1*
787 %{_mandir}/man1/ssh-add.1*
788 %{_mandir}/man1/ssh-copy-id.1*
789 %{_mandir}/man5/ssh_config.5*
790 %lang(it) %{_mandir}/it/man1/ssh.1*
791 %lang(it) %{_mandir}/it/man5/ssh_config.5*
792 %lang(pl) %{_mandir}/pl/man1/scp.1*
793 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
794
795 # for host-based auth (suid required for accessing private host key)
796 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
797 #%{_mandir}/man8/ssh-keysign.8*
798
799 %files clients-agent-profile_d
800 %defattr(644,root,root,755)
801 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
802 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
803
804 %files clients-agent-xinitrc
805 %defattr(644,root,root,755)
806 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
807
808 %files server
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_sbindir}/sshd
811 %attr(755,root,root) %{_libexecdir}/sftp-server
812 %attr(755,root,root) %{_libexecdir}/ssh-keysign
813 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
814 %attr(755,root,root) %{_libexecdir}/sshd-keygen
815 %{_mandir}/man8/sshd.8*
816 %{_mandir}/man8/sftp-server.8*
817 %{_mandir}/man8/ssh-keysign.8*
818 %{_mandir}/man8/ssh-pkcs11-helper.8*
819 %{_mandir}/man5/sshd_config.5*
820 %{_mandir}/man5/moduli.5*
821 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
822 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
823 %attr(640,root,root) %{_sysconfdir}/moduli
824 %attr(754,root,root) /etc/rc.d/init.d/sshd
825 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
826 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
827 %{systemdunitdir}/sshd.service
828 %{systemdunitdir}/sshd.socket
829 %{systemdunitdir}/sshd@.service
830
831 %if %{with ldap}
832 %files server-ldap
833 %defattr(644,root,root,755)
834 %doc HOWTO.ldap-keys ldap.conf
835 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
836 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
837 %{_mandir}/man5/ssh-ldap.conf.5*
838 %{_mandir}/man8/ssh-ldap-helper.8*
839 %endif
840
841 %if %{with gnome} || %{with gtk}
842 %files gnome-askpass
843 %defattr(644,root,root,755)
844 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
845 %dir %{_libexecdir}/ssh
846 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
847 %attr(755,root,root) %{_libexecdir}/ssh-askpass
848 %endif
849
850 %if %{with ldap}
851 %files -n openldap-schema-openssh-lpk
852 %defattr(644,root,root,755)
853 %{schemadir}/openssh-lpk.schema
854 %endif
855
856 %if "%{pld_release}" != "ti"
857 %files server-upstart
858 %defattr(644,root,root,755)
859 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
860 %endif
This page took 0.117068 seconds and 4 git commands to generate.