]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
sshd-keygen: do not exit as failure if restorecon is missing
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_without  libseccomp      # use libseccomp for seccomp privsep (requires 3.5 kernel)
15 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
16 %bcond_without  tests
17
18 # gtk2-based gnome-askpass means no gnome1-based
19 %{?with_gtk:%undefine with_gnome}
20
21 %ifnarch x32
22 # libseccomp requires 3.5 kernel, avoid such requirement where possible (non-x32 arches)
23 %undefine       with_libseccomp
24 %endif
25
26 %define sandbox %{?with_libseccomp:lib}seccomp_filter
27
28 %ifarch x32
29 %{!?with_libseccomp:%error openssh seccomp implementation is broken! do not disable libseccomp on x32}
30 %endif
31
32 %if "%{pld_release}" == "ac"
33 %define         pam_ver 0.79.0
34 %else
35 %define         pam_ver 1:1.1.8-5
36 %endif
37 Summary:        OpenSSH free Secure Shell (SSH) implementation
38 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
39 Summary(es.UTF-8):      Implementación libre de SSH
40 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
41 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
42 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
43 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
44 Summary(pt_BR.UTF-8):   Implementação livre do SSH
45 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
46 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
47 Name:           openssh
48 Version:        7.2p2
49 Release:        2
50 Epoch:          2
51 License:        BSD
52 Group:          Applications/Networking
53 Source0:        http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
54 # Source0-md5:  13009a9156510d8f27e752659075cced
55 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
57 Source2:        %{name}d.init
58 Source3:        %{name}d.pamd
59 Source4:        %{name}.sysconfig
60 Source5:        ssh-agent.sh
61 Source6:        ssh-agent.conf
62 Source7:        %{name}-lpk.schema
63 Source9:        sshd.service
64 Source10:       sshd-keygen
65 Source11:       sshd.socket
66 Source12:       sshd@.service
67 Patch1:         %{name}-tests-reuseport.patch
68 Patch2:         %{name}-pam_misc.patch
69 Patch3:         %{name}-sigpipe.patch
70 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
71 Patch4:         %{name}-ldap.patch
72 Patch5:         %{name}-ldap-fixes.patch
73 Patch6:         ldap.conf.patch
74 Patch7:         %{name}-config.patch
75 Patch8:         ldap-helper-sigpipe.patch
76 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
77 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
78 Patch9:         %{name}-5.2p1-hpn13v6.diff
79 Patch10:        %{name}-include.patch
80 Patch11:        %{name}-chroot.patch
81 Patch14:        %{name}-bind.patch
82 Patch15:        %{name}-disable_ldap.patch
83 Patch16:        libseccomp-sandbox.patch
84 URL:            http://www.openssh.com/portable.html
85 BuildRequires:  %{__perl}
86 %{?with_audit:BuildRequires:    audit-libs-devel}
87 BuildRequires:  autoconf >= 2.50
88 BuildRequires:  automake
89 %{?with_gnome:BuildRequires:    gnome-libs-devel}
90 %{?with_gtk:BuildRequires:      gtk+2-devel}
91 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
92 %{?with_libedit:BuildRequires:  libedit-devel}
93 BuildRequires:  libseccomp-devel
94 %{?with_selinux:BuildRequires:  libselinux-devel}
95 %{?with_ldap:BuildRequires:     openldap-devel}
96 BuildRequires:  openssl-devel >= 0.9.8f
97 BuildRequires:  pam-devel
98 %{?with_gtk:BuildRequires:      pkgconfig}
99 BuildRequires:  rpm >= 4.4.9-56
100 BuildRequires:  rpmbuild(macros) >= 1.627
101 BuildRequires:  sed >= 4.0
102 BuildRequires:  zlib-devel >= 1.2.3
103 %if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
104 BuildRequires:  %{name}-server
105 %endif
106 %if %{with tests} && %{with libseccomp}
107 # libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
108 BuildRequires:  uname(release) >= 3.5
109 %endif
110 Requires:       zlib >= 1.2.3
111 %if "%{pld_release}" == "ac"
112 Requires:       filesystem >= 2.0-1
113 Requires:       pam >= 0.79.0
114 %else
115 Requires:       filesystem >= 3.0-11
116 Requires:       pam >= %{pam_ver}
117 Suggests:       xorg-app-xauth
118 %endif
119 Obsoletes:      ssh
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         _sysconfdir     /etc/ssh
123 %define         _libexecdir     %{_libdir}/%{name}
124 %define         _privsepdir     /usr/share/empty
125 %define         schemadir       /usr/share/openldap/schema
126
127 %description
128 Ssh (Secure Shell) a program for logging into a remote machine and for
129 executing commands in a remote machine. It is intended to replace
130 rlogin and rsh, and provide secure encrypted communications between
131 two untrusted hosts over an insecure network. X11 connections and
132 arbitrary TCP/IP ports can also be forwarded over the secure channel.
133
134 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
135 it up to date in terms of security and features, as well as removing
136 all patented algorithms to seperate libraries (OpenSSL).
137
138 This package includes the core files necessary for both the OpenSSH
139 client and server. To make this package useful, you should also
140 install openssh-clients, openssh-server, or both.
141
142 %if %{with hpn}
143 This release includes High Performance SSH/SCP patches from
144 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
145 increase throughput on fast connections with high RTT (20-150 msec).
146 See the website for '-w' values for your connection and /proc/sys TCP
147 values. BTW. in a LAN you have got generally RTT < 1 msec.
148 %endif
149
150 %description -l de.UTF-8
151 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
152 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
153 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
154 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
155 andere TCP/IP Ports können ebenso über den sicheren Channel
156 weitergeleitet werden.
157
158 %description -l es.UTF-8
159 SSH es un programa para accesar y ejecutar órdenes en computadores
160 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
161 seguro entre dos servidores en una red insegura. Conexiones X11 y
162 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
163 seguro.
164
165 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
166 continuar la última versión gratuita de SSH, actualizándolo en
167 términos de seguridad y recursos,así también eliminando todos los
168 algoritmos patentados y colocándolos en bibliotecas separadas
169 (OpenSSL).
170
171 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
172 también el paquete openssh-clients u openssh-server o ambos.
173
174 %description -l fr.UTF-8
175 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
176 remplace telnet, rlogin, rexec et rsh, tout en assurant des
177 communications cryptées securisées entre deux hôtes non fiabilisés sur
178 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
179 arbitraires peuvent également être transmis sur le canal sécurisé.
180
181 %description -l it.UTF-8
182 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
183 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
184 sicure e crittate tra due host non fidati su una rete non sicura. Le
185 connessioni X11 ad una porta TCP/IP arbitraria possono essere
186 inoltrate attraverso un canale sicuro.
187
188 %description -l pl.UTF-8
189 Ssh (Secure Shell) to program służący do logowania się na zdalną
190 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
191 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
192 pomiędzy dwoma hostami.
193
194 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
195 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
196 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
197
198 %if %{with hpn}
199 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
200 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
201 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
202 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
203 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
204 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
205 %endif
206
207 %description -l pt.UTF-8
208 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
209 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
210 cifradas entre duas máquinas sem confiança mútua sobre uma rede
211 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
212 reenviados pelo canal seguro.
213
214 %description -l pt_BR.UTF-8
215 SSH é um programa para acessar e executar comandos em máquinas
216 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
217 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
218 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
219
220 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
221 última versão gratuita do SSH, atualizando-o em termos de segurança e
222 recursos, assim como removendo todos os algoritmos patenteados e
223 colocando-os em bibliotecas separadas (OpenSSL).
224
225 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
226 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
227
228 %description -l ru.UTF-8
229 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
230 машину и для выполнения команд на удаленной машине. Она предназначена
231 для замены rlogin и rsh и обеспечивает безопасную шифрованную
232 коммуникацию между двумя хостами в сети, являющейся небезопасной.
233 Соединения X11 и любые порты TCP/IP могут также быть проведены через
234 безопасный канал.
235
236 OpenSSH - это переделка командой разработчиков OpenBSD последней
237 свободной версии SSH, доведенная до современного состояния в терминах
238 уровня безопасности и поддерживаемых возможностей. Все патентованные
239 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
240
241 Этот пакет содержит файлы, необходимые как для клиента, так и для
242 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
243 openssh-server, или оба пакета.
244
245 %description -l uk.UTF-8
246 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
247 машини та для виконання команд на віддаленій машині. Вона призначена
248 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
249 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
250 довільні порти TCP/IP можуть також бути проведені через безпечний
251 канал.
252
253 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
254 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
255 підтримуваних можливостей. Всі патентовані алгоритми винесені до
256 окремих бібліотек (OpenSSL).
257
258 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
259 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
260 openssh-server, чи обидва пакети.
261
262 %package clients
263 Summary:        OpenSSH Secure Shell protocol clients
264 Summary(es.UTF-8):      Clientes de OpenSSH
265 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
266 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
267 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
268 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
269 Group:          Applications/Networking
270 Requires:       %{name}
271 Provides:       ssh-clients
272 Obsoletes:      ssh-clients
273 %requires_eq_to openssl openssl-devel
274
275 %description clients
276 Ssh (Secure Shell) a program for logging into a remote machine and for
277 executing commands in a remote machine. It is intended to replace
278 rlogin and rsh, and provide secure encrypted communications between
279 two untrusted hosts over an insecure network. X11 connections and
280 arbitrary TCP/IP ports can also be forwarded over the secure channel.
281
282 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
283 it up to date in terms of security and features, as well as removing
284 all patented algorithms to seperate libraries (OpenSSL).
285
286 This package includes the clients necessary to make encrypted
287 connections to SSH servers.
288
289 %description clients -l es.UTF-8
290 Este paquete incluye los clientes que se necesitan para hacer
291 conexiones codificadas con servidores SSH.
292
293 %description clients -l pl.UTF-8
294 Ssh (Secure Shell) to program służący do logowania się na zdalną
295 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
296 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
297 pomiędzy dwoma hostami.
298
299 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
300
301 %description clients -l pt_BR.UTF-8
302 Esse pacote inclui os clientes necessários para fazer conexões
303 encriptadas com servidores SSH.
304
305 %description clients -l ru.UTF-8
306 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
307 машину и для выполнения команд на удаленной машине.
308
309 Этот пакет содержит программы-клиенты, необходимые для установления
310 зашифрованных соединений с серверами SSH.
311
312 %description clients -l uk.UTF-8
313 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
314 машини та для виконання команд на віддаленій машині.
315
316 Цей пакет містить програми-клієнти, необхідні для встановлення
317 зашифрованих з'єднань з серверами SSH.
318
319 %package clients-agent-profile_d
320 Summary:        OpenSSH Secure Shell agent init script
321 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
322 Group:          Applications/Networking
323 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
324
325 %description clients-agent-profile_d
326 profile.d scripts for starting SSH agent.
327
328 %description clients-agent-profile_d -l pl.UTF-8
329 Skrypty profile.d do uruchamiania agenta SSH.
330
331 %package clients-agent-xinitrc
332 Summary:        OpenSSH Secure Shell agent init script
333 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
334 Group:          Applications/Networking
335 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
336 Requires:       xinitrc
337
338 %description clients-agent-xinitrc
339 xinitrc scripts for starting SSH agent.
340
341 %description clients-agent-xinitrc -l pl.UTF-8
342 Skrypty xinitrc do uruchamiania agenta SSH.
343
344 %package server
345 Summary:        OpenSSH Secure Shell protocol server (sshd)
346 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
347 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
348 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
349 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
350 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
351 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
352 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
353 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
354 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
355 Group:          Networking/Daemons
356 Requires(post): /sbin/chkconfig
357 Requires(post): grep
358 Requires(post,preun):   /sbin/chkconfig
359 Requires(postun):       /usr/sbin/userdel
360 Requires(pre):  /bin/id
361 Requires(pre):  /usr/sbin/useradd
362 Requires(post,preun,postun):    systemd-units >= 38
363 Requires:       %{name} = %{epoch}:%{version}-%{release}
364 Requires:       pam >= %{pam_ver}
365 Requires:       rc-scripts >= 0.4.3.0
366 Requires:       systemd-units >= 38
367 %{?with_libseccomp:Requires:    uname(release) >= 3.5}
368 Requires:       util-linux
369 %{?with_ldap:Suggests:  %{name}-server-ldap}
370 Suggests:       /bin/login
371 Suggests:       xorg-app-xauth
372 Provides:       ssh-server
373 Provides:       user(sshd)
374 %requires_eq_to openssl openssl-devel
375
376 %description server
377 Ssh (Secure Shell) a program for logging into a remote machine and for
378 executing commands in a remote machine. It is intended to replace
379 rlogin and rsh, and provide secure encrypted communications between
380 two untrusted hosts over an insecure network. X11 connections and
381 arbitrary TCP/IP ports can also be forwarded over the secure channel.
382
383 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
384 it up to date in terms of security and features, as well as removing
385 all patented algorithms to seperate libraries (OpenSSL).
386
387 This package contains the secure shell daemon. The sshd is the server
388 part of the secure shell protocol and allows ssh clients to connect to
389 your host.
390
391 %description server -l de.UTF-8
392 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
393
394 %description server -l es.UTF-8
395 Este paquete contiene el servidor SSH. sshd es la parte servidor del
396 protocolo secure shell y permite que clientes ssh se conecten a su
397 servidor.
398
399 %description server -l fr.UTF-8
400 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
401
402 %description server -l it.UTF-8
403 Questo pacchetto installa sshd, il server di OpenSSH.
404
405 %description server -l pl.UTF-8
406 Ssh (Secure Shell) to program służący do logowania się na zdalną
407 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
408 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
409 pomiędzy dwoma hostami.
410
411 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
412 ssh).
413
414 %description server -l pt.UTF-8
415 Este pacote intala o sshd, o servidor do OpenSSH.
416
417 %description server -l pt_BR.UTF-8
418 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
419 protocolo secure shell e permite que clientes ssh se conectem ao seu
420 host.
421
422 %description server -l ru.UTF-8
423 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
424 машину и для выполнения команд на удаленной машине.
425
426 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
427 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
428 вашим хостом.
429
430 %description server -l uk.UTF-8
431 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
432 машини та для виконання команд на віддаленій машині.
433
434 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
435 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
436 з вашим хостом.
437
438 %package server-ldap
439 Summary:        A LDAP support for open source SSH server daemon
440 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
441 Group:          Daemons
442 Requires:       %{name} = %{epoch}:%{version}-%{release}
443 Requires:       openldap-nss-config
444
445 %description server-ldap
446 OpenSSH LDAP backend is a way how to distribute the authorized tokens
447 among the servers in the network.
448
449 %description server-ldap -l pl.UTF-8
450 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
451 tokenów między serwerami w sieci.
452
453 %package gnome-askpass
454 Summary:        OpenSSH GNOME passphrase dialog
455 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
456 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
457 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
458 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
459 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
460 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
461 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
462 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
463 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
464 Group:          Applications/Networking
465 Requires:       %{name} = %{epoch}:%{version}-%{release}
466 Obsoletes:      openssh-askpass
467 Obsoletes:      ssh-askpass
468 Obsoletes:      ssh-extras
469
470 %description gnome-askpass
471 Ssh (Secure Shell) a program for logging into a remote machine and for
472 executing commands in a remote machine. It is intended to replace
473 rlogin and rsh, and provide secure encrypted communications between
474 two untrusted hosts over an insecure network. X11 connections and
475 arbitrary TCP/IP ports can also be forwarded over the secure channel.
476
477 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
478 it up to date in terms of security and features, as well as removing
479 all patented algorithms to seperate libraries (OpenSSL).
480
481 This package contains the GNOME passphrase dialog.
482
483 %description gnome-askpass -l es.UTF-8
484 Este paquete contiene un programa que abre una caja de diálogo para
485 entrada de passphrase en GNOME.
486
487 %description gnome-askpass -l pl.UTF-8
488 Ssh (Secure Shell) to program służący do logowania się na zdalną
489 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
490 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
491 pomiędzy dwoma hostami.
492
493 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
494
495 %description gnome-askpass -l pt_BR.UTF-8
496 Esse pacote contém um programa que abre uma caixa de diálogo para
497 entrada de passphrase no GNOME.
498
499 %description gnome-askpass -l ru.UTF-8
500 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
501 машину и для выполнения команд на удаленной машине.
502
503 Этот пакет содержит диалог ввода ключевой фразы для использования под
504 GNOME.
505
506 %description gnome-askpass -l uk.UTF-8
507 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
508 машини та для виконання команд на віддаленій машині.
509
510 Цей пакет містить діалог вводу ключової фрази для використання під
511 GNOME.
512
513 %package -n openldap-schema-openssh-lpk
514 Summary:        OpenSSH LDAP Public Key schema
515 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
516 Group:          Networking/Daemons
517 Requires(post,postun):  sed >= 4.0
518 Requires:       openldap-servers
519 %if "%{_rpmversion}" >= "5"
520 BuildArch:      noarch
521 %endif
522
523 %description -n openldap-schema-openssh-lpk
524 This package contains OpenSSH LDAP Public Key schema for openldap.
525
526 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
527 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
528 openldap-a.
529
530 %prep
531 %setup -q
532 %patch1 -p1
533 %patch2 -p1
534 %patch3 -p1
535 %patch4 -p1
536 %patch5 -p1
537 %patch6 -p1
538 %patch7 -p1
539 %patch8 -p1
540
541 %{?with_hpn:%patch9 -p1}
542 %patch10 -p1
543 %patch11 -p1
544
545 %patch14 -p1
546 %{!?with_ldap:%patch15 -p1}
547 %{?with_libseccomp:%patch16 -p1}
548
549 %if "%{pld_release}" == "ac"
550 # fix for missing x11.pc
551 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
552 %endif
553
554 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
555 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh -lopenbsd-compat#g' Makefile*
556
557 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
558 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
559
560 # prevent being ovewritten by aclocal calls
561 mv aclocal.m4 acinclude.m4
562
563 %build
564 cp /usr/share/automake/config.sub .
565 %{__aclocal}
566 %{__autoconf}
567 %{__autoheader}
568 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
569 %configure \
570         PERL=%{__perl} \
571         --disable-strip \
572         --enable-utmpx \
573         --enable-wtmpx \
574         --with-4in6 \
575         %{?with_audit:--with-audit=linux} \
576         --with-ipaddr-display \
577         %{?with_kerberos5:--with-kerberos5=/usr} \
578         --with-ldap%{!?with_ldap:=no} \
579         %{?with_libedit:--with-libedit} \
580         --with-mantype=man \
581         --with-md5-passwords \
582         --with-pam \
583         --with-pid-dir=%{_localstatedir}/run \
584         --with-privsep-path=%{_privsepdir} \
585         --with-privsep-user=sshd \
586         %{?with_selinux:--with-selinux} \
587 %if "%{pld_release}" == "ac"
588         --with-xauth=/usr/X11R6/bin/xauth
589 %else
590         --with-sandbox=%{sandbox} \
591         --with-xauth=%{_bindir}/xauth
592 %endif
593
594 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
595
596 %{__make}
597
598 %{?with_tests:%{__make} -j1 tests}
599
600 cd contrib
601 %if %{with gnome}
602 %{__make} gnome-ssh-askpass1 \
603         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
604 %endif
605 %if %{with gtk}
606 %{__make} gnome-ssh-askpass2 \
607         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
608 %endif
609
610 %install
611 rm -rf $RPM_BUILD_ROOT
612 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
613         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
614 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
615
616 %{__make} install \
617         DESTDIR=$RPM_BUILD_ROOT
618
619 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
620
621 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
622 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
623 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
624 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
625 ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
626 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
627 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
628
629 cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
630 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
631
632 %{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
633         $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
634         $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
635         $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
636
637 %if %{with gnome}
638 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
639 %endif
640 %if %{with gtk}
641 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
642 %endif
643 %if %{with gnome} || %{with gtk}
644 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
645 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
646 EOF
647 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
648 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
649 EOF
650 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
651 %endif
652
653 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
654 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
655
656 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
657
658 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
659 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
660 EOF
661
662 %if "%{pld_release}" == "ac"
663 # not present in ac, no point searching it
664 %{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
665 # openssl on ac does not have OPENSSL_HAS_ECC
666 %{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
667 %endif
668
669 %if %{without audit}
670 # remove recording user's login uid to the process attribute
671 %{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
672 %endif
673
674 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
675 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
676
677 %clean
678 rm -rf $RPM_BUILD_ROOT
679
680 %post clients
681 %env_update
682
683 %postun clients
684 %env_update
685
686 %post gnome-askpass
687 %env_update
688
689 %postun gnome-askpass
690 %env_update
691
692 %pre server
693 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
694
695 %post server
696 /sbin/chkconfig --add sshd
697 %service sshd reload "OpenSSH Daemon"
698 NORESTART=1
699 %systemd_post sshd.service
700
701 %preun server
702 if [ "$1" = "0" ]; then
703         %service sshd stop
704         /sbin/chkconfig --del sshd
705 fi
706 %systemd_preun sshd.service
707
708 %postun server
709 if [ "$1" = "0" ]; then
710         %userremove sshd
711 fi
712 %systemd_reload
713
714 %triggerpostun server -- %{name}-server < 2:7.0p1-2
715 %banner %{name}-server -e << EOF
716 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
717 ! Starting from openssh 7.0 DSA keys are disabled !
718 ! on server and client side. You will NOT be able !
719 ! to use DSA keys for authentication. Please read !
720 ! about PubkeyAcceptedKeyTypes in man ssh_config. !
721 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
722 EOF
723
724 %triggerpostun server -- %{name}-server < 6.2p1-1
725 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
726 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
727
728 %triggerpostun server -- %{name}-server < 2:5.9p1-8
729 # lpk.patch to ldap.patch
730 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
731         echo >&2 "Migrating LPK patch to LDAP patch"
732         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
733         %{__sed} -i -e '
734                 # disable old configs
735                 # just UseLPK/LkpLdapConf supported for now
736                 s/^\s*UseLPK/## Obsolete &/
737                 s/^\s*Lpk/## Obsolete &/
738                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
739                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
740         ' %{_sysconfdir}/sshd_config
741         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
742                 /bin/systemctl try-restart sshd.service || :
743         else
744                 %service -q sshd reload
745         fi
746 fi
747 %systemd_trigger sshd.service
748 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
749 %banner %{name}-server -e << EOF
750 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
751 ! Native systemd support for sshd has been installed.   !
752 ! Restarting sshd.service with systemctl WILL kill all  !
753 ! active ssh sessions (daemon as such will be started). !
754 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
755 EOF
756 fi
757
758 %post -n openldap-schema-openssh-lpk
759 %openldap_schema_register %{schemadir}/openssh-lpk.schema
760 %service -q ldap restart
761
762 %postun -n openldap-schema-openssh-lpk
763 if [ "$1" = "0" ]; then
764         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
765         %service -q ldap restart
766 fi
767
768 %files
769 %defattr(644,root,root,755)
770 %doc TODO README OVERVIEW CREDITS Change*
771 %attr(755,root,root) %{_bindir}/ssh-key*
772 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
773 %{_mandir}/man1/ssh-key*.1*
774 #%{_mandir}/man1/ssh-vulnkey*.1*
775 %dir %{_sysconfdir}
776 %dir %{_libexecdir}
777
778 %files clients
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_bindir}/ssh
781 %attr(755,root,root) %{_bindir}/sftp
782 %attr(755,root,root) %{_bindir}/ssh-agent
783 %attr(755,root,root) %{_bindir}/ssh-add
784 %attr(755,root,root) %{_bindir}/ssh-copy-id
785 %attr(755,root,root) %{_bindir}/scp
786 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
787 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
788 %{_mandir}/man1/scp.1*
789 %{_mandir}/man1/ssh.1*
790 %{_mandir}/man1/sftp.1*
791 %{_mandir}/man1/ssh-agent.1*
792 %{_mandir}/man1/ssh-add.1*
793 %{_mandir}/man1/ssh-copy-id.1*
794 %{_mandir}/man5/ssh_config.5*
795 %lang(it) %{_mandir}/it/man1/ssh.1*
796 %lang(it) %{_mandir}/it/man5/ssh_config.5*
797 %lang(pl) %{_mandir}/pl/man1/scp.1*
798 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
799
800 # for host-based auth (suid required for accessing private host key)
801 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
802 #%{_mandir}/man8/ssh-keysign.8*
803
804 %files clients-agent-profile_d
805 %defattr(644,root,root,755)
806 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
807 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
808
809 %files clients-agent-xinitrc
810 %defattr(644,root,root,755)
811 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
812
813 %files server
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_sbindir}/sshd
816 %attr(755,root,root) %{_libexecdir}/sftp-server
817 %attr(755,root,root) %{_libexecdir}/ssh-keysign
818 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
819 %attr(755,root,root) %{_libexecdir}/sshd-keygen
820 %{_mandir}/man8/sshd.8*
821 %{_mandir}/man8/sftp-server.8*
822 %{_mandir}/man8/ssh-keysign.8*
823 %{_mandir}/man8/ssh-pkcs11-helper.8*
824 %{_mandir}/man5/sshd_config.5*
825 %{_mandir}/man5/moduli.5*
826 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
827 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
828 %attr(640,root,root) %{_sysconfdir}/moduli
829 %attr(754,root,root) /etc/rc.d/init.d/sshd
830 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
831 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
832 %{systemdunitdir}/sshd.service
833 %{systemdunitdir}/sshd.socket
834 %{systemdunitdir}/sshd@.service
835
836 %if %{with ldap}
837 %files server-ldap
838 %defattr(644,root,root,755)
839 %doc HOWTO.ldap-keys ldap.conf
840 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
841 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
842 %{_mandir}/man5/ssh-ldap.conf.5*
843 %{_mandir}/man8/ssh-ldap-helper.8*
844 %endif
845
846 %if %{with gnome} || %{with gtk}
847 %files gnome-askpass
848 %defattr(644,root,root,755)
849 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
850 %dir %{_libexecdir}/ssh
851 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
852 %attr(755,root,root) %{_libexecdir}/ssh-askpass
853 %endif
854
855 %if %{with ldap}
856 %files -n openldap-schema-openssh-lpk
857 %defattr(644,root,root,755)
858 %{schemadir}/openssh-lpk.schema
859 %endif
This page took 0.126427 seconds and 4 git commands to generate.