]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
fix sshd-keygen in sshd initscript
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_without  libseccomp      # use libseccomp for seccomp privsep (requires 3.5 kernel)
15 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
16 %bcond_without  tests
17
18 # gtk2-based gnome-askpass means no gnome1-based
19 %{?with_gtk:%undefine with_gnome}
20
21 %define sandbox %{?with_libseccomp:lib}seccomp_filter
22
23 %ifarch x32
24 %{!?with_libseccomp:%error openssh seccomp implementation is broken! do not disable libseccomp on x32}
25 %endif
26
27 %if "%{pld_release}" == "ac"
28 %define         pam_ver 0.79.0
29 %else
30 %define         pam_ver 1:1.1.8-5
31 %endif
32 Summary:        OpenSSH free Secure Shell (SSH) implementation
33 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
34 Summary(es.UTF-8):      Implementación libre de SSH
35 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
36 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
37 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
38 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
39 Summary(pt_BR.UTF-8):   Implementação livre do SSH
40 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
41 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
42 Name:           openssh
43 Version:        6.8p1
44 Release:        8
45 Epoch:          2
46 License:        BSD
47 Group:          Applications/Networking
48 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
49 # Source0-md5:  08f72de6751acfbd0892b5f003922701
50 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
51 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
52 Source2:        %{name}d.init
53 Source3:        %{name}d.pamd
54 Source4:        %{name}.sysconfig
55 Source5:        ssh-agent.sh
56 Source6:        ssh-agent.conf
57 Source7:        %{name}-lpk.schema
58 Source9:        sshd.service
59 Source10:       sshd-keygen
60 Source11:       sshd.socket
61 Source12:       sshd@.service
62 Patch0:         %{name}-no_libnsl.patch
63 Patch2:         %{name}-pam_misc.patch
64 Patch3:         %{name}-sigpipe.patch
65 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
66 Patch4:         %{name}-ldap.patch
67 Patch5:         %{name}-ldap-fixes.patch
68 Patch6:         ldap.conf.patch
69 Patch7:         %{name}-config.patch
70 Patch8:         ldap-helper-sigpipe.patch
71 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
72 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
73 Patch9:         %{name}-5.2p1-hpn13v6.diff
74 Patch10:        %{name}-include.patch
75 Patch11:        %{name}-chroot.patch
76
77 Patch14:        %{name}-bind.patch
78 Patch15:        %{name}-disable_ldap.patch
79 Patch16:        libseccomp-sandbox.patch
80 URL:            http://www.openssh.com/portable.html
81 BuildRequires:  %{__perl}
82 %{?with_audit:BuildRequires:    audit-libs-devel}
83 BuildRequires:  autoconf >= 2.50
84 BuildRequires:  automake
85 %{?with_gnome:BuildRequires:    gnome-libs-devel}
86 %{?with_gtk:BuildRequires:      gtk+2-devel}
87 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
88 %{?with_libedit:BuildRequires:  libedit-devel}
89 BuildRequires:  libseccomp-devel
90 %{?with_selinux:BuildRequires:  libselinux-devel}
91 %{?with_ldap:BuildRequires:     openldap-devel}
92 BuildRequires:  openssl-devel >= 0.9.8f
93 BuildRequires:  pam-devel
94 %{?with_gtk:BuildRequires:      pkgconfig}
95 BuildRequires:  rpm >= 4.4.9-56
96 BuildRequires:  rpmbuild(macros) >= 1.627
97 BuildRequires:  sed >= 4.0
98 BuildRequires:  zlib-devel >= 1.2.3
99 %if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
100 BuildRequires:  %{name}-server
101 %endif
102 %if %{with tests} && %{with libseccomp}
103 # libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
104 BuildRequires:  uname(release) >= 3.5
105 %endif
106 Requires:       zlib >= 1.2.3
107 %if "%{pld_release}" == "ac"
108 Requires:       filesystem >= 2.0-1
109 Requires:       pam >= 0.79.0
110 %else
111 Requires:       filesystem >= 3.0-11
112 Requires:       pam >= %{pam_ver}
113 Suggests:       xorg-app-xauth
114 %endif
115 %{?with_libseccomp:Requires:    uname(release) >= 3.5}
116 Obsoletes:      ssh
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %define         _sysconfdir     /etc/ssh
120 %define         _libexecdir     %{_libdir}/%{name}
121 %define         _privsepdir     /usr/share/empty
122 %define         schemadir       /usr/share/openldap/schema
123
124 %description
125 Ssh (Secure Shell) a program for logging into a remote machine and for
126 executing commands in a remote machine. It is intended to replace
127 rlogin and rsh, and provide secure encrypted communications between
128 two untrusted hosts over an insecure network. X11 connections and
129 arbitrary TCP/IP ports can also be forwarded over the secure channel.
130
131 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
132 it up to date in terms of security and features, as well as removing
133 all patented algorithms to seperate libraries (OpenSSL).
134
135 This package includes the core files necessary for both the OpenSSH
136 client and server. To make this package useful, you should also
137 install openssh-clients, openssh-server, or both.
138
139 %if %{with hpn}
140 This release includes High Performance SSH/SCP patches from
141 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
142 increase throughput on fast connections with high RTT (20-150 msec).
143 See the website for '-w' values for your connection and /proc/sys TCP
144 values. BTW. in a LAN you have got generally RTT < 1 msec.
145 %endif
146
147 %description -l de.UTF-8
148 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
149 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
150 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
151 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
152 andere TCP/IP Ports können ebenso über den sicheren Channel
153 weitergeleitet werden.
154
155 %description -l es.UTF-8
156 SSH es un programa para accesar y ejecutar órdenes en computadores
157 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
158 seguro entre dos servidores en una red insegura. Conexiones X11 y
159 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
160 seguro.
161
162 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
163 continuar la última versión gratuita de SSH, actualizándolo en
164 términos de seguridad y recursos,así también eliminando todos los
165 algoritmos patentados y colocándolos en bibliotecas separadas
166 (OpenSSL).
167
168 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
169 también el paquete openssh-clients u openssh-server o ambos.
170
171 %description -l fr.UTF-8
172 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
173 remplace telnet, rlogin, rexec et rsh, tout en assurant des
174 communications cryptées securisées entre deux hôtes non fiabilisés sur
175 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
176 arbitraires peuvent également être transmis sur le canal sécurisé.
177
178 %description -l it.UTF-8
179 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
180 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
181 sicure e crittate tra due host non fidati su una rete non sicura. Le
182 connessioni X11 ad una porta TCP/IP arbitraria possono essere
183 inoltrate attraverso un canale sicuro.
184
185 %description -l pl.UTF-8
186 Ssh (Secure Shell) to program służący do logowania się na zdalną
187 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
188 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
189 pomiędzy dwoma hostami.
190
191 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
192 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
193 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
194
195 %if %{with hpn}
196 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
197 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
198 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
199 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
200 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
201 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
202 %endif
203
204 %description -l pt.UTF-8
205 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
206 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
207 cifradas entre duas máquinas sem confiança mútua sobre uma rede
208 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
209 reenviados pelo canal seguro.
210
211 %description -l pt_BR.UTF-8
212 SSH é um programa para acessar e executar comandos em máquinas
213 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
214 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
215 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
216
217 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
218 última versão gratuita do SSH, atualizando-o em termos de segurança e
219 recursos, assim como removendo todos os algoritmos patenteados e
220 colocando-os em bibliotecas separadas (OpenSSL).
221
222 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
223 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
224
225 %description -l ru.UTF-8
226 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
227 машину и для выполнения команд на удаленной машине. Она предназначена
228 для замены rlogin и rsh и обеспечивает безопасную шифрованную
229 коммуникацию между двумя хостами в сети, являющейся небезопасной.
230 Соединения X11 и любые порты TCP/IP могут также быть проведены через
231 безопасный канал.
232
233 OpenSSH - это переделка командой разработчиков OpenBSD последней
234 свободной версии SSH, доведенная до современного состояния в терминах
235 уровня безопасности и поддерживаемых возможностей. Все патентованные
236 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
237
238 Этот пакет содержит файлы, необходимые как для клиента, так и для
239 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
240 openssh-server, или оба пакета.
241
242 %description -l uk.UTF-8
243 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
244 машини та для виконання команд на віддаленій машині. Вона призначена
245 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
246 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
247 довільні порти TCP/IP можуть також бути проведені через безпечний
248 канал.
249
250 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
251 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
252 підтримуваних можливостей. Всі патентовані алгоритми винесені до
253 окремих бібліотек (OpenSSL).
254
255 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
256 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
257 openssh-server, чи обидва пакети.
258
259 %package clients
260 Summary:        OpenSSH Secure Shell protocol clients
261 Summary(es.UTF-8):      Clientes de OpenSSH
262 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
263 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
264 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
265 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
266 Group:          Applications/Networking
267 Requires:       %{name}
268 Provides:       ssh-clients
269 Obsoletes:      ssh-clients
270 %requires_eq_to openssl openssl-devel
271
272 %description clients
273 Ssh (Secure Shell) a program for logging into a remote machine and for
274 executing commands in a remote machine. It is intended to replace
275 rlogin and rsh, and provide secure encrypted communications between
276 two untrusted hosts over an insecure network. X11 connections and
277 arbitrary TCP/IP ports can also be forwarded over the secure channel.
278
279 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
280 it up to date in terms of security and features, as well as removing
281 all patented algorithms to seperate libraries (OpenSSL).
282
283 This package includes the clients necessary to make encrypted
284 connections to SSH servers.
285
286 %description clients -l es.UTF-8
287 Este paquete incluye los clientes que se necesitan para hacer
288 conexiones codificadas con servidores SSH.
289
290 %description clients -l pl.UTF-8
291 Ssh (Secure Shell) to program służący do logowania się na zdalną
292 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
293 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
294 pomiędzy dwoma hostami.
295
296 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
297
298 %description clients -l pt_BR.UTF-8
299 Esse pacote inclui os clientes necessários para fazer conexões
300 encriptadas com servidores SSH.
301
302 %description clients -l ru.UTF-8
303 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
304 машину и для выполнения команд на удаленной машине.
305
306 Этот пакет содержит программы-клиенты, необходимые для установления
307 зашифрованных соединений с серверами SSH.
308
309 %description clients -l uk.UTF-8
310 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
311 машини та для виконання команд на віддаленій машині.
312
313 Цей пакет містить програми-клієнти, необхідні для встановлення
314 зашифрованих з'єднань з серверами SSH.
315
316 %package clients-agent-profile_d
317 Summary:        OpenSSH Secure Shell agent init script
318 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
319 Group:          Applications/Networking
320 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
321
322 %description clients-agent-profile_d
323 profile.d scripts for starting SSH agent.
324
325 %description clients-agent-profile_d -l pl.UTF-8
326 Skrypty profile.d do uruchamiania agenta SSH.
327
328 %package clients-agent-xinitrc
329 Summary:        OpenSSH Secure Shell agent init script
330 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
331 Group:          Applications/Networking
332 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
333 Requires:       xinitrc
334
335 %description clients-agent-xinitrc
336 xinitrc scripts for starting SSH agent.
337
338 %description clients-agent-xinitrc -l pl.UTF-8
339 Skrypty xinitrc do uruchamiania agenta SSH.
340
341 %package server
342 Summary:        OpenSSH Secure Shell protocol server (sshd)
343 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
344 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
345 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
346 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
347 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
348 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
349 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
350 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
351 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
352 Group:          Networking/Daemons
353 Requires(post): /sbin/chkconfig
354 Requires(post): grep
355 Requires(post,preun):   /sbin/chkconfig
356 Requires(postun):       /usr/sbin/userdel
357 Requires(pre):  /bin/id
358 Requires(pre):  /usr/sbin/useradd
359 Requires(post,preun,postun):    systemd-units >= 38
360 Requires:       %{name} = %{epoch}:%{version}-%{release}
361 Requires:       pam >= %{pam_ver}
362 Requires:       rc-scripts >= 0.4.3.0
363 Requires:       systemd-units >= 38
364 Requires:       util-linux
365 %{?with_ldap:Suggests:  %{name}-server-ldap}
366 Suggests:       /bin/login
367 Suggests:       xorg-app-xauth
368 Provides:       ssh-server
369 Provides:       user(sshd)
370 %requires_eq_to openssl openssl-devel
371
372 %description server
373 Ssh (Secure Shell) a program for logging into a remote machine and for
374 executing commands in a remote machine. It is intended to replace
375 rlogin and rsh, and provide secure encrypted communications between
376 two untrusted hosts over an insecure network. X11 connections and
377 arbitrary TCP/IP ports can also be forwarded over the secure channel.
378
379 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
380 it up to date in terms of security and features, as well as removing
381 all patented algorithms to seperate libraries (OpenSSL).
382
383 This package contains the secure shell daemon. The sshd is the server
384 part of the secure shell protocol and allows ssh clients to connect to
385 your host.
386
387 %description server -l de.UTF-8
388 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
389
390 %description server -l es.UTF-8
391 Este paquete contiene el servidor SSH. sshd es la parte servidor del
392 protocolo secure shell y permite que clientes ssh se conecten a su
393 servidor.
394
395 %description server -l fr.UTF-8
396 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
397
398 %description server -l it.UTF-8
399 Questo pacchetto installa sshd, il server di OpenSSH.
400
401 %description server -l pl.UTF-8
402 Ssh (Secure Shell) to program służący do logowania się na zdalną
403 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
404 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
405 pomiędzy dwoma hostami.
406
407 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
408 ssh).
409
410 %description server -l pt.UTF-8
411 Este pacote intala o sshd, o servidor do OpenSSH.
412
413 %description server -l pt_BR.UTF-8
414 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
415 protocolo secure shell e permite que clientes ssh se conectem ao seu
416 host.
417
418 %description server -l ru.UTF-8
419 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
420 машину и для выполнения команд на удаленной машине.
421
422 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
423 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
424 вашим хостом.
425
426 %description server -l uk.UTF-8
427 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
428 машини та для виконання команд на віддаленій машині.
429
430 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
431 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
432 з вашим хостом.
433
434 %package server-ldap
435 Summary:        A LDAP support for open source SSH server daemon
436 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
437 Group:          Daemons
438 Requires:       %{name} = %{epoch}:%{version}-%{release}
439 Requires:       openldap-nss-config
440
441 %description server-ldap
442 OpenSSH LDAP backend is a way how to distribute the authorized tokens
443 among the servers in the network.
444
445 %description server-ldap -l pl.UTF-8
446 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
447 tokenów między serwerami w sieci.
448
449 %package gnome-askpass
450 Summary:        OpenSSH GNOME passphrase dialog
451 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
452 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
453 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
454 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
455 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
456 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
457 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
458 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
459 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
460 Group:          Applications/Networking
461 Requires:       %{name} = %{epoch}:%{version}-%{release}
462 Obsoletes:      openssh-askpass
463 Obsoletes:      ssh-askpass
464 Obsoletes:      ssh-extras
465
466 %description gnome-askpass
467 Ssh (Secure Shell) a program for logging into a remote machine and for
468 executing commands in a remote machine. It is intended to replace
469 rlogin and rsh, and provide secure encrypted communications between
470 two untrusted hosts over an insecure network. X11 connections and
471 arbitrary TCP/IP ports can also be forwarded over the secure channel.
472
473 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
474 it up to date in terms of security and features, as well as removing
475 all patented algorithms to seperate libraries (OpenSSL).
476
477 This package contains the GNOME passphrase dialog.
478
479 %description gnome-askpass -l es.UTF-8
480 Este paquete contiene un programa que abre una caja de diálogo para
481 entrada de passphrase en GNOME.
482
483 %description gnome-askpass -l pl.UTF-8
484 Ssh (Secure Shell) to program służący do logowania się na zdalną
485 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
486 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
487 pomiędzy dwoma hostami.
488
489 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
490
491 %description gnome-askpass -l pt_BR.UTF-8
492 Esse pacote contém um programa que abre uma caixa de diálogo para
493 entrada de passphrase no GNOME.
494
495 %description gnome-askpass -l ru.UTF-8
496 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
497 машину и для выполнения команд на удаленной машине.
498
499 Этот пакет содержит диалог ввода ключевой фразы для использования под
500 GNOME.
501
502 %description gnome-askpass -l uk.UTF-8
503 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
504 машини та для виконання команд на віддаленій машині.
505
506 Цей пакет містить діалог вводу ключової фрази для використання під
507 GNOME.
508
509 %package -n openldap-schema-openssh-lpk
510 Summary:        OpenSSH LDAP Public Key schema
511 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
512 Group:          Networking/Daemons
513 Requires(post,postun):  sed >= 4.0
514 Requires:       openldap-servers
515 %if "%{_rpmversion}" >= "5"
516 BuildArch:      noarch
517 %endif
518
519 %description -n openldap-schema-openssh-lpk
520 This package contains OpenSSH LDAP Public Key schema for openldap.
521
522 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
523 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
524 openldap-a.
525
526 %prep
527 %setup -q
528 %patch0 -p1
529 %patch2 -p1
530 %patch3 -p1
531 %patch4 -p1
532 %patch5 -p1
533 %patch6 -p1
534 %patch7 -p1
535 %patch8 -p1
536
537 %{?with_hpn:%patch9 -p1}
538 %patch10 -p1
539 %patch11 -p1
540
541 %patch14 -p1
542 %{!?with_ldap:%patch15 -p1}
543 %{?with_libseccomp:%patch16 -p1}
544
545 %if "%{pld_release}" == "ac"
546 # fix for missing x11.pc
547 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
548 %endif
549
550 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
551 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
552
553 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
554 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
555
556 # prevent being ovewritten by aclocal calls
557 mv aclocal.m4 acinclude.m4
558
559 %build
560 cp /usr/share/automake/config.sub .
561 %{__aclocal}
562 %{__autoconf}
563 %{__autoheader}
564 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
565 %configure \
566         PERL=%{__perl} \
567         --disable-strip \
568         --enable-utmpx \
569         --enable-wtmpx \
570         --with-4in6 \
571         %{?with_audit:--with-audit=linux} \
572         --with-ipaddr-display \
573         %{?with_kerberos5:--with-kerberos5=/usr} \
574         --with-ldap%{!?with_ldap:=no} \
575         %{?with_libedit:--with-libedit} \
576         --with-mantype=man \
577         --with-md5-passwords \
578         --with-pam \
579         --with-pid-dir=%{_localstatedir}/run \
580         --with-privsep-path=%{_privsepdir} \
581         --with-privsep-user=sshd \
582         %{?with_selinux:--with-selinux} \
583 %if "%{pld_release}" == "ac"
584         --with-xauth=/usr/X11R6/bin/xauth
585 %else
586         --with-sandbox=%{sandbox} \
587         --with-xauth=%{_bindir}/xauth
588 %endif
589
590 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
591
592 %{__make}
593
594 %{?with_tests:%{__make} -j1 tests}
595
596 cd contrib
597 %if %{with gnome}
598 %{__make} gnome-ssh-askpass1 \
599         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
600 %endif
601 %if %{with gtk}
602 %{__make} gnome-ssh-askpass2 \
603         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
604 %endif
605
606 %install
607 rm -rf $RPM_BUILD_ROOT
608 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
609         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
610 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
611
612 %{__make} install \
613         DESTDIR=$RPM_BUILD_ROOT
614
615 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
616
617 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
618 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
619 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
620 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
621 ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
622 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
623 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
624
625 cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
626 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
627
628 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
629         $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
630         $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
631         $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
632
633 %if %{with gnome}
634 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
635 %endif
636 %if %{with gtk}
637 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
638 %endif
639 %if %{with gnome} || %{with gtk}
640 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
641 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
642 EOF
643 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
644 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
645 EOF
646 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
647 %endif
648
649 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
650 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
651
652 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
653 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
654
655 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
656
657 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
658 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
659 EOF
660
661 %if "%{pld_release}" == "ac"
662 # not present in ac, no point searching it
663 %{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
664 # openssl on ac does not have OPENSSL_HAS_ECC
665 %{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
666 %endif
667
668 %if %{without audit}
669 # remove recording user's login uid to the process attribute
670 %{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
671 %endif
672
673 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
674 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
675
676 %clean
677 rm -rf $RPM_BUILD_ROOT
678
679 %post clients
680 %env_update
681
682 %postun clients
683 %env_update
684
685 %post gnome-askpass
686 %env_update
687
688 %postun gnome-askpass
689 %env_update
690
691 %pre server
692 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
693
694 %post server
695 /sbin/chkconfig --add sshd
696 %service sshd reload "OpenSSH Daemon"
697 NORESTART=1
698 %systemd_post sshd.service
699
700 %preun server
701 if [ "$1" = "0" ]; then
702         %service sshd stop
703         /sbin/chkconfig --del sshd
704 fi
705 %systemd_preun sshd.service
706
707 %postun server
708 if [ "$1" = "0" ]; then
709         %userremove sshd
710 fi
711 %systemd_reload
712
713 %triggerpostun server -- %{name}-server < 6.2p1-1
714 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
715 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
716
717 %triggerpostun server -- %{name}-server < 2:5.9p1-8
718 # lpk.patch to ldap.patch
719 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
720         echo >&2 "Migrating LPK patch to LDAP patch"
721         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
722         %{__sed} -i -e '
723                 # disable old configs
724                 # just UseLPK/LkpLdapConf supported for now
725                 s/^\s*UseLPK/## Obsolete &/
726                 s/^\s*Lpk/## Obsolete &/
727                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
728                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
729         ' %{_sysconfdir}/sshd_config
730         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
731                 /bin/systemctl try-restart sshd.service || :
732         else
733                 %service -q sshd reload
734         fi
735 fi
736 %systemd_trigger sshd.service
737 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
738 %banner %{name}-server -e << EOF
739 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
740 ! Native systemd support for sshd has been installed.   !
741 ! Restarting sshd.service with systemctl WILL kill all  !
742 ! active ssh sessions (daemon as such will be started). !
743 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
744 EOF
745 fi
746
747 %post -n openldap-schema-openssh-lpk
748 %openldap_schema_register %{schemadir}/openssh-lpk.schema
749 %service -q ldap restart
750
751 %postun -n openldap-schema-openssh-lpk
752 if [ "$1" = "0" ]; then
753         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
754         %service -q ldap restart
755 fi
756
757 %files
758 %defattr(644,root,root,755)
759 %doc TODO README OVERVIEW CREDITS Change*
760 %attr(755,root,root) %{_bindir}/ssh-key*
761 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
762 %{_mandir}/man1/ssh-key*.1*
763 #%{_mandir}/man1/ssh-vulnkey*.1*
764 %dir %{_sysconfdir}
765 %dir %{_libexecdir}
766
767 %files clients
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_bindir}/ssh
770 %attr(755,root,root) %{_bindir}/slogin
771 %attr(755,root,root) %{_bindir}/sftp
772 %attr(755,root,root) %{_bindir}/ssh-agent
773 %attr(755,root,root) %{_bindir}/ssh-add
774 %attr(755,root,root) %{_bindir}/ssh-copy-id
775 %attr(755,root,root) %{_bindir}/scp
776 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
777 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
778 %{_mandir}/man1/scp.1*
779 %{_mandir}/man1/ssh.1*
780 %{_mandir}/man1/slogin.1*
781 %{_mandir}/man1/sftp.1*
782 %{_mandir}/man1/ssh-agent.1*
783 %{_mandir}/man1/ssh-add.1*
784 %{_mandir}/man1/ssh-copy-id.1*
785 %{_mandir}/man5/ssh_config.5*
786 %lang(it) %{_mandir}/it/man1/ssh.1*
787 %lang(it) %{_mandir}/it/man5/ssh_config.5*
788 %lang(pl) %{_mandir}/pl/man1/scp.1*
789 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
790
791 # for host-based auth (suid required for accessing private host key)
792 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
793 #%{_mandir}/man8/ssh-keysign.8*
794
795 %files clients-agent-profile_d
796 %defattr(644,root,root,755)
797 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
798 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
799
800 %files clients-agent-xinitrc
801 %defattr(644,root,root,755)
802 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
803
804 %files server
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_sbindir}/sshd
807 %attr(755,root,root) %{_libexecdir}/sftp-server
808 %attr(755,root,root) %{_libexecdir}/ssh-keysign
809 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
810 %attr(755,root,root) %{_libexecdir}/sshd-keygen
811 %{_mandir}/man8/sshd.8*
812 %{_mandir}/man8/sftp-server.8*
813 %{_mandir}/man8/ssh-keysign.8*
814 %{_mandir}/man8/ssh-pkcs11-helper.8*
815 %{_mandir}/man5/sshd_config.5*
816 %{_mandir}/man5/moduli.5*
817 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
818 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
819 %attr(640,root,root) %{_sysconfdir}/moduli
820 %attr(754,root,root) /etc/rc.d/init.d/sshd
821 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
822 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
823 %{systemdunitdir}/sshd.service
824 %{systemdunitdir}/sshd.socket
825 %{systemdunitdir}/sshd@.service
826
827 %if %{with ldap}
828 %files server-ldap
829 %defattr(644,root,root,755)
830 %doc HOWTO.ldap-keys ldap.conf
831 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
832 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
833 %{_mandir}/man5/ssh-ldap.conf.5*
834 %{_mandir}/man8/ssh-ldap-helper.8*
835 %endif
836
837 %if %{with gnome} || %{with gtk}
838 %files gnome-askpass
839 %defattr(644,root,root,755)
840 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
841 %dir %{_libexecdir}/ssh
842 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
843 %attr(755,root,root) %{_libexecdir}/ssh-askpass
844 %endif
845
846 %if %{with ldap}
847 %files -n openldap-schema-openssh-lpk
848 %defattr(644,root,root,755)
849 %{schemadir}/openssh-lpk.schema
850 %endif
This page took 0.116029 seconds and 4 git commands to generate.