]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- fix ssh-ldap-helper path
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11
12 # gtk2-based gnome-askpass means no gnome1-based
13 %{?with_gtk:%undefine with_gnome}
14
15 %if "%{pld_release}" == "ac"
16 %define         pam_ver 0.79.0
17 %else
18 %define         pam_ver 0.99.7.1
19 %endif
20
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        5.9p1
33 Release:        2
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  b50a499fa02616a47984b1920848b565
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Source7:        %{name}-lpk.schema
47 Source8:        %{name}d.upstart
48 Patch100:       %{name}-heimdal.patch
49 Patch0:         %{name}-no_libnsl.patch
50 Patch2:         %{name}-pam_misc.patch
51 Patch3:         %{name}-sigpipe.patch
52 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
53 Patch4:         %{name}-5.9p1-ldap.patch
54 Patch5:         %{name}-5.9p1-ldap-fixes.patch
55 Patch8:         ldap.conf.patch
56 Patch6:         %{name}-config.patch
57 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
58 Patch7:         authorized-keys-command.patch
59 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
61 Patch9:         %{name}-5.2p1-hpn13v6.diff
62 Patch10:        %{name}-include.patch
63 Patch11:        %{name}-chroot.patch
64 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
65 Patch12:        %{name}-blacklist.diff
66 Patch13:        %{name}-kuserok.patch
67 URL:            http://www.openssh.com/portable.html
68 BuildRequires:  %{__perl}
69 %{?with_audit:BuildRequires:    audit-libs-devel}
70 BuildRequires:  autoconf >= 2.50
71 BuildRequires:  automake
72 %{?with_gnome:BuildRequires:    gnome-libs-devel}
73 %{?with_gtk:BuildRequires:      gtk+2-devel}
74 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
75 %{?with_libedit:BuildRequires:  libedit-devel}
76 %{?with_selinux:BuildRequires:  libselinux-devel}
77 BuildRequires:  libwrap-devel
78 %{?with_ldap:BuildRequires:     openldap-devel}
79 BuildRequires:  openssl-devel >= 0.9.7d
80 BuildRequires:  pam-devel
81 %{?with_gtk:BuildRequires:      pkgconfig}
82 BuildRequires:  rpm >= 4.4.9-56
83 BuildRequires:  rpmbuild(macros) >= 1.318
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  zlib-devel
86 %if "%{pld_release}" == "ac"
87 Requires:       filesystem >= 2.0-1
88 Requires:       pam >= 0.79.0
89 %else
90 Requires:       filesystem >= 3.0-11
91 Requires:       pam >= %{pam_ver}
92 Suggests:       openssh-blacklist
93 Suggests:       xorg-app-xauth
94 %endif
95 Obsoletes:      ssh
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         _sysconfdir     /etc/ssh
99 %define         _libexecdir     %{_libdir}/%{name}
100 %define         _privsepdir     /usr/share/empty
101 %define         schemadir       /usr/share/openldap/schema
102
103 %description
104 Ssh (Secure Shell) a program for logging into a remote machine and for
105 executing commands in a remote machine. It is intended to replace
106 rlogin and rsh, and provide secure encrypted communications between
107 two untrusted hosts over an insecure network. X11 connections and
108 arbitrary TCP/IP ports can also be forwarded over the secure channel.
109
110 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
111 it up to date in terms of security and features, as well as removing
112 all patented algorithms to seperate libraries (OpenSSL).
113
114 This package includes the core files necessary for both the OpenSSH
115 client and server. To make this package useful, you should also
116 install openssh-clients, openssh-server, or both.
117
118 %if %{with hpn}
119 This release includes High Performance SSH/SCP patches from
120 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
121 increase throughput on fast connections with high RTT (20-150 msec).
122 See the website for '-w' values for your connection and /proc/sys TCP
123 values. BTW. in a LAN you have got generally RTT < 1 msec.
124 %endif
125
126 %description -l de.UTF-8
127 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
128 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
129 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
130 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
131 andere TCP/IP Ports können ebenso über den sicheren Channel
132 weitergeleitet werden.
133
134 %description -l es.UTF-8
135 SSH es un programa para accesar y ejecutar órdenes en computadores
136 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
137 seguro entre dos servidores en una red insegura. Conexiones X11 y
138 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
139 seguro.
140
141 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
142 continuar la última versión gratuita de SSH, actualizándolo en
143 términos de seguridad y recursos,así también eliminando todos los
144 algoritmos patentados y colocándolos en bibliotecas separadas
145 (OpenSSL).
146
147 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
148 también el paquete openssh-clients u openssh-server o ambos.
149
150 %description -l fr.UTF-8
151 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
152 remplace telnet, rlogin, rexec et rsh, tout en assurant des
153 communications cryptées securisées entre deux hôtes non fiabilisés sur
154 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
155 arbitraires peuvent également être transmis sur le canal sécurisé.
156
157 %description -l it.UTF-8
158 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
159 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
160 sicure e crittate tra due host non fidati su una rete non sicura. Le
161 connessioni X11 ad una porta TCP/IP arbitraria possono essere
162 inoltrate attraverso un canale sicuro.
163
164 %description -l pl.UTF-8
165 Ssh (Secure Shell) to program służący do logowania się na zdalną
166 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
167 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
168 pomiędzy dwoma hostami.
169
170 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
171 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
172 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
173
174 %if %{with hpn}
175 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
176 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
177 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
178 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
179 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
180 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
181 %endif
182
183 %description -l pt.UTF-8
184 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
185 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
186 cifradas entre duas máquinas sem confiança mútua sobre uma rede
187 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
188 reenviados pelo canal seguro.
189
190 %description -l pt_BR.UTF-8
191 SSH é um programa para acessar e executar comandos em máquinas
192 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
193 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
194 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
195
196 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
197 última versão gratuita do SSH, atualizando-o em termos de segurança e
198 recursos, assim como removendo todos os algoritmos patenteados e
199 colocando-os em bibliotecas separadas (OpenSSL).
200
201 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
202 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
203
204 %description -l ru.UTF-8
205 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
206 машину и для выполнения команд на удаленной машине. Она предназначена
207 для замены rlogin и rsh и обеспечивает безопасную шифрованную
208 коммуникацию между двумя хостами в сети, являющейся небезопасной.
209 Соединения X11 и любые порты TCP/IP могут также быть проведены через
210 безопасный канал.
211
212 OpenSSH - это переделка командой разработчиков OpenBSD последней
213 свободной версии SSH, доведенная до современного состояния в терминах
214 уровня безопасности и поддерживаемых возможностей. Все патентованные
215 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
216
217 Этот пакет содержит файлы, необходимые как для клиента, так и для
218 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
219 openssh-server, или оба пакета.
220
221 %description -l uk.UTF-8
222 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
223 машини та для виконання команд на віддаленій машині. Вона призначена
224 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
225 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
226 довільні порти TCP/IP можуть також бути проведені через безпечний
227 канал.
228
229 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
230 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
231 підтримуваних можливостей. Всі патентовані алгоритми винесені до
232 окремих бібліотек (OpenSSL).
233
234 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
235 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
236 openssh-server, чи обидва пакети.
237
238 %package clients
239 Summary:        OpenSSH Secure Shell protocol clients
240 Summary(es.UTF-8):      Clientes de OpenSSH
241 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
242 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
243 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
244 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
245 Group:          Applications/Networking
246 Requires:       %{name}
247 Provides:       ssh-clients
248 Obsoletes:      ssh-clients
249
250 %description clients
251 Ssh (Secure Shell) a program for logging into a remote machine and for
252 executing commands in a remote machine. It is intended to replace
253 rlogin and rsh, and provide secure encrypted communications between
254 two untrusted hosts over an insecure network. X11 connections and
255 arbitrary TCP/IP ports can also be forwarded over the secure channel.
256
257 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
258 it up to date in terms of security and features, as well as removing
259 all patented algorithms to seperate libraries (OpenSSL).
260
261 This package includes the clients necessary to make encrypted
262 connections to SSH servers.
263
264 %description clients -l es.UTF-8
265 Este paquete incluye los clientes que se necesitan para hacer
266 conexiones codificadas con servidores SSH.
267
268 %description clients -l pl.UTF-8
269 Ssh (Secure Shell) to program służący do logowania się na zdalną
270 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
271 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
272 pomiędzy dwoma hostami.
273
274 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
275
276 %description clients -l pt_BR.UTF-8
277 Esse pacote inclui os clientes necessários para fazer conexões
278 encriptadas com servidores SSH.
279
280 %description clients -l ru.UTF-8
281 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
282 машину и для выполнения команд на удаленной машине.
283
284 Этот пакет содержит программы-клиенты, необходимые для установления
285 зашифрованных соединений с серверами SSH.
286
287 %description clients -l uk.UTF-8
288 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
289 машини та для виконання команд на віддаленій машині.
290
291 Цей пакет містить програми-клієнти, необхідні для встановлення
292 зашифрованих з'єднань з серверами SSH.
293
294 %package clients-agent-profile_d
295 Summary:        OpenSSH Secure Shell agent init script
296 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
297 Group:          Applications/Networking
298 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
299
300 %description clients-agent-profile_d
301 profile.d scripts for starting SSH agent.
302
303 %description clients-agent-profile_d -l pl.UTF-8
304 Skrypty profile.d do uruchamiania agenta SSH.
305
306 %package clients-agent-xinitrc
307 Summary:        OpenSSH Secure Shell agent init script
308 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
309 Group:          Applications/Networking
310 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
311 Requires:       xinitrc
312
313 %description clients-agent-xinitrc
314 xinitrc scripts for starting SSH agent.
315
316 %description clients-agent-xinitrc -l pl.UTF-8
317 Skrypty xinitrc do uruchamiania agenta SSH.
318
319 %package server
320 Summary:        OpenSSH Secure Shell protocol server (sshd)
321 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
322 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
323 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
324 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
325 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
326 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
327 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
328 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
329 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
330 Group:          Networking/Daemons
331 Requires(post): /sbin/chkconfig
332 Requires(post): grep
333 Requires(post,preun):   /sbin/chkconfig
334 Requires(postun):       /usr/sbin/userdel
335 Requires(pre):  /bin/id
336 Requires(pre):  /usr/sbin/useradd
337 Requires:       %{name} = %{epoch}:%{version}-%{release}
338 Requires:       pam >= %{pam_ver}
339 Requires:       rc-scripts >= 0.4.3.0
340 Requires:       util-linux
341 Suggests:       /bin/login
342 Provides:       ssh-server
343 Provides:       user(sshd)
344
345 %description server
346 Ssh (Secure Shell) a program for logging into a remote machine and for
347 executing commands in a remote machine. It is intended to replace
348 rlogin and rsh, and provide secure encrypted communications between
349 two untrusted hosts over an insecure network. X11 connections and
350 arbitrary TCP/IP ports can also be forwarded over the secure channel.
351
352 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
353 it up to date in terms of security and features, as well as removing
354 all patented algorithms to seperate libraries (OpenSSL).
355
356 This package contains the secure shell daemon. The sshd is the server
357 part of the secure shell protocol and allows ssh clients to connect to
358 your host.
359
360 %description server -l de.UTF-8
361 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
362
363 %description server -l es.UTF-8
364 Este paquete contiene el servidor SSH. sshd es la parte servidor del
365 protocolo secure shell y permite que clientes ssh se conecten a su
366 servidor.
367
368 %description server -l fr.UTF-8
369 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
370
371 %description server -l it.UTF-8
372 Questo pacchetto installa sshd, il server di OpenSSH.
373
374 %description server -l pl.UTF-8
375 Ssh (Secure Shell) to program służący do logowania się na zdalną
376 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
377 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
378 pomiędzy dwoma hostami.
379
380 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
381 ssh).
382
383 %description server -l pt.UTF-8
384 Este pacote intala o sshd, o servidor do OpenSSH.
385
386 %description server -l pt_BR.UTF-8
387 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
388 protocolo secure shell e permite que clientes ssh se conectem ao seu
389 host.
390
391 %description server -l ru.UTF-8
392 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
393 машину и для выполнения команд на удаленной машине.
394
395 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
396 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
397 вашим хостом.
398
399 %description server -l uk.UTF-8
400 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
401 машини та для виконання команд на віддаленій машині.
402
403 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
404 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
405 з вашим хостом.
406
407 %package server-upstart
408 Summary:        Upstart job description for OpenSSH server
409 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
410 Group:          Daemons
411 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
412 Requires:       upstart >= 0.6
413 Conflicts:      syslog-ng < 3.2.4-1
414
415 %description server-upstart
416 Upstart job description for OpenSSH.
417
418 %description server-upstart -l pl.UTF-8
419 Opis zadania Upstart dla OpenSSH.
420
421 %package gnome-askpass
422 Summary:        OpenSSH GNOME passphrase dialog
423 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
424 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
425 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
426 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
427 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
428 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
429 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
430 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
431 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
432 Group:          Applications/Networking
433 Requires:       %{name} = %{epoch}:%{version}-%{release}
434 Obsoletes:      openssh-askpass
435 Obsoletes:      ssh-askpass
436 Obsoletes:      ssh-extras
437
438 %description gnome-askpass
439 Ssh (Secure Shell) a program for logging into a remote machine and for
440 executing commands in a remote machine. It is intended to replace
441 rlogin and rsh, and provide secure encrypted communications between
442 two untrusted hosts over an insecure network. X11 connections and
443 arbitrary TCP/IP ports can also be forwarded over the secure channel.
444
445 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
446 it up to date in terms of security and features, as well as removing
447 all patented algorithms to seperate libraries (OpenSSL).
448
449 This package contains the GNOME passphrase dialog.
450
451 %description gnome-askpass -l es.UTF-8
452 Este paquete contiene un programa que abre una caja de diálogo para
453 entrada de passphrase en GNOME.
454
455 %description gnome-askpass -l pl.UTF-8
456 Ssh (Secure Shell) to program służący do logowania się na zdalną
457 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
458 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
459 pomiędzy dwoma hostami.
460
461 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
462
463 %description gnome-askpass -l pt_BR.UTF-8
464 Esse pacote contém um programa que abre uma caixa de diálogo para
465 entrada de passphrase no GNOME.
466
467 %description gnome-askpass -l ru.UTF-8
468 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
469 машину и для выполнения команд на удаленной машине.
470
471 Этот пакет содержит диалог ввода ключевой фразы для использования под
472 GNOME.
473
474 %description gnome-askpass -l uk.UTF-8
475 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
476 машини та для виконання команд на віддаленій машині.
477
478 Цей пакет містить діалог вводу ключової фрази для використання під
479 GNOME.
480
481 %package -n openldap-schema-openssh-lpk
482 Summary:        OpenSSH LDAP Public Key schema
483 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
484 Group:          Networking/Daemons
485 Requires(post,postun):  sed >= 4.0
486 Requires:       openldap-servers
487
488 %description -n openldap-schema-openssh-lpk
489 This package contains OpenSSH LDAP Public Key schema for openldap.
490
491 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
492 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
493 openldap-a.
494
495 %prep
496 %setup -q
497 %{?with_kerberos5:%patch100 -p1}
498 %patch0 -p1
499 %patch2 -p1
500 %patch3 -p1
501 %patch4 -p1
502 %patch5 -p1
503 %patch8 -p1
504 %patch6 -p1
505 %patch7 -p1
506 %{?with_hpn:%patch9 -p1}
507 %patch10 -p1
508 %patch11 -p1
509 %patch12 -p1
510 %patch13 -p1
511
512 cp -p %{SOURCE3} sshd.pam
513 install -p %{SOURCE2} sshd.init
514
515 %if "%{pld_release}" == "ac"
516 # fix for missing x11.pc
517 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
518 # not present in ac, no point searching it
519 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
520
521 # openssl on ac does not have OPENSSL_HAS_ECC
522 %{__sed} -i -e '/ecdsa/d' sshd.init
523 %endif
524
525 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
526 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
527
528 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
529 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
530
531 %build
532 cp /usr/share/automake/config.sub .
533 %{__aclocal}
534 %{__autoconf}
535 %{__autoheader}
536 CPPFLAGS="-DCHROOT"
537 %configure \
538         PERL=%{__perl} \
539         --disable-strip \
540         --enable-utmpx \
541         --enable-wtmpx \
542         --with-4in6 \
543         %{?with_audit:--with-audit=linux} \
544         --with-ipaddr-display \
545         %{?with_kerberos5:--with-kerberos5=/usr} \
546         --with-ldap%{!?with_ldap:=no} \
547         %{?with_libedit:--with-libedit} \
548         --with-mantype=man \
549         --with-md5-passwords \
550         --with-pam \
551         --with-authorized-keys-command \
552         --with-pid-dir=%{_localstatedir}/run \
553         --with-privsep-path=%{_privsepdir} \
554         %{?with_selinux:--with-selinux} \
555         --with-tcp-wrappers \
556 %if "%{pld_release}" == "ac"
557         --with-xauth=/usr/X11R6/bin/xauth
558 %else
559         --with-xauth=%{_bindir}/xauth
560 %endif
561
562 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
563
564 %{__make}
565
566 cd contrib
567 %if %{with gnome}
568 %{__make} gnome-ssh-askpass1 \
569         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
570 %endif
571 %if %{with gtk}
572 %{__make} gnome-ssh-askpass2 \
573         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
574 %endif
575
576 %install
577 rm -rf $RPM_BUILD_ROOT
578 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
579         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
580 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
581
582 %{__make} install \
583         DESTDIR=$RPM_BUILD_ROOT
584
585 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
586
587 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
588 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
589 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
590 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
591 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
592 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
593 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
594 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
595
596 %if %{with gnome}
597 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
598 %endif
599 %if %{with gtk}
600 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
601 %endif
602 %if %{with gnome} || %{with gtk}
603 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
604 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
605 EOF
606 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
607 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
608 EOF
609 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
610 %endif
611
612 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
613 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
614
615 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
616 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
617
618 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
619
620 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
621 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
622 EOF
623
624 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
625 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
626
627 %clean
628 rm -rf $RPM_BUILD_ROOT
629
630 %post clients
631 %env_update
632
633 %postun clients
634 %env_update
635
636 %post gnome-askpass
637 %env_update
638
639 %postun gnome-askpass
640 %env_update
641
642 %pre server
643 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
644
645 %post server
646 /sbin/chkconfig --add sshd
647 %service sshd reload "openssh daemon"
648 if ! grep -qs ssh /etc/security/passwd.conf ; then
649         umask 022
650         echo "ssh" >> /etc/security/passwd.conf
651 fi
652
653 %preun server
654 if [ "$1" = "0" ]; then
655         %service sshd stop
656         /sbin/chkconfig --del sshd
657 fi
658
659 %postun server
660 if [ "$1" = "0" ]; then
661         %userremove sshd
662 fi
663
664 %triggerpostun server -- %{name}-server < 2:5.9p1-1
665 # lpk.patch to ldap.patch
666 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
667         echo >&2 "Migrating LPK patch to LDAP patch"
668         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
669         %{__sed} -i -e '
670                 # disable old configs
671                 # just UseLPK/LkpLdapConf supported for now
672                 s/^UseLPK/## Obsolete &/
673                 s/^Lpk/## Obsolete &/
674                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
675                 /UseLPK/iAuthorizedKeysCommand "%{_libexecdir}/ssh-ldap-wrapper"
676         ' %{_sysconfdir}/sshd_config
677 fi
678
679 %post server-upstart
680 %upstart_post sshd
681
682 %postun server-upstart
683 %upstart_postun sshd
684
685 %post -n openldap-schema-openssh-lpk
686 %openldap_schema_register %{schemadir}/openssh-lpk.schema
687 %service -q ldap restart
688
689 %postun -n openldap-schema-openssh-lpk
690 if [ "$1" = "0" ]; then
691         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
692         %service -q ldap restart
693 fi
694
695 %files
696 %defattr(644,root,root,755)
697 %doc TODO README OVERVIEW CREDITS Change*
698 %attr(755,root,root) %{_bindir}/ssh-key*
699 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
700 %{_mandir}/man1/ssh-key*.1*
701 %{_mandir}/man1/ssh-vulnkey*.1*
702 %dir %{_sysconfdir}
703 %dir %{_libexecdir}
704
705 %files clients
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_bindir}/ssh
708 %attr(755,root,root) %{_bindir}/slogin
709 %attr(755,root,root) %{_bindir}/sftp
710 %attr(755,root,root) %{_bindir}/ssh-agent
711 %attr(755,root,root) %{_bindir}/ssh-add
712 %attr(755,root,root) %{_bindir}/ssh-copy-id
713 %attr(755,root,root) %{_bindir}/scp
714 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
715 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
716 %{_mandir}/man1/scp.1*
717 %{_mandir}/man1/ssh.1*
718 %{_mandir}/man1/slogin.1*
719 %{_mandir}/man1/sftp.1*
720 %{_mandir}/man1/ssh-agent.1*
721 %{_mandir}/man1/ssh-add.1*
722 %{_mandir}/man1/ssh-copy-id.1*
723 %{_mandir}/man5/ssh_config.5*
724 %lang(it) %{_mandir}/it/man1/ssh.1*
725 %lang(it) %{_mandir}/it/man5/ssh_config.5*
726 %lang(pl) %{_mandir}/pl/man1/scp.1*
727 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
728
729 # for host-based auth (suid required for accessing private host key)
730 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
731 #%{_mandir}/man8/ssh-keysign.8*
732
733 %files clients-agent-profile_d
734 %defattr(644,root,root,755)
735 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
736 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
737
738 %files clients-agent-xinitrc
739 %defattr(644,root,root,755)
740 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
741
742 %files server
743 %defattr(644,root,root,755)
744 %doc HOWTO.ldap-keys ldap.conf
745 %attr(755,root,root) %{_sbindir}/sshd
746 %attr(755,root,root) %{_libexecdir}/sftp-server
747 %attr(755,root,root) %{_libexecdir}/ssh-keysign
748 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
749 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
750 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
751 %{_mandir}/man8/sshd.8*
752 %{_mandir}/man8/sftp-server.8*
753 %{_mandir}/man8/ssh-keysign.8*
754 %{_mandir}/man8/ssh-ldap-helper.8*
755 %{_mandir}/man8/ssh-pkcs11-helper.8*
756 %{_mandir}/man5/sshd_config.5*
757 %{_mandir}/man5/ssh-ldap.conf.5*
758 %{_mandir}/man5/moduli.5*
759 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
760 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
761 %attr(640,root,root) %{_sysconfdir}/moduli
762 %attr(754,root,root) /etc/rc.d/init.d/sshd
763 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
764 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
765
766 %if %{with gnome} || %{with gtk}
767 %files gnome-askpass
768 %defattr(644,root,root,755)
769 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
770 %dir %{_libexecdir}/ssh
771 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
772 %attr(755,root,root) %{_libexecdir}/ssh-askpass
773 %endif
774
775 %if %{with ldap}
776 %files -n openldap-schema-openssh-lpk
777 %defattr(644,root,root,755)
778 %{schemadir}/openssh-lpk.schema
779 %endif
780
781 %if "%{pld_release}" != "ti"
782 %files server-upstart
783 %defattr(644,root,root,755)
784 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
785 %endif
This page took 0.134608 seconds and 3 git commands to generate.