]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
use -std=gnu99
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15 %bcond_without  tests
16
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19
20 %if "%{pld_release}" == "ac"
21 %define         pam_ver 0.79.0
22 %else
23 %define         pam_ver 1:1.1.5-5
24 %endif
25 Summary:        OpenSSH free Secure Shell (SSH) implementation
26 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
27 Summary(es.UTF-8):      Implementación libre de SSH
28 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
29 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
30 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
31 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
32 Summary(pt_BR.UTF-8):   Implementação livre do SSH
33 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
34 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
35 Name:           openssh
36 Version:        6.6p1
37 Release:        2
38 Epoch:          2
39 License:        BSD
40 Group:          Applications/Networking
41 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
42 # Source0-md5:  3e9800e6bca1fbac0eea4d41baa7f239
43 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
44 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
45 Source2:        %{name}d.init
46 Source3:        %{name}d.pamd
47 Source4:        %{name}.sysconfig
48 Source5:        ssh-agent.sh
49 Source6:        ssh-agent.conf
50 Source7:        %{name}-lpk.schema
51 Source8:        %{name}d.upstart
52 Source9:        sshd.service
53 Source10:       sshd-keygen
54 Source11:       sshd.socket
55 Source12:       sshd@.service
56 Patch0:         %{name}-no_libnsl.patch
57 Patch2:         %{name}-pam_misc.patch
58 Patch3:         %{name}-sigpipe.patch
59 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
60 Patch4:         %{name}-ldap.patch
61 Patch5:         %{name}-ldap-fixes.patch
62 Patch6:         ldap.conf.patch
63 Patch7:         %{name}-config.patch
64 Patch8:         ldap-helper-sigpipe.patch
65 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
66 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
67 Patch9:         %{name}-5.2p1-hpn13v6.diff
68 Patch10:        %{name}-include.patch
69 Patch11:        %{name}-chroot.patch
70
71 Patch14:        %{name}-bind.patch
72 Patch15:        %{name}-disable_ldap.patch
73 URL:            http://www.openssh.com/portable.html
74 BuildRequires:  %{__perl}
75 %{?with_tests:BuildRequires:    %{name}-server}
76 %{?with_audit:BuildRequires:    audit-libs-devel}
77 BuildRequires:  autoconf >= 2.50
78 BuildRequires:  automake
79 %{?with_gnome:BuildRequires:    gnome-libs-devel}
80 %{?with_gtk:BuildRequires:      gtk+2-devel}
81 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
82 %{?with_libedit:BuildRequires:  libedit-devel}
83 %{?with_selinux:BuildRequires:  libselinux-devel}
84 BuildRequires:  libwrap-devel
85 %{?with_ldap:BuildRequires:     openldap-devel}
86 BuildRequires:  openssl-devel >= 0.9.7d
87 BuildRequires:  pam-devel
88 %{?with_gtk:BuildRequires:      pkgconfig}
89 BuildRequires:  rpm >= 4.4.9-56
90 BuildRequires:  rpmbuild(macros) >= 1.627
91 BuildRequires:  sed >= 4.0
92 BuildRequires:  zlib-devel >= 1.2.3
93 Requires:       zlib >= 1.2.3
94 %if "%{pld_release}" == "ac"
95 Requires:       filesystem >= 2.0-1
96 Requires:       pam >= 0.79.0
97 %else
98 Requires:       filesystem >= 3.0-11
99 Requires:       pam >= %{pam_ver}
100 Suggests:       xorg-app-xauth
101 %endif
102 Obsoletes:      ssh
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _sysconfdir     /etc/ssh
106 %define         _libexecdir     %{_libdir}/%{name}
107 %define         _privsepdir     /usr/share/empty
108 %define         schemadir       /usr/share/openldap/schema
109
110 %description
111 Ssh (Secure Shell) a program for logging into a remote machine and for
112 executing commands in a remote machine. It is intended to replace
113 rlogin and rsh, and provide secure encrypted communications between
114 two untrusted hosts over an insecure network. X11 connections and
115 arbitrary TCP/IP ports can also be forwarded over the secure channel.
116
117 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
118 it up to date in terms of security and features, as well as removing
119 all patented algorithms to seperate libraries (OpenSSL).
120
121 This package includes the core files necessary for both the OpenSSH
122 client and server. To make this package useful, you should also
123 install openssh-clients, openssh-server, or both.
124
125 %if %{with hpn}
126 This release includes High Performance SSH/SCP patches from
127 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
128 increase throughput on fast connections with high RTT (20-150 msec).
129 See the website for '-w' values for your connection and /proc/sys TCP
130 values. BTW. in a LAN you have got generally RTT < 1 msec.
131 %endif
132
133 %description -l de.UTF-8
134 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
135 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
136 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
137 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
138 andere TCP/IP Ports können ebenso über den sicheren Channel
139 weitergeleitet werden.
140
141 %description -l es.UTF-8
142 SSH es un programa para accesar y ejecutar órdenes en computadores
143 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
144 seguro entre dos servidores en una red insegura. Conexiones X11 y
145 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
146 seguro.
147
148 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
149 continuar la última versión gratuita de SSH, actualizándolo en
150 términos de seguridad y recursos,así también eliminando todos los
151 algoritmos patentados y colocándolos en bibliotecas separadas
152 (OpenSSL).
153
154 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
155 también el paquete openssh-clients u openssh-server o ambos.
156
157 %description -l fr.UTF-8
158 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
159 remplace telnet, rlogin, rexec et rsh, tout en assurant des
160 communications cryptées securisées entre deux hôtes non fiabilisés sur
161 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
162 arbitraires peuvent également être transmis sur le canal sécurisé.
163
164 %description -l it.UTF-8
165 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
166 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
167 sicure e crittate tra due host non fidati su una rete non sicura. Le
168 connessioni X11 ad una porta TCP/IP arbitraria possono essere
169 inoltrate attraverso un canale sicuro.
170
171 %description -l pl.UTF-8
172 Ssh (Secure Shell) to program służący do logowania się na zdalną
173 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
174 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
175 pomiędzy dwoma hostami.
176
177 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
178 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
179 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
180
181 %if %{with hpn}
182 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
183 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
184 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
185 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
186 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
187 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
188 %endif
189
190 %description -l pt.UTF-8
191 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
192 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
193 cifradas entre duas máquinas sem confiança mútua sobre uma rede
194 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
195 reenviados pelo canal seguro.
196
197 %description -l pt_BR.UTF-8
198 SSH é um programa para acessar e executar comandos em máquinas
199 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
200 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
201 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
202
203 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
204 última versão gratuita do SSH, atualizando-o em termos de segurança e
205 recursos, assim como removendo todos os algoritmos patenteados e
206 colocando-os em bibliotecas separadas (OpenSSL).
207
208 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
209 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
210
211 %description -l ru.UTF-8
212 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
213 машину и для выполнения команд на удаленной машине. Она предназначена
214 для замены rlogin и rsh и обеспечивает безопасную шифрованную
215 коммуникацию между двумя хостами в сети, являющейся небезопасной.
216 Соединения X11 и любые порты TCP/IP могут также быть проведены через
217 безопасный канал.
218
219 OpenSSH - это переделка командой разработчиков OpenBSD последней
220 свободной версии SSH, доведенная до современного состояния в терминах
221 уровня безопасности и поддерживаемых возможностей. Все патентованные
222 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
223
224 Этот пакет содержит файлы, необходимые как для клиента, так и для
225 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
226 openssh-server, или оба пакета.
227
228 %description -l uk.UTF-8
229 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
230 машини та для виконання команд на віддаленій машині. Вона призначена
231 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
232 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
233 довільні порти TCP/IP можуть також бути проведені через безпечний
234 канал.
235
236 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
237 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
238 підтримуваних можливостей. Всі патентовані алгоритми винесені до
239 окремих бібліотек (OpenSSL).
240
241 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
242 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
243 openssh-server, чи обидва пакети.
244
245 %package clients
246 Summary:        OpenSSH Secure Shell protocol clients
247 Summary(es.UTF-8):      Clientes de OpenSSH
248 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
249 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
250 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
251 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
252 Group:          Applications/Networking
253 Requires:       %{name}
254 Provides:       ssh-clients
255 Obsoletes:      ssh-clients
256 %requires_eq_to openssl openssl-devel
257
258 %description clients
259 Ssh (Secure Shell) a program for logging into a remote machine and for
260 executing commands in a remote machine. It is intended to replace
261 rlogin and rsh, and provide secure encrypted communications between
262 two untrusted hosts over an insecure network. X11 connections and
263 arbitrary TCP/IP ports can also be forwarded over the secure channel.
264
265 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
266 it up to date in terms of security and features, as well as removing
267 all patented algorithms to seperate libraries (OpenSSL).
268
269 This package includes the clients necessary to make encrypted
270 connections to SSH servers.
271
272 %description clients -l es.UTF-8
273 Este paquete incluye los clientes que se necesitan para hacer
274 conexiones codificadas con servidores SSH.
275
276 %description clients -l pl.UTF-8
277 Ssh (Secure Shell) to program służący do logowania się na zdalną
278 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
279 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
280 pomiędzy dwoma hostami.
281
282 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
283
284 %description clients -l pt_BR.UTF-8
285 Esse pacote inclui os clientes necessários para fazer conexões
286 encriptadas com servidores SSH.
287
288 %description clients -l ru.UTF-8
289 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
290 машину и для выполнения команд на удаленной машине.
291
292 Этот пакет содержит программы-клиенты, необходимые для установления
293 зашифрованных соединений с серверами SSH.
294
295 %description clients -l uk.UTF-8
296 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
297 машини та для виконання команд на віддаленій машині.
298
299 Цей пакет містить програми-клієнти, необхідні для встановлення
300 зашифрованих з'єднань з серверами SSH.
301
302 %package clients-agent-profile_d
303 Summary:        OpenSSH Secure Shell agent init script
304 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
305 Group:          Applications/Networking
306 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
307
308 %description clients-agent-profile_d
309 profile.d scripts for starting SSH agent.
310
311 %description clients-agent-profile_d -l pl.UTF-8
312 Skrypty profile.d do uruchamiania agenta SSH.
313
314 %package clients-agent-xinitrc
315 Summary:        OpenSSH Secure Shell agent init script
316 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
317 Group:          Applications/Networking
318 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
319 Requires:       xinitrc
320
321 %description clients-agent-xinitrc
322 xinitrc scripts for starting SSH agent.
323
324 %description clients-agent-xinitrc -l pl.UTF-8
325 Skrypty xinitrc do uruchamiania agenta SSH.
326
327 %package server
328 Summary:        OpenSSH Secure Shell protocol server (sshd)
329 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
330 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
331 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
332 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
333 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
334 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
335 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
336 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
337 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
338 Group:          Networking/Daemons
339 Requires(post): /sbin/chkconfig
340 Requires(post): grep
341 Requires(post,preun):   /sbin/chkconfig
342 Requires(postun):       /usr/sbin/userdel
343 Requires(pre):  /bin/id
344 Requires(pre):  /usr/sbin/useradd
345 Requires(post,preun,postun):    systemd-units >= 38
346 Requires:       %{name} = %{epoch}:%{version}-%{release}
347 Requires:       pam >= %{pam_ver}
348 Requires:       rc-scripts >= 0.4.3.0
349 Requires:       systemd-units >= 38
350 Requires:       util-linux
351 %{?with_ldap:Suggests:  %{name}-server-ldap}
352 Suggests:       /bin/login
353 Suggests:       xorg-app-xauth
354 Provides:       ssh-server
355 Provides:       user(sshd)
356 %requires_eq_to openssl openssl-devel
357
358 %description server
359 Ssh (Secure Shell) a program for logging into a remote machine and for
360 executing commands in a remote machine. It is intended to replace
361 rlogin and rsh, and provide secure encrypted communications between
362 two untrusted hosts over an insecure network. X11 connections and
363 arbitrary TCP/IP ports can also be forwarded over the secure channel.
364
365 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
366 it up to date in terms of security and features, as well as removing
367 all patented algorithms to seperate libraries (OpenSSL).
368
369 This package contains the secure shell daemon. The sshd is the server
370 part of the secure shell protocol and allows ssh clients to connect to
371 your host.
372
373 %description server -l de.UTF-8
374 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
375
376 %description server -l es.UTF-8
377 Este paquete contiene el servidor SSH. sshd es la parte servidor del
378 protocolo secure shell y permite que clientes ssh se conecten a su
379 servidor.
380
381 %description server -l fr.UTF-8
382 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
383
384 %description server -l it.UTF-8
385 Questo pacchetto installa sshd, il server di OpenSSH.
386
387 %description server -l pl.UTF-8
388 Ssh (Secure Shell) to program służący do logowania się na zdalną
389 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
390 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
391 pomiędzy dwoma hostami.
392
393 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
394 ssh).
395
396 %description server -l pt.UTF-8
397 Este pacote intala o sshd, o servidor do OpenSSH.
398
399 %description server -l pt_BR.UTF-8
400 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
401 protocolo secure shell e permite que clientes ssh se conectem ao seu
402 host.
403
404 %description server -l ru.UTF-8
405 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
406 машину и для выполнения команд на удаленной машине.
407
408 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
409 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
410 вашим хостом.
411
412 %description server -l uk.UTF-8
413 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
414 машини та для виконання команд на віддаленій машині.
415
416 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
417 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
418 з вашим хостом.
419
420 %package server-ldap
421 Summary:        A LDAP support for open source SSH server daemon
422 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
423 Group:          Daemons
424 Requires:       %{name} = %{epoch}:%{version}-%{release}
425 Requires:       openldap-nss-config
426
427 %description server-ldap
428 OpenSSH LDAP backend is a way how to distribute the authorized tokens
429 among the servers in the network.
430
431 %description server-ldap -l pl.UTF-8
432 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
433 tokenów między serwerami w sieci.
434
435 %package server-upstart
436 Summary:        Upstart job description for OpenSSH server
437 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
438 Group:          Daemons
439 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
440 Requires:       upstart >= 0.6
441 Conflicts:      syslog-ng < 3.2.4-1
442
443 %description server-upstart
444 Upstart job description for OpenSSH.
445
446 %description server-upstart -l pl.UTF-8
447 Opis zadania Upstart dla OpenSSH.
448
449 %package gnome-askpass
450 Summary:        OpenSSH GNOME passphrase dialog
451 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
452 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
453 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
454 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
455 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
456 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
457 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
458 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
459 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
460 Group:          Applications/Networking
461 Requires:       %{name} = %{epoch}:%{version}-%{release}
462 Obsoletes:      openssh-askpass
463 Obsoletes:      ssh-askpass
464 Obsoletes:      ssh-extras
465
466 %description gnome-askpass
467 Ssh (Secure Shell) a program for logging into a remote machine and for
468 executing commands in a remote machine. It is intended to replace
469 rlogin and rsh, and provide secure encrypted communications between
470 two untrusted hosts over an insecure network. X11 connections and
471 arbitrary TCP/IP ports can also be forwarded over the secure channel.
472
473 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
474 it up to date in terms of security and features, as well as removing
475 all patented algorithms to seperate libraries (OpenSSL).
476
477 This package contains the GNOME passphrase dialog.
478
479 %description gnome-askpass -l es.UTF-8
480 Este paquete contiene un programa que abre una caja de diálogo para
481 entrada de passphrase en GNOME.
482
483 %description gnome-askpass -l pl.UTF-8
484 Ssh (Secure Shell) to program służący do logowania się na zdalną
485 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
486 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
487 pomiędzy dwoma hostami.
488
489 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
490
491 %description gnome-askpass -l pt_BR.UTF-8
492 Esse pacote contém um programa que abre uma caixa de diálogo para
493 entrada de passphrase no GNOME.
494
495 %description gnome-askpass -l ru.UTF-8
496 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
497 машину и для выполнения команд на удаленной машине.
498
499 Этот пакет содержит диалог ввода ключевой фразы для использования под
500 GNOME.
501
502 %description gnome-askpass -l uk.UTF-8
503 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
504 машини та для виконання команд на віддаленій машині.
505
506 Цей пакет містить діалог вводу ключової фрази для використання під
507 GNOME.
508
509 %package -n openldap-schema-openssh-lpk
510 Summary:        OpenSSH LDAP Public Key schema
511 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
512 Group:          Networking/Daemons
513 Requires(post,postun):  sed >= 4.0
514 Requires:       openldap-servers
515 %if "%{_rpmversion}" >= "5"
516 BuildArch:      noarch
517 %endif
518
519 %description -n openldap-schema-openssh-lpk
520 This package contains OpenSSH LDAP Public Key schema for openldap.
521
522 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
523 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
524 openldap-a.
525
526 %prep
527 %setup -q
528 %patch0 -p1
529 %patch2 -p1
530 %patch3 -p1
531 %patch4 -p1
532 %patch5 -p1
533 %patch6 -p1
534 %patch7 -p1
535 %patch8 -p1
536
537 %{?with_hpn:%patch9 -p1}
538 %patch10 -p1
539 %patch11 -p1
540
541 %patch14 -p1
542 %{!?with_ldap:%patch15 -p1}
543
544 %if "%{pld_release}" == "ac"
545 # fix for missing x11.pc
546 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
547 %endif
548
549 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
550 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
551
552 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
553 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
554
555 %build
556 cp /usr/share/automake/config.sub .
557 %{__aclocal}
558 %{__autoconf}
559 %{__autoheader}
560 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
561 %configure \
562         PERL=%{__perl} \
563         --disable-strip \
564         --enable-utmpx \
565         --enable-wtmpx \
566         --with-4in6 \
567         %{?with_audit:--with-audit=linux} \
568         --with-ipaddr-display \
569         %{?with_kerberos5:--with-kerberos5=/usr} \
570         --with-ldap%{!?with_ldap:=no} \
571         %{?with_libedit:--with-libedit} \
572         --with-mantype=man \
573         --with-md5-passwords \
574         --with-pam \
575         --with-pid-dir=%{_localstatedir}/run \
576         --with-privsep-path=%{_privsepdir} \
577 %if "%{pld_release}" != "ac"
578         --with-sandbox=seccomp_filter \
579 %endif
580         %{?with_selinux:--with-selinux} \
581         --with-tcp-wrappers \
582 %if "%{pld_release}" == "ac"
583         --with-xauth=/usr/X11R6/bin/xauth
584 %else
585         --with-xauth=%{_bindir}/xauth
586 %endif
587
588 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
589
590 %{__make}
591
592 %{?with_tests:%{__make} tests}
593
594 cd contrib
595 %if %{with gnome}
596 %{__make} gnome-ssh-askpass1 \
597         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
598 %endif
599 %if %{with gtk}
600 %{__make} gnome-ssh-askpass2 \
601         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
602 %endif
603
604 %install
605 rm -rf $RPM_BUILD_ROOT
606 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
607         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
608 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
609
610 %{__make} install \
611         DESTDIR=$RPM_BUILD_ROOT
612
613 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
614
615 cp -p %{SOURCE3} sshd.pam
616 install -p %{SOURCE2} sshd.init
617
618 %if "%{pld_release}" == "ac"
619 # not present in ac, no point searching it
620 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
621 # openssl on ac does not have OPENSSL_HAS_ECC
622 %{__sed} -i -e '/ecdsa/d' sshd.init
623 %endif
624
625 %if %{without audit}
626 # remove recording user's login uid to the process attribute
627 %{__sed} -i -e '/pam_loginuid.so/d' sshd.pam
628 %endif
629
630 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
631 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
632 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
633 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
634 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
635 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
636 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
637 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
638
639 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
640 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
641
642 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
643 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
644
645 %if %{with gnome}
646 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
647 %endif
648 %if %{with gtk}
649 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
650 %endif
651 %if %{with gnome} || %{with gtk}
652 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
653 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
654 EOF
655 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
656 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
657 EOF
658 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
659 %endif
660
661 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
662 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
663
664 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
665 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
666
667 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
668
669 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
670 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
671 EOF
672
673 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
674 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
675
676 %clean
677 rm -rf $RPM_BUILD_ROOT
678
679 %post clients
680 %env_update
681
682 %postun clients
683 %env_update
684
685 %post gnome-askpass
686 %env_update
687
688 %postun gnome-askpass
689 %env_update
690
691 %pre server
692 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
693
694 %post server
695 /sbin/chkconfig --add sshd
696 %service sshd reload "OpenSSH Daemon"
697 NORESTART=1
698 %systemd_post sshd.service
699
700 %preun server
701 if [ "$1" = "0" ]; then
702         %service sshd stop
703         /sbin/chkconfig --del sshd
704 fi
705 %systemd_preun sshd.service
706
707 %postun server
708 if [ "$1" = "0" ]; then
709         %userremove sshd
710 fi
711 %systemd_reload
712
713 %triggerpostun server -- %{name}-server < 6.2p1-1
714 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
715 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
716
717 %triggerpostun server -- %{name}-server < 2:5.9p1-8
718 # lpk.patch to ldap.patch
719 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
720         echo >&2 "Migrating LPK patch to LDAP patch"
721         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
722         %{__sed} -i -e '
723                 # disable old configs
724                 # just UseLPK/LkpLdapConf supported for now
725                 s/^\s*UseLPK/## Obsolete &/
726                 s/^\s*Lpk/## Obsolete &/
727                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
728                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
729         ' %{_sysconfdir}/sshd_config
730         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
731                 /bin/systemctl try-restart sshd.service || :
732         else
733                 %service -q sshd reload
734         fi
735 fi
736 %systemd_trigger sshd.service
737 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
738 %banner %{name}-server -e << EOF
739 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
740 ! Native systemd support for sshd has been installed.   !
741 ! Restarting sshd.service with systemctl WILL kill all  !
742 ! active ssh sessions (daemon as such will be started). !
743 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
744 EOF
745 fi
746
747 %post server-upstart
748 %upstart_post sshd
749
750 %postun server-upstart
751 %upstart_postun sshd
752
753 %post -n openldap-schema-openssh-lpk
754 %openldap_schema_register %{schemadir}/openssh-lpk.schema
755 %service -q ldap restart
756
757 %postun -n openldap-schema-openssh-lpk
758 if [ "$1" = "0" ]; then
759         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
760         %service -q ldap restart
761 fi
762
763 %files
764 %defattr(644,root,root,755)
765 %doc TODO README OVERVIEW CREDITS Change*
766 %attr(755,root,root) %{_bindir}/ssh-key*
767 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
768 %{_mandir}/man1/ssh-key*.1*
769 #%{_mandir}/man1/ssh-vulnkey*.1*
770 %dir %{_sysconfdir}
771 %dir %{_libexecdir}
772
773 %files clients
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_bindir}/ssh
776 %attr(755,root,root) %{_bindir}/slogin
777 %attr(755,root,root) %{_bindir}/sftp
778 %attr(755,root,root) %{_bindir}/ssh-agent
779 %attr(755,root,root) %{_bindir}/ssh-add
780 %attr(755,root,root) %{_bindir}/ssh-copy-id
781 %attr(755,root,root) %{_bindir}/scp
782 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
783 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
784 %{_mandir}/man1/scp.1*
785 %{_mandir}/man1/ssh.1*
786 %{_mandir}/man1/slogin.1*
787 %{_mandir}/man1/sftp.1*
788 %{_mandir}/man1/ssh-agent.1*
789 %{_mandir}/man1/ssh-add.1*
790 %{_mandir}/man1/ssh-copy-id.1*
791 %{_mandir}/man5/ssh_config.5*
792 %lang(it) %{_mandir}/it/man1/ssh.1*
793 %lang(it) %{_mandir}/it/man5/ssh_config.5*
794 %lang(pl) %{_mandir}/pl/man1/scp.1*
795 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
796
797 # for host-based auth (suid required for accessing private host key)
798 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
799 #%{_mandir}/man8/ssh-keysign.8*
800
801 %files clients-agent-profile_d
802 %defattr(644,root,root,755)
803 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
804 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
805
806 %files clients-agent-xinitrc
807 %defattr(644,root,root,755)
808 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
809
810 %files server
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_sbindir}/sshd
813 %attr(755,root,root) %{_libexecdir}/sftp-server
814 %attr(755,root,root) %{_libexecdir}/ssh-keysign
815 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
816 %attr(755,root,root) %{_libexecdir}/sshd-keygen
817 %{_mandir}/man8/sshd.8*
818 %{_mandir}/man8/sftp-server.8*
819 %{_mandir}/man8/ssh-keysign.8*
820 %{_mandir}/man8/ssh-pkcs11-helper.8*
821 %{_mandir}/man5/sshd_config.5*
822 %{_mandir}/man5/moduli.5*
823 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
824 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
825 %attr(640,root,root) %{_sysconfdir}/moduli
826 %attr(754,root,root) /etc/rc.d/init.d/sshd
827 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
828 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
829 %{systemdunitdir}/sshd.service
830 %{systemdunitdir}/sshd.socket
831 %{systemdunitdir}/sshd@.service
832
833 %if %{with ldap}
834 %files server-ldap
835 %defattr(644,root,root,755)
836 %doc HOWTO.ldap-keys ldap.conf
837 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
838 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
839 %{_mandir}/man5/ssh-ldap.conf.5*
840 %{_mandir}/man8/ssh-ldap-helper.8*
841 %endif
842
843 %if %{with gnome} || %{with gtk}
844 %files gnome-askpass
845 %defattr(644,root,root,755)
846 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
847 %dir %{_libexecdir}/ssh
848 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
849 %attr(755,root,root) %{_libexecdir}/ssh-askpass
850 %endif
851
852 %if %{with ldap}
853 %files -n openldap-schema-openssh-lpk
854 %defattr(644,root,root,755)
855 %{schemadir}/openssh-lpk.schema
856 %endif
857
858 %if "%{pld_release}" != "ti"
859 %files server-upstart
860 %defattr(644,root,root,755)
861 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
862 %endif
This page took 0.15995 seconds and 3 git commands to generate.