]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
93d0f90a940f810d489361205b5514dc8b123a81
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # gnome-askpass (GTK+ 2.x) utility
10 %bcond_without  ldap            # LDAP support
11 %bcond_with     ldns            # DNSSEC support via libldns
12 %bcond_without  libedit         # libedit (editline/history support in sftp client)
13 %bcond_without  kerberos5       # Kerberos5 support
14 %bcond_without  selinux         # SELinux support
15 %bcond_without  libseccomp      # use libseccomp for seccomp privsep (requires 3.5 kernel)
16 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
17 %bcond_without  tests           # test suite
18 %bcond_with     tests_conch     # run conch interoperability tests
19
20 # gtk2-based gnome-askpass means no gnome1-based
21 %{?with_gtk:%undefine with_gnome}
22
23 %if "%{pld_release}" == "ac"
24 %define         pam_ver 0.79.0
25 %else
26 %define         pam_ver 1:1.1.8-5
27 %endif
28 Summary:        OpenSSH free Secure Shell (SSH) implementation
29 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
30 Summary(es.UTF-8):      Implementación libre de SSH
31 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
32 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
33 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
34 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
35 Summary(pt_BR.UTF-8):   Implementação livre do SSH
36 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
37 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
38 Name:           openssh
39 Version:        8.2p1
40 Release:        5
41 Epoch:          2
42 License:        BSD
43 Group:          Applications/Networking
44 Source0:        http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
45 # Source0-md5:  3076e6413e8dbe56d33848c1054ac091
46 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
47 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
48 Source2:        %{name}d.init
49 Source3:        %{name}d.pamd
50 Source4:        %{name}.sysconfig
51 Source5:        ssh-agent.sh
52 Source6:        ssh-agent.conf
53 Source7:        %{name}-lpk.schema
54 Source9:        sshd.service
55 Source10:       sshd-keygen
56 Source11:       sshd.socket
57 Source12:       sshd@.service
58 Patch0:         %{name}-no-pty-tests.patch
59 Patch1:         %{name}-tests-reuseport.patch
60 Patch2:         %{name}-pam_misc.patch
61 Patch3:         %{name}-sigpipe.patch
62 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
63 Patch4:         %{name}-ldap.patch
64 Patch5:         %{name}-ldap-fixes.patch
65 Patch6:         ldap.conf.patch
66 Patch7:         %{name}-config.patch
67 Patch8:         ldap-helper-sigpipe.patch
68 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
69 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
70 Patch9:         %{name}-5.2p1-hpn13v6.diff
71
72 Patch11:        %{name}-chroot.patch
73 Patch12:        openssh-bug-2905.patch
74 Patch13:        %{name}-skip-interop-tests.patch
75 Patch14:        %{name}-bind.patch
76 Patch15:        %{name}-disable_ldap.patch
77 URL:            http://www.openssh.com/portable.html
78 BuildRequires:  %{__perl}
79 %{?with_audit:BuildRequires:    audit-libs-devel}
80 BuildRequires:  autoconf >= 2.50
81 BuildRequires:  automake
82 %{?with_gnome:BuildRequires:    gnome-libs-devel}
83 %{?with_gtk:BuildRequires:      gtk+2-devel}
84 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
85 %{?with_ldns:BuildRequires:     ldns-devel}
86 %{?with_libedit:BuildRequires:  libedit-devel}
87 BuildRequires:  libfido2-devel
88 BuildRequires:  libseccomp-devel
89 %{?with_selinux:BuildRequires:  libselinux-devel}
90 %{?with_ldap:BuildRequires:     openldap-devel}
91 BuildRequires:  openssl-devel >= 1.1.0g
92 BuildRequires:  pam-devel
93 %{?with_gtk:BuildRequires:      pkgconfig}
94 %if %{with tests} && %{with tests_conch}
95 BuildRequires:  python-TwistedConch
96 %endif
97 BuildRequires:  rpm >= 4.4.9-56
98 BuildRequires:  rpmbuild(macros) >= 1.627
99 BuildRequires:  sed >= 4.0
100 BuildRequires:  zlib-devel >= 1.2.3
101 %if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
102 BuildRequires:  %{name}-server
103 %endif
104 %if %{with tests} && %{with libseccomp}
105 # libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
106 BuildRequires:  uname(release) >= 3.5
107 %endif
108 Requires:       zlib >= 1.2.3
109 %if "%{pld_release}" == "ac"
110 Requires:       filesystem >= 2.0-1
111 Requires:       pam >= 0.79.0
112 %else
113 Requires:       filesystem >= 3.0-11
114 Requires:       pam >= %{pam_ver}
115 Suggests:       xorg-app-xauth
116 %endif
117 Obsoletes:      ssh
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %define         _sysconfdir     /etc/ssh
121 %define         _libexecdir     %{_libdir}/%{name}
122 %define         _privsepdir     /usr/share/empty
123 %define         schemadir       /usr/share/openldap/schema
124
125 %description
126 Ssh (Secure Shell) a program for logging into a remote machine and for
127 executing commands in a remote machine. It is intended to replace
128 rlogin and rsh, and provide secure encrypted communications between
129 two untrusted hosts over an insecure network. X11 connections and
130 arbitrary TCP/IP ports can also be forwarded over the secure channel.
131
132 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
133 it up to date in terms of security and features, as well as removing
134 all patented algorithms to seperate libraries (OpenSSL).
135
136 This package includes the core files necessary for both the OpenSSH
137 client and server. To make this package useful, you should also
138 install openssh-clients, openssh-server, or both.
139
140 %if %{with hpn}
141 This release includes High Performance SSH/SCP patches from
142 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
143 increase throughput on fast connections with high RTT (20-150 msec).
144 See the website for '-w' values for your connection and /proc/sys TCP
145 values. BTW. in a LAN you have got generally RTT < 1 msec.
146 %endif
147
148 %description -l de.UTF-8
149 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
150 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
151 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
152 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
153 andere TCP/IP Ports können ebenso über den sicheren Channel
154 weitergeleitet werden.
155
156 %description -l es.UTF-8
157 SSH es un programa para accesar y ejecutar órdenes en computadores
158 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
159 seguro entre dos servidores en una red insegura. Conexiones X11 y
160 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
161 seguro.
162
163 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
164 continuar la última versión gratuita de SSH, actualizándolo en
165 términos de seguridad y recursos,así también eliminando todos los
166 algoritmos patentados y colocándolos en bibliotecas separadas
167 (OpenSSL).
168
169 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
170 también el paquete openssh-clients u openssh-server o ambos.
171
172 %description -l fr.UTF-8
173 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
174 remplace telnet, rlogin, rexec et rsh, tout en assurant des
175 communications cryptées securisées entre deux hôtes non fiabilisés sur
176 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
177 arbitraires peuvent également être transmis sur le canal sécurisé.
178
179 %description -l it.UTF-8
180 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
181 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
182 sicure e crittate tra due host non fidati su una rete non sicura. Le
183 connessioni X11 ad una porta TCP/IP arbitraria possono essere
184 inoltrate attraverso un canale sicuro.
185
186 %description -l pl.UTF-8
187 Ssh (Secure Shell) to program służący do logowania się na zdalną
188 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
189 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
190 pomiędzy dwoma hostami.
191
192 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
193 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
194 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
195
196 %if %{with hpn}
197 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
198 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
199 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
200 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
201 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
202 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
203 %endif
204
205 %description -l pt.UTF-8
206 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
207 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
208 cifradas entre duas máquinas sem confiança mútua sobre uma rede
209 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
210 reenviados pelo canal seguro.
211
212 %description -l pt_BR.UTF-8
213 SSH é um programa para acessar e executar comandos em máquinas
214 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
215 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
216 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
217
218 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
219 última versão gratuita do SSH, atualizando-o em termos de segurança e
220 recursos, assim como removendo todos os algoritmos patenteados e
221 colocando-os em bibliotecas separadas (OpenSSL).
222
223 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
224 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
225
226 %description -l ru.UTF-8
227 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
228 машину и для выполнения команд на удаленной машине. Она предназначена
229 для замены rlogin и rsh и обеспечивает безопасную шифрованную
230 коммуникацию между двумя хостами в сети, являющейся небезопасной.
231 Соединения X11 и любые порты TCP/IP могут также быть проведены через
232 безопасный канал.
233
234 OpenSSH - это переделка командой разработчиков OpenBSD последней
235 свободной версии SSH, доведенная до современного состояния в терминах
236 уровня безопасности и поддерживаемых возможностей. Все патентованные
237 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
238
239 Этот пакет содержит файлы, необходимые как для клиента, так и для
240 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
241 openssh-server, или оба пакета.
242
243 %description -l uk.UTF-8
244 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
245 машини та для виконання команд на віддаленій машині. Вона призначена
246 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
247 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
248 довільні порти TCP/IP можуть також бути проведені через безпечний
249 канал.
250
251 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
252 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
253 підтримуваних можливостей. Всі патентовані алгоритми винесені до
254 окремих бібліотек (OpenSSL).
255
256 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
257 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
258 openssh-server, чи обидва пакети.
259
260 %package clients
261 Summary:        OpenSSH Secure Shell protocol clients
262 Summary(es.UTF-8):      Clientes de OpenSSH
263 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
264 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
265 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
266 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
267 Group:          Applications/Networking
268 Requires:       %{name}
269 Suggests:       %{name}-clients-helper-fido = %{epoch}:%{version}-%{release}
270 Provides:       ssh-clients
271 Obsoletes:      ssh-clients
272 %requires_eq_to openssl openssl-devel
273
274 %description clients
275 Ssh (Secure Shell) a program for logging into a remote machine and for
276 executing commands in a remote machine. It is intended to replace
277 rlogin and rsh, and provide secure encrypted communications between
278 two untrusted hosts over an insecure network. X11 connections and
279 arbitrary TCP/IP ports can also be forwarded over the secure channel.
280
281 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
282 it up to date in terms of security and features, as well as removing
283 all patented algorithms to seperate libraries (OpenSSL).
284
285 This package includes the clients necessary to make encrypted
286 connections to SSH servers.
287
288 %description clients -l es.UTF-8
289 Este paquete incluye los clientes que se necesitan para hacer
290 conexiones codificadas con servidores SSH.
291
292 %description clients -l pl.UTF-8
293 Ssh (Secure Shell) to program służący do logowania się na zdalną
294 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
295 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
296 pomiędzy dwoma hostami.
297
298 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
299
300 %description clients -l pt_BR.UTF-8
301 Esse pacote inclui os clientes necessários para fazer conexões
302 encriptadas com servidores SSH.
303
304 %description clients -l ru.UTF-8
305 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
306 машину и для выполнения команд на удаленной машине.
307
308 Этот пакет содержит программы-клиенты, необходимые для установления
309 зашифрованных соединений с серверами SSH.
310
311 %description clients -l uk.UTF-8
312 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
313 машини та для виконання команд на віддаленій машині.
314
315 Цей пакет містить програми-клієнти, необхідні для встановлення
316 зашифрованих з'єднань з серверами SSH.
317
318 %package clients-agent-profile_d
319 Summary:        OpenSSH Secure Shell agent init script
320 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
321 Group:          Applications/Networking
322 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
323
324 %description clients-agent-profile_d
325 profile.d scripts for starting SSH agent.
326
327 %description clients-agent-profile_d -l pl.UTF-8
328 Skrypty profile.d do uruchamiania agenta SSH.
329
330 %package clients-agent-xinitrc
331 Summary:        OpenSSH Secure Shell agent init script
332 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
333 Group:          Applications/Networking
334 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
335 Requires:       xinitrc
336
337 %description clients-agent-xinitrc
338 xinitrc scripts for starting SSH agent.
339
340 %description clients-agent-xinitrc -l pl.UTF-8
341 Skrypty xinitrc do uruchamiania agenta SSH.
342
343 %package clients-helper-fido
344 Summary:        OpenSSH helper for FIDO authenticator
345 Summary(pl.UTF-8):      OpenSSH helper obsługujący klucz autoryzujący FIDO
346 Group:          Applications/Networking
347 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
348
349 %description clients-helper-fido
350 OpenSSH helper for FIDO authenticator.
351
352 %description clients-helper-fido -l pl.UTF-8
353 OpenSSH helper obsługujący klucz autoryzujący FIDO.
354
355 %package server
356 Summary:        OpenSSH Secure Shell protocol server (sshd)
357 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
358 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
359 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
360 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
361 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
362 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
363 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
364 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
365 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
366 Group:          Networking/Daemons
367 Requires(post): /sbin/chkconfig
368 Requires(post): grep
369 Requires(post,preun):   /sbin/chkconfig
370 Requires(postun):       /usr/sbin/userdel
371 Requires(pre):  /bin/id
372 Requires(pre):  /usr/sbin/useradd
373 Requires(post,preun,postun):    systemd-units >= 38
374 Requires:       %{name} = %{epoch}:%{version}-%{release}
375 Requires:       pam >= %{pam_ver}
376 Requires:       rc-scripts >= 0.4.3.0
377 Requires:       systemd-units >= 38
378 %{?with_libseccomp:Requires:    uname(release) >= 3.5}
379 Requires:       util-linux
380 %{?with_ldap:Suggests:  %{name}-server-ldap}
381 Suggests:       /bin/login
382 Suggests:       xorg-app-xauth
383 Provides:       ssh-server
384 Provides:       user(sshd)
385 %requires_eq_to openssl openssl-devel
386
387 %description server
388 Ssh (Secure Shell) a program for logging into a remote machine and for
389 executing commands in a remote machine. It is intended to replace
390 rlogin and rsh, and provide secure encrypted communications between
391 two untrusted hosts over an insecure network. X11 connections and
392 arbitrary TCP/IP ports can also be forwarded over the secure channel.
393
394 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
395 it up to date in terms of security and features, as well as removing
396 all patented algorithms to seperate libraries (OpenSSL).
397
398 This package contains the secure shell daemon. The sshd is the server
399 part of the secure shell protocol and allows ssh clients to connect to
400 your host.
401
402 %description server -l de.UTF-8
403 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
404
405 %description server -l es.UTF-8
406 Este paquete contiene el servidor SSH. sshd es la parte servidor del
407 protocolo secure shell y permite que clientes ssh se conecten a su
408 servidor.
409
410 %description server -l fr.UTF-8
411 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
412
413 %description server -l it.UTF-8
414 Questo pacchetto installa sshd, il server di OpenSSH.
415
416 %description server -l pl.UTF-8
417 Ssh (Secure Shell) to program służący do logowania się na zdalną
418 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
419 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
420 pomiędzy dwoma hostami.
421
422 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
423 ssh).
424
425 %description server -l pt.UTF-8
426 Este pacote intala o sshd, o servidor do OpenSSH.
427
428 %description server -l pt_BR.UTF-8
429 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
430 protocolo secure shell e permite que clientes ssh se conectem ao seu
431 host.
432
433 %description server -l ru.UTF-8
434 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
435 машину и для выполнения команд на удаленной машине.
436
437 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
438 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
439 вашим хостом.
440
441 %description server -l uk.UTF-8
442 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
443 машини та для виконання команд на віддаленій машині.
444
445 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
446 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
447 з вашим хостом.
448
449 %package server-ldap
450 Summary:        A LDAP support for open source SSH server daemon
451 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
452 Group:          Daemons
453 Requires:       %{name} = %{epoch}:%{version}-%{release}
454 Requires:       openldap-nss-config
455
456 %description server-ldap
457 OpenSSH LDAP backend is a way how to distribute the authorized tokens
458 among the servers in the network.
459
460 %description server-ldap -l pl.UTF-8
461 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
462 tokenów między serwerami w sieci.
463
464 %package gnome-askpass
465 Summary:        OpenSSH GNOME passphrase dialog
466 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
467 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
468 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
469 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
470 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
471 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
472 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
473 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
474 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
475 Group:          Applications/Networking
476 Requires:       %{name} = %{epoch}:%{version}-%{release}
477 Obsoletes:      openssh-askpass
478 Obsoletes:      ssh-askpass
479 Obsoletes:      ssh-extras
480
481 %description gnome-askpass
482 Ssh (Secure Shell) a program for logging into a remote machine and for
483 executing commands in a remote machine. It is intended to replace
484 rlogin and rsh, and provide secure encrypted communications between
485 two untrusted hosts over an insecure network. X11 connections and
486 arbitrary TCP/IP ports can also be forwarded over the secure channel.
487
488 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
489 it up to date in terms of security and features, as well as removing
490 all patented algorithms to seperate libraries (OpenSSL).
491
492 This package contains the GNOME passphrase dialog.
493
494 %description gnome-askpass -l es.UTF-8
495 Este paquete contiene un programa que abre una caja de diálogo para
496 entrada de passphrase en GNOME.
497
498 %description gnome-askpass -l pl.UTF-8
499 Ssh (Secure Shell) to program służący do logowania się na zdalną
500 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
501 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
502 pomiędzy dwoma hostami.
503
504 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
505
506 %description gnome-askpass -l pt_BR.UTF-8
507 Esse pacote contém um programa que abre uma caixa de diálogo para
508 entrada de passphrase no GNOME.
509
510 %description gnome-askpass -l ru.UTF-8
511 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
512 машину и для выполнения команд на удаленной машине.
513
514 Этот пакет содержит диалог ввода ключевой фразы для использования под
515 GNOME.
516
517 %description gnome-askpass -l uk.UTF-8
518 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
519 машини та для виконання команд на віддаленій машині.
520
521 Цей пакет містить діалог вводу ключової фрази для використання під
522 GNOME.
523
524 %package -n openldap-schema-openssh-lpk
525 Summary:        OpenSSH LDAP Public Key schema
526 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
527 Group:          Networking/Daemons
528 Requires(post,postun):  sed >= 4.0
529 Requires:       openldap-servers
530 %if "%{_rpmversion}" >= "5"
531 BuildArch:      noarch
532 %endif
533
534 %description -n openldap-schema-openssh-lpk
535 This package contains OpenSSH LDAP Public Key schema for openldap.
536
537 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
538 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
539 openldap-a.
540
541 %prep
542 %setup -q
543 %patch0 -p1
544 %patch1 -p1
545 %patch2 -p1
546 %patch3 -p1
547 %patch4 -p1
548 %patch5 -p1
549 %patch6 -p1
550 %patch7 -p1
551 %patch8 -p1
552
553 %{?with_hpn:%patch9 -p1}
554
555 %patch11 -p1
556 %patch12 -p1
557 %patch13 -p1
558
559 %patch14 -p1
560 %{!?with_ldap:%patch15 -p1}
561
562 %if "%{pld_release}" == "ac"
563 # fix for missing x11.pc
564 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
565 %endif
566
567 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
568 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh -lopenbsd-compat#g' Makefile*
569
570 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
571 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
572
573 # prevent being ovewritten by aclocal calls
574 %{__mv} aclocal.m4 acinclude.m4
575
576 %build
577 cp /usr/share/automake/config.sub .
578 %{__aclocal}
579 %{__autoconf}
580 %{__autoheader}
581 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
582 %configure \
583         PERL=%{__perl} \
584         --disable-strip \
585         --enable-utmpx \
586         --enable-wtmpx \
587         --with-4in6 \
588         %{?with_audit:--with-audit=linux} \
589         --with-ipaddr-display \
590         %{?with_kerberos5:--with-kerberos5=/usr} \
591         --with-ldap%{!?with_ldap:=no} \
592         %{?with_ldns:--with-ldns} \
593         %{?with_libedit:--with-libedit} \
594         --with-mantype=man \
595         --with-md5-passwords \
596         --with-pam \
597         --with-pid-dir=%{_localstatedir}/run \
598         --with-privsep-path=%{_privsepdir} \
599         --with-privsep-user=sshd \
600         --with-security-key-builtin \
601         %{?with_selinux:--with-selinux} \
602 %if "%{pld_release}" == "ac"
603         --with-xauth=/usr/X11R6/bin/xauth
604 %else
605         --with-sandbox=seccomp_filter \
606         --with-xauth=%{_bindir}/xauth
607 %endif
608
609 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
610
611 %{__make}
612
613 %if %{with tests}
614 %{__make} -j1 tests \
615         TEST_SSH_PORT=$((4242 + ${RANDOM:-$$} % 1000)) \
616         TEST_SSH_TRACE="yes" \
617 %if %{without tests_conch}
618         SKIP_LTESTS="conch-ciphers"
619 %endif
620 %endif
621
622 cd contrib
623 %if %{with gnome}
624 %{__make} gnome-ssh-askpass1 \
625         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
626 %endif
627 %if %{with gtk}
628 %{__make} gnome-ssh-askpass2 \
629         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
630 %endif
631
632 %install
633 rm -rf $RPM_BUILD_ROOT
634 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
635         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
636 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
637
638 %{__make} install \
639         DESTDIR=$RPM_BUILD_ROOT
640
641 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
642
643 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
644 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
645 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
646 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
647 ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
648 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
649 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
650
651 cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
652 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
653
654 %{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
655         $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
656         $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
657         $RPM_BUILD_ROOT%{systemdunitdir}/sshd@.service \
658         $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
659
660 %if %{with gnome}
661 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
662 %endif
663 %if %{with gtk}
664 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
665 %endif
666 %if %{with gnome} || %{with gtk}
667 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
668 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
669 EOF
670 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
671 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
672 EOF
673 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
674 %endif
675
676 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
677 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
678
679 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
680
681 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
682 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
683 EOF
684
685 %if "%{pld_release}" == "ac"
686 # not present in ac, no point searching it
687 %{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
688 # openssl on ac does not have OPENSSL_HAS_ECC
689 %{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
690 %endif
691
692 %if %{without audit}
693 # remove recording user's login uid to the process attribute
694 %{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
695 %endif
696
697 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
698 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
699
700 %clean
701 rm -rf $RPM_BUILD_ROOT
702
703 %post clients
704 %env_update
705
706 %postun clients
707 %env_update
708
709 %post gnome-askpass
710 %env_update
711
712 %postun gnome-askpass
713 %env_update
714
715 %pre server
716 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
717
718 %post server
719 /sbin/chkconfig --add sshd
720 %service sshd reload "OpenSSH Daemon"
721 NORESTART=1
722 %systemd_post sshd.service
723
724 %preun server
725 if [ "$1" = "0" ]; then
726         %service sshd stop
727         /sbin/chkconfig --del sshd
728 fi
729 %systemd_preun sshd.service
730
731 %postun server
732 if [ "$1" = "0" ]; then
733         %userremove sshd
734 fi
735 %systemd_reload
736
737 %triggerpostun server -- %{name}-server < 2:7.0p1-2
738 %banner %{name}-server -e << EOF
739 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
740 ! Starting from openssh 7.0 DSA keys are disabled !
741 ! on server and client side. You will NOT be able !
742 ! to use DSA keys for authentication. Please read !
743 ! about PubkeyAcceptedKeyTypes in man ssh_config. !
744 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
745 EOF
746
747 %triggerpostun server -- %{name}-server < 6.2p1-1
748 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
749 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
750
751 %triggerpostun server -- %{name}-server < 2:5.9p1-8
752 # lpk.patch to ldap.patch
753 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
754         echo >&2 "Migrating LPK patch to LDAP patch"
755         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
756         %{__sed} -i -e '
757                 # disable old configs
758                 # just UseLPK/LkpLdapConf supported for now
759                 s/^\s*UseLPK/## Obsolete &/
760                 s/^\s*Lpk/## Obsolete &/
761                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
762                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
763         ' %{_sysconfdir}/sshd_config
764         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
765                 /bin/systemctl try-restart sshd.service || :
766         else
767                 %service -q sshd reload
768         fi
769 fi
770 %systemd_trigger sshd.service
771 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
772 %banner %{name}-server -e << EOF
773 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
774 ! Native systemd support for sshd has been installed.   !
775 ! Restarting sshd.service with systemctl WILL kill all  !
776 ! active ssh sessions (daemon as such will be started). !
777 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
778 EOF
779 fi
780
781 %post -n openldap-schema-openssh-lpk
782 %openldap_schema_register %{schemadir}/openssh-lpk.schema
783 %service -q ldap restart
784
785 %postun -n openldap-schema-openssh-lpk
786 if [ "$1" = "0" ]; then
787         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
788         %service -q ldap restart
789 fi
790
791 %files
792 %defattr(644,root,root,755)
793 %doc TODO README OVERVIEW CREDITS Change*
794 %attr(755,root,root) %{_bindir}/ssh-key*
795 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
796 %{_mandir}/man1/ssh-key*.1*
797 #%{_mandir}/man1/ssh-vulnkey*.1*
798 %dir %{_sysconfdir}
799 %dir %{_libexecdir}
800
801 %files clients
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_bindir}/ssh
804 %attr(755,root,root) %{_bindir}/sftp
805 %attr(755,root,root) %{_bindir}/ssh-agent
806 %attr(755,root,root) %{_bindir}/ssh-add
807 %attr(755,root,root) %{_bindir}/ssh-copy-id
808 %attr(755,root,root) %{_bindir}/scp
809 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
810 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
811 %{_mandir}/man1/scp.1*
812 %{_mandir}/man1/ssh.1*
813 %{_mandir}/man1/sftp.1*
814 %{_mandir}/man1/ssh-agent.1*
815 %{_mandir}/man1/ssh-add.1*
816 %{_mandir}/man1/ssh-copy-id.1*
817 %{_mandir}/man5/ssh_config.5*
818 %lang(it) %{_mandir}/it/man1/ssh.1*
819 %lang(it) %{_mandir}/it/man5/ssh_config.5*
820 %lang(pl) %{_mandir}/pl/man1/scp.1*
821 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
822
823 # for host-based auth (suid required for accessing private host key)
824 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
825 #%{_mandir}/man8/ssh-keysign.8*
826
827 %files clients-agent-profile_d
828 %defattr(644,root,root,755)
829 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
830 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
831
832 %files clients-agent-xinitrc
833 %defattr(644,root,root,755)
834 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
835
836 %files clients-helper-fido
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_libexecdir}/ssh-sk-helper
839 %{_mandir}/man8/ssh-sk-helper.8*
840
841 %files server
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_sbindir}/sshd
844 %attr(755,root,root) %{_libexecdir}/sftp-server
845 %attr(755,root,root) %{_libexecdir}/ssh-keysign
846 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
847 %attr(755,root,root) %{_libexecdir}/sshd-keygen
848 %{_mandir}/man8/sshd.8*
849 %{_mandir}/man8/sftp-server.8*
850 %{_mandir}/man8/ssh-keysign.8*
851 %{_mandir}/man8/ssh-pkcs11-helper.8*
852 %{_mandir}/man5/sshd_config.5*
853 %{_mandir}/man5/moduli.5*
854 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
855 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
856 %{_sysconfdir}/moduli
857 %attr(754,root,root) /etc/rc.d/init.d/sshd
858 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
859 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
860 %{systemdunitdir}/sshd.service
861 %{systemdunitdir}/sshd.socket
862 %{systemdunitdir}/sshd@.service
863
864 %if %{with ldap}
865 %files server-ldap
866 %defattr(644,root,root,755)
867 %doc HOWTO.ldap-keys ldap.conf
868 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
869 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
870 %{_mandir}/man5/ssh-ldap.conf.5*
871 %{_mandir}/man8/ssh-ldap-helper.8*
872 %endif
873
874 %if %{with gnome} || %{with gtk}
875 %files gnome-askpass
876 %defattr(644,root,root,755)
877 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
878 %dir %{_libexecdir}/ssh
879 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
880 %attr(755,root,root) %{_libexecdir}/ssh-askpass
881 %endif
882
883 %if %{with ldap}
884 %files -n openldap-schema-openssh-lpk
885 %defattr(644,root,root,755)
886 %{schemadir}/openssh-lpk.schema
887 %endif
This page took 0.083529 seconds and 2 git commands to generate.