]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
patches tend to work better if they are applied
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # gnome-askpass (GTK+ 2.x) utility
10 %bcond_without  ldap            # LDAP support
11 %bcond_with     ldns            # DNSSEC support via libldns
12 %bcond_without  libedit         # libedit (editline/history support in sftp client)
13 %bcond_without  kerberos5       # Kerberos5 support
14 %bcond_without  selinux         # SELinux support
15 %bcond_without  libseccomp      # use libseccomp for seccomp privsep (requires 3.5 kernel)
16 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
17 %bcond_without  tests           # test suite
18
19 # gtk2-based gnome-askpass means no gnome1-based
20 %{?with_gtk:%undefine with_gnome}
21
22 %if "%{pld_release}" == "ac"
23 %define         pam_ver 0.79.0
24 %else
25 %define         pam_ver 1:1.1.8-5
26 %endif
27 Summary:        OpenSSH free Secure Shell (SSH) implementation
28 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
29 Summary(es.UTF-8):      Implementación libre de SSH
30 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
31 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
32 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
33 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
34 Summary(pt_BR.UTF-8):   Implementação livre do SSH
35 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
36 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
37 Name:           openssh
38 Version:        8.1p1
39 Release:        2
40 Epoch:          2
41 License:        BSD
42 Group:          Applications/Networking
43 Source0:        http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
44 # Source0-md5:  513694343631a99841e815306806edf0
45 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
46 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
47 Source2:        %{name}d.init
48 Source3:        %{name}d.pamd
49 Source4:        %{name}.sysconfig
50 Source5:        ssh-agent.sh
51 Source6:        ssh-agent.conf
52 Source7:        %{name}-lpk.schema
53 Source9:        sshd.service
54 Source10:       sshd-keygen
55 Source11:       sshd.socket
56 Source12:       sshd@.service
57 Patch0:         %{name}-no-pty-tests.patch
58 Patch1:         %{name}-tests-reuseport.patch
59 Patch2:         %{name}-pam_misc.patch
60 Patch3:         %{name}-sigpipe.patch
61 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
62 Patch4:         %{name}-ldap.patch
63 Patch5:         %{name}-ldap-fixes.patch
64 Patch6:         ldap.conf.patch
65 Patch7:         %{name}-config.patch
66 Patch8:         ldap-helper-sigpipe.patch
67 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
68 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
69 Patch9:         %{name}-5.2p1-hpn13v6.diff
70 Patch10:        %{name}-include.patch
71 Patch11:        %{name}-chroot.patch
72 Patch12:        openssh-bug-2905.patch
73
74 Patch14:        %{name}-bind.patch
75 Patch15:        %{name}-disable_ldap.patch
76 URL:            http://www.openssh.com/portable.html
77 BuildRequires:  %{__perl}
78 %{?with_audit:BuildRequires:    audit-libs-devel}
79 BuildRequires:  autoconf >= 2.50
80 BuildRequires:  automake
81 %{?with_gnome:BuildRequires:    gnome-libs-devel}
82 %{?with_gtk:BuildRequires:      gtk+2-devel}
83 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
84 %{?with_ldns:BuildRequires:     ldns-devel}
85 %{?with_libedit:BuildRequires:  libedit-devel}
86 BuildRequires:  libseccomp-devel
87 %{?with_selinux:BuildRequires:  libselinux-devel}
88 %{?with_ldap:BuildRequires:     openldap-devel}
89 BuildRequires:  openssl-devel >= 1.1.0g
90 BuildRequires:  pam-devel
91 %{?with_gtk:BuildRequires:      pkgconfig}
92 BuildRequires:  rpm >= 4.4.9-56
93 BuildRequires:  rpmbuild(macros) >= 1.627
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  zlib-devel >= 1.2.3
96 %if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
97 BuildRequires:  %{name}-server
98 %endif
99 %if %{with tests} && %{with libseccomp}
100 # libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
101 BuildRequires:  uname(release) >= 3.5
102 %endif
103 Requires:       zlib >= 1.2.3
104 %if "%{pld_release}" == "ac"
105 Requires:       filesystem >= 2.0-1
106 Requires:       pam >= 0.79.0
107 %else
108 Requires:       filesystem >= 3.0-11
109 Requires:       pam >= %{pam_ver}
110 Suggests:       xorg-app-xauth
111 %endif
112 Obsoletes:      ssh
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         _sysconfdir     /etc/ssh
116 %define         _libexecdir     %{_libdir}/%{name}
117 %define         _privsepdir     /usr/share/empty
118 %define         schemadir       /usr/share/openldap/schema
119
120 %description
121 Ssh (Secure Shell) a program for logging into a remote machine and for
122 executing commands in a remote machine. It is intended to replace
123 rlogin and rsh, and provide secure encrypted communications between
124 two untrusted hosts over an insecure network. X11 connections and
125 arbitrary TCP/IP ports can also be forwarded over the secure channel.
126
127 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
128 it up to date in terms of security and features, as well as removing
129 all patented algorithms to seperate libraries (OpenSSL).
130
131 This package includes the core files necessary for both the OpenSSH
132 client and server. To make this package useful, you should also
133 install openssh-clients, openssh-server, or both.
134
135 %if %{with hpn}
136 This release includes High Performance SSH/SCP patches from
137 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
138 increase throughput on fast connections with high RTT (20-150 msec).
139 See the website for '-w' values for your connection and /proc/sys TCP
140 values. BTW. in a LAN you have got generally RTT < 1 msec.
141 %endif
142
143 %description -l de.UTF-8
144 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
145 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
146 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
147 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
148 andere TCP/IP Ports können ebenso über den sicheren Channel
149 weitergeleitet werden.
150
151 %description -l es.UTF-8
152 SSH es un programa para accesar y ejecutar órdenes en computadores
153 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
154 seguro entre dos servidores en una red insegura. Conexiones X11 y
155 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
156 seguro.
157
158 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
159 continuar la última versión gratuita de SSH, actualizándolo en
160 términos de seguridad y recursos,así también eliminando todos los
161 algoritmos patentados y colocándolos en bibliotecas separadas
162 (OpenSSL).
163
164 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
165 también el paquete openssh-clients u openssh-server o ambos.
166
167 %description -l fr.UTF-8
168 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
169 remplace telnet, rlogin, rexec et rsh, tout en assurant des
170 communications cryptées securisées entre deux hôtes non fiabilisés sur
171 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
172 arbitraires peuvent également être transmis sur le canal sécurisé.
173
174 %description -l it.UTF-8
175 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
176 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
177 sicure e crittate tra due host non fidati su una rete non sicura. Le
178 connessioni X11 ad una porta TCP/IP arbitraria possono essere
179 inoltrate attraverso un canale sicuro.
180
181 %description -l pl.UTF-8
182 Ssh (Secure Shell) to program służący do logowania się na zdalną
183 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
184 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
185 pomiędzy dwoma hostami.
186
187 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
188 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
189 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
190
191 %if %{with hpn}
192 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
193 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
194 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
195 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
196 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
197 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
198 %endif
199
200 %description -l pt.UTF-8
201 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
202 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
203 cifradas entre duas máquinas sem confiança mútua sobre uma rede
204 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
205 reenviados pelo canal seguro.
206
207 %description -l pt_BR.UTF-8
208 SSH é um programa para acessar e executar comandos em máquinas
209 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
210 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
211 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
212
213 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
214 última versão gratuita do SSH, atualizando-o em termos de segurança e
215 recursos, assim como removendo todos os algoritmos patenteados e
216 colocando-os em bibliotecas separadas (OpenSSL).
217
218 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
219 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
220
221 %description -l ru.UTF-8
222 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
223 машину и для выполнения команд на удаленной машине. Она предназначена
224 для замены rlogin и rsh и обеспечивает безопасную шифрованную
225 коммуникацию между двумя хостами в сети, являющейся небезопасной.
226 Соединения X11 и любые порты TCP/IP могут также быть проведены через
227 безопасный канал.
228
229 OpenSSH - это переделка командой разработчиков OpenBSD последней
230 свободной версии SSH, доведенная до современного состояния в терминах
231 уровня безопасности и поддерживаемых возможностей. Все патентованные
232 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
233
234 Этот пакет содержит файлы, необходимые как для клиента, так и для
235 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
236 openssh-server, или оба пакета.
237
238 %description -l uk.UTF-8
239 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
240 машини та для виконання команд на віддаленій машині. Вона призначена
241 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
242 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
243 довільні порти TCP/IP можуть також бути проведені через безпечний
244 канал.
245
246 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
247 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
248 підтримуваних можливостей. Всі патентовані алгоритми винесені до
249 окремих бібліотек (OpenSSL).
250
251 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
252 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
253 openssh-server, чи обидва пакети.
254
255 %package clients
256 Summary:        OpenSSH Secure Shell protocol clients
257 Summary(es.UTF-8):      Clientes de OpenSSH
258 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
259 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
260 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
261 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
262 Group:          Applications/Networking
263 Requires:       %{name}
264 Provides:       ssh-clients
265 Obsoletes:      ssh-clients
266 %requires_eq_to openssl openssl-devel
267
268 %description clients
269 Ssh (Secure Shell) a program for logging into a remote machine and for
270 executing commands in a remote machine. It is intended to replace
271 rlogin and rsh, and provide secure encrypted communications between
272 two untrusted hosts over an insecure network. X11 connections and
273 arbitrary TCP/IP ports can also be forwarded over the secure channel.
274
275 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
276 it up to date in terms of security and features, as well as removing
277 all patented algorithms to seperate libraries (OpenSSL).
278
279 This package includes the clients necessary to make encrypted
280 connections to SSH servers.
281
282 %description clients -l es.UTF-8
283 Este paquete incluye los clientes que se necesitan para hacer
284 conexiones codificadas con servidores SSH.
285
286 %description clients -l pl.UTF-8
287 Ssh (Secure Shell) to program służący do logowania się na zdalną
288 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
289 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
290 pomiędzy dwoma hostami.
291
292 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
293
294 %description clients -l pt_BR.UTF-8
295 Esse pacote inclui os clientes necessários para fazer conexões
296 encriptadas com servidores SSH.
297
298 %description clients -l ru.UTF-8
299 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
300 машину и для выполнения команд на удаленной машине.
301
302 Этот пакет содержит программы-клиенты, необходимые для установления
303 зашифрованных соединений с серверами SSH.
304
305 %description clients -l uk.UTF-8
306 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
307 машини та для виконання команд на віддаленій машині.
308
309 Цей пакет містить програми-клієнти, необхідні для встановлення
310 зашифрованих з'єднань з серверами SSH.
311
312 %package clients-agent-profile_d
313 Summary:        OpenSSH Secure Shell agent init script
314 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
315 Group:          Applications/Networking
316 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
317
318 %description clients-agent-profile_d
319 profile.d scripts for starting SSH agent.
320
321 %description clients-agent-profile_d -l pl.UTF-8
322 Skrypty profile.d do uruchamiania agenta SSH.
323
324 %package clients-agent-xinitrc
325 Summary:        OpenSSH Secure Shell agent init script
326 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
327 Group:          Applications/Networking
328 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
329 Requires:       xinitrc
330
331 %description clients-agent-xinitrc
332 xinitrc scripts for starting SSH agent.
333
334 %description clients-agent-xinitrc -l pl.UTF-8
335 Skrypty xinitrc do uruchamiania agenta SSH.
336
337 %package server
338 Summary:        OpenSSH Secure Shell protocol server (sshd)
339 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
340 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
341 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
342 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
343 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
344 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
345 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
346 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
347 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
348 Group:          Networking/Daemons
349 Requires(post): /sbin/chkconfig
350 Requires(post): grep
351 Requires(post,preun):   /sbin/chkconfig
352 Requires(postun):       /usr/sbin/userdel
353 Requires(pre):  /bin/id
354 Requires(pre):  /usr/sbin/useradd
355 Requires(post,preun,postun):    systemd-units >= 38
356 Requires:       %{name} = %{epoch}:%{version}-%{release}
357 Requires:       pam >= %{pam_ver}
358 Requires:       rc-scripts >= 0.4.3.0
359 Requires:       systemd-units >= 38
360 %{?with_libseccomp:Requires:    uname(release) >= 3.5}
361 Requires:       util-linux
362 %{?with_ldap:Suggests:  %{name}-server-ldap}
363 Suggests:       /bin/login
364 Suggests:       xorg-app-xauth
365 Provides:       ssh-server
366 Provides:       user(sshd)
367 %requires_eq_to openssl openssl-devel
368
369 %description server
370 Ssh (Secure Shell) a program for logging into a remote machine and for
371 executing commands in a remote machine. It is intended to replace
372 rlogin and rsh, and provide secure encrypted communications between
373 two untrusted hosts over an insecure network. X11 connections and
374 arbitrary TCP/IP ports can also be forwarded over the secure channel.
375
376 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
377 it up to date in terms of security and features, as well as removing
378 all patented algorithms to seperate libraries (OpenSSL).
379
380 This package contains the secure shell daemon. The sshd is the server
381 part of the secure shell protocol and allows ssh clients to connect to
382 your host.
383
384 %description server -l de.UTF-8
385 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
386
387 %description server -l es.UTF-8
388 Este paquete contiene el servidor SSH. sshd es la parte servidor del
389 protocolo secure shell y permite que clientes ssh se conecten a su
390 servidor.
391
392 %description server -l fr.UTF-8
393 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
394
395 %description server -l it.UTF-8
396 Questo pacchetto installa sshd, il server di OpenSSH.
397
398 %description server -l pl.UTF-8
399 Ssh (Secure Shell) to program służący do logowania się na zdalną
400 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
401 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
402 pomiędzy dwoma hostami.
403
404 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
405 ssh).
406
407 %description server -l pt.UTF-8
408 Este pacote intala o sshd, o servidor do OpenSSH.
409
410 %description server -l pt_BR.UTF-8
411 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
412 protocolo secure shell e permite que clientes ssh se conectem ao seu
413 host.
414
415 %description server -l ru.UTF-8
416 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
417 машину и для выполнения команд на удаленной машине.
418
419 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
420 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
421 вашим хостом.
422
423 %description server -l uk.UTF-8
424 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
425 машини та для виконання команд на віддаленій машині.
426
427 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
428 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
429 з вашим хостом.
430
431 %package server-ldap
432 Summary:        A LDAP support for open source SSH server daemon
433 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
434 Group:          Daemons
435 Requires:       %{name} = %{epoch}:%{version}-%{release}
436 Requires:       openldap-nss-config
437
438 %description server-ldap
439 OpenSSH LDAP backend is a way how to distribute the authorized tokens
440 among the servers in the network.
441
442 %description server-ldap -l pl.UTF-8
443 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
444 tokenów między serwerami w sieci.
445
446 %package gnome-askpass
447 Summary:        OpenSSH GNOME passphrase dialog
448 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
449 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
450 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
451 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
452 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
453 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
454 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
455 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
456 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
457 Group:          Applications/Networking
458 Requires:       %{name} = %{epoch}:%{version}-%{release}
459 Obsoletes:      openssh-askpass
460 Obsoletes:      ssh-askpass
461 Obsoletes:      ssh-extras
462
463 %description gnome-askpass
464 Ssh (Secure Shell) a program for logging into a remote machine and for
465 executing commands in a remote machine. It is intended to replace
466 rlogin and rsh, and provide secure encrypted communications between
467 two untrusted hosts over an insecure network. X11 connections and
468 arbitrary TCP/IP ports can also be forwarded over the secure channel.
469
470 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
471 it up to date in terms of security and features, as well as removing
472 all patented algorithms to seperate libraries (OpenSSL).
473
474 This package contains the GNOME passphrase dialog.
475
476 %description gnome-askpass -l es.UTF-8
477 Este paquete contiene un programa que abre una caja de diálogo para
478 entrada de passphrase en GNOME.
479
480 %description gnome-askpass -l pl.UTF-8
481 Ssh (Secure Shell) to program służący do logowania się na zdalną
482 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
483 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
484 pomiędzy dwoma hostami.
485
486 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
487
488 %description gnome-askpass -l pt_BR.UTF-8
489 Esse pacote contém um programa que abre uma caixa de diálogo para
490 entrada de passphrase no GNOME.
491
492 %description gnome-askpass -l ru.UTF-8
493 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
494 машину и для выполнения команд на удаленной машине.
495
496 Этот пакет содержит диалог ввода ключевой фразы для использования под
497 GNOME.
498
499 %description gnome-askpass -l uk.UTF-8
500 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
501 машини та для виконання команд на віддаленій машині.
502
503 Цей пакет містить діалог вводу ключової фрази для використання під
504 GNOME.
505
506 %package -n openldap-schema-openssh-lpk
507 Summary:        OpenSSH LDAP Public Key schema
508 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
509 Group:          Networking/Daemons
510 Requires(post,postun):  sed >= 4.0
511 Requires:       openldap-servers
512 %if "%{_rpmversion}" >= "5"
513 BuildArch:      noarch
514 %endif
515
516 %description -n openldap-schema-openssh-lpk
517 This package contains OpenSSH LDAP Public Key schema for openldap.
518
519 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
520 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
521 openldap-a.
522
523 %prep
524 %setup -q
525 %patch0 -p1
526 %patch1 -p1
527 %patch2 -p1
528 %patch3 -p1
529 %patch4 -p1
530 %patch5 -p1
531 %patch6 -p1
532 %patch7 -p1
533 %patch8 -p1
534
535 %{?with_hpn:%patch9 -p1}
536 %patch10 -p1
537 %patch11 -p1
538 %patch12 -p1
539
540 %patch14 -p1
541 %{!?with_ldap:%patch15 -p1}
542
543 %if "%{pld_release}" == "ac"
544 # fix for missing x11.pc
545 %{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
546 %endif
547
548 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
549 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh -lopenbsd-compat#g' Makefile*
550
551 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
552 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
553
554 # prevent being ovewritten by aclocal calls
555 %{__mv} aclocal.m4 acinclude.m4
556
557 %build
558 cp /usr/share/automake/config.sub .
559 %{__aclocal}
560 %{__autoconf}
561 %{__autoheader}
562 CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
563 %configure \
564         PERL=%{__perl} \
565         --disable-strip \
566         --enable-utmpx \
567         --enable-wtmpx \
568         --with-4in6 \
569         %{?with_audit:--with-audit=linux} \
570         --with-ipaddr-display \
571         %{?with_kerberos5:--with-kerberos5=/usr} \
572         --with-ldap%{!?with_ldap:=no} \
573         %{?with_ldns:--with-ldns} \
574         %{?with_libedit:--with-libedit} \
575         --with-mantype=man \
576         --with-md5-passwords \
577         --with-pam \
578         --with-pid-dir=%{_localstatedir}/run \
579         --with-privsep-path=%{_privsepdir} \
580         --with-privsep-user=sshd \
581         %{?with_selinux:--with-selinux} \
582 %if "%{pld_release}" == "ac"
583         --with-xauth=/usr/X11R6/bin/xauth
584 %else
585         --with-sandbox=seccomp_filter \
586         --with-xauth=%{_bindir}/xauth
587 %endif
588
589 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
590
591 %{__make}
592
593 %if %{with tests}
594 %{__make} -j1 tests \
595         TEST_SSH_PORT=$((4242 + ${RANDOM:-$$} % 1000)) \
596         TEST_SSH_TRACE="yes"
597 %endif
598
599 cd contrib
600 %if %{with gnome}
601 %{__make} gnome-ssh-askpass1 \
602         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
603 %endif
604 %if %{with gtk}
605 %{__make} gnome-ssh-askpass2 \
606         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
607 %endif
608
609 %install
610 rm -rf $RPM_BUILD_ROOT
611 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
612         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
613 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
614
615 %{__make} install \
616         DESTDIR=$RPM_BUILD_ROOT
617
618 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
619
620 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
621 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
622 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
623 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
624 ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
625 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
626 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
627
628 cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
629 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
630
631 %{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
632         $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
633         $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
634         $RPM_BUILD_ROOT%{systemdunitdir}/sshd@.service \
635         $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
636
637 %if %{with gnome}
638 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
639 %endif
640 %if %{with gtk}
641 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
642 %endif
643 %if %{with gnome} || %{with gtk}
644 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
645 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
646 EOF
647 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
648 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
649 EOF
650 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
651 %endif
652
653 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
654 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
655
656 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
657
658 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
659 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
660 EOF
661
662 %if "%{pld_release}" == "ac"
663 # not present in ac, no point searching it
664 %{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
665 # openssl on ac does not have OPENSSL_HAS_ECC
666 %{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
667 %endif
668
669 %if %{without audit}
670 # remove recording user's login uid to the process attribute
671 %{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
672 %endif
673
674 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
675 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
676
677 %clean
678 rm -rf $RPM_BUILD_ROOT
679
680 %post clients
681 %env_update
682
683 %postun clients
684 %env_update
685
686 %post gnome-askpass
687 %env_update
688
689 %postun gnome-askpass
690 %env_update
691
692 %pre server
693 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
694
695 %post server
696 /sbin/chkconfig --add sshd
697 %service sshd reload "OpenSSH Daemon"
698 NORESTART=1
699 %systemd_post sshd.service
700
701 %preun server
702 if [ "$1" = "0" ]; then
703         %service sshd stop
704         /sbin/chkconfig --del sshd
705 fi
706 %systemd_preun sshd.service
707
708 %postun server
709 if [ "$1" = "0" ]; then
710         %userremove sshd
711 fi
712 %systemd_reload
713
714 %triggerpostun server -- %{name}-server < 2:7.0p1-2
715 %banner %{name}-server -e << EOF
716 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
717 ! Starting from openssh 7.0 DSA keys are disabled !
718 ! on server and client side. You will NOT be able !
719 ! to use DSA keys for authentication. Please read !
720 ! about PubkeyAcceptedKeyTypes in man ssh_config. !
721 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
722 EOF
723
724 %triggerpostun server -- %{name}-server < 6.2p1-1
725 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
726 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
727
728 %triggerpostun server -- %{name}-server < 2:5.9p1-8
729 # lpk.patch to ldap.patch
730 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
731         echo >&2 "Migrating LPK patch to LDAP patch"
732         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
733         %{__sed} -i -e '
734                 # disable old configs
735                 # just UseLPK/LkpLdapConf supported for now
736                 s/^\s*UseLPK/## Obsolete &/
737                 s/^\s*Lpk/## Obsolete &/
738                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
739                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
740         ' %{_sysconfdir}/sshd_config
741         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
742                 /bin/systemctl try-restart sshd.service || :
743         else
744                 %service -q sshd reload
745         fi
746 fi
747 %systemd_trigger sshd.service
748 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
749 %banner %{name}-server -e << EOF
750 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
751 ! Native systemd support for sshd has been installed.   !
752 ! Restarting sshd.service with systemctl WILL kill all  !
753 ! active ssh sessions (daemon as such will be started). !
754 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
755 EOF
756 fi
757
758 %post -n openldap-schema-openssh-lpk
759 %openldap_schema_register %{schemadir}/openssh-lpk.schema
760 %service -q ldap restart
761
762 %postun -n openldap-schema-openssh-lpk
763 if [ "$1" = "0" ]; then
764         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
765         %service -q ldap restart
766 fi
767
768 %files
769 %defattr(644,root,root,755)
770 %doc TODO README OVERVIEW CREDITS Change*
771 %attr(755,root,root) %{_bindir}/ssh-key*
772 #%attr(755,root,root) %{_bindir}/ssh-vulnkey*
773 %{_mandir}/man1/ssh-key*.1*
774 #%{_mandir}/man1/ssh-vulnkey*.1*
775 %dir %{_sysconfdir}
776 %dir %{_libexecdir}
777
778 %files clients
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_bindir}/ssh
781 %attr(755,root,root) %{_bindir}/sftp
782 %attr(755,root,root) %{_bindir}/ssh-agent
783 %attr(755,root,root) %{_bindir}/ssh-add
784 %attr(755,root,root) %{_bindir}/ssh-copy-id
785 %attr(755,root,root) %{_bindir}/scp
786 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
787 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
788 %{_mandir}/man1/scp.1*
789 %{_mandir}/man1/ssh.1*
790 %{_mandir}/man1/sftp.1*
791 %{_mandir}/man1/ssh-agent.1*
792 %{_mandir}/man1/ssh-add.1*
793 %{_mandir}/man1/ssh-copy-id.1*
794 %{_mandir}/man5/ssh_config.5*
795 %lang(it) %{_mandir}/it/man1/ssh.1*
796 %lang(it) %{_mandir}/it/man5/ssh_config.5*
797 %lang(pl) %{_mandir}/pl/man1/scp.1*
798 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
799
800 # for host-based auth (suid required for accessing private host key)
801 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
802 #%{_mandir}/man8/ssh-keysign.8*
803
804 %files clients-agent-profile_d
805 %defattr(644,root,root,755)
806 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
807 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
808
809 %files clients-agent-xinitrc
810 %defattr(644,root,root,755)
811 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
812
813 %files server
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_sbindir}/sshd
816 %attr(755,root,root) %{_libexecdir}/sftp-server
817 %attr(755,root,root) %{_libexecdir}/ssh-keysign
818 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
819 %attr(755,root,root) %{_libexecdir}/sshd-keygen
820 %{_mandir}/man8/sshd.8*
821 %{_mandir}/man8/sftp-server.8*
822 %{_mandir}/man8/ssh-keysign.8*
823 %{_mandir}/man8/ssh-pkcs11-helper.8*
824 %{_mandir}/man5/sshd_config.5*
825 %{_mandir}/man5/moduli.5*
826 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
827 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
828 %{_sysconfdir}/moduli
829 %attr(754,root,root) /etc/rc.d/init.d/sshd
830 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
831 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
832 %{systemdunitdir}/sshd.service
833 %{systemdunitdir}/sshd.socket
834 %{systemdunitdir}/sshd@.service
835
836 %if %{with ldap}
837 %files server-ldap
838 %defattr(644,root,root,755)
839 %doc HOWTO.ldap-keys ldap.conf
840 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
841 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
842 %{_mandir}/man5/ssh-ldap.conf.5*
843 %{_mandir}/man8/ssh-ldap-helper.8*
844 %endif
845
846 %if %{with gnome} || %{with gtk}
847 %files gnome-askpass
848 %defattr(644,root,root,755)
849 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
850 %dir %{_libexecdir}/ssh
851 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
852 %attr(755,root,root) %{_libexecdir}/ssh-askpass
853 %endif
854
855 %if %{with ldap}
856 %files -n openldap-schema-openssh-lpk
857 %defattr(644,root,root,755)
858 %{schemadir}/openssh-lpk.schema
859 %endif
This page took 0.108965 seconds and 3 git commands to generate.