]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- removed one more senseless strict internal dep - clients subpackage needs
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# Conditional build:
2%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
3%bcond_without gtk # without GTK+ (2.x)
4%bcond_without ldap # with ldap support
5%bcond_without libedit # without libedit (editline/history support in sftp client)
6%bcond_without kerberos5 # without kerberos5 support
7%bcond_without selinux # build without SELinux support
8%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
9
10# gtk2-based gnome-askpass means no gnome1-based
11%{?with_gtk:%undefine with_gnome}
12#
13Summary: OpenSSH free Secure Shell (SSH) implementation
14Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
15Summary(es.UTF-8): Implementación libre de SSH
16Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
17Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
18Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
19Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
20Summary(pt_BR.UTF-8): Implementação livre do SSH
21Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
22Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
23Name: openssh
24Version: 5.2p1
25Release: 3
26Epoch: 2
27License: BSD
28Group: Applications/Networking
29Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
30# Source0-md5: ada79c7328a8551bdf55c95e631e7dad
31Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32# Source1-md5: 66943d481cc422512b537bcc2c7400d1
33Source2: %{name}d.init
34Source3: %{name}d.pamd
35Source4: %{name}.sysconfig
36Source5: ssh-agent.sh
37Source6: ssh-agent.conf
38Source7: %{name}-lpk.schema
39Patch0: %{name}-no_libnsl.patch
40Patch2: %{name}-pam_misc.patch
41Patch3: %{name}-sigpipe.patch
42# http://code.google.com/p/openssh-lpk/
43Patch4: %{name}-lpk.patch
44Patch5: %{name}-config.patch
45Patch7: %{name}-selinux.patch
46# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
47# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
48Patch9: %{name}-5.0p1-hpn13v4.diff
49Patch10: %{name}-include.patch
50Patch11: %{name}-chroot.patch
51Patch12: http://people.debian.org/~cjwatson/%{name}-blacklist.diff
52URL: http://www.openssh.com/
53BuildRequires: %{__perl}
54BuildRequires: autoconf
55BuildRequires: automake
56%{?with_gnome:BuildRequires: gnome-libs-devel}
57%{?with_gtk:BuildRequires: gtk+2-devel}
58%{?with_kerberos5:BuildRequires: krb5-devel}
59%{?with_libedit:BuildRequires: libedit-devel}
60%{?with_selinux:BuildRequires: libselinux-devel}
61BuildRequires: libwrap-devel
62%{?with_ldap:BuildRequires: openldap-devel >= 2.4.6}
63BuildRequires: openssl-devel >= 0.9.7d
64BuildRequires: pam-devel
65%{?with_gtk:BuildRequires: pkgconfig}
66BuildRequires: rpmbuild(macros) >= 1.318
67BuildRequires: zlib-devel
68Requires: filesystem >= 3.0-11
69Requires: pam >= 0.99.7.1
70Suggests: openssh-blacklist
71Suggests: xorg-app-xauth
72Obsoletes: ssh
73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75%define _sysconfdir /etc/ssh
76%define _libexecdir %{_libdir}/%{name}
77%define _privsepdir /usr/share/empty
78%define schemadir /usr/share/openldap/schema
79
80%description
81Ssh (Secure Shell) a program for logging into a remote machine and for
82executing commands in a remote machine. It is intended to replace
83rlogin and rsh, and provide secure encrypted communications between
84two untrusted hosts over an insecure network. X11 connections and
85arbitrary TCP/IP ports can also be forwarded over the secure channel.
86
87OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
88it up to date in terms of security and features, as well as removing
89all patented algorithms to seperate libraries (OpenSSL).
90
91This package includes the core files necessary for both the OpenSSH
92client and server. To make this package useful, you should also
93install openssh-clients, openssh-server, or both.
94%if %{with hpn} || %{with hpn_none}
95This release includes High Performance SSH/SCP patches from
96http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
97to increase throughput on fast connections with high RTT (20-150 msec).
98See the website for '-w' values for your connection and /proc/sys TCP
99values. BTW. in a LAN you have got generally RTT < 1 msec.
100%endif
101%if %{with hpn_none}
102It also includes an undocumented '-z' option which switches
103the cipher to none after authentication is completed. Data is
104still secured from tampering and corruption in transit through
105the use of the Message Authentication Code (MAC).
106This option will significantly reduce the number of cpu cycles used
107by the SSH/SCP process. This may allow some users to see significant
108improvement in (sniffable) data tranfer rates.
109%endif
110
111%description -l de.UTF-8
112OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
113ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
114verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
115über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
116andere TCP/IP Ports können ebenso über den sicheren Channel
117weitergeleitet werden.
118
119%description -l es.UTF-8
120SSH es un programa para accesar y ejecutar órdenes en computadores
121remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
122seguro entre dos servidores en una red insegura. Conexiones X11 y
123puertas TCP/IP arbitrárias también pueden ser usadas por el canal
124seguro.
125
126OpenSSH es el resultado del trabajo del equipo de OpenBSD para
127continuar la última versión gratuita de SSH, actualizándolo en
128términos de seguridad y recursos,así también eliminando todos los
129algoritmos patentados y colocándolos en bibliotecas separadas
130(OpenSSL).
131
132Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
133también el paquete openssh-clients u openssh-server o ambos.
134
135%description -l fr.UTF-8
136OpenSSH (Secure Shell) fournit un accès à un système distant. Il
137remplace telnet, rlogin, rexec et rsh, tout en assurant des
138communications cryptées securisées entre deux hôtes non fiabilisés sur
139un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
140arbitraires peuvent également être transmis sur le canal sécurisé.
141
142%description -l it.UTF-8
143OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
144Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
145sicure e crittate tra due host non fidati su una rete non sicura. Le
146connessioni X11 ad una porta TCP/IP arbitraria possono essere
147inoltrate attraverso un canale sicuro.
148
149%description -l pl.UTF-8
150Ssh (Secure Shell) to program służący do logowania się na zdalną
151maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
152zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
153pomiędzy dwoma hostami.
154
155Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
156klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
157co najmniej jeden z pakietów: openssh-clients lub openssh-server.
158%if %{with hpn} || %{with hpn_none}
159Ta wersja zawiera łaty z projektu High Performance SSH/SCP
160http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
161zwiększenie przepustowości transmisji dla szybkich połączeń
162z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
163odpowednie dla danego połączenia wartości parametru '-w' oraz
164opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
165%endif
166%if %{with hpn_none}
167Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
168za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
169Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
170stosowanie Message Authentication Code (MAC).
171Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
172procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
173na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
174%endif
175
176%description -l pt.UTF-8
177OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
178telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
179cifradas entre duas máquinas sem confiança mútua sobre uma rede
180insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
181reenviados pelo canal seguro.
182
183%description -l pt_BR.UTF-8
184SSH é um programa para acessar e executar comandos em máquinas
185remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
186seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
187TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
188
189OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
190última versão gratuita do SSH, atualizando-o em termos de segurança e
191recursos, assim como removendo todos os algoritmos patenteados e
192colocando-os em bibliotecas separadas (OpenSSL).
193
194Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
195também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
196
197%description -l ru.UTF-8
198Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
199машину и для выполнения команд на удаленной машине. Она предназначена
200для замены rlogin и rsh и обеспечивает безопасную шифрованную
201коммуникацию между двумя хостами в сети, являющейся небезопасной.
202Соединения X11 и любые порты TCP/IP могут также быть проведены через
203безопасный канал.
204
205OpenSSH - это переделка командой разработчиков OpenBSD последней
206свободной версии SSH, доведенная до современного состояния в терминах
207уровня безопасности и поддерживаемых возможностей. Все патентованные
208алгоритмы вынесены в отдельные библиотеки (OpenSSL).
209
210Этот пакет содержит файлы, необходимые как для клиента, так и для
211сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
212openssh-server, или оба пакета.
213
214%description -l uk.UTF-8
215Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
216машини та для виконання команд на віддаленій машині. Вона призначена
217для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
218між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
219довільні порти TCP/IP можуть також бути проведені через безпечний
220канал.
221
222OpenSSH - це переробка командою розробників OpenBSD останньої вільної
223версії SSH, доведена до сучасного стану в термінах рівня безпеки та
224підтримуваних можливостей. Всі патентовані алгоритми винесені до
225окремих бібліотек (OpenSSL).
226
227Цей пакет містить файли, необхідні як для клієнта, так і для сервера
228OpenSSH. Вам потрібно буде ще встановити openssh-clients,
229openssh-server, чи обидва пакети.
230
231%package clients
232Summary: OpenSSH Secure Shell protocol clients
233Summary(es.UTF-8): Clientes de OpenSSH
234Summary(pl.UTF-8): Klienci protokołu Secure Shell
235Summary(pt_BR.UTF-8): Clientes do OpenSSH
236Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
237Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
238Group: Applications/Networking
239Requires: %{name}
240Provides: ssh-clients
241Obsoletes: ssh-clients
242
243%description clients
244Ssh (Secure Shell) a program for logging into a remote machine and for
245executing commands in a remote machine. It is intended to replace
246rlogin and rsh, and provide secure encrypted communications between
247two untrusted hosts over an insecure network. X11 connections and
248arbitrary TCP/IP ports can also be forwarded over the secure channel.
249
250OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
251it up to date in terms of security and features, as well as removing
252all patented algorithms to seperate libraries (OpenSSL).
253
254This package includes the clients necessary to make encrypted
255connections to SSH servers.
256
257%description clients -l es.UTF-8
258Este paquete incluye los clientes que se necesitan para hacer
259conexiones codificadas con servidores SSH.
260
261%description clients -l pl.UTF-8
262Ssh (Secure Shell) to program służący do logowania się na zdalną
263maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
264zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
265pomiędzy dwoma hostami.
266
267Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
268
269%description clients -l pt_BR.UTF-8
270Esse pacote inclui os clientes necessários para fazer conexões
271encriptadas com servidores SSH.
272
273%description clients -l ru.UTF-8
274Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
275машину и для выполнения команд на удаленной машине.
276
277Этот пакет содержит программы-клиенты, необходимые для установления
278зашифрованных соединений с серверами SSH.
279
280%description clients -l uk.UTF-8
281Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
282машини та для виконання команд на віддаленій машині.
283
284Цей пакет містить програми-клієнти, необхідні для встановлення
285зашифрованих з'єднань з серверами SSH.
286
287%package clients-agent-profile_d
288Summary: OpenSSH Secure Shell agent init script
289Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
290Group: Applications/Networking
291Requires: %{name}-clients = %{epoch}:%{version}-%{release}
292
293%description clients-agent-profile_d
294profile.d scripts for starting SSH agent.
295
296%description clients-agent-profile_d -l pl.UTF-8
297Skrypty profile.d do uruchamiania agenta SSH.
298
299%package clients-agent-xinitrc
300Summary: OpenSSH Secure Shell agent init script
301Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
302Group: Applications/Networking
303Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
304Requires: xinitrc
305
306%description clients-agent-xinitrc
307xinitrc scripts for starting SSH agent.
308
309%description clients-agent-xinitrc -l pl.UTF-8
310Skrypty xinitrc do uruchamiania agenta SSH.
311
312%package server
313Summary: OpenSSH Secure Shell protocol server (sshd)
314Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
315Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
316Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
317Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
318Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
319Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
320Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
321Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
322Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
323Group: Networking/Daemons
324Requires(post): chkconfig >= 0.9
325Requires(post): grep
326Requires(post,preun): /sbin/chkconfig
327Requires(postun): /usr/sbin/userdel
328Requires(pre): /bin/id
329Requires(pre): /usr/sbin/useradd
330Requires: %{name} = %{epoch}:%{version}-%{release}
331Requires: /bin/login
332Requires: pam >= 0.99.7.1
333Requires: rc-scripts >= 0.4.1.23
334Requires: util-linux
335Provides: ssh-server
336Provides: user(sshd)
337
338%description server
339Ssh (Secure Shell) a program for logging into a remote machine and for
340executing commands in a remote machine. It is intended to replace
341rlogin and rsh, and provide secure encrypted communications between
342two untrusted hosts over an insecure network. X11 connections and
343arbitrary TCP/IP ports can also be forwarded over the secure channel.
344
345OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
346it up to date in terms of security and features, as well as removing
347all patented algorithms to seperate libraries (OpenSSL).
348
349This package contains the secure shell daemon. The sshd is the server
350part of the secure shell protocol and allows ssh clients to connect to
351your host.
352
353%description server -l de.UTF-8
354Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
355
356%description server -l es.UTF-8
357Este paquete contiene el servidor SSH. sshd es la parte servidor del
358protocolo secure shell y permite que clientes ssh se conecten a su
359servidor.
360
361%description server -l fr.UTF-8
362Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
363
364%description server -l it.UTF-8
365Questo pacchetto installa sshd, il server di OpenSSH.
366
367%description server -l pl.UTF-8
368Ssh (Secure Shell) to program służący do logowania się na zdalną
369maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
370zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
371pomiędzy dwoma hostami.
372
373Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
374ssh).
375
376%description server -l pt.UTF-8
377Este pacote intala o sshd, o servidor do OpenSSH.
378
379%description server -l pt_BR.UTF-8
380Esse pacote contém o servidor SSH. O sshd é a parte servidor do
381protocolo secure shell e permite que clientes ssh se conectem ao seu
382host.
383
384%description server -l ru.UTF-8
385Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
386машину и для выполнения команд на удаленной машине.
387
388Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
389часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
390вашим хостом.
391
392%description server -l uk.UTF-8
393Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
394машини та для виконання команд на віддаленій машині.
395
396Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
397частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
398з вашим хостом.
399
400%package gnome-askpass
401Summary: OpenSSH GNOME passphrase dialog
402Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
403Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
404Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
405Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
406Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
407Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
408Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
409Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
410Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
411Group: Applications/Networking
412Requires: %{name} = %{epoch}:%{version}-%{release}
413Obsoletes: openssh-askpass
414Obsoletes: ssh-askpass
415Obsoletes: ssh-extras
416
417%description gnome-askpass
418Ssh (Secure Shell) a program for logging into a remote machine and for
419executing commands in a remote machine. It is intended to replace
420rlogin and rsh, and provide secure encrypted communications between
421two untrusted hosts over an insecure network. X11 connections and
422arbitrary TCP/IP ports can also be forwarded over the secure channel.
423
424OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
425it up to date in terms of security and features, as well as removing
426all patented algorithms to seperate libraries (OpenSSL).
427
428This package contains the GNOME passphrase dialog.
429
430%description gnome-askpass -l es.UTF-8
431Este paquete contiene un programa que abre una caja de diálogo para
432entrada de passphrase en GNOME.
433
434%description gnome-askpass -l pl.UTF-8
435Ssh (Secure Shell) to program służący do logowania się na zdalną
436maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
437zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
438pomiędzy dwoma hostami.
439
440Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
441
442%description gnome-askpass -l pt_BR.UTF-8
443Esse pacote contém um programa que abre uma caixa de diálogo para
444entrada de passphrase no GNOME.
445
446%description gnome-askpass -l ru.UTF-8
447Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
448машину и для выполнения команд на удаленной машине.
449
450Этот пакет содержит диалог ввода ключевой фразы для использования под
451GNOME.
452
453%description gnome-askpass -l uk.UTF-8
454Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
455машини та для виконання команд на віддаленій машині.
456
457Цей пакет містить діалог вводу ключової фрази для використання під
458GNOME.
459
460%package -n openldap-schema-openssh-lpk
461Summary: OpenSSH LDAP Public Key schema
462Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
463Group: Networking/Daemons
464Requires(post,postun): sed >= 4.0
465Requires: openldap-servers
466
467%description -n openldap-schema-openssh-lpk
468This package contains OpenSSH LDAP Public Key schema for openldap.
469
470%description -n openldap-schema-openssh-lpk -l pl.UTF-8
471Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH
472dla openldap-a.
473
474%prep
475%setup -q
476%patch0 -p1
477%patch2 -p1
478%patch3 -p1
479%{?with_ldap:%patch4 -p1}
480%patch5 -p1
481%patch7 -p1
482%{?with_hpn:%patch9 -p1}
483%patch10 -p1
484%patch11 -p1
485%patch12 -p1
486
487%build
488cp /usr/share/automake/config.sub .
489%{__aclocal}
490%{__autoconf}
491CPPFLAGS="-DCHROOT"
492%configure \
493 PERL=%{__perl} \
494 --with-dns \
495 --with-pam \
496 --with-mantype=man \
497 --with-md5-passwords \
498 --with-ipaddr-display \
499 %{?with_libedit:--with-libedit} \
500 --with-4in6 \
501 --disable-suid-ssh \
502 --with-tcp-wrappers \
503 %{?with_ldap:--with-libs="-lldap -llber"} \
504 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
505 %{?with_kerberos5:--with-kerberos5=/usr} \
506 --with-privsep-path=%{_privsepdir} \
507 --with-pid-dir=%{_localstatedir}/run \
508 --with-xauth=/usr/bin/xauth \
509 --enable-utmpx \
510 --enable-wtmpx
511
512echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
513
514%{__make}
515
516cd contrib
517%if %{with gnome}
518%{__make} gnome-ssh-askpass1 \
519 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520%endif
521%if %{with gtk}
522%{__make} gnome-ssh-askpass2 \
523 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
524%endif
525
526%install
527rm -rf $RPM_BUILD_ROOT
528install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
529 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
530install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
531
532%{__make} install \
533 DESTDIR=$RPM_BUILD_ROOT
534
535bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
536
537install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
538install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
539install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
540install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
541ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
542install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
543install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
544
545%if %{with gnome}
546install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
547%endif
548%if %{with gtk}
549install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
550%endif
551%if %{with gnome} || %{with gtk}
552cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
553#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
554EOF
555cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
556#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
557EOF
558ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
559%endif
560
561install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
562install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
563
564rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
565echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
566
567touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
568
569cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
570#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
571EOF
572
573rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
574rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
575
576%clean
577rm -rf $RPM_BUILD_ROOT
578
579%post clients
580%env_update
581
582%postun clients
583%env_update
584
585%post gnome-askpass
586%env_update
587
588%postun gnome-askpass
589%env_update
590
591%pre server
592%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
593
594%post server
595/sbin/chkconfig --add sshd
596%service sshd reload "openssh daemon"
597if ! grep -qs ssh /etc/security/passwd.conf ; then
598 umask 022
599 echo "ssh" >> /etc/security/passwd.conf
600fi
601
602%preun server
603if [ "$1" = "0" ]; then
604 %service sshd stop
605 /sbin/chkconfig --del sshd
606fi
607
608%postun server
609if [ "$1" = "0" ]; then
610 %userremove sshd
611fi
612
613%post -n openldap-schema-openssh-lpk
614%openldap_schema_register %{schemadir}/openssh-lpk.schema
615%service -q ldap restart
616
617%postun -n openldap-schema-openssh-lpk
618if [ "$1" = "0" ]; then
619 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
620 %service -q ldap restart
621fi
622
623%files
624%defattr(644,root,root,755)
625%doc *.RNG TODO README OVERVIEW CREDITS Change*
626%attr(755,root,root) %{_bindir}/ssh-key*
627%attr(755,root,root) %{_bindir}/ssh-vulnkey*
628%{_mandir}/man1/ssh-key*.1*
629%{_mandir}/man1/ssh-vulnkey*.1*
630%dir %{_sysconfdir}
631%dir %{_libexecdir}
632
633%files clients
634%defattr(644,root,root,755)
635%attr(755,root,root) %{_bindir}/ssh
636%attr(755,root,root) %{_bindir}/slogin
637%attr(755,root,root) %{_bindir}/sftp
638%attr(755,root,root) %{_bindir}/ssh-agent
639%attr(755,root,root) %{_bindir}/ssh-add
640%attr(755,root,root) %{_bindir}/ssh-copy-id
641%attr(755,root,root) %{_bindir}/scp
642%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
643%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
644%{_mandir}/man1/scp.1*
645%{_mandir}/man1/ssh.1*
646%{_mandir}/man1/slogin.1*
647%{_mandir}/man1/sftp.1*
648%{_mandir}/man1/ssh-agent.1*
649%{_mandir}/man1/ssh-add.1*
650%{_mandir}/man1/ssh-copy-id.1*
651%{_mandir}/man5/ssh_config.5*
652%lang(it) %{_mandir}/it/man1/ssh.1*
653%lang(it) %{_mandir}/it/man5/ssh_config.5*
654%lang(pl) %{_mandir}/pl/man1/scp.1*
655%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
656
657# for host-based auth (suid required for accessing private host key)
658#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
659#%{_mandir}/man8/ssh-keysign.8*
660
661%files clients-agent-profile_d
662%defattr(644,root,root,755)
663%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
664%attr(755,root,root) /etc/profile.d/ssh-agent.sh
665
666%files clients-agent-xinitrc
667%defattr(644,root,root,755)
668%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
669
670%files server
671%defattr(644,root,root,755)
672%attr(755,root,root) %{_sbindir}/sshd
673%attr(755,root,root) %{_libexecdir}/sftp-server
674%attr(755,root,root) %{_libexecdir}/ssh-keysign
675%{_mandir}/man8/sshd.8*
676%{_mandir}/man8/sftp-server.8*
677%{_mandir}/man8/ssh-keysign.8*
678%{_mandir}/man5/sshd_config.5*
679%{_mandir}/man5/moduli.5*
680%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
681%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
682%attr(640,root,root) %{_sysconfdir}/moduli
683%attr(754,root,root) /etc/rc.d/init.d/sshd
684%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
685%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
686
687%if %{with gnome} || %{with gtk}
688%files gnome-askpass
689%defattr(644,root,root,755)
690%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
691%dir %{_libexecdir}/ssh
692%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
693%attr(755,root,root) %{_libexecdir}/ssh-askpass
694%endif
695
696%if %{with ldap}
697%files -n openldap-schema-openssh-lpk
698%defattr(644,root,root,755)
699%{schemadir}/openssh-lpk.schema
700%endif
This page took 0.075478 seconds and 4 git commands to generate.