]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- fix SSHv1 compatibility even when working with openssl 0.9.8e
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without chroot # without chrooted user environment support
4%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
5%bcond_without gtk # without GTK+ (2.x)
6%bcond_with ldap # with ldap support
7%bcond_without libedit # without libedit (editline/history support in sftp client)
8%bcond_without kerberos5 # without kerberos5 support
9%bcond_without selinux # build without SELinux support
10%bcond_with hpn # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11%bcond_with hpn_none # with hpn (above) and '-z' none cipher option
12#
13%if %{with hpn_none}
14%undefine with_hpn
15%endif
16# gtk2-based gnome-askpass means no gnome1-based
17%{?with_gtk:%undefine with_gnome}
18Summary: OpenSSH free Secure Shell (SSH) implementation
19Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
20Summary(es.UTF-8): Implementación libre de SSH
21Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
22Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
23Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
24Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
25Summary(pt_BR.UTF-8): Implementação livre do SSH
26Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
27Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
28Name: openssh
29Version: 4.6p1
30Release: 3%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
31Epoch: 2
32License: BSD
33Group: Applications/Networking
34Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
35# Source0-md5: 6a7fa99f44d9e1b5b04d15256e1405bb
36Source1: %{name}d.conf
37Source2: %{name}.conf
38Source3: %{name}d.init
39Source4: %{name}d.pamd
40Source5: %{name}.sysconfig
41Source6: passwd.pamd
42Source7: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
43# Source7-md5: 66943d481cc422512b537bcc2c7400d1
44Source11: ssh-agent.sh
45Source12: ssh-agent.conf
46Patch0: %{name}-no_libnsl.patch
47Patch2: %{name}-linux-ipv6.patch
48Patch3: %{name}-pam_misc.patch
49Patch4: %{name}-sigpipe.patch
50# http://www.opendarwin.org/projects/openssh-lpk/
51Patch5: %{name}-lpk-4.3p1-0.3.7.patch
52Patch7: %{name}-pam-conv.patch
53# http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
54Patch8: %{name}-chroot.patch
55Patch9: %{name}-selinux.patch
56# HPN patches rediffed due sigpipe patch.
57# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
58# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
59Patch10: %{name}-4.3p1-hpn11.patch
60# Adds HPN (see p11) and an undocumented -z none cipher flag
61# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
62Patch11: %{name}-4.3p1-hpn11-none.patch
63Patch12: %{name}-include.patch
64URL: http://www.openssh.com/
65BuildRequires: %{__perl}
66BuildRequires: autoconf
67BuildRequires: automake
68%{?with_gnome:BuildRequires: gnome-libs-devel}
69%{?with_gtk:BuildRequires: gtk+2-devel}
70%{?with_kerberos5:BuildRequires: krb5-devel}
71%{?with_libedit:BuildRequires: libedit-devel}
72%{?with_selinux:BuildRequires: libselinux-devel}
73BuildRequires: libwrap-devel
74%{?with_ldap:BuildRequires: openldap-devel}
75BuildRequires: openssl-devel >= 0.9.7d
76BuildRequires: pam-devel
77%{?with_gtk:BuildRequires: pkgconfig}
78BuildRequires: rpmbuild(macros) >= 1.318
79BuildRequires: zlib-devel
80Requires: filesystem >= 3.0-11
81Requires: pam >= 0.99.7.1
82Obsoletes: ssh
83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85%define _sysconfdir /etc/ssh
86%define _libexecdir %{_libdir}/%{name}
87%define _privsepdir /usr/share/empty
88
89%description
90Ssh (Secure Shell) a program for logging into a remote machine and for
91executing commands in a remote machine. It is intended to replace
92rlogin and rsh, and provide secure encrypted communications between
93two untrusted hosts over an insecure network. X11 connections and
94arbitrary TCP/IP ports can also be forwarded over the secure channel.
95
96OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
97it up to date in terms of security and features, as well as removing
98all patented algorithms to seperate libraries (OpenSSL).
99
100This package includes the core files necessary for both the OpenSSH
101client and server. To make this package useful, you should also
102install openssh-clients, openssh-server, or both.
103%if %{with hpn} || %{with hpn_none}
104This release includes High Performance SSH/SCP patches from
105http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
106to increase throughput on fast connections with high RTT (20-150 msec).
107See the website for '-w' values for your connection and /proc/sys TCP
108values. BTW. in a LAN you have got generally RTT < 1 msec.
109%endif
110%if %{with hpn_none}
111It also includes an undocumented '-z' option which switches
112the cipher to none after authentication is completed. Data is
113still secured from tampering and corruption in transit through
114the use of the Message Authentication Code (MAC).
115This option will significantly reduce the number of cpu cycles used
116by the SSH/SCP process. This may allow some users to see significant
117improvement in (sniffable) data tranfer rates.
118%endif
119
120%description -l de.UTF-8
121OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
122ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
123verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
124über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
125andere TCP/IP Ports können ebenso über den sicheren Channel
126weitergeleitet werden.
127
128%description -l es.UTF-8
129SSH es un programa para accesar y ejecutar órdenes en computadores
130remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
131seguro entre dos servidores en una red insegura. Conexiones X11 y
132puertas TCP/IP arbitrárias también pueden ser usadas por el canal
133seguro.
134
135OpenSSH es el resultado del trabajo del equipo de OpenBSD para
136continuar la última versión gratuita de SSH, actualizándolo en
137términos de seguridad y recursos,así también eliminando todos los
138algoritmos patentados y colocándolos en bibliotecas separadas
139(OpenSSL).
140
141Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
142también el paquete openssh-clients u openssh-server o ambos.
143
144%description -l fr.UTF-8
145OpenSSH (Secure Shell) fournit un accès à un système distant. Il
146remplace telnet, rlogin, rexec et rsh, tout en assurant des
147communications cryptées securisées entre deux hôtes non fiabilisés sur
148un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
149arbitraires peuvent également être transmis sur le canal sécurisé.
150
151%description -l it.UTF-8
152OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
153Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
154sicure e crittate tra due host non fidati su una rete non sicura. Le
155connessioni X11 ad una porta TCP/IP arbitraria possono essere
156inoltrate attraverso un canale sicuro.
157
158%description -l pl.UTF-8
159Ssh (Secure Shell) to program służący do logowania się na zdalną
160maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
161zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
162pomiędzy dwoma hostami.
163
164Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
165klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
166co najmniej jeden z pakietów: openssh-clients lub openssh-server.
167%if %{with hpn} || %{with hpn_none}
168Ta wersja zawiera łaty z projektu High Performance SSH/SCP
169http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
170zwiększenie przepustowości transmisji dla szybkich połączeń
171z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
172odpowednie dla danego połączenia wartości parametru '-w' oraz
173opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
174%endif
175%if %{with hpn_none}
176Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
177za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
178Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
179stosowanie Message Authentication Code (MAC).
180Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
181procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
182na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
183%endif
184
185%description -l pt.UTF-8
186OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
187telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
188cifradas entre duas máquinas sem confiança mútua sobre uma rede
189insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
190reenviados pelo canal seguro.
191
192%description -l pt_BR.UTF-8
193SSH é um programa para acessar e executar comandos em máquinas
194remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
195seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
196TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
197
198OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
199última versão gratuita do SSH, atualizando-o em termos de segurança e
200recursos, assim como removendo todos os algoritmos patenteados e
201colocando-os em bibliotecas separadas (OpenSSL).
202
203Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
204também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
205
206%description -l ru.UTF-8
207Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
208машину и для выполнения команд на удаленной машине. Она предназначена
209для замены rlogin и rsh и обеспечивает безопасную шифрованную
210коммуникацию между двумя хостами в сети, являющейся небезопасной.
211Соединения X11 и любые порты TCP/IP могут также быть проведены через
212безопасный канал.
213
214OpenSSH - это переделка командой разработчиков OpenBSD последней
215свободной версии SSH, доведенная до современного состояния в терминах
216уровня безопасности и поддерживаемых возможностей. Все патентованные
217алгоритмы вынесены в отдельные библиотеки (OpenSSL).
218
219Этот пакет содержит файлы, необходимые как для клиента, так и для
220сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
221openssh-server, или оба пакета.
222
223%description -l uk.UTF-8
224Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
225машини та для виконання команд на віддаленій машині. Вона призначена
226для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
227між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
228довільні порти TCP/IP можуть також бути проведені через безпечний
229канал.
230
231OpenSSH - це переробка командою розробників OpenBSD останньої вільної
232версії SSH, доведена до сучасного стану в термінах рівня безпеки та
233підтримуваних можливостей. Всі патентовані алгоритми винесені до
234окремих бібліотек (OpenSSL).
235
236Цей пакет містить файли, необхідні як для клієнта, так і для сервера
237OpenSSH. Вам потрібно буде ще встановити openssh-clients,
238openssh-server, чи обидва пакети.
239
240%package clients
241Summary: OpenSSH Secure Shell protocol clients
242Summary(es.UTF-8): Clientes de OpenSSH
243Summary(pl.UTF-8): Klienci protokołu Secure Shell
244Summary(pt_BR.UTF-8): Clientes do OpenSSH
245Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
246Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
247Group: Applications/Networking
248Requires: %{name} = %{epoch}:%{version}-%{release}
249Provides: ssh-clients
250Obsoletes: ssh-clients
251
252%description clients
253Ssh (Secure Shell) a program for logging into a remote machine and for
254executing commands in a remote machine. It is intended to replace
255rlogin and rsh, and provide secure encrypted communications between
256two untrusted hosts over an insecure network. X11 connections and
257arbitrary TCP/IP ports can also be forwarded over the secure channel.
258
259OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
260it up to date in terms of security and features, as well as removing
261all patented algorithms to seperate libraries (OpenSSL).
262
263This package includes the clients necessary to make encrypted
264connections to SSH servers.
265
266%description clients -l es.UTF-8
267Este paquete incluye los clientes que se necesitan para hacer
268conexiones codificadas con servidores SSH.
269
270%description clients -l pl.UTF-8
271Ssh (Secure Shell) to program służący do logowania się na zdalną
272maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
273zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
274pomiędzy dwoma hostami.
275
276Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
277
278%description clients -l pt_BR.UTF-8
279Esse pacote inclui os clientes necessários para fazer conexões
280encriptadas com servidores SSH.
281
282%description clients -l ru.UTF-8
283Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
284машину и для выполнения команд на удаленной машине.
285
286Этот пакет содержит программы-клиенты, необходимые для установления
287зашифрованных соединений с серверами SSH.
288
289%description clients -l uk.UTF-8
290Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
291машини та для виконання команд на віддаленій машині.
292
293Цей пакет містить програми-клієнти, необхідні для встановлення
294зашифрованих з'єднань з серверами SSH.
295
296%package clients-agent-profile_d
297Summary: OpenSSH Secure Shell agent init script
298Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
299Group: Applications/Networking
300Requires: %{name}-clients = %{epoch}:%{version}-%{release}
301
302%description clients-agent-profile_d
303profile.d scripts for starting SSH agent.
304
305%description clients-agent-profile_d -l pl.UTF-8
306Skrypty profile.d do uruchamiania agenta SSH.
307
308%package clients-agent-xinitrc
309Summary: OpenSSH Secure Shell agent init script
310Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
311Group: Applications/Networking
312Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
313Requires: xinitrc
314
315%description clients-agent-xinitrc
316xinitrc scripts for starting SSH agent.
317
318%description clients-agent-xinitrc -l pl.UTF-8
319Skrypty xinitrc do uruchamiania agenta SSH.
320
321%package server
322Summary: OpenSSH Secure Shell protocol server (sshd)
323Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
324Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
325Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
326Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
327Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
328Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
329Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
330Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
331Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
332Group: Networking/Daemons
333Requires(post): chkconfig >= 0.9
334Requires(post): grep
335Requires(post,preun): /sbin/chkconfig
336Requires(postun): /usr/sbin/userdel
337Requires(pre): /bin/id
338Requires(pre): /usr/sbin/useradd
339Requires: %{name} = %{epoch}:%{version}-%{release}
340Requires: /bin/login
341Requires: pam >= 0.99.7.1
342Requires: rc-scripts >= 0.4.0.18
343Requires: util-linux
344Provides: ssh-server
345Provides: user(sshd)
346
347%description server
348Ssh (Secure Shell) a program for logging into a remote machine and for
349executing commands in a remote machine. It is intended to replace
350rlogin and rsh, and provide secure encrypted communications between
351two untrusted hosts over an insecure network. X11 connections and
352arbitrary TCP/IP ports can also be forwarded over the secure channel.
353
354OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
355it up to date in terms of security and features, as well as removing
356all patented algorithms to seperate libraries (OpenSSL).
357
358This package contains the secure shell daemon. The sshd is the server
359part of the secure shell protocol and allows ssh clients to connect to
360your host.
361
362%description server -l de.UTF-8
363Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
364
365%description server -l es.UTF-8
366Este paquete contiene el servidor SSH. sshd es la parte servidor del
367protocolo secure shell y permite que clientes ssh se conecten a su
368servidor.
369
370%description server -l fr.UTF-8
371Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
372
373%description server -l it.UTF-8
374Questo pacchetto installa sshd, il server di OpenSSH.
375
376%description server -l pl.UTF-8
377Ssh (Secure Shell) to program służący do logowania się na zdalną
378maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
379zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
380pomiędzy dwoma hostami.
381
382Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
383ssh).
384
385%description server -l pt.UTF-8
386Este pacote intala o sshd, o servidor do OpenSSH.
387
388%description server -l pt_BR.UTF-8
389Esse pacote contém o servidor SSH. O sshd é a parte servidor do
390protocolo secure shell e permite que clientes ssh se conectem ao seu
391host.
392
393%description server -l ru.UTF-8
394Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
395машину и для выполнения команд на удаленной машине.
396
397Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
398часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
399вашим хостом.
400
401%description server -l uk.UTF-8
402Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
403машини та для виконання команд на віддаленій машині.
404
405Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
406частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
407з вашим хостом.
408
409%package gnome-askpass
410Summary: OpenSSH GNOME passphrase dialog
411Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
412Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
413Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
414Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
415Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
416Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
417Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
418Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
419Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
420Group: Applications/Networking
421Requires: %{name} = %{epoch}:%{version}-%{release}
422Obsoletes: openssh-askpass
423Obsoletes: ssh-askpass
424Obsoletes: ssh-extras
425
426%description gnome-askpass
427Ssh (Secure Shell) a program for logging into a remote machine and for
428executing commands in a remote machine. It is intended to replace
429rlogin and rsh, and provide secure encrypted communications between
430two untrusted hosts over an insecure network. X11 connections and
431arbitrary TCP/IP ports can also be forwarded over the secure channel.
432
433OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
434it up to date in terms of security and features, as well as removing
435all patented algorithms to seperate libraries (OpenSSL).
436
437This package contains the GNOME passphrase dialog.
438
439%description gnome-askpass -l es.UTF-8
440Este paquete contiene un programa que abre una caja de diálogo para
441entrada de passphrase en GNOME.
442
443%description gnome-askpass -l pl.UTF-8
444Ssh (Secure Shell) to program służący do logowania się na zdalną
445maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
446zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
447pomiędzy dwoma hostami.
448
449Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
450
451%description gnome-askpass -l pt_BR.UTF-8
452Esse pacote contém um programa que abre uma caixa de diálogo para
453entrada de passphrase no GNOME.
454
455%description gnome-askpass -l ru.UTF-8
456Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
457машину и для выполнения команд на удаленной машине.
458
459Этот пакет содержит диалог ввода ключевой фразы для использования под
460GNOME.
461
462%description gnome-askpass -l uk.UTF-8
463Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
464машини та для виконання команд на віддаленій машині.
465
466Цей пакет містить діалог вводу ключової фрази для використання під
467GNOME.
468
469%prep
470%setup -q
471%patch0 -p1
472%patch2 -p1
473%patch3 -p1
474%patch4 -p1
475%{?with_ldap:%patch5 -p1}
476#%patch7 -p1
477%patch8 -p1
478%patch9 -p1
479%{?with_hpn:%patch10 -p1}
480%{?with_hpn_none:%patch11 -p1}
481%patch12 -p1
482
483%build
484cp /usr/share/automake/config.sub .
485%{__aclocal}
486%{__autoconf}
487%{?with_chroot:CPPFLAGS="-DCHROOT"}
488%configure \
489 PERL=%{__perl} \
490 --with-dns \
491 --with-pam \
492 --with-mantype=man \
493 --with-md5-passwords \
494 --with-ipaddr-display \
495 %{?with_libedit:--with-libedit} \
496 --with-4in6 \
497 --disable-suid-ssh \
498 --with-tcp-wrappers \
499 %{?with_ldap:--with-libs="-lldap -llber"} \
500 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
501 %{?with_kerberos5:--with-kerberos5} \
502 --with-privsep-path=%{_privsepdir} \
503 --with-pid-dir=%{_localstatedir}/run \
504 --with-xauth=/usr/bin/xauth \
505 --enable-utmpx \
506 --enable-wtmpx
507
508echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
509
510%{__make}
511
512cd contrib
513%if %{with gnome}
514%{__make} gnome-ssh-askpass1 \
515 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
516%endif
517%if %{with gtk}
518%{__make} gnome-ssh-askpass2 \
519 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520%endif
521
522%install
523rm -rf $RPM_BUILD_ROOT
524install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
525 $RPM_BUILD_ROOT%{_libexecdir}/ssh
526install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
527
528%{__make} install \
529 DESTDIR=$RPM_BUILD_ROOT
530
531install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
532install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
533install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
534install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
535install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
536install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
537install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
538ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
539install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
540
541bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
542
543%if %{with gnome}
544install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
545%endif
546%if %{with gtk}
547install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
548%endif
549%if %{with gnome} || %{with gtk}
550cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
551#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
552EOF
553cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
554#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
555EOF
556ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
557%endif
558
559rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
560echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
561
562touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
563
564%if "%{_lib}" != "lib"
565find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
566%endif
567
568cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
569#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
570EOF
571
572%clean
573rm -rf $RPM_BUILD_ROOT
574
575%post clients
576%env_update
577
578%postun clients
579%env_update
580
581%post gnome-askpass
582%env_update
583
584%postun gnome-askpass
585%env_update
586
587%pre server
588%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
589
590%post server
591/sbin/chkconfig --add sshd
592%service sshd reload "openssh daemon"
593if ! grep -qs ssh /etc/security/passwd.conf ; then
594 umask 022
595 echo "ssh" >> /etc/security/passwd.conf
596fi
597
598%preun server
599if [ "$1" = "0" ]; then
600 %service sshd stop
601 /sbin/chkconfig --del sshd
602fi
603
604%postun server
605if [ "$1" = "0" ]; then
606 %userremove sshd
607fi
608
609%files
610%defattr(644,root,root,755)
611%doc *.RNG TODO README OVERVIEW CREDITS Change*
612%attr(755,root,root) %{_bindir}/ssh-key*
613%{_mandir}/man1/ssh-key*.1*
614%dir %{_sysconfdir}
615%dir %{_libexecdir}
616
617%files clients
618%defattr(644,root,root,755)
619%attr(755,root,root) %{_bindir}/ssh
620%attr(755,root,root) %{_bindir}/slogin
621%attr(755,root,root) %{_bindir}/sftp
622%attr(755,root,root) %{_bindir}/ssh-agent
623%attr(755,root,root) %{_bindir}/ssh-add
624%attr(755,root,root) %{_bindir}/scp
625%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
626%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
627%{_mandir}/man1/scp.1*
628%{_mandir}/man1/ssh.1*
629%{_mandir}/man1/slogin.1*
630%{_mandir}/man1/sftp.1*
631%{_mandir}/man1/ssh-agent.1*
632%{_mandir}/man1/ssh-add.1*
633%{_mandir}/man5/ssh_config.5*
634%lang(it) %{_mandir}/it/man1/ssh.1*
635%lang(it) %{_mandir}/it/man5/ssh_config.5*
636%lang(pl) %{_mandir}/pl/man1/scp.1*
637%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
638
639# for host-based auth (suid required for accessing private host key)
640#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
641#%{_mandir}/man8/ssh-keysign.8*
642
643%files clients-agent-profile_d
644%defattr(644,root,root,755)
645%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
646%attr(755,root,root) /etc/profile.d/ssh-agent.sh
647
648%files clients-agent-xinitrc
649%defattr(644,root,root,755)
650%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
651
652%files server
653%defattr(644,root,root,755)
654%attr(755,root,root) %{_sbindir}/sshd
655%attr(755,root,root) %{_libexecdir}/sftp-server
656%attr(755,root,root) %{_libexecdir}/ssh-keysign
657%{_mandir}/man8/sshd.8*
658%{_mandir}/man8/sftp-server.8*
659%{_mandir}/man8/ssh-keysign.8*
660%{_mandir}/man5/sshd_config.5*
661%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
662%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
663%attr(640,root,root) %{_sysconfdir}/moduli
664%attr(754,root,root) /etc/rc.d/init.d/sshd
665%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
666%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
667
668%if %{with gnome} || %{with gtk}
669%files gnome-askpass
670%defattr(644,root,root,755)
671%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
672%dir %{_libexecdir}/ssh
673%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
674%attr(755,root,root) %{_libexecdir}/ssh-askpass
675%endif
This page took 0.042449 seconds and 4 git commands to generate.