]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- rel 6; disable rsa1 host key generation (it's used with ssh1 which is disabled...
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# TODO:
2# - add trigger to enable this:
3# * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4# new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5#
6# Conditional build:
7%bcond_without audit # sshd audit support
8%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
9%bcond_without gtk # without GTK+ (2.x)
10%bcond_without ldap # with ldap support
11%bcond_without libedit # without libedit (editline/history support in sftp client)
12%bcond_without kerberos5 # without kerberos5 support
13%bcond_without selinux # build without SELinux support
14%bcond_without libseccomp # use libseccomp for seccomp privsep (requires 3.5 kernel)
15%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
16%bcond_without tests
17
18# gtk2-based gnome-askpass means no gnome1-based
19%{?with_gtk:%undefine with_gnome}
20
21%ifnarch x32
22# libseccomp requires 3.5 kernel, avoid such requirement where possible (non-x32 arches)
23%undefine with_libseccomp
24%endif
25
26%define sandbox %{?with_libseccomp:lib}seccomp_filter
27
28%ifarch x32
29%{!?with_libseccomp:%error openssh seccomp implementation is broken! do not disable libseccomp on x32}
30%endif
31
32%if "%{pld_release}" == "ac"
33%define pam_ver 0.79.0
34%else
35%define pam_ver 1:1.1.8-5
36%endif
37Summary: OpenSSH free Secure Shell (SSH) implementation
38Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
39Summary(es.UTF-8): Implementación libre de SSH
40Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
41Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
42Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
43Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
44Summary(pt_BR.UTF-8): Implementação livre do SSH
45Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
46Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
47Name: openssh
48Version: 7.1p1
49Release: 6
50Epoch: 2
51License: BSD
52Group: Applications/Networking
53Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
54# Source0-md5: 8709736bc8a8c253bc4eeb4829888ca5
55Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56# Source1-md5: 66943d481cc422512b537bcc2c7400d1
57Source2: %{name}d.init
58Source3: %{name}d.pamd
59Source4: %{name}.sysconfig
60Source5: ssh-agent.sh
61Source6: ssh-agent.conf
62Source7: %{name}-lpk.schema
63Source9: sshd.service
64Source10: sshd-keygen
65Source11: sshd.socket
66Source12: sshd@.service
67Patch0: %{name}-no_libnsl.patch
68Patch1: %{name}-tests-reuseport.patch
69Patch2: %{name}-pam_misc.patch
70Patch3: %{name}-sigpipe.patch
71# http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
72Patch4: %{name}-ldap.patch
73Patch5: %{name}-ldap-fixes.patch
74Patch6: ldap.conf.patch
75Patch7: %{name}-config.patch
76Patch8: ldap-helper-sigpipe.patch
77# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
78# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
79Patch9: %{name}-5.2p1-hpn13v6.diff
80Patch10: %{name}-include.patch
81Patch11: %{name}-chroot.patch
82Patch14: %{name}-bind.patch
83Patch15: %{name}-disable_ldap.patch
84Patch16: libseccomp-sandbox.patch
85URL: http://www.openssh.com/portable.html
86BuildRequires: %{__perl}
87%{?with_audit:BuildRequires: audit-libs-devel}
88BuildRequires: autoconf >= 2.50
89BuildRequires: automake
90%{?with_gnome:BuildRequires: gnome-libs-devel}
91%{?with_gtk:BuildRequires: gtk+2-devel}
92%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
93%{?with_libedit:BuildRequires: libedit-devel}
94BuildRequires: libseccomp-devel
95%{?with_selinux:BuildRequires: libselinux-devel}
96%{?with_ldap:BuildRequires: openldap-devel}
97BuildRequires: openssl-devel >= 0.9.8f
98BuildRequires: pam-devel
99%{?with_gtk:BuildRequires: pkgconfig}
100BuildRequires: rpm >= 4.4.9-56
101BuildRequires: rpmbuild(macros) >= 1.627
102BuildRequires: sed >= 4.0
103BuildRequires: zlib-devel >= 1.2.3
104%if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
105BuildRequires: %{name}-server
106%endif
107%if %{with tests} && %{with libseccomp}
108# libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
109BuildRequires: uname(release) >= 3.5
110%endif
111Requires: zlib >= 1.2.3
112%if "%{pld_release}" == "ac"
113Requires: filesystem >= 2.0-1
114Requires: pam >= 0.79.0
115%else
116Requires: filesystem >= 3.0-11
117Requires: pam >= %{pam_ver}
118Suggests: xorg-app-xauth
119%endif
120Obsoletes: ssh
121BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123%define _sysconfdir /etc/ssh
124%define _libexecdir %{_libdir}/%{name}
125%define _privsepdir /usr/share/empty
126%define schemadir /usr/share/openldap/schema
127
128%description
129Ssh (Secure Shell) a program for logging into a remote machine and for
130executing commands in a remote machine. It is intended to replace
131rlogin and rsh, and provide secure encrypted communications between
132two untrusted hosts over an insecure network. X11 connections and
133arbitrary TCP/IP ports can also be forwarded over the secure channel.
134
135OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
136it up to date in terms of security and features, as well as removing
137all patented algorithms to seperate libraries (OpenSSL).
138
139This package includes the core files necessary for both the OpenSSH
140client and server. To make this package useful, you should also
141install openssh-clients, openssh-server, or both.
142
143%if %{with hpn}
144This release includes High Performance SSH/SCP patches from
145http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
146increase throughput on fast connections with high RTT (20-150 msec).
147See the website for '-w' values for your connection and /proc/sys TCP
148values. BTW. in a LAN you have got generally RTT < 1 msec.
149%endif
150
151%description -l de.UTF-8
152OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
153ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
154verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
155über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
156andere TCP/IP Ports können ebenso über den sicheren Channel
157weitergeleitet werden.
158
159%description -l es.UTF-8
160SSH es un programa para accesar y ejecutar órdenes en computadores
161remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
162seguro entre dos servidores en una red insegura. Conexiones X11 y
163puertas TCP/IP arbitrárias también pueden ser usadas por el canal
164seguro.
165
166OpenSSH es el resultado del trabajo del equipo de OpenBSD para
167continuar la última versión gratuita de SSH, actualizándolo en
168términos de seguridad y recursos,así también eliminando todos los
169algoritmos patentados y colocándolos en bibliotecas separadas
170(OpenSSL).
171
172Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
173también el paquete openssh-clients u openssh-server o ambos.
174
175%description -l fr.UTF-8
176OpenSSH (Secure Shell) fournit un accès à un système distant. Il
177remplace telnet, rlogin, rexec et rsh, tout en assurant des
178communications cryptées securisées entre deux hôtes non fiabilisés sur
179un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
180arbitraires peuvent également être transmis sur le canal sécurisé.
181
182%description -l it.UTF-8
183OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
184Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
185sicure e crittate tra due host non fidati su una rete non sicura. Le
186connessioni X11 ad una porta TCP/IP arbitraria possono essere
187inoltrate attraverso un canale sicuro.
188
189%description -l pl.UTF-8
190Ssh (Secure Shell) to program służący do logowania się na zdalną
191maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
192zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
193pomiędzy dwoma hostami.
194
195Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
196klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
197co najmniej jeden z pakietów: openssh-clients lub openssh-server.
198
199%if %{with hpn}
200Ta wersja zawiera łaty z projektu High Performance SSH/SCP
201http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
202zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
203RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
204danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
205TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
206%endif
207
208%description -l pt.UTF-8
209OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
210telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
211cifradas entre duas máquinas sem confiança mútua sobre uma rede
212insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
213reenviados pelo canal seguro.
214
215%description -l pt_BR.UTF-8
216SSH é um programa para acessar e executar comandos em máquinas
217remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
218seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
219TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
220
221OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
222última versão gratuita do SSH, atualizando-o em termos de segurança e
223recursos, assim como removendo todos os algoritmos patenteados e
224colocando-os em bibliotecas separadas (OpenSSL).
225
226Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
227também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
228
229%description -l ru.UTF-8
230Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
231машину и для выполнения команд на удаленной машине. Она предназначена
232для замены rlogin и rsh и обеспечивает безопасную шифрованную
233коммуникацию между двумя хостами в сети, являющейся небезопасной.
234Соединения X11 и любые порты TCP/IP могут также быть проведены через
235безопасный канал.
236
237OpenSSH - это переделка командой разработчиков OpenBSD последней
238свободной версии SSH, доведенная до современного состояния в терминах
239уровня безопасности и поддерживаемых возможностей. Все патентованные
240алгоритмы вынесены в отдельные библиотеки (OpenSSL).
241
242Этот пакет содержит файлы, необходимые как для клиента, так и для
243сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
244openssh-server, или оба пакета.
245
246%description -l uk.UTF-8
247Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
248машини та для виконання команд на віддаленій машині. Вона призначена
249для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
250між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
251довільні порти TCP/IP можуть також бути проведені через безпечний
252канал.
253
254OpenSSH - це переробка командою розробників OpenBSD останньої вільної
255версії SSH, доведена до сучасного стану в термінах рівня безпеки та
256підтримуваних можливостей. Всі патентовані алгоритми винесені до
257окремих бібліотек (OpenSSL).
258
259Цей пакет містить файли, необхідні як для клієнта, так і для сервера
260OpenSSH. Вам потрібно буде ще встановити openssh-clients,
261openssh-server, чи обидва пакети.
262
263%package clients
264Summary: OpenSSH Secure Shell protocol clients
265Summary(es.UTF-8): Clientes de OpenSSH
266Summary(pl.UTF-8): Klienci protokołu Secure Shell
267Summary(pt_BR.UTF-8): Clientes do OpenSSH
268Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
269Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
270Group: Applications/Networking
271Requires: %{name}
272Provides: ssh-clients
273Obsoletes: ssh-clients
274%requires_eq_to openssl openssl-devel
275
276%description clients
277Ssh (Secure Shell) a program for logging into a remote machine and for
278executing commands in a remote machine. It is intended to replace
279rlogin and rsh, and provide secure encrypted communications between
280two untrusted hosts over an insecure network. X11 connections and
281arbitrary TCP/IP ports can also be forwarded over the secure channel.
282
283OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
284it up to date in terms of security and features, as well as removing
285all patented algorithms to seperate libraries (OpenSSL).
286
287This package includes the clients necessary to make encrypted
288connections to SSH servers.
289
290%description clients -l es.UTF-8
291Este paquete incluye los clientes que se necesitan para hacer
292conexiones codificadas con servidores SSH.
293
294%description clients -l pl.UTF-8
295Ssh (Secure Shell) to program służący do logowania się na zdalną
296maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
297zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
298pomiędzy dwoma hostami.
299
300Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
301
302%description clients -l pt_BR.UTF-8
303Esse pacote inclui os clientes necessários para fazer conexões
304encriptadas com servidores SSH.
305
306%description clients -l ru.UTF-8
307Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
308машину и для выполнения команд на удаленной машине.
309
310Этот пакет содержит программы-клиенты, необходимые для установления
311зашифрованных соединений с серверами SSH.
312
313%description clients -l uk.UTF-8
314Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
315машини та для виконання команд на віддаленій машині.
316
317Цей пакет містить програми-клієнти, необхідні для встановлення
318зашифрованих з'єднань з серверами SSH.
319
320%package clients-agent-profile_d
321Summary: OpenSSH Secure Shell agent init script
322Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
323Group: Applications/Networking
324Requires: %{name}-clients = %{epoch}:%{version}-%{release}
325
326%description clients-agent-profile_d
327profile.d scripts for starting SSH agent.
328
329%description clients-agent-profile_d -l pl.UTF-8
330Skrypty profile.d do uruchamiania agenta SSH.
331
332%package clients-agent-xinitrc
333Summary: OpenSSH Secure Shell agent init script
334Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
335Group: Applications/Networking
336Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
337Requires: xinitrc
338
339%description clients-agent-xinitrc
340xinitrc scripts for starting SSH agent.
341
342%description clients-agent-xinitrc -l pl.UTF-8
343Skrypty xinitrc do uruchamiania agenta SSH.
344
345%package server
346Summary: OpenSSH Secure Shell protocol server (sshd)
347Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
348Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
349Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
350Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
351Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
352Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
353Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
354Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
355Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
356Group: Networking/Daemons
357Requires(post): /sbin/chkconfig
358Requires(post): grep
359Requires(post,preun): /sbin/chkconfig
360Requires(postun): /usr/sbin/userdel
361Requires(pre): /bin/id
362Requires(pre): /usr/sbin/useradd
363Requires(post,preun,postun): systemd-units >= 38
364Requires: %{name} = %{epoch}:%{version}-%{release}
365Requires: pam >= %{pam_ver}
366Requires: rc-scripts >= 0.4.3.0
367Requires: systemd-units >= 38
368%{?with_libseccomp:Requires: uname(release) >= 3.5}
369Requires: util-linux
370%{?with_ldap:Suggests: %{name}-server-ldap}
371Suggests: /bin/login
372Suggests: xorg-app-xauth
373Provides: ssh-server
374Provides: user(sshd)
375%requires_eq_to openssl openssl-devel
376
377%description server
378Ssh (Secure Shell) a program for logging into a remote machine and for
379executing commands in a remote machine. It is intended to replace
380rlogin and rsh, and provide secure encrypted communications between
381two untrusted hosts over an insecure network. X11 connections and
382arbitrary TCP/IP ports can also be forwarded over the secure channel.
383
384OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
385it up to date in terms of security and features, as well as removing
386all patented algorithms to seperate libraries (OpenSSL).
387
388This package contains the secure shell daemon. The sshd is the server
389part of the secure shell protocol and allows ssh clients to connect to
390your host.
391
392%description server -l de.UTF-8
393Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
394
395%description server -l es.UTF-8
396Este paquete contiene el servidor SSH. sshd es la parte servidor del
397protocolo secure shell y permite que clientes ssh se conecten a su
398servidor.
399
400%description server -l fr.UTF-8
401Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
402
403%description server -l it.UTF-8
404Questo pacchetto installa sshd, il server di OpenSSH.
405
406%description server -l pl.UTF-8
407Ssh (Secure Shell) to program służący do logowania się na zdalną
408maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
409zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
410pomiędzy dwoma hostami.
411
412Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
413ssh).
414
415%description server -l pt.UTF-8
416Este pacote intala o sshd, o servidor do OpenSSH.
417
418%description server -l pt_BR.UTF-8
419Esse pacote contém o servidor SSH. O sshd é a parte servidor do
420protocolo secure shell e permite que clientes ssh se conectem ao seu
421host.
422
423%description server -l ru.UTF-8
424Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
425машину и для выполнения команд на удаленной машине.
426
427Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
428часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
429вашим хостом.
430
431%description server -l uk.UTF-8
432Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
433машини та для виконання команд на віддаленій машині.
434
435Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
436частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
437з вашим хостом.
438
439%package server-ldap
440Summary: A LDAP support for open source SSH server daemon
441Summary(pl.UTF-8): Wsparcie LDAP dla serwera OpenSSH
442Group: Daemons
443Requires: %{name} = %{epoch}:%{version}-%{release}
444Requires: openldap-nss-config
445
446%description server-ldap
447OpenSSH LDAP backend is a way how to distribute the authorized tokens
448among the servers in the network.
449
450%description server-ldap -l pl.UTF-8
451Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
452tokenów między serwerami w sieci.
453
454%package gnome-askpass
455Summary: OpenSSH GNOME passphrase dialog
456Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
457Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
458Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
459Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
460Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
461Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
462Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
463Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
464Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
465Group: Applications/Networking
466Requires: %{name} = %{epoch}:%{version}-%{release}
467Obsoletes: openssh-askpass
468Obsoletes: ssh-askpass
469Obsoletes: ssh-extras
470
471%description gnome-askpass
472Ssh (Secure Shell) a program for logging into a remote machine and for
473executing commands in a remote machine. It is intended to replace
474rlogin and rsh, and provide secure encrypted communications between
475two untrusted hosts over an insecure network. X11 connections and
476arbitrary TCP/IP ports can also be forwarded over the secure channel.
477
478OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
479it up to date in terms of security and features, as well as removing
480all patented algorithms to seperate libraries (OpenSSL).
481
482This package contains the GNOME passphrase dialog.
483
484%description gnome-askpass -l es.UTF-8
485Este paquete contiene un programa que abre una caja de diálogo para
486entrada de passphrase en GNOME.
487
488%description gnome-askpass -l pl.UTF-8
489Ssh (Secure Shell) to program służący do logowania się na zdalną
490maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
491zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
492pomiędzy dwoma hostami.
493
494Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
495
496%description gnome-askpass -l pt_BR.UTF-8
497Esse pacote contém um programa que abre uma caixa de diálogo para
498entrada de passphrase no GNOME.
499
500%description gnome-askpass -l ru.UTF-8
501Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
502машину и для выполнения команд на удаленной машине.
503
504Этот пакет содержит диалог ввода ключевой фразы для использования под
505GNOME.
506
507%description gnome-askpass -l uk.UTF-8
508Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
509машини та для виконання команд на віддаленій машині.
510
511Цей пакет містить діалог вводу ключової фрази для використання під
512GNOME.
513
514%package -n openldap-schema-openssh-lpk
515Summary: OpenSSH LDAP Public Key schema
516Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
517Group: Networking/Daemons
518Requires(post,postun): sed >= 4.0
519Requires: openldap-servers
520%if "%{_rpmversion}" >= "5"
521BuildArch: noarch
522%endif
523
524%description -n openldap-schema-openssh-lpk
525This package contains OpenSSH LDAP Public Key schema for openldap.
526
527%description -n openldap-schema-openssh-lpk -l pl.UTF-8
528Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
529openldap-a.
530
531%prep
532%setup -q
533%patch0 -p1
534%patch1 -p1
535%patch2 -p1
536%patch3 -p1
537%patch4 -p1
538%patch5 -p1
539%patch6 -p1
540%patch7 -p1
541%patch8 -p1
542
543%{?with_hpn:%patch9 -p1}
544%patch10 -p1
545%patch11 -p1
546
547%patch14 -p1
548%{!?with_ldap:%patch15 -p1}
549%{?with_libseccomp:%patch16 -p1}
550
551%if "%{pld_release}" == "ac"
552# fix for missing x11.pc
553%{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
554%endif
555
556# hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
557sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
558
559grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
560%{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
561
562# prevent being ovewritten by aclocal calls
563mv aclocal.m4 acinclude.m4
564
565%build
566cp /usr/share/automake/config.sub .
567%{__aclocal}
568%{__autoconf}
569%{__autoheader}
570CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
571%configure \
572 PERL=%{__perl} \
573 --disable-strip \
574 --enable-utmpx \
575 --enable-wtmpx \
576 --with-4in6 \
577 %{?with_audit:--with-audit=linux} \
578 --with-ipaddr-display \
579 %{?with_kerberos5:--with-kerberos5=/usr} \
580 --with-ldap%{!?with_ldap:=no} \
581 %{?with_libedit:--with-libedit} \
582 --with-mantype=man \
583 --with-md5-passwords \
584 --with-pam \
585 --with-pid-dir=%{_localstatedir}/run \
586 --with-privsep-path=%{_privsepdir} \
587 --with-privsep-user=sshd \
588 %{?with_selinux:--with-selinux} \
589%if "%{pld_release}" == "ac"
590 --with-xauth=/usr/X11R6/bin/xauth
591%else
592 --with-sandbox=%{sandbox} \
593 --with-xauth=%{_bindir}/xauth
594%endif
595
596echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
597
598%{__make}
599
600%{?with_tests:%{__make} -j1 tests}
601
602cd contrib
603%if %{with gnome}
604%{__make} gnome-ssh-askpass1 \
605 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
606%endif
607%if %{with gtk}
608%{__make} gnome-ssh-askpass2 \
609 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
610%endif
611
612%install
613rm -rf $RPM_BUILD_ROOT
614install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
615 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
616install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
617
618%{__make} install \
619 DESTDIR=$RPM_BUILD_ROOT
620
621bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
622
623install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
624cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
625cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
626cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
627ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
628cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
629cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
630
631cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
632install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
633
634%{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
635 $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
636 $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
637 $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
638
639%if %{with gnome}
640install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
641%endif
642%if %{with gtk}
643install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
644%endif
645%if %{with gnome} || %{with gtk}
646cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
647#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
648EOF
649cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
650#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
651EOF
652ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
653%endif
654
655install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
656cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
657
658%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
659echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
660
661touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
662
663cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
664#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
665EOF
666
667%if "%{pld_release}" == "ac"
668# not present in ac, no point searching it
669%{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
670# openssl on ac does not have OPENSSL_HAS_ECC
671%{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
672%endif
673
674%if %{without audit}
675# remove recording user's login uid to the process attribute
676%{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
677%endif
678
679%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
680%{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
681
682%clean
683rm -rf $RPM_BUILD_ROOT
684
685%post clients
686%env_update
687
688%postun clients
689%env_update
690
691%post gnome-askpass
692%env_update
693
694%postun gnome-askpass
695%env_update
696
697%pre server
698%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
699
700%post server
701/sbin/chkconfig --add sshd
702%service sshd reload "OpenSSH Daemon"
703NORESTART=1
704%systemd_post sshd.service
705
706%preun server
707if [ "$1" = "0" ]; then
708 %service sshd stop
709 /sbin/chkconfig --del sshd
710fi
711%systemd_preun sshd.service
712
713%postun server
714if [ "$1" = "0" ]; then
715 %userremove sshd
716fi
717%systemd_reload
718
719%triggerpostun server -- %{name}-server < 2:7.0p1-2
720%banner %{name}-server -e << EOF
721!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
722! Starting from openssh 7.0 DSA keys are disabled !
723! on server and client side. You will NOT be able !
724! to use DSA keys for authentication. Please read !
725! about PubkeyAcceptedKeyTypes in man ssh_config. !
726!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
727EOF
728
729%triggerpostun server -- %{name}-server < 6.2p1-1
730cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
731sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
732
733%triggerpostun server -- %{name}-server < 2:5.9p1-8
734# lpk.patch to ldap.patch
735if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
736 echo >&2 "Migrating LPK patch to LDAP patch"
737 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
738 %{__sed} -i -e '
739 # disable old configs
740 # just UseLPK/LkpLdapConf supported for now
741 s/^\s*UseLPK/## Obsolete &/
742 s/^\s*Lpk/## Obsolete &/
743 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
744 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
745 ' %{_sysconfdir}/sshd_config
746 if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
747 /bin/systemctl try-restart sshd.service || :
748 else
749 %service -q sshd reload
750 fi
751fi
752%systemd_trigger sshd.service
753if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
754%banner %{name}-server -e << EOF
755!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
756! Native systemd support for sshd has been installed. !
757! Restarting sshd.service with systemctl WILL kill all !
758! active ssh sessions (daemon as such will be started). !
759!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
760EOF
761fi
762
763%post -n openldap-schema-openssh-lpk
764%openldap_schema_register %{schemadir}/openssh-lpk.schema
765%service -q ldap restart
766
767%postun -n openldap-schema-openssh-lpk
768if [ "$1" = "0" ]; then
769 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
770 %service -q ldap restart
771fi
772
773%files
774%defattr(644,root,root,755)
775%doc TODO README OVERVIEW CREDITS Change*
776%attr(755,root,root) %{_bindir}/ssh-key*
777#%attr(755,root,root) %{_bindir}/ssh-vulnkey*
778%{_mandir}/man1/ssh-key*.1*
779#%{_mandir}/man1/ssh-vulnkey*.1*
780%dir %{_sysconfdir}
781%dir %{_libexecdir}
782
783%files clients
784%defattr(644,root,root,755)
785%attr(755,root,root) %{_bindir}/ssh
786%attr(755,root,root) %{_bindir}/slogin
787%attr(755,root,root) %{_bindir}/sftp
788%attr(755,root,root) %{_bindir}/ssh-agent
789%attr(755,root,root) %{_bindir}/ssh-add
790%attr(755,root,root) %{_bindir}/ssh-copy-id
791%attr(755,root,root) %{_bindir}/scp
792%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
793%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
794%{_mandir}/man1/scp.1*
795%{_mandir}/man1/ssh.1*
796%{_mandir}/man1/slogin.1*
797%{_mandir}/man1/sftp.1*
798%{_mandir}/man1/ssh-agent.1*
799%{_mandir}/man1/ssh-add.1*
800%{_mandir}/man1/ssh-copy-id.1*
801%{_mandir}/man5/ssh_config.5*
802%lang(it) %{_mandir}/it/man1/ssh.1*
803%lang(it) %{_mandir}/it/man5/ssh_config.5*
804%lang(pl) %{_mandir}/pl/man1/scp.1*
805%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
806
807# for host-based auth (suid required for accessing private host key)
808#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
809#%{_mandir}/man8/ssh-keysign.8*
810
811%files clients-agent-profile_d
812%defattr(644,root,root,755)
813%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
814%attr(755,root,root) /etc/profile.d/ssh-agent.sh
815
816%files clients-agent-xinitrc
817%defattr(644,root,root,755)
818%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
819
820%files server
821%defattr(644,root,root,755)
822%attr(755,root,root) %{_sbindir}/sshd
823%attr(755,root,root) %{_libexecdir}/sftp-server
824%attr(755,root,root) %{_libexecdir}/ssh-keysign
825%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
826%attr(755,root,root) %{_libexecdir}/sshd-keygen
827%{_mandir}/man8/sshd.8*
828%{_mandir}/man8/sftp-server.8*
829%{_mandir}/man8/ssh-keysign.8*
830%{_mandir}/man8/ssh-pkcs11-helper.8*
831%{_mandir}/man5/sshd_config.5*
832%{_mandir}/man5/moduli.5*
833%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
834%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
835%attr(640,root,root) %{_sysconfdir}/moduli
836%attr(754,root,root) /etc/rc.d/init.d/sshd
837%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
838%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
839%{systemdunitdir}/sshd.service
840%{systemdunitdir}/sshd.socket
841%{systemdunitdir}/sshd@.service
842
843%if %{with ldap}
844%files server-ldap
845%defattr(644,root,root,755)
846%doc HOWTO.ldap-keys ldap.conf
847%attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
848%attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
849%{_mandir}/man5/ssh-ldap.conf.5*
850%{_mandir}/man8/ssh-ldap-helper.8*
851%endif
852
853%if %{with gnome} || %{with gtk}
854%files gnome-askpass
855%defattr(644,root,root,755)
856%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
857%dir %{_libexecdir}/ssh
858%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
859%attr(755,root,root) %{_libexecdir}/ssh-askpass
860%endif
861
862%if %{with ldap}
863%files -n openldap-schema-openssh-lpk
864%defattr(644,root,root,755)
865%{schemadir}/openssh-lpk.schema
866%endif
This page took 0.061816 seconds and 4 git commands to generate.