]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- up to 6.0p1
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without audit # sshd audit support
4%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
5%bcond_without gtk # without GTK+ (2.x)
6%bcond_without ldap # with ldap support
7%bcond_without libedit # without libedit (editline/history support in sftp client)
8%bcond_without kerberos5 # without kerberos5 support
9%bcond_without selinux # build without SELinux support
10%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11%bcond_without tests
12
13# gtk2-based gnome-askpass means no gnome1-based
14%{?with_gtk:%undefine with_gnome}
15
16%if "%{pld_release}" == "ac"
17%define pam_ver 0.79.0
18%else
19%define pam_ver 1:1.1.5-5
20%endif
21
22Summary: OpenSSH free Secure Shell (SSH) implementation
23Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
24Summary(es.UTF-8): Implementación libre de SSH
25Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
26Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
27Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
28Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29Summary(pt_BR.UTF-8): Implementação livre do SSH
30Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
31Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
32Name: openssh
33Version: 6.0p1
34Release: 1
35Epoch: 2
36License: BSD
37Group: Applications/Networking
38Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
39# Source0-md5: 3c9347aa67862881c5da3f3b1c08da7b
40Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41# Source1-md5: 66943d481cc422512b537bcc2c7400d1
42Source2: %{name}d.init
43Source3: %{name}d.pamd
44Source4: %{name}.sysconfig
45Source5: ssh-agent.sh
46Source6: ssh-agent.conf
47Source7: %{name}-lpk.schema
48Source8: %{name}d.upstart
49Source9: sshd.service
50Source10: sshd-keygen
51Patch100: %{name}-heimdal.patch
52Patch0: %{name}-no_libnsl.patch
53Patch2: %{name}-pam_misc.patch
54Patch3: %{name}-sigpipe.patch
55# http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
56Patch4: %{name}-5.9p1-ldap.patch
57Patch5: %{name}-5.9p1-ldap-fixes.patch
58Patch8: ldap.conf.patch
59Patch6: %{name}-config.patch
60# https://bugzilla.mindrot.org/show_bug.cgi?id=1663
61Patch7: authorized-keys-command.patch
62# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
63# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
64Patch9: %{name}-5.2p1-hpn13v6.diff
65Patch10: %{name}-include.patch
66Patch11: %{name}-chroot.patch
67# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
68Patch12: %{name}-blacklist.diff
69Patch13: %{name}-kuserok.patch
70Patch14: %{name}-bind.patch
71URL: http://www.openssh.com/portable.html
72BuildRequires: %{__perl}
73%{?with_audit:BuildRequires: audit-libs-devel}
74BuildRequires: autoconf >= 2.50
75BuildRequires: automake
76%{?with_gnome:BuildRequires: gnome-libs-devel}
77%{?with_gtk:BuildRequires: gtk+2-devel}
78%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
79%{?with_libedit:BuildRequires: libedit-devel}
80%{?with_selinux:BuildRequires: libselinux-devel}
81BuildRequires: libwrap-devel
82%{?with_ldap:BuildRequires: openldap-devel}
83BuildRequires: openssl-devel >= 0.9.7d
84BuildRequires: pam-devel
85%{?with_gtk:BuildRequires: pkgconfig}
86BuildRequires: rpm >= 4.4.9-56
87BuildRequires: rpmbuild(macros) >= 1.627
88BuildRequires: sed >= 4.0
89BuildRequires: zlib-devel
90%if "%{pld_release}" == "ac"
91Requires: filesystem >= 2.0-1
92Requires: pam >= 0.79.0
93%else
94Requires: filesystem >= 3.0-11
95Requires: pam >= %{pam_ver}
96Suggests: openssh-blacklist
97Suggests: xorg-app-xauth
98%endif
99Obsoletes: ssh
100BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102%define _sysconfdir /etc/ssh
103%define _libexecdir %{_libdir}/%{name}
104%define _privsepdir /usr/share/empty
105%define schemadir /usr/share/openldap/schema
106
107%description
108Ssh (Secure Shell) a program for logging into a remote machine and for
109executing commands in a remote machine. It is intended to replace
110rlogin and rsh, and provide secure encrypted communications between
111two untrusted hosts over an insecure network. X11 connections and
112arbitrary TCP/IP ports can also be forwarded over the secure channel.
113
114OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
115it up to date in terms of security and features, as well as removing
116all patented algorithms to seperate libraries (OpenSSL).
117
118This package includes the core files necessary for both the OpenSSH
119client and server. To make this package useful, you should also
120install openssh-clients, openssh-server, or both.
121
122%if %{with hpn}
123This release includes High Performance SSH/SCP patches from
124http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
125increase throughput on fast connections with high RTT (20-150 msec).
126See the website for '-w' values for your connection and /proc/sys TCP
127values. BTW. in a LAN you have got generally RTT < 1 msec.
128%endif
129
130%description -l de.UTF-8
131OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
132ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
133verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
134über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
135andere TCP/IP Ports können ebenso über den sicheren Channel
136weitergeleitet werden.
137
138%description -l es.UTF-8
139SSH es un programa para accesar y ejecutar órdenes en computadores
140remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
141seguro entre dos servidores en una red insegura. Conexiones X11 y
142puertas TCP/IP arbitrárias también pueden ser usadas por el canal
143seguro.
144
145OpenSSH es el resultado del trabajo del equipo de OpenBSD para
146continuar la última versión gratuita de SSH, actualizándolo en
147términos de seguridad y recursos,así también eliminando todos los
148algoritmos patentados y colocándolos en bibliotecas separadas
149(OpenSSL).
150
151Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
152también el paquete openssh-clients u openssh-server o ambos.
153
154%description -l fr.UTF-8
155OpenSSH (Secure Shell) fournit un accès à un système distant. Il
156remplace telnet, rlogin, rexec et rsh, tout en assurant des
157communications cryptées securisées entre deux hôtes non fiabilisés sur
158un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
159arbitraires peuvent également être transmis sur le canal sécurisé.
160
161%description -l it.UTF-8
162OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
163Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
164sicure e crittate tra due host non fidati su una rete non sicura. Le
165connessioni X11 ad una porta TCP/IP arbitraria possono essere
166inoltrate attraverso un canale sicuro.
167
168%description -l pl.UTF-8
169Ssh (Secure Shell) to program służący do logowania się na zdalną
170maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
171zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
172pomiędzy dwoma hostami.
173
174Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
175klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
176co najmniej jeden z pakietów: openssh-clients lub openssh-server.
177
178%if %{with hpn}
179Ta wersja zawiera łaty z projektu High Performance SSH/SCP
180http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
181zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
182RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
183danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
184TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
185%endif
186
187%description -l pt.UTF-8
188OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
189telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
190cifradas entre duas máquinas sem confiança mútua sobre uma rede
191insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
192reenviados pelo canal seguro.
193
194%description -l pt_BR.UTF-8
195SSH é um programa para acessar e executar comandos em máquinas
196remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
197seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
198TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
199
200OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
201última versão gratuita do SSH, atualizando-o em termos de segurança e
202recursos, assim como removendo todos os algoritmos patenteados e
203colocando-os em bibliotecas separadas (OpenSSL).
204
205Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
206também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
207
208%description -l ru.UTF-8
209Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
210машину и для выполнения команд на удаленной машине. Она предназначена
211для замены rlogin и rsh и обеспечивает безопасную шифрованную
212коммуникацию между двумя хостами в сети, являющейся небезопасной.
213Соединения X11 и любые порты TCP/IP могут также быть проведены через
214безопасный канал.
215
216OpenSSH - это переделка командой разработчиков OpenBSD последней
217свободной версии SSH, доведенная до современного состояния в терминах
218уровня безопасности и поддерживаемых возможностей. Все патентованные
219алгоритмы вынесены в отдельные библиотеки (OpenSSL).
220
221Этот пакет содержит файлы, необходимые как для клиента, так и для
222сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
223openssh-server, или оба пакета.
224
225%description -l uk.UTF-8
226Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
227машини та для виконання команд на віддаленій машині. Вона призначена
228для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
229між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
230довільні порти TCP/IP можуть також бути проведені через безпечний
231канал.
232
233OpenSSH - це переробка командою розробників OpenBSD останньої вільної
234версії SSH, доведена до сучасного стану в термінах рівня безпеки та
235підтримуваних можливостей. Всі патентовані алгоритми винесені до
236окремих бібліотек (OpenSSL).
237
238Цей пакет містить файли, необхідні як для клієнта, так і для сервера
239OpenSSH. Вам потрібно буде ще встановити openssh-clients,
240openssh-server, чи обидва пакети.
241
242%package clients
243Summary: OpenSSH Secure Shell protocol clients
244Summary(es.UTF-8): Clientes de OpenSSH
245Summary(pl.UTF-8): Klienci protokołu Secure Shell
246Summary(pt_BR.UTF-8): Clientes do OpenSSH
247Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
248Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
249Group: Applications/Networking
250Requires: %{name}
251Provides: ssh-clients
252Obsoletes: ssh-clients
253
254%description clients
255Ssh (Secure Shell) a program for logging into a remote machine and for
256executing commands in a remote machine. It is intended to replace
257rlogin and rsh, and provide secure encrypted communications between
258two untrusted hosts over an insecure network. X11 connections and
259arbitrary TCP/IP ports can also be forwarded over the secure channel.
260
261OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
262it up to date in terms of security and features, as well as removing
263all patented algorithms to seperate libraries (OpenSSL).
264
265This package includes the clients necessary to make encrypted
266connections to SSH servers.
267
268%description clients -l es.UTF-8
269Este paquete incluye los clientes que se necesitan para hacer
270conexiones codificadas con servidores SSH.
271
272%description clients -l pl.UTF-8
273Ssh (Secure Shell) to program służący do logowania się na zdalną
274maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
275zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
276pomiędzy dwoma hostami.
277
278Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
279
280%description clients -l pt_BR.UTF-8
281Esse pacote inclui os clientes necessários para fazer conexões
282encriptadas com servidores SSH.
283
284%description clients -l ru.UTF-8
285Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
286машину и для выполнения команд на удаленной машине.
287
288Этот пакет содержит программы-клиенты, необходимые для установления
289зашифрованных соединений с серверами SSH.
290
291%description clients -l uk.UTF-8
292Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
293машини та для виконання команд на віддаленій машині.
294
295Цей пакет містить програми-клієнти, необхідні для встановлення
296зашифрованих з'єднань з серверами SSH.
297
298%package clients-agent-profile_d
299Summary: OpenSSH Secure Shell agent init script
300Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
301Group: Applications/Networking
302Requires: %{name}-clients = %{epoch}:%{version}-%{release}
303
304%description clients-agent-profile_d
305profile.d scripts for starting SSH agent.
306
307%description clients-agent-profile_d -l pl.UTF-8
308Skrypty profile.d do uruchamiania agenta SSH.
309
310%package clients-agent-xinitrc
311Summary: OpenSSH Secure Shell agent init script
312Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
313Group: Applications/Networking
314Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
315Requires: xinitrc
316
317%description clients-agent-xinitrc
318xinitrc scripts for starting SSH agent.
319
320%description clients-agent-xinitrc -l pl.UTF-8
321Skrypty xinitrc do uruchamiania agenta SSH.
322
323%package server
324Summary: OpenSSH Secure Shell protocol server (sshd)
325Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
326Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
327Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
328Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
329Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
330Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
331Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
332Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
333Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
334Group: Networking/Daemons
335Requires(post): /sbin/chkconfig
336Requires(post): grep
337Requires(post,preun): /sbin/chkconfig
338Requires(postun): /usr/sbin/userdel
339Requires(pre): /bin/id
340Requires(pre): /usr/sbin/useradd
341Requires(post,preun,postun): systemd-units >= 38
342Requires: %{name} = %{epoch}:%{version}-%{release}
343# remove in 6.0, kept for flawless upgrade
344Requires: %{name}-server-ldap = %{epoch}:%{version}-%{release}
345Requires: pam >= %{pam_ver}
346Requires: rc-scripts >= 0.4.3.0
347Requires: systemd-units >= 38
348Requires: util-linux
349Suggests: /bin/login
350Provides: ssh-server
351Provides: user(sshd)
352
353%description server
354Ssh (Secure Shell) a program for logging into a remote machine and for
355executing commands in a remote machine. It is intended to replace
356rlogin and rsh, and provide secure encrypted communications between
357two untrusted hosts over an insecure network. X11 connections and
358arbitrary TCP/IP ports can also be forwarded over the secure channel.
359
360OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
361it up to date in terms of security and features, as well as removing
362all patented algorithms to seperate libraries (OpenSSL).
363
364This package contains the secure shell daemon. The sshd is the server
365part of the secure shell protocol and allows ssh clients to connect to
366your host.
367
368%description server -l de.UTF-8
369Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
370
371%description server -l es.UTF-8
372Este paquete contiene el servidor SSH. sshd es la parte servidor del
373protocolo secure shell y permite que clientes ssh se conecten a su
374servidor.
375
376%description server -l fr.UTF-8
377Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
378
379%description server -l it.UTF-8
380Questo pacchetto installa sshd, il server di OpenSSH.
381
382%description server -l pl.UTF-8
383Ssh (Secure Shell) to program służący do logowania się na zdalną
384maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
385zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
386pomiędzy dwoma hostami.
387
388Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
389ssh).
390
391%description server -l pt.UTF-8
392Este pacote intala o sshd, o servidor do OpenSSH.
393
394%description server -l pt_BR.UTF-8
395Esse pacote contém o servidor SSH. O sshd é a parte servidor do
396protocolo secure shell e permite que clientes ssh se conectem ao seu
397host.
398
399%description server -l ru.UTF-8
400Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
401машину и для выполнения команд на удаленной машине.
402
403Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
404часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
405вашим хостом.
406
407%description server -l uk.UTF-8
408Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
409машини та для виконання команд на віддаленій машині.
410
411Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
412частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
413з вашим хостом.
414
415%package server-ldap
416Summary: A LDAP support for open source SSH server daemon
417Summary(pl.UTF-8): Wsparcie LDAP dla serwera OpenSSH
418Group: Daemons
419Requires: %{name} = %{epoch}:%{version}-%{release}
420
421%description server-ldap
422OpenSSH LDAP backend is a way how to distribute the authorized tokens
423among the servers in the network.
424
425%description server-ldap -l pl.UTF-8
426Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
427tokenów między serwerami w sieci.
428
429%package server-upstart
430Summary: Upstart job description for OpenSSH server
431Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
432Group: Daemons
433Requires: %{name}-server = %{epoch}:%{version}-%{release}
434Requires: upstart >= 0.6
435Conflicts: syslog-ng < 3.2.4-1
436
437%description server-upstart
438Upstart job description for OpenSSH.
439
440%description server-upstart -l pl.UTF-8
441Opis zadania Upstart dla OpenSSH.
442
443%package gnome-askpass
444Summary: OpenSSH GNOME passphrase dialog
445Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
446Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
447Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
448Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
449Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
450Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
451Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
452Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
453Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
454Group: Applications/Networking
455Requires: %{name} = %{epoch}:%{version}-%{release}
456Obsoletes: openssh-askpass
457Obsoletes: ssh-askpass
458Obsoletes: ssh-extras
459
460%description gnome-askpass
461Ssh (Secure Shell) a program for logging into a remote machine and for
462executing commands in a remote machine. It is intended to replace
463rlogin and rsh, and provide secure encrypted communications between
464two untrusted hosts over an insecure network. X11 connections and
465arbitrary TCP/IP ports can also be forwarded over the secure channel.
466
467OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
468it up to date in terms of security and features, as well as removing
469all patented algorithms to seperate libraries (OpenSSL).
470
471This package contains the GNOME passphrase dialog.
472
473%description gnome-askpass -l es.UTF-8
474Este paquete contiene un programa que abre una caja de diálogo para
475entrada de passphrase en GNOME.
476
477%description gnome-askpass -l pl.UTF-8
478Ssh (Secure Shell) to program służący do logowania się na zdalną
479maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
480zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
481pomiędzy dwoma hostami.
482
483Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
484
485%description gnome-askpass -l pt_BR.UTF-8
486Esse pacote contém um programa que abre uma caixa de diálogo para
487entrada de passphrase no GNOME.
488
489%description gnome-askpass -l ru.UTF-8
490Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
491машину и для выполнения команд на удаленной машине.
492
493Этот пакет содержит диалог ввода ключевой фразы для использования под
494GNOME.
495
496%description gnome-askpass -l uk.UTF-8
497Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
498машини та для виконання команд на віддаленій машині.
499
500Цей пакет містить діалог вводу ключової фрази для використання під
501GNOME.
502
503%package -n openldap-schema-openssh-lpk
504Summary: OpenSSH LDAP Public Key schema
505Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
506Group: Networking/Daemons
507Requires(post,postun): sed >= 4.0
508Requires: openldap-servers
509
510%description -n openldap-schema-openssh-lpk
511This package contains OpenSSH LDAP Public Key schema for openldap.
512
513%description -n openldap-schema-openssh-lpk -l pl.UTF-8
514Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
515openldap-a.
516
517%prep
518%setup -q
519%{?with_kerberos5:%patch100 -p1}
520%patch0 -p1
521%patch2 -p1
522%patch3 -p1
523%patch4 -p1
524%patch5 -p1
525%patch8 -p1
526%patch6 -p1
527%patch7 -p1
528%{?with_hpn:%patch9 -p1}
529%patch10 -p1
530%patch11 -p1
531%patch12 -p1
532%patch13 -p1
533%patch14 -p1
534
535%if "%{pld_release}" == "ac"
536# fix for missing x11.pc
537%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
538%endif
539
540# hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
541sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
542
543grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
544%{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
545
546%build
547cp /usr/share/automake/config.sub .
548%{__aclocal}
549%{__autoconf}
550%{__autoheader}
551CPPFLAGS="-DCHROOT"
552%configure \
553 PERL=%{__perl} \
554 --disable-strip \
555 --enable-utmpx \
556 --enable-wtmpx \
557 --with-4in6 \
558 %{?with_audit:--with-audit=linux} \
559 --with-ipaddr-display \
560 %{?with_kerberos5:--with-kerberos5=/usr} \
561 --with-ldap%{!?with_ldap:=no} \
562 %{?with_libedit:--with-libedit} \
563 --with-mantype=man \
564 --with-md5-passwords \
565 --with-pam \
566 --with-authorized-keys-command \
567 --with-pid-dir=%{_localstatedir}/run \
568 --with-privsep-path=%{_privsepdir} \
569 %{?with_selinux:--with-selinux} \
570 --with-tcp-wrappers \
571%if "%{pld_release}" == "ac"
572 --with-xauth=/usr/X11R6/bin/xauth
573%else
574 --with-xauth=%{_bindir}/xauth
575%endif
576
577echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
578
579%{__make}
580
581%{?with_tests:%{__make} tests}
582
583cd contrib
584%if %{with gnome}
585%{__make} gnome-ssh-askpass1 \
586 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
587%endif
588%if %{with gtk}
589%{__make} gnome-ssh-askpass2 \
590 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
591%endif
592
593%install
594rm -rf $RPM_BUILD_ROOT
595install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
596 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
597install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
598
599%{__make} install \
600 DESTDIR=$RPM_BUILD_ROOT
601
602bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
603
604cp -p %{SOURCE3} sshd.pam
605install -p %{SOURCE2} sshd.init
606
607%if "%{pld_release}" == "ac"
608# not present in ac, no point searching it
609%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
610# openssl on ac does not have OPENSSL_HAS_ECC
611%{__sed} -i -e '/ecdsa/d' sshd.init
612%endif
613
614install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
615cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
616cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
617cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
618ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
619cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
620cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
621cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
622
623%{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
624cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
625
626%if %{with gnome}
627install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
628%endif
629%if %{with gtk}
630install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
631%endif
632%if %{with gnome} || %{with gtk}
633cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
634#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
635EOF
636cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
637#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
638EOF
639ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
640%endif
641
642install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
643cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
644
645%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
646echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
647
648touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
649
650cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
651#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
652EOF
653
654%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
655%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
656
657%clean
658rm -rf $RPM_BUILD_ROOT
659
660%post clients
661%env_update
662
663%postun clients
664%env_update
665
666%post gnome-askpass
667%env_update
668
669%postun gnome-askpass
670%env_update
671
672%pre server
673%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
674
675%post server
676/sbin/chkconfig --add sshd
677%service sshd reload "OpenSSH Daemon"
678if ! grep -qs ssh /etc/security/passwd.conf ; then
679 umask 022
680 echo "ssh" >> /etc/security/passwd.conf
681fi
682if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
683%banner %{name}-server -e << EOF
684!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
685! Native systemd support for sshd has been installed. !
686! Restarting sshd.service with systemctl WILL kill all !
687! active ssh sessions (daemon as such will be started). !
688!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
689EOF
690fi
691NORESTART=1
692%systemd_post sshd.service
693
694%preun server
695if [ "$1" = "0" ]; then
696 %service sshd stop
697 /sbin/chkconfig --del sshd
698fi
699%systemd_preun sshd.service
700
701%postun server
702if [ "$1" = "0" ]; then
703 %userremove sshd
704fi
705%systemd_reload
706
707%triggerpostun server -- %{name}-server < 2:5.9p1-8
708# lpk.patch to ldap.patch
709if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
710 echo >&2 "Migrating LPK patch to LDAP patch"
711 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
712 %{__sed} -i -e '
713 # disable old configs
714 # just UseLPK/LkpLdapConf supported for now
715 s/^UseLPK/## Obsolete &/
716 s/^Lpk/## Obsolete &/
717 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
718 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
719 ' %{_sysconfdir}/sshd_config
720 if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
721 /bin/systemctl try-restart sshd.service || :
722 else
723 %service -q sshd reload
724 fi
725fi
726%systemd_trigger sshd.service
727
728%post server-upstart
729%upstart_post sshd
730
731%postun server-upstart
732%upstart_postun sshd
733
734%post -n openldap-schema-openssh-lpk
735%openldap_schema_register %{schemadir}/openssh-lpk.schema
736%service -q ldap restart
737
738%postun -n openldap-schema-openssh-lpk
739if [ "$1" = "0" ]; then
740 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
741 %service -q ldap restart
742fi
743
744%files
745%defattr(644,root,root,755)
746%doc TODO README OVERVIEW CREDITS Change*
747%attr(755,root,root) %{_bindir}/ssh-key*
748%attr(755,root,root) %{_bindir}/ssh-vulnkey*
749%{_mandir}/man1/ssh-key*.1*
750%{_mandir}/man1/ssh-vulnkey*.1*
751%dir %{_sysconfdir}
752%dir %{_libexecdir}
753
754%files clients
755%defattr(644,root,root,755)
756%attr(755,root,root) %{_bindir}/ssh
757%attr(755,root,root) %{_bindir}/slogin
758%attr(755,root,root) %{_bindir}/sftp
759%attr(755,root,root) %{_bindir}/ssh-agent
760%attr(755,root,root) %{_bindir}/ssh-add
761%attr(755,root,root) %{_bindir}/ssh-copy-id
762%attr(755,root,root) %{_bindir}/scp
763%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
764%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
765%{_mandir}/man1/scp.1*
766%{_mandir}/man1/ssh.1*
767%{_mandir}/man1/slogin.1*
768%{_mandir}/man1/sftp.1*
769%{_mandir}/man1/ssh-agent.1*
770%{_mandir}/man1/ssh-add.1*
771%{_mandir}/man1/ssh-copy-id.1*
772%{_mandir}/man5/ssh_config.5*
773%lang(it) %{_mandir}/it/man1/ssh.1*
774%lang(it) %{_mandir}/it/man5/ssh_config.5*
775%lang(pl) %{_mandir}/pl/man1/scp.1*
776%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
777
778# for host-based auth (suid required for accessing private host key)
779#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
780#%{_mandir}/man8/ssh-keysign.8*
781
782%files clients-agent-profile_d
783%defattr(644,root,root,755)
784%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
785%attr(755,root,root) /etc/profile.d/ssh-agent.sh
786
787%files clients-agent-xinitrc
788%defattr(644,root,root,755)
789%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
790
791%files server
792%defattr(644,root,root,755)
793%attr(755,root,root) %{_sbindir}/sshd
794%attr(755,root,root) %{_libexecdir}/sftp-server
795%attr(755,root,root) %{_libexecdir}/ssh-keysign
796%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
797%attr(755,root,root) %{_libexecdir}/sshd-keygen
798%{_mandir}/man8/sshd.8*
799%{_mandir}/man8/sftp-server.8*
800%{_mandir}/man8/ssh-keysign.8*
801%{_mandir}/man8/ssh-pkcs11-helper.8*
802%{_mandir}/man5/sshd_config.5*
803%{_mandir}/man5/moduli.5*
804%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
805%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
806%attr(640,root,root) %{_sysconfdir}/moduli
807%attr(754,root,root) /etc/rc.d/init.d/sshd
808%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
809%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
810%{systemdunitdir}/sshd.service
811
812%if %{with ldap}
813%files server-ldap
814%defattr(644,root,root,755)
815%doc HOWTO.ldap-keys ldap.conf
816%attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
817%attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
818%{_mandir}/man5/ssh-ldap.conf.5*
819%{_mandir}/man8/ssh-ldap-helper.8*
820%endif
821
822%if %{with gnome} || %{with gtk}
823%files gnome-askpass
824%defattr(644,root,root,755)
825%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
826%dir %{_libexecdir}/ssh
827%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
828%attr(755,root,root) %{_libexecdir}/ssh-askpass
829%endif
830
831%if %{with ldap}
832%files -n openldap-schema-openssh-lpk
833%defattr(644,root,root,755)
834%{schemadir}/openssh-lpk.schema
835%endif
836
837%if "%{pld_release}" != "ti"
838%files server-upstart
839%defattr(644,root,root,755)
840%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
841%endif
This page took 0.056106 seconds and 4 git commands to generate.