]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- tabs in preamble
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without chroot # without chrooted user environment support
4%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
5%bcond_without gtk # without GTK+ (2.x)
6%bcond_with ldap # with ldap support
7%bcond_without libedit # without libedit (editline/history support in sftp client)
8%bcond_without kerberos5 # without kerberos5 support
9%bcond_without selinux # build without SELinux support
10%bcond_with sshagentsh # with system-wide script for starting ssh-agent
11%bcond_with hpn # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12%bcond_with hpn_none # with hpn (above) and '-z' none cipher option
13#
14%if %{with hpn_none}
15%undefine with_hpn
16%endif
17# gtk2-based gnome-askpass means no gnome1-based
18%{?with_gtk:%undefine with_gnome}
19Summary: OpenSSH free Secure Shell (SSH) implementation
20Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
21Summary(es.UTF-8): Implementación libre de SSH
22Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
23Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
24Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
25Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
26Summary(pt_BR.UTF-8): Implementação livre do SSH
27Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
28Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
29Name: openssh
30Version: 4.5p1
31Release: 3%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
32Epoch: 2
33License: BSD
34Group: Applications/Networking
35Source0: ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
36# Source0-md5: 6468c339886f78e8a149b88f695839dd
37Source1: %{name}d.conf
38Source2: %{name}.conf
39Source3: %{name}d.init
40Source4: %{name}d.pamd
41Source5: %{name}.sysconfig
42Source6: passwd.pamd
43Source7: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
44# Source7-md5: 66943d481cc422512b537bcc2c7400d1
45Source11: ssh-agent.sh
46Source12: ssh-agent.conf
47Patch0: %{name}-no_libnsl.patch
48Patch2: %{name}-linux-ipv6.patch
49Patch3: %{name}-pam_misc.patch
50Patch4: %{name}-sigpipe.patch
51# http://www.opendarwin.org/projects/openssh-lpk/
52Patch5: %{name}-lpk-4.3p1-0.3.7.patch
53Patch6: %{name}-heimdal.patch
54Patch7: %{name}-pam-conv.patch
55# http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
56Patch8: %{name}-chroot.patch
57Patch9: %{name}-selinux.patch
58# HPN patches rediffed due sigpipe patch.
59# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
61Patch10: %{name}-4.3p1-hpn11.patch
62# Adds HPN (see p11) and an undocumented -z none cipher flag
63# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
64Patch11: %{name}-4.3p1-hpn11-none.patch
65Patch12: %{name}-include.patch
66URL: http://www.openssh.com/
67BuildRequires: %{__perl}
68BuildRequires: autoconf
69BuildRequires: automake
70%{?with_gnome:BuildRequires: gnome-libs-devel}
71%{?with_gtk:BuildRequires: gtk+2-devel}
72%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
73%{?with_libedit:BuildRequires: libedit-devel}
74%{?with_selinux:BuildRequires: libselinux-devel}
75BuildRequires: libwrap-devel
76%{?with_ldap:BuildRequires: openldap-devel}
77BuildRequires: openssl-devel >= 0.9.7d
78BuildRequires: pam-devel
79%{?with_gtk:BuildRequires: pkgconfig}
80BuildRequires: rpmbuild(macros) >= 1.318
81BuildRequires: zlib-devel
82Requires: filesystem >= 3.0-11
83Requires: pam >= 0.99.7.1
84Obsoletes: ssh
85BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87%define _sysconfdir /etc/ssh
88%define _libexecdir %{_libdir}/%{name}
89%define _privsepdir /usr/share/empty
90
91%description
92Ssh (Secure Shell) a program for logging into a remote machine and for
93executing commands in a remote machine. It is intended to replace
94rlogin and rsh, and provide secure encrypted communications between
95two untrusted hosts over an insecure network. X11 connections and
96arbitrary TCP/IP ports can also be forwarded over the secure channel.
97
98OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
99it up to date in terms of security and features, as well as removing
100all patented algorithms to seperate libraries (OpenSSL).
101
102This package includes the core files necessary for both the OpenSSH
103client and server. To make this package useful, you should also
104install openssh-clients, openssh-server, or both.
105%if %{with hpn} || %{with hpn_none}
106This release includes High Performance SSH/SCP patches from
107http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
108to increase throughput on fast connections with high RTT (20-150 msec).
109See the website for '-w' values for your connection and /proc/sys TCP
110values. BTW. in a LAN you have got generally RTT < 1 msec.
111%endif
112%if %{with hpn_none}
113It also includes an undocumented '-z' option which switches
114the cipher to none after authentication is completed. Data is
115still secured from tampering and corruption in transit through
116the use of the Message Authentication Code (MAC).
117This option will significantly reduce the number of cpu cycles used
118by the SSH/SCP process. This may allow some users to see significant
119improvement in (sniffable) data tranfer rates.
120%endif
121
122%description -l de.UTF-8
123OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
124ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
125verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
126über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
127andere TCP/IP Ports können ebenso über den sicheren Channel
128weitergeleitet werden.
129
130%description -l es.UTF-8
131SSH es un programa para accesar y ejecutar órdenes en computadores
132remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
133seguro entre dos servidores en una red insegura. Conexiones X11 y
134puertas TCP/IP arbitrárias también pueden ser usadas por el canal
135seguro.
136
137OpenSSH es el resultado del trabajo del equipo de OpenBSD para
138continuar la última versión gratuita de SSH, actualizándolo en
139términos de seguridad y recursos,así también eliminando todos los
140algoritmos patentados y colocándolos en bibliotecas separadas
141(OpenSSL).
142
143Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
144también el paquete openssh-clients u openssh-server o ambos.
145
146%description -l fr.UTF-8
147OpenSSH (Secure Shell) fournit un accès à un système distant. Il
148remplace telnet, rlogin, rexec et rsh, tout en assurant des
149communications cryptées securisées entre deux hôtes non fiabilisés sur
150un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
151arbitraires peuvent également être transmis sur le canal sécurisé.
152
153%description -l it.UTF-8
154OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
155Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
156sicure e crittate tra due host non fidati su una rete non sicura. Le
157connessioni X11 ad una porta TCP/IP arbitraria possono essere
158inoltrate attraverso un canale sicuro.
159
160%description -l pl.UTF-8
161Ssh (Secure Shell) to program służący do logowania się na zdalną
162maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
163zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
164pomiędzy dwoma hostami.
165
166Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
167klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
168co najmniej jeden z pakietów: openssh-clients lub openssh-server.
169%if %{with hpn} || %{with hpn_none}
170Ta wersja zawiera łaty z projektu High Performance SSH/SCP
171http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
172zwiększenie przepustowości transmisji dla szybkich połączeń
173z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
174odpowednie dla danego połączenia wartości parametru '-w' oraz
175opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
176%endif
177%if %{with hpn_none}
178Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
179za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
180Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
181stosowanie Message Authentication Code (MAC).
182Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
183procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
184na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
185%endif
186
187%description -l pt.UTF-8
188OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
189telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
190cifradas entre duas máquinas sem confiança mútua sobre uma rede
191insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
192reenviados pelo canal seguro.
193
194%description -l pt_BR.UTF-8
195SSH é um programa para acessar e executar comandos em máquinas
196remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
197seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
198TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
199
200OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
201última versão gratuita do SSH, atualizando-o em termos de segurança e
202recursos, assim como removendo todos os algoritmos patenteados e
203colocando-os em bibliotecas separadas (OpenSSL).
204
205Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
206também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
207
208%description -l ru.UTF-8
209Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
210машину и для выполнения команд на удаленной машине. Она предназначена
211для замены rlogin и rsh и обеспечивает безопасную шифрованную
212коммуникацию между двумя хостами в сети, являющейся небезопасной.
213Соединения X11 и любые порты TCP/IP могут также быть проведены через
214безопасный канал.
215
216OpenSSH - это переделка командой разработчиков OpenBSD последней
217свободной версии SSH, доведенная до современного состояния в терминах
218уровня безопасности и поддерживаемых возможностей. Все патентованные
219алгоритмы вынесены в отдельные библиотеки (OpenSSL).
220
221Этот пакет содержит файлы, необходимые как для клиента, так и для
222сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
223openssh-server, или оба пакета.
224
225%description -l uk.UTF-8
226Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
227машини та для виконання команд на віддаленій машині. Вона призначена
228для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
229між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
230довільні порти TCP/IP можуть також бути проведені через безпечний
231канал.
232
233OpenSSH - це переробка командою розробників OpenBSD останньої вільної
234версії SSH, доведена до сучасного стану в термінах рівня безпеки та
235підтримуваних можливостей. Всі патентовані алгоритми винесені до
236окремих бібліотек (OpenSSL).
237
238Цей пакет містить файли, необхідні як для клієнта, так і для сервера
239OpenSSH. Вам потрібно буде ще встановити openssh-clients,
240openssh-server, чи обидва пакети.
241
242%package clients
243Summary: OpenSSH Secure Shell protocol clients
244Summary(es.UTF-8): Clientes de OpenSSH
245Summary(pl.UTF-8): Klienci protokołu Secure Shell
246Summary(pt_BR.UTF-8): Clientes do OpenSSH
247Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
248Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
249Group: Applications/Networking
250Requires: %{name} = %{epoch}:%{version}-%{release}
251%{?with_sshagentsh:Requires: xinitrc}
252Provides: ssh-clients
253Obsoletes: ssh-clients
254
255%description clients
256Ssh (Secure Shell) a program for logging into a remote machine and for
257executing commands in a remote machine. It is intended to replace
258rlogin and rsh, and provide secure encrypted communications between
259two untrusted hosts over an insecure network. X11 connections and
260arbitrary TCP/IP ports can also be forwarded over the secure channel.
261
262OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
263it up to date in terms of security and features, as well as removing
264all patented algorithms to seperate libraries (OpenSSL).
265
266This package includes the clients necessary to make encrypted
267connections to SSH servers.
268
269%description clients -l es.UTF-8
270Este paquete incluye los clientes que se necesitan para hacer
271conexiones codificadas con servidores SSH.
272
273%description clients -l pl.UTF-8
274Ssh (Secure Shell) to program służący do logowania się na zdalną
275maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
276zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
277pomiędzy dwoma hostami.
278
279Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
280
281%description clients -l pt_BR.UTF-8
282Esse pacote inclui os clientes necessários para fazer conexões
283encriptadas com servidores SSH.
284
285%description clients -l ru.UTF-8
286Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
287машину и для выполнения команд на удаленной машине.
288
289Этот пакет содержит программы-клиенты, необходимые для установления
290зашифрованных соединений с серверами SSH.
291
292%description clients -l uk.UTF-8
293Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
294машини та для виконання команд на віддаленій машині.
295
296Цей пакет містить програми-клієнти, необхідні для встановлення
297зашифрованих з'єднань з серверами SSH.
298
299%package server
300Summary: OpenSSH Secure Shell protocol server (sshd)
301Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
302Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
303Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
304Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
305Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
306Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
307Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
308Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
309Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
310Group: Networking/Daemons
311Requires(post): chkconfig >= 0.9
312Requires(post): grep
313Requires(post,preun): /sbin/chkconfig
314Requires(postun): /usr/sbin/userdel
315Requires(pre): /bin/id
316Requires(pre): /usr/sbin/useradd
317Requires: %{name} = %{epoch}:%{version}-%{release}
318Requires: /bin/login
319Requires: pam >= 0.99.7.1
320Requires: rc-scripts >= 0.4.0.18
321Requires: util-linux
322Provides: ssh-server
323Provides: user(sshd)
324
325%description server
326Ssh (Secure Shell) a program for logging into a remote machine and for
327executing commands in a remote machine. It is intended to replace
328rlogin and rsh, and provide secure encrypted communications between
329two untrusted hosts over an insecure network. X11 connections and
330arbitrary TCP/IP ports can also be forwarded over the secure channel.
331
332OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
333it up to date in terms of security and features, as well as removing
334all patented algorithms to seperate libraries (OpenSSL).
335
336This package contains the secure shell daemon. The sshd is the server
337part of the secure shell protocol and allows ssh clients to connect to
338your host.
339
340%description server -l de.UTF-8
341Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
342
343%description server -l es.UTF-8
344Este paquete contiene el servidor SSH. sshd es la parte servidor del
345protocolo secure shell y permite que clientes ssh se conecten a su
346servidor.
347
348%description server -l fr.UTF-8
349Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
350
351%description server -l it.UTF-8
352Questo pacchetto installa sshd, il server di OpenSSH.
353
354%description server -l pl.UTF-8
355Ssh (Secure Shell) to program służący do logowania się na zdalną
356maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
357zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
358pomiędzy dwoma hostami.
359
360Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
361ssh).
362
363%description server -l pt.UTF-8
364Este pacote intala o sshd, o servidor do OpenSSH.
365
366%description server -l pt_BR.UTF-8
367Esse pacote contém o servidor SSH. O sshd é a parte servidor do
368protocolo secure shell e permite que clientes ssh se conectem ao seu
369host.
370
371%description server -l ru.UTF-8
372Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
373машину и для выполнения команд на удаленной машине.
374
375Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
376часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
377вашим хостом.
378
379%description server -l uk.UTF-8
380Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
381машини та для виконання команд на віддаленій машині.
382
383Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
384частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
385з вашим хостом.
386
387%package gnome-askpass
388Summary: OpenSSH GNOME passphrase dialog
389Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
390Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
391Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
392Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
393Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
394Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
395Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
396Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
397Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
398Group: Applications/Networking
399Requires: %{name} = %{epoch}:%{version}-%{release}
400Obsoletes: openssh-askpass
401Obsoletes: ssh-askpass
402Obsoletes: ssh-extras
403
404%description gnome-askpass
405Ssh (Secure Shell) a program for logging into a remote machine and for
406executing commands in a remote machine. It is intended to replace
407rlogin and rsh, and provide secure encrypted communications between
408two untrusted hosts over an insecure network. X11 connections and
409arbitrary TCP/IP ports can also be forwarded over the secure channel.
410
411OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
412it up to date in terms of security and features, as well as removing
413all patented algorithms to seperate libraries (OpenSSL).
414
415This package contains the GNOME passphrase dialog.
416
417%description gnome-askpass -l es.UTF-8
418Este paquete contiene un programa que abre una caja de diálogo para
419entrada de passphrase en GNOME.
420
421%description gnome-askpass -l pl.UTF-8
422Ssh (Secure Shell) to program służący do logowania się na zdalną
423maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
424zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
425pomiędzy dwoma hostami.
426
427Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
428
429%description gnome-askpass -l pt_BR.UTF-8
430Esse pacote contém um programa que abre uma caixa de diálogo para
431entrada de passphrase no GNOME.
432
433%description gnome-askpass -l ru.UTF-8
434Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
435машину и для выполнения команд на удаленной машине.
436
437Этот пакет содержит диалог ввода ключевой фразы для использования под
438GNOME.
439
440%description gnome-askpass -l uk.UTF-8
441Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
442машини та для виконання команд на віддаленій машині.
443
444Цей пакет містить діалог вводу ключової фрази для використання під
445GNOME.
446
447%prep
448%setup -q
449%patch0 -p1
450%patch2 -p1
451%patch3 -p1
452%patch4 -p1
453%{?with_ldap:%patch5 -p1}
454%{?with_kerberos5:%patch6 -p1}
455#%patch7 -p1
456%patch8 -p1
457%patch9 -p1
458%{?with_hpn:%patch10 -p1}
459%{?with_hpn_none:%patch11 -p1}
460%patch12 -p1
461
462%build
463cp /usr/share/automake/config.sub .
464%{__aclocal}
465%{__autoconf}
466%{?with_chroot:CPPFLAGS="-DCHROOT"}
467%configure \
468 PERL=%{__perl} \
469 --with-dns \
470 --with-pam \
471 --with-mantype=man \
472 --with-md5-passwords \
473 --with-ipaddr-display \
474 %{?with_libedit:--with-libedit} \
475 --with-4in6 \
476 --disable-suid-ssh \
477 --with-tcp-wrappers \
478 %{?with_ldap:--with-libs="-lldap -llber"} \
479 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
480 %{?with_kerberos5:--with-kerberos5} \
481 --with-privsep-path=%{_privsepdir} \
482 --with-pid-dir=%{_localstatedir}/run \
483 --with-xauth=/usr/bin/xauth \
484 --enable-utmpx \
485 --enable-wtmpx
486
487echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
488
489%{__make}
490
491cd contrib
492%if %{with gnome}
493%{__make} gnome-ssh-askpass1 \
494 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
495%endif
496%if %{with gtk}
497%{__make} gnome-ssh-askpass2 \
498 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
499%endif
500
501%install
502rm -rf $RPM_BUILD_ROOT
503install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
504 $RPM_BUILD_ROOT%{_libexecdir}/ssh
505%{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
506
507%{__make} install \
508 DESTDIR=$RPM_BUILD_ROOT
509
510install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
511install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
512install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
513install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
514install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
515install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
516%if %{with sshagentsh}
517install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
518ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
519install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
520%endif
521
522bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
523
524%if %{with gnome}
525install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
526%endif
527%if %{with gtk}
528install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
529%endif
530%if %{with gnome} || %{with gtk}
531cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
532#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
533EOF
534cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
535#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
536EOF
537ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
538%endif
539
540rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
541echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
542
543touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
544
545%if "%{_lib}" != "lib"
546find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
547%endif
548
549cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
550#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
551EOF
552
553%clean
554rm -rf $RPM_BUILD_ROOT
555
556%post clients
557%env_update
558
559%postun clients
560%env_update
561
562%post gnome-askpass
563%env_update
564
565%postun gnome-askpass
566%env_update
567
568%pre server
569%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
570
571%post server
572/sbin/chkconfig --add sshd
573%service sshd reload "openssh daemon"
574if ! grep -qs ssh /etc/security/passwd.conf ; then
575 umask 022
576 echo "ssh" >> /etc/security/passwd.conf
577fi
578
579%preun server
580if [ "$1" = "0" ]; then
581 %service sshd stop
582 /sbin/chkconfig --del sshd
583fi
584
585%postun server
586if [ "$1" = "0" ]; then
587 %userremove sshd
588fi
589
590%files
591%defattr(644,root,root,755)
592%doc *.RNG TODO README OVERVIEW CREDITS Change*
593%attr(755,root,root) %{_bindir}/ssh-key*
594%{_mandir}/man1/ssh-key*.1*
595%dir %{_sysconfdir}
596%dir %{_libexecdir}
597
598%files clients
599%defattr(644,root,root,755)
600%attr(755,root,root) %{_bindir}/ssh
601%attr(755,root,root) %{_bindir}/slogin
602%attr(755,root,root) %{_bindir}/sftp
603%attr(755,root,root) %{_bindir}/ssh-agent
604%attr(755,root,root) %{_bindir}/ssh-add
605%attr(755,root,root) %{_bindir}/scp
606%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
607%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
608%if %{with sshagentsh}
609%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
610%attr(755,root,root) /etc/profile.d/ssh-agent.sh
611%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
612%endif
613%{_mandir}/man1/scp.1*
614%{_mandir}/man1/ssh.1*
615%{_mandir}/man1/slogin.1*
616%{_mandir}/man1/sftp.1*
617%{_mandir}/man1/ssh-agent.1*
618%{_mandir}/man1/ssh-add.1*
619%{_mandir}/man5/ssh_config.5*
620%lang(it) %{_mandir}/it/man1/ssh.1*
621%lang(it) %{_mandir}/it/man5/ssh_config.5*
622%lang(pl) %{_mandir}/pl/man1/scp.1*
623%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
624
625# for host-based auth (suid required for accessing private host key)
626#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
627#%{_mandir}/man8/ssh-keysign.8*
628
629%files server
630%defattr(644,root,root,755)
631%attr(755,root,root) %{_sbindir}/sshd
632%attr(755,root,root) %{_libexecdir}/sftp-server
633%attr(755,root,root) %{_libexecdir}/ssh-keysign
634%{_mandir}/man8/sshd.8*
635%{_mandir}/man8/sftp-server.8*
636%{_mandir}/man8/ssh-keysign.8*
637%{_mandir}/man5/sshd_config.5*
638%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
639%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
640%attr(640,root,root) %{_sysconfdir}/moduli
641%attr(754,root,root) /etc/rc.d/init.d/sshd
642%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
643%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
644
645%if %{with gnome} || %{with gtk}
646%files gnome-askpass
647%defattr(644,root,root,755)
648%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
649%dir %{_libexecdir}/ssh
650%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
651%attr(755,root,root) %{_libexecdir}/ssh-askpass
652%endif
This page took 0.070301 seconds and 4 git commands to generate.