]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- up to 8.2p1; new - FIDO/U2F support
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# TODO:
2# - add trigger to enable this:
3# * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4# new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5#
6# Conditional build:
7%bcond_without audit # sshd audit support
8%bcond_with gnome # gnome-askpass (GNOME 1.x) utility
9%bcond_without gtk # gnome-askpass (GTK+ 2.x) utility
10%bcond_without ldap # LDAP support
11%bcond_with ldns # DNSSEC support via libldns
12%bcond_without libedit # libedit (editline/history support in sftp client)
13%bcond_without kerberos5 # Kerberos5 support
14%bcond_without selinux # SELinux support
15%bcond_without libseccomp # use libseccomp for seccomp privsep (requires 3.5 kernel)
16%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
17%bcond_without tests # test suite
18%bcond_with tests_conch # run conch interoperability tests
19
20# gtk2-based gnome-askpass means no gnome1-based
21%{?with_gtk:%undefine with_gnome}
22
23%if "%{pld_release}" == "ac"
24%define pam_ver 0.79.0
25%else
26%define pam_ver 1:1.1.8-5
27%endif
28Summary: OpenSSH free Secure Shell (SSH) implementation
29Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
30Summary(es.UTF-8): Implementación libre de SSH
31Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
32Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
33Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
34Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
35Summary(pt_BR.UTF-8): Implementação livre do SSH
36Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
37Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
38Name: openssh
39Version: 8.2p1
40Release: 1
41Epoch: 2
42License: BSD
43Group: Applications/Networking
44Source0: http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
45# Source0-md5: 3076e6413e8dbe56d33848c1054ac091
46Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
47# Source1-md5: 66943d481cc422512b537bcc2c7400d1
48Source2: %{name}d.init
49Source3: %{name}d.pamd
50Source4: %{name}.sysconfig
51Source5: ssh-agent.sh
52Source6: ssh-agent.conf
53Source7: %{name}-lpk.schema
54Source9: sshd.service
55Source10: sshd-keygen
56Source11: sshd.socket
57Source12: sshd@.service
58Patch0: %{name}-no-pty-tests.patch
59Patch1: %{name}-tests-reuseport.patch
60Patch2: %{name}-pam_misc.patch
61Patch3: %{name}-sigpipe.patch
62# http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
63Patch4: %{name}-ldap.patch
64Patch5: %{name}-ldap-fixes.patch
65Patch6: ldap.conf.patch
66Patch7: %{name}-config.patch
67Patch8: ldap-helper-sigpipe.patch
68# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
69# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
70Patch9: %{name}-5.2p1-hpn13v6.diff
71
72Patch11: %{name}-chroot.patch
73Patch12: openssh-bug-2905.patch
74Patch13: %{name}-skip-interop-tests.patch
75Patch14: %{name}-bind.patch
76Patch15: %{name}-disable_ldap.patch
77URL: http://www.openssh.com/portable.html
78BuildRequires: %{__perl}
79%{?with_audit:BuildRequires: audit-libs-devel}
80BuildRequires: autoconf >= 2.50
81BuildRequires: automake
82%{?with_gnome:BuildRequires: gnome-libs-devel}
83%{?with_gtk:BuildRequires: gtk+2-devel}
84%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
85%{?with_ldns:BuildRequires: ldns-devel}
86%{?with_libedit:BuildRequires: libedit-devel}
87BuildRequires: libfido2-devel
88BuildRequires: libseccomp-devel
89%{?with_selinux:BuildRequires: libselinux-devel}
90%{?with_ldap:BuildRequires: openldap-devel}
91BuildRequires: openssl-devel >= 1.1.0g
92BuildRequires: pam-devel
93%{?with_gtk:BuildRequires: pkgconfig}
94%if %{with tests} && %{with tests_conch}
95BuildRequires: python-TwistedConch
96%endif
97BuildRequires: rpm >= 4.4.9-56
98BuildRequires: rpmbuild(macros) >= 1.627
99BuildRequires: sed >= 4.0
100BuildRequires: zlib-devel >= 1.2.3
101%if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
102BuildRequires: %{name}-server
103%endif
104%if %{with tests} && %{with libseccomp}
105# libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
106BuildRequires: uname(release) >= 3.5
107%endif
108Requires: zlib >= 1.2.3
109%if "%{pld_release}" == "ac"
110Requires: filesystem >= 2.0-1
111Requires: pam >= 0.79.0
112%else
113Requires: filesystem >= 3.0-11
114Requires: pam >= %{pam_ver}
115Suggests: xorg-app-xauth
116%endif
117Obsoletes: ssh
118BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120%define _sysconfdir /etc/ssh
121%define _libexecdir %{_libdir}/%{name}
122%define _privsepdir /usr/share/empty
123%define schemadir /usr/share/openldap/schema
124
125%description
126Ssh (Secure Shell) a program for logging into a remote machine and for
127executing commands in a remote machine. It is intended to replace
128rlogin and rsh, and provide secure encrypted communications between
129two untrusted hosts over an insecure network. X11 connections and
130arbitrary TCP/IP ports can also be forwarded over the secure channel.
131
132OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
133it up to date in terms of security and features, as well as removing
134all patented algorithms to seperate libraries (OpenSSL).
135
136This package includes the core files necessary for both the OpenSSH
137client and server. To make this package useful, you should also
138install openssh-clients, openssh-server, or both.
139
140%if %{with hpn}
141This release includes High Performance SSH/SCP patches from
142http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
143increase throughput on fast connections with high RTT (20-150 msec).
144See the website for '-w' values for your connection and /proc/sys TCP
145values. BTW. in a LAN you have got generally RTT < 1 msec.
146%endif
147
148%description -l de.UTF-8
149OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
150ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
151verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
152über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
153andere TCP/IP Ports können ebenso über den sicheren Channel
154weitergeleitet werden.
155
156%description -l es.UTF-8
157SSH es un programa para accesar y ejecutar órdenes en computadores
158remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
159seguro entre dos servidores en una red insegura. Conexiones X11 y
160puertas TCP/IP arbitrárias también pueden ser usadas por el canal
161seguro.
162
163OpenSSH es el resultado del trabajo del equipo de OpenBSD para
164continuar la última versión gratuita de SSH, actualizándolo en
165términos de seguridad y recursos,así también eliminando todos los
166algoritmos patentados y colocándolos en bibliotecas separadas
167(OpenSSL).
168
169Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
170también el paquete openssh-clients u openssh-server o ambos.
171
172%description -l fr.UTF-8
173OpenSSH (Secure Shell) fournit un accès à un système distant. Il
174remplace telnet, rlogin, rexec et rsh, tout en assurant des
175communications cryptées securisées entre deux hôtes non fiabilisés sur
176un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
177arbitraires peuvent également être transmis sur le canal sécurisé.
178
179%description -l it.UTF-8
180OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
181Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
182sicure e crittate tra due host non fidati su una rete non sicura. Le
183connessioni X11 ad una porta TCP/IP arbitraria possono essere
184inoltrate attraverso un canale sicuro.
185
186%description -l pl.UTF-8
187Ssh (Secure Shell) to program służący do logowania się na zdalną
188maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
189zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
190pomiędzy dwoma hostami.
191
192Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
193klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
194co najmniej jeden z pakietów: openssh-clients lub openssh-server.
195
196%if %{with hpn}
197Ta wersja zawiera łaty z projektu High Performance SSH/SCP
198http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
199zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
200RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
201danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
202TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
203%endif
204
205%description -l pt.UTF-8
206OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
207telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
208cifradas entre duas máquinas sem confiança mútua sobre uma rede
209insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
210reenviados pelo canal seguro.
211
212%description -l pt_BR.UTF-8
213SSH é um programa para acessar e executar comandos em máquinas
214remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
215seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
216TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
217
218OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
219última versão gratuita do SSH, atualizando-o em termos de segurança e
220recursos, assim como removendo todos os algoritmos patenteados e
221colocando-os em bibliotecas separadas (OpenSSL).
222
223Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
224também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
225
226%description -l ru.UTF-8
227Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
228машину и для выполнения команд на удаленной машине. Она предназначена
229для замены rlogin и rsh и обеспечивает безопасную шифрованную
230коммуникацию между двумя хостами в сети, являющейся небезопасной.
231Соединения X11 и любые порты TCP/IP могут также быть проведены через
232безопасный канал.
233
234OpenSSH - это переделка командой разработчиков OpenBSD последней
235свободной версии SSH, доведенная до современного состояния в терминах
236уровня безопасности и поддерживаемых возможностей. Все патентованные
237алгоритмы вынесены в отдельные библиотеки (OpenSSL).
238
239Этот пакет содержит файлы, необходимые как для клиента, так и для
240сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
241openssh-server, или оба пакета.
242
243%description -l uk.UTF-8
244Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
245машини та для виконання команд на віддаленій машині. Вона призначена
246для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
247між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
248довільні порти TCP/IP можуть також бути проведені через безпечний
249канал.
250
251OpenSSH - це переробка командою розробників OpenBSD останньої вільної
252версії SSH, доведена до сучасного стану в термінах рівня безпеки та
253підтримуваних можливостей. Всі патентовані алгоритми винесені до
254окремих бібліотек (OpenSSL).
255
256Цей пакет містить файли, необхідні як для клієнта, так і для сервера
257OpenSSH. Вам потрібно буде ще встановити openssh-clients,
258openssh-server, чи обидва пакети.
259
260%package clients
261Summary: OpenSSH Secure Shell protocol clients
262Summary(es.UTF-8): Clientes de OpenSSH
263Summary(pl.UTF-8): Klienci protokołu Secure Shell
264Summary(pt_BR.UTF-8): Clientes do OpenSSH
265Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
266Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
267Group: Applications/Networking
268Requires: %{name}
269Provides: ssh-clients
270Obsoletes: ssh-clients
271%requires_eq_to openssl openssl-devel
272
273%description clients
274Ssh (Secure Shell) a program for logging into a remote machine and for
275executing commands in a remote machine. It is intended to replace
276rlogin and rsh, and provide secure encrypted communications between
277two untrusted hosts over an insecure network. X11 connections and
278arbitrary TCP/IP ports can also be forwarded over the secure channel.
279
280OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
281it up to date in terms of security and features, as well as removing
282all patented algorithms to seperate libraries (OpenSSL).
283
284This package includes the clients necessary to make encrypted
285connections to SSH servers.
286
287%description clients -l es.UTF-8
288Este paquete incluye los clientes que se necesitan para hacer
289conexiones codificadas con servidores SSH.
290
291%description clients -l pl.UTF-8
292Ssh (Secure Shell) to program służący do logowania się na zdalną
293maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
294zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
295pomiędzy dwoma hostami.
296
297Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
298
299%description clients -l pt_BR.UTF-8
300Esse pacote inclui os clientes necessários para fazer conexões
301encriptadas com servidores SSH.
302
303%description clients -l ru.UTF-8
304Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
305машину и для выполнения команд на удаленной машине.
306
307Этот пакет содержит программы-клиенты, необходимые для установления
308зашифрованных соединений с серверами SSH.
309
310%description clients -l uk.UTF-8
311Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
312машини та для виконання команд на віддаленій машині.
313
314Цей пакет містить програми-клієнти, необхідні для встановлення
315зашифрованих з'єднань з серверами SSH.
316
317%package clients-agent-profile_d
318Summary: OpenSSH Secure Shell agent init script
319Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
320Group: Applications/Networking
321Requires: %{name}-clients = %{epoch}:%{version}-%{release}
322
323%description clients-agent-profile_d
324profile.d scripts for starting SSH agent.
325
326%description clients-agent-profile_d -l pl.UTF-8
327Skrypty profile.d do uruchamiania agenta SSH.
328
329%package clients-agent-xinitrc
330Summary: OpenSSH Secure Shell agent init script
331Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
332Group: Applications/Networking
333Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
334Requires: xinitrc
335
336%description clients-agent-xinitrc
337xinitrc scripts for starting SSH agent.
338
339%description clients-agent-xinitrc -l pl.UTF-8
340Skrypty xinitrc do uruchamiania agenta SSH.
341
342%package server
343Summary: OpenSSH Secure Shell protocol server (sshd)
344Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
345Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
346Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
347Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
348Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
349Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
350Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
351Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
352Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
353Group: Networking/Daemons
354Requires(post): /sbin/chkconfig
355Requires(post): grep
356Requires(post,preun): /sbin/chkconfig
357Requires(postun): /usr/sbin/userdel
358Requires(pre): /bin/id
359Requires(pre): /usr/sbin/useradd
360Requires(post,preun,postun): systemd-units >= 38
361Requires: %{name} = %{epoch}:%{version}-%{release}
362Requires: pam >= %{pam_ver}
363Requires: rc-scripts >= 0.4.3.0
364Requires: systemd-units >= 38
365%{?with_libseccomp:Requires: uname(release) >= 3.5}
366Requires: util-linux
367%{?with_ldap:Suggests: %{name}-server-ldap}
368Suggests: /bin/login
369Suggests: xorg-app-xauth
370Provides: ssh-server
371Provides: user(sshd)
372%requires_eq_to openssl openssl-devel
373
374%description server
375Ssh (Secure Shell) a program for logging into a remote machine and for
376executing commands in a remote machine. It is intended to replace
377rlogin and rsh, and provide secure encrypted communications between
378two untrusted hosts over an insecure network. X11 connections and
379arbitrary TCP/IP ports can also be forwarded over the secure channel.
380
381OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
382it up to date in terms of security and features, as well as removing
383all patented algorithms to seperate libraries (OpenSSL).
384
385This package contains the secure shell daemon. The sshd is the server
386part of the secure shell protocol and allows ssh clients to connect to
387your host.
388
389%description server -l de.UTF-8
390Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
391
392%description server -l es.UTF-8
393Este paquete contiene el servidor SSH. sshd es la parte servidor del
394protocolo secure shell y permite que clientes ssh se conecten a su
395servidor.
396
397%description server -l fr.UTF-8
398Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
399
400%description server -l it.UTF-8
401Questo pacchetto installa sshd, il server di OpenSSH.
402
403%description server -l pl.UTF-8
404Ssh (Secure Shell) to program służący do logowania się na zdalną
405maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
406zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
407pomiędzy dwoma hostami.
408
409Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
410ssh).
411
412%description server -l pt.UTF-8
413Este pacote intala o sshd, o servidor do OpenSSH.
414
415%description server -l pt_BR.UTF-8
416Esse pacote contém o servidor SSH. O sshd é a parte servidor do
417protocolo secure shell e permite que clientes ssh se conectem ao seu
418host.
419
420%description server -l ru.UTF-8
421Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
422машину и для выполнения команд на удаленной машине.
423
424Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
425часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
426вашим хостом.
427
428%description server -l uk.UTF-8
429Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
430машини та для виконання команд на віддаленій машині.
431
432Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
433частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
434з вашим хостом.
435
436%package server-ldap
437Summary: A LDAP support for open source SSH server daemon
438Summary(pl.UTF-8): Wsparcie LDAP dla serwera OpenSSH
439Group: Daemons
440Requires: %{name} = %{epoch}:%{version}-%{release}
441Requires: openldap-nss-config
442
443%description server-ldap
444OpenSSH LDAP backend is a way how to distribute the authorized tokens
445among the servers in the network.
446
447%description server-ldap -l pl.UTF-8
448Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
449tokenów między serwerami w sieci.
450
451%package gnome-askpass
452Summary: OpenSSH GNOME passphrase dialog
453Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
454Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
455Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
456Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
457Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
458Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
459Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
460Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
461Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
462Group: Applications/Networking
463Requires: %{name} = %{epoch}:%{version}-%{release}
464Obsoletes: openssh-askpass
465Obsoletes: ssh-askpass
466Obsoletes: ssh-extras
467
468%description gnome-askpass
469Ssh (Secure Shell) a program for logging into a remote machine and for
470executing commands in a remote machine. It is intended to replace
471rlogin and rsh, and provide secure encrypted communications between
472two untrusted hosts over an insecure network. X11 connections and
473arbitrary TCP/IP ports can also be forwarded over the secure channel.
474
475OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
476it up to date in terms of security and features, as well as removing
477all patented algorithms to seperate libraries (OpenSSL).
478
479This package contains the GNOME passphrase dialog.
480
481%description gnome-askpass -l es.UTF-8
482Este paquete contiene un programa que abre una caja de diálogo para
483entrada de passphrase en GNOME.
484
485%description gnome-askpass -l pl.UTF-8
486Ssh (Secure Shell) to program służący do logowania się na zdalną
487maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
488zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
489pomiędzy dwoma hostami.
490
491Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
492
493%description gnome-askpass -l pt_BR.UTF-8
494Esse pacote contém um programa que abre uma caixa de diálogo para
495entrada de passphrase no GNOME.
496
497%description gnome-askpass -l ru.UTF-8
498Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
499машину и для выполнения команд на удаленной машине.
500
501Этот пакет содержит диалог ввода ключевой фразы для использования под
502GNOME.
503
504%description gnome-askpass -l uk.UTF-8
505Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
506машини та для виконання команд на віддаленій машині.
507
508Цей пакет містить діалог вводу ключової фрази для використання під
509GNOME.
510
511%package -n openldap-schema-openssh-lpk
512Summary: OpenSSH LDAP Public Key schema
513Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
514Group: Networking/Daemons
515Requires(post,postun): sed >= 4.0
516Requires: openldap-servers
517%if "%{_rpmversion}" >= "5"
518BuildArch: noarch
519%endif
520
521%description -n openldap-schema-openssh-lpk
522This package contains OpenSSH LDAP Public Key schema for openldap.
523
524%description -n openldap-schema-openssh-lpk -l pl.UTF-8
525Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
526openldap-a.
527
528%prep
529%setup -q
530%patch0 -p1
531%patch1 -p1
532%patch2 -p1
533%patch3 -p1
534%patch4 -p1
535%patch5 -p1
536%patch6 -p1
537%patch7 -p1
538%patch8 -p1
539
540%{?with_hpn:%patch9 -p1}
541
542%patch11 -p1
543%patch12 -p1
544%patch13 -p1
545
546%patch14 -p1
547%{!?with_ldap:%patch15 -p1}
548
549%if "%{pld_release}" == "ac"
550# fix for missing x11.pc
551%{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
552%endif
553
554# hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
555sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh -lopenbsd-compat#g' Makefile*
556
557grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
558%{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
559
560# prevent being ovewritten by aclocal calls
561%{__mv} aclocal.m4 acinclude.m4
562
563%build
564cp /usr/share/automake/config.sub .
565%{__aclocal}
566%{__autoconf}
567%{__autoheader}
568CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
569%configure \
570 PERL=%{__perl} \
571 --disable-strip \
572 --enable-utmpx \
573 --enable-wtmpx \
574 --with-4in6 \
575 %{?with_audit:--with-audit=linux} \
576 --with-ipaddr-display \
577 %{?with_kerberos5:--with-kerberos5=/usr} \
578 --with-ldap%{!?with_ldap:=no} \
579 %{?with_ldns:--with-ldns} \
580 %{?with_libedit:--with-libedit} \
581 --with-mantype=man \
582 --with-md5-passwords \
583 --with-pam \
584 --with-pid-dir=%{_localstatedir}/run \
585 --with-privsep-path=%{_privsepdir} \
586 --with-privsep-user=sshd \
587 --with-security-key-builtin \
588 %{?with_selinux:--with-selinux} \
589%if "%{pld_release}" == "ac"
590 --with-xauth=/usr/X11R6/bin/xauth
591%else
592 --with-sandbox=seccomp_filter \
593 --with-xauth=%{_bindir}/xauth
594%endif
595
596echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
597
598%{__make}
599
600%if %{with tests}
601%{__make} -j1 tests \
602 TEST_SSH_PORT=$((4242 + ${RANDOM:-$$} % 1000)) \
603 TEST_SSH_TRACE="yes" \
604%if %{without tests_conch}
605 SKIP_LTESTS="conch-ciphers"
606%endif
607%endif
608
609cd contrib
610%if %{with gnome}
611%{__make} gnome-ssh-askpass1 \
612 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
613%endif
614%if %{with gtk}
615%{__make} gnome-ssh-askpass2 \
616 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
617%endif
618
619%install
620rm -rf $RPM_BUILD_ROOT
621install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
622 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
623install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
624
625%{__make} install \
626 DESTDIR=$RPM_BUILD_ROOT
627
628bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
629
630install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
631cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
632cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
633cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
634ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
635cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
636cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
637
638cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
639install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
640
641%{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
642 $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
643 $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
644 $RPM_BUILD_ROOT%{systemdunitdir}/sshd@.service \
645 $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
646
647%if %{with gnome}
648install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
649%endif
650%if %{with gtk}
651install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
652%endif
653%if %{with gnome} || %{with gtk}
654cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
655#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
656EOF
657cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
658#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
659EOF
660ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
661%endif
662
663install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
664cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
665
666touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
667
668cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
669#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
670EOF
671
672%if "%{pld_release}" == "ac"
673# not present in ac, no point searching it
674%{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
675# openssl on ac does not have OPENSSL_HAS_ECC
676%{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
677%endif
678
679%if %{without audit}
680# remove recording user's login uid to the process attribute
681%{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
682%endif
683
684%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
685%{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
686
687%clean
688rm -rf $RPM_BUILD_ROOT
689
690%post clients
691%env_update
692
693%postun clients
694%env_update
695
696%post gnome-askpass
697%env_update
698
699%postun gnome-askpass
700%env_update
701
702%pre server
703%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
704
705%post server
706/sbin/chkconfig --add sshd
707%service sshd reload "OpenSSH Daemon"
708NORESTART=1
709%systemd_post sshd.service
710
711%preun server
712if [ "$1" = "0" ]; then
713 %service sshd stop
714 /sbin/chkconfig --del sshd
715fi
716%systemd_preun sshd.service
717
718%postun server
719if [ "$1" = "0" ]; then
720 %userremove sshd
721fi
722%systemd_reload
723
724%triggerpostun server -- %{name}-server < 2:7.0p1-2
725%banner %{name}-server -e << EOF
726!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
727! Starting from openssh 7.0 DSA keys are disabled !
728! on server and client side. You will NOT be able !
729! to use DSA keys for authentication. Please read !
730! about PubkeyAcceptedKeyTypes in man ssh_config. !
731!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
732EOF
733
734%triggerpostun server -- %{name}-server < 6.2p1-1
735cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
736sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
737
738%triggerpostun server -- %{name}-server < 2:5.9p1-8
739# lpk.patch to ldap.patch
740if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
741 echo >&2 "Migrating LPK patch to LDAP patch"
742 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
743 %{__sed} -i -e '
744 # disable old configs
745 # just UseLPK/LkpLdapConf supported for now
746 s/^\s*UseLPK/## Obsolete &/
747 s/^\s*Lpk/## Obsolete &/
748 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
749 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
750 ' %{_sysconfdir}/sshd_config
751 if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
752 /bin/systemctl try-restart sshd.service || :
753 else
754 %service -q sshd reload
755 fi
756fi
757%systemd_trigger sshd.service
758if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
759%banner %{name}-server -e << EOF
760!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
761! Native systemd support for sshd has been installed. !
762! Restarting sshd.service with systemctl WILL kill all !
763! active ssh sessions (daemon as such will be started). !
764!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
765EOF
766fi
767
768%post -n openldap-schema-openssh-lpk
769%openldap_schema_register %{schemadir}/openssh-lpk.schema
770%service -q ldap restart
771
772%postun -n openldap-schema-openssh-lpk
773if [ "$1" = "0" ]; then
774 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
775 %service -q ldap restart
776fi
777
778%files
779%defattr(644,root,root,755)
780%doc TODO README OVERVIEW CREDITS Change*
781%attr(755,root,root) %{_bindir}/ssh-key*
782#%attr(755,root,root) %{_bindir}/ssh-vulnkey*
783%{_mandir}/man1/ssh-key*.1*
784#%{_mandir}/man1/ssh-vulnkey*.1*
785%dir %{_sysconfdir}
786%dir %{_libexecdir}
787
788%files clients
789%defattr(644,root,root,755)
790%attr(755,root,root) %{_bindir}/ssh
791%attr(755,root,root) %{_bindir}/sftp
792%attr(755,root,root) %{_bindir}/ssh-agent
793%attr(755,root,root) %{_bindir}/ssh-add
794%attr(755,root,root) %{_bindir}/ssh-copy-id
795%attr(755,root,root) %{_bindir}/scp
796%attr(755,root,root) %{_libexecdir}/ssh-sk-helper
797%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
798%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
799%{_mandir}/man1/scp.1*
800%{_mandir}/man1/ssh.1*
801%{_mandir}/man1/sftp.1*
802%{_mandir}/man1/ssh-agent.1*
803%{_mandir}/man1/ssh-add.1*
804%{_mandir}/man1/ssh-copy-id.1*
805%{_mandir}/man5/ssh_config.5*
806%{_mandir}/man8/ssh-sk-helper.8*
807%lang(it) %{_mandir}/it/man1/ssh.1*
808%lang(it) %{_mandir}/it/man5/ssh_config.5*
809%lang(pl) %{_mandir}/pl/man1/scp.1*
810%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
811
812# for host-based auth (suid required for accessing private host key)
813#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
814#%{_mandir}/man8/ssh-keysign.8*
815
816%files clients-agent-profile_d
817%defattr(644,root,root,755)
818%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
819%attr(755,root,root) /etc/profile.d/ssh-agent.sh
820
821%files clients-agent-xinitrc
822%defattr(644,root,root,755)
823%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
824
825%files server
826%defattr(644,root,root,755)
827%attr(755,root,root) %{_sbindir}/sshd
828%attr(755,root,root) %{_libexecdir}/sftp-server
829%attr(755,root,root) %{_libexecdir}/ssh-keysign
830%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
831%attr(755,root,root) %{_libexecdir}/sshd-keygen
832%{_mandir}/man8/sshd.8*
833%{_mandir}/man8/sftp-server.8*
834%{_mandir}/man8/ssh-keysign.8*
835%{_mandir}/man8/ssh-pkcs11-helper.8*
836%{_mandir}/man5/sshd_config.5*
837%{_mandir}/man5/moduli.5*
838%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
839%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
840%{_sysconfdir}/moduli
841%attr(754,root,root) /etc/rc.d/init.d/sshd
842%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
843%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
844%{systemdunitdir}/sshd.service
845%{systemdunitdir}/sshd.socket
846%{systemdunitdir}/sshd@.service
847
848%if %{with ldap}
849%files server-ldap
850%defattr(644,root,root,755)
851%doc HOWTO.ldap-keys ldap.conf
852%attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
853%attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
854%{_mandir}/man5/ssh-ldap.conf.5*
855%{_mandir}/man8/ssh-ldap-helper.8*
856%endif
857
858%if %{with gnome} || %{with gtk}
859%files gnome-askpass
860%defattr(644,root,root,755)
861%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
862%dir %{_libexecdir}/ssh
863%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
864%attr(755,root,root) %{_libexecdir}/ssh-askpass
865%endif
866
867%if %{with ldap}
868%files -n openldap-schema-openssh-lpk
869%defattr(644,root,root,755)
870%{schemadir}/openssh-lpk.schema
871%endif
This page took 0.078723 seconds and 4 git commands to generate.