]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- adjust to apply with lpk.patch
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# Conditional build:
2%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
3%bcond_without gtk # without GTK+ (2.x)
4%bcond_without ldap # with ldap support
5%bcond_without libedit # without libedit (editline/history support in sftp client)
6%bcond_without kerberos5 # without kerberos5 support
7%bcond_without selinux # build without SELinux support
8%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
9
10# gtk2-based gnome-askpass means no gnome1-based
11%{?with_gtk:%undefine with_gnome}
12#
13Summary: OpenSSH free Secure Shell (SSH) implementation
14Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
15Summary(es.UTF-8): Implementación libre de SSH
16Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
17Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
18Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
19Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
20Summary(pt_BR.UTF-8): Implementação livre do SSH
21Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
22Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
23Name: openssh
24Version: 5.2p1
25Release: 6
26Epoch: 2
27License: BSD
28Group: Applications/Networking
29Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
30# Source0-md5: ada79c7328a8551bdf55c95e631e7dad
31Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32# Source1-md5: 66943d481cc422512b537bcc2c7400d1
33Source2: %{name}d.init
34Source3: %{name}d.pamd
35Source4: %{name}.sysconfig
36Source5: ssh-agent.sh
37Source6: ssh-agent.conf
38Source7: %{name}-lpk.schema
39Patch0: %{name}-no_libnsl.patch
40Patch2: %{name}-pam_misc.patch
41Patch3: %{name}-sigpipe.patch
42# http://code.google.com/p/openssh-lpk/
43Patch4: %{name}-lpk.patch
44Patch5: %{name}-config.patch
45Patch7: %{name}-selinux.patch
46# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
47# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
48Patch9: %{name}-5.2p1-hpn13v6.diff
49Patch10: %{name}-include.patch
50Patch11: %{name}-chroot.patch
51Patch12: http://people.debian.org/~cjwatson/%{name}-blacklist.diff
52URL: http://www.openssh.com/
53BuildRequires: %{__perl}
54BuildRequires: autoconf
55BuildRequires: automake
56%{?with_gnome:BuildRequires: gnome-libs-devel}
57%{?with_gtk:BuildRequires: gtk+2-devel}
58%{?with_kerberos5:BuildRequires: heimdal-devel}
59%{?with_libedit:BuildRequires: libedit-devel}
60%{?with_selinux:BuildRequires: libselinux-devel}
61BuildRequires: libwrap-devel
62%{?with_ldap:BuildRequires: openldap-devel >= 2.4.6}
63BuildRequires: openssl-devel >= 0.9.7d
64BuildRequires: pam-devel
65%{?with_gtk:BuildRequires: pkgconfig}
66BuildRequires: rpmbuild(macros) >= 1.318
67BuildRequires: zlib-devel
68Requires: filesystem >= 3.0-11
69Requires: pam >= 0.99.7.1
70Suggests: openssh-blacklist
71Suggests: xorg-app-xauth
72Obsoletes: ssh
73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75%define _sysconfdir /etc/ssh
76%define _libexecdir %{_libdir}/%{name}
77%define _privsepdir /usr/share/empty
78%define schemadir /usr/share/openldap/schema
79
80%description
81Ssh (Secure Shell) a program for logging into a remote machine and for
82executing commands in a remote machine. It is intended to replace
83rlogin and rsh, and provide secure encrypted communications between
84two untrusted hosts over an insecure network. X11 connections and
85arbitrary TCP/IP ports can also be forwarded over the secure channel.
86
87OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
88it up to date in terms of security and features, as well as removing
89all patented algorithms to seperate libraries (OpenSSL).
90
91This package includes the core files necessary for both the OpenSSH
92client and server. To make this package useful, you should also
93install openssh-clients, openssh-server, or both.
94%if %{with hpn}
95This release includes High Performance SSH/SCP patches from
96http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
97to increase throughput on fast connections with high RTT (20-150 msec).
98See the website for '-w' values for your connection and /proc/sys TCP
99values. BTW. in a LAN you have got generally RTT < 1 msec.
100%endif
101
102%description -l de.UTF-8
103OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
104ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
105verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
106über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
107andere TCP/IP Ports können ebenso über den sicheren Channel
108weitergeleitet werden.
109
110%description -l es.UTF-8
111SSH es un programa para accesar y ejecutar órdenes en computadores
112remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
113seguro entre dos servidores en una red insegura. Conexiones X11 y
114puertas TCP/IP arbitrárias también pueden ser usadas por el canal
115seguro.
116
117OpenSSH es el resultado del trabajo del equipo de OpenBSD para
118continuar la última versión gratuita de SSH, actualizándolo en
119términos de seguridad y recursos,así también eliminando todos los
120algoritmos patentados y colocándolos en bibliotecas separadas
121(OpenSSL).
122
123Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
124también el paquete openssh-clients u openssh-server o ambos.
125
126%description -l fr.UTF-8
127OpenSSH (Secure Shell) fournit un accès à un système distant. Il
128remplace telnet, rlogin, rexec et rsh, tout en assurant des
129communications cryptées securisées entre deux hôtes non fiabilisés sur
130un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
131arbitraires peuvent également être transmis sur le canal sécurisé.
132
133%description -l it.UTF-8
134OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
135Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
136sicure e crittate tra due host non fidati su una rete non sicura. Le
137connessioni X11 ad una porta TCP/IP arbitraria possono essere
138inoltrate attraverso un canale sicuro.
139
140%description -l pl.UTF-8
141Ssh (Secure Shell) to program służący do logowania się na zdalną
142maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
143zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
144pomiędzy dwoma hostami.
145
146Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
147klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
148co najmniej jeden z pakietów: openssh-clients lub openssh-server.
149%if %{with hpn}
150Ta wersja zawiera łaty z projektu High Performance SSH/SCP
151http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
152zwiększenie przepustowości transmisji dla szybkich połączeń
153z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
154odpowednie dla danego połączenia wartości parametru '-w' oraz
155opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
156%endif
157
158%description -l pt.UTF-8
159OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
160telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
161cifradas entre duas máquinas sem confiança mútua sobre uma rede
162insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
163reenviados pelo canal seguro.
164
165%description -l pt_BR.UTF-8
166SSH é um programa para acessar e executar comandos em máquinas
167remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
168seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
169TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
170
171OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
172última versão gratuita do SSH, atualizando-o em termos de segurança e
173recursos, assim como removendo todos os algoritmos patenteados e
174colocando-os em bibliotecas separadas (OpenSSL).
175
176Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
177também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
178
179%description -l ru.UTF-8
180Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
181машину и для выполнения команд на удаленной машине. Она предназначена
182для замены rlogin и rsh и обеспечивает безопасную шифрованную
183коммуникацию между двумя хостами в сети, являющейся небезопасной.
184Соединения X11 и любые порты TCP/IP могут также быть проведены через
185безопасный канал.
186
187OpenSSH - это переделка командой разработчиков OpenBSD последней
188свободной версии SSH, доведенная до современного состояния в терминах
189уровня безопасности и поддерживаемых возможностей. Все патентованные
190алгоритмы вынесены в отдельные библиотеки (OpenSSL).
191
192Этот пакет содержит файлы, необходимые как для клиента, так и для
193сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
194openssh-server, или оба пакета.
195
196%description -l uk.UTF-8
197Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
198машини та для виконання команд на віддаленій машині. Вона призначена
199для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
200між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
201довільні порти TCP/IP можуть також бути проведені через безпечний
202канал.
203
204OpenSSH - це переробка командою розробників OpenBSD останньої вільної
205версії SSH, доведена до сучасного стану в термінах рівня безпеки та
206підтримуваних можливостей. Всі патентовані алгоритми винесені до
207окремих бібліотек (OpenSSL).
208
209Цей пакет містить файли, необхідні як для клієнта, так і для сервера
210OpenSSH. Вам потрібно буде ще встановити openssh-clients,
211openssh-server, чи обидва пакети.
212
213%package clients
214Summary: OpenSSH Secure Shell protocol clients
215Summary(es.UTF-8): Clientes de OpenSSH
216Summary(pl.UTF-8): Klienci protokołu Secure Shell
217Summary(pt_BR.UTF-8): Clientes do OpenSSH
218Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
219Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
220Group: Applications/Networking
221Requires: %{name}
222Provides: ssh-clients
223Obsoletes: ssh-clients
224
225%description clients
226Ssh (Secure Shell) a program for logging into a remote machine and for
227executing commands in a remote machine. It is intended to replace
228rlogin and rsh, and provide secure encrypted communications between
229two untrusted hosts over an insecure network. X11 connections and
230arbitrary TCP/IP ports can also be forwarded over the secure channel.
231
232OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
233it up to date in terms of security and features, as well as removing
234all patented algorithms to seperate libraries (OpenSSL).
235
236This package includes the clients necessary to make encrypted
237connections to SSH servers.
238
239%description clients -l es.UTF-8
240Este paquete incluye los clientes que se necesitan para hacer
241conexiones codificadas con servidores SSH.
242
243%description clients -l pl.UTF-8
244Ssh (Secure Shell) to program służący do logowania się na zdalną
245maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
246zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
247pomiędzy dwoma hostami.
248
249Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
250
251%description clients -l pt_BR.UTF-8
252Esse pacote inclui os clientes necessários para fazer conexões
253encriptadas com servidores SSH.
254
255%description clients -l ru.UTF-8
256Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
257машину и для выполнения команд на удаленной машине.
258
259Этот пакет содержит программы-клиенты, необходимые для установления
260зашифрованных соединений с серверами SSH.
261
262%description clients -l uk.UTF-8
263Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
264машини та для виконання команд на віддаленій машині.
265
266Цей пакет містить програми-клієнти, необхідні для встановлення
267зашифрованих з'єднань з серверами SSH.
268
269%package clients-agent-profile_d
270Summary: OpenSSH Secure Shell agent init script
271Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
272Group: Applications/Networking
273Requires: %{name}-clients = %{epoch}:%{version}-%{release}
274
275%description clients-agent-profile_d
276profile.d scripts for starting SSH agent.
277
278%description clients-agent-profile_d -l pl.UTF-8
279Skrypty profile.d do uruchamiania agenta SSH.
280
281%package clients-agent-xinitrc
282Summary: OpenSSH Secure Shell agent init script
283Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
284Group: Applications/Networking
285Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
286Requires: xinitrc
287
288%description clients-agent-xinitrc
289xinitrc scripts for starting SSH agent.
290
291%description clients-agent-xinitrc -l pl.UTF-8
292Skrypty xinitrc do uruchamiania agenta SSH.
293
294%package server
295Summary: OpenSSH Secure Shell protocol server (sshd)
296Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
297Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
298Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
299Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
300Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
301Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
302Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
303Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
304Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
305Group: Networking/Daemons
306Requires(post): chkconfig >= 0.9
307Requires(post): grep
308Requires(post,preun): /sbin/chkconfig
309Requires(postun): /usr/sbin/userdel
310Requires(pre): /bin/id
311Requires(pre): /usr/sbin/useradd
312Requires: %{name} = %{epoch}:%{version}-%{release}
313Requires: pam >= 0.99.7.1
314Requires: rc-scripts >= 0.4.1.23
315Requires: util-linux
316Suggests: /bin/login
317Provides: ssh-server
318Provides: user(sshd)
319
320%description server
321Ssh (Secure Shell) a program for logging into a remote machine and for
322executing commands in a remote machine. It is intended to replace
323rlogin and rsh, and provide secure encrypted communications between
324two untrusted hosts over an insecure network. X11 connections and
325arbitrary TCP/IP ports can also be forwarded over the secure channel.
326
327OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
328it up to date in terms of security and features, as well as removing
329all patented algorithms to seperate libraries (OpenSSL).
330
331This package contains the secure shell daemon. The sshd is the server
332part of the secure shell protocol and allows ssh clients to connect to
333your host.
334
335%description server -l de.UTF-8
336Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
337
338%description server -l es.UTF-8
339Este paquete contiene el servidor SSH. sshd es la parte servidor del
340protocolo secure shell y permite que clientes ssh se conecten a su
341servidor.
342
343%description server -l fr.UTF-8
344Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
345
346%description server -l it.UTF-8
347Questo pacchetto installa sshd, il server di OpenSSH.
348
349%description server -l pl.UTF-8
350Ssh (Secure Shell) to program służący do logowania się na zdalną
351maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
352zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
353pomiędzy dwoma hostami.
354
355Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
356ssh).
357
358%description server -l pt.UTF-8
359Este pacote intala o sshd, o servidor do OpenSSH.
360
361%description server -l pt_BR.UTF-8
362Esse pacote contém o servidor SSH. O sshd é a parte servidor do
363protocolo secure shell e permite que clientes ssh se conectem ao seu
364host.
365
366%description server -l ru.UTF-8
367Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
368машину и для выполнения команд на удаленной машине.
369
370Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
371часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
372вашим хостом.
373
374%description server -l uk.UTF-8
375Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
376машини та для виконання команд на віддаленій машині.
377
378Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
379частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
380з вашим хостом.
381
382%package gnome-askpass
383Summary: OpenSSH GNOME passphrase dialog
384Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
385Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
386Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
387Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
388Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
389Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
390Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
391Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
392Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
393Group: Applications/Networking
394Requires: %{name} = %{epoch}:%{version}-%{release}
395Obsoletes: openssh-askpass
396Obsoletes: ssh-askpass
397Obsoletes: ssh-extras
398
399%description gnome-askpass
400Ssh (Secure Shell) a program for logging into a remote machine and for
401executing commands in a remote machine. It is intended to replace
402rlogin and rsh, and provide secure encrypted communications between
403two untrusted hosts over an insecure network. X11 connections and
404arbitrary TCP/IP ports can also be forwarded over the secure channel.
405
406OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
407it up to date in terms of security and features, as well as removing
408all patented algorithms to seperate libraries (OpenSSL).
409
410This package contains the GNOME passphrase dialog.
411
412%description gnome-askpass -l es.UTF-8
413Este paquete contiene un programa que abre una caja de diálogo para
414entrada de passphrase en GNOME.
415
416%description gnome-askpass -l pl.UTF-8
417Ssh (Secure Shell) to program służący do logowania się na zdalną
418maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
419zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
420pomiędzy dwoma hostami.
421
422Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
423
424%description gnome-askpass -l pt_BR.UTF-8
425Esse pacote contém um programa que abre uma caixa de diálogo para
426entrada de passphrase no GNOME.
427
428%description gnome-askpass -l ru.UTF-8
429Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
430машину и для выполнения команд на удаленной машине.
431
432Этот пакет содержит диалог ввода ключевой фразы для использования под
433GNOME.
434
435%description gnome-askpass -l uk.UTF-8
436Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
437машини та для виконання команд на віддаленій машині.
438
439Цей пакет містить діалог вводу ключової фрази для використання під
440GNOME.
441
442%package -n openldap-schema-openssh-lpk
443Summary: OpenSSH LDAP Public Key schema
444Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
445Group: Networking/Daemons
446Requires(post,postun): sed >= 4.0
447Requires: openldap-servers
448
449%description -n openldap-schema-openssh-lpk
450This package contains OpenSSH LDAP Public Key schema for openldap.
451
452%description -n openldap-schema-openssh-lpk -l pl.UTF-8
453Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
454openldap-a.
455
456%prep
457%setup -q
458%patch0 -p1
459%patch2 -p1
460%patch3 -p1
461%{?with_ldap:%patch4 -p1}
462%patch5 -p1
463%patch7 -p1
464%{?with_hpn:%patch9 -p1}
465%patch10 -p1
466%patch11 -p1
467%patch12 -p1
468
469%build
470cp /usr/share/automake/config.sub .
471%{__aclocal}
472%{__autoconf}
473CPPFLAGS="-DCHROOT"
474%configure \
475 PERL=%{__perl} \
476 --with-dns \
477 --with-pam \
478 --with-mantype=man \
479 --with-md5-passwords \
480 --with-ipaddr-display \
481 %{?with_libedit:--with-libedit} \
482 --with-4in6 \
483 --disable-suid-ssh \
484 --with-tcp-wrappers \
485 %{?with_ldap:--with-libs="-lldap -llber"} \
486 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
487 %{?with_kerberos5:--with-kerberos5=/usr} \
488 --with-privsep-path=%{_privsepdir} \
489 --with-pid-dir=%{_localstatedir}/run \
490 --with-xauth=/usr/bin/xauth \
491 --enable-utmpx \
492 --enable-wtmpx
493
494echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
495
496%{__make}
497
498cd contrib
499%if %{with gnome}
500%{__make} gnome-ssh-askpass1 \
501 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
502%endif
503%if %{with gtk}
504%{__make} gnome-ssh-askpass2 \
505 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
506%endif
507
508%install
509rm -rf $RPM_BUILD_ROOT
510install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
511 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
512install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
513
514%{__make} install \
515 DESTDIR=$RPM_BUILD_ROOT
516
517bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
518
519install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
520install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
521install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
522install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
523ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
524install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
525install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
526
527%if %{with gnome}
528install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
529%endif
530%if %{with gtk}
531install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
532%endif
533%if %{with gnome} || %{with gtk}
534cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
535#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
536EOF
537cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
538#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
539EOF
540ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
541%endif
542
543install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
544install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
545
546rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
547echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
548
549touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
550
551cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
552#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
553EOF
554
555rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
556rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
557
558%clean
559rm -rf $RPM_BUILD_ROOT
560
561%post clients
562%env_update
563
564%postun clients
565%env_update
566
567%post gnome-askpass
568%env_update
569
570%postun gnome-askpass
571%env_update
572
573%pre server
574%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
575
576%post server
577/sbin/chkconfig --add sshd
578%service sshd reload "openssh daemon"
579if ! grep -qs ssh /etc/security/passwd.conf ; then
580 umask 022
581 echo "ssh" >> /etc/security/passwd.conf
582fi
583
584%preun server
585if [ "$1" = "0" ]; then
586 %service sshd stop
587 /sbin/chkconfig --del sshd
588fi
589
590%postun server
591if [ "$1" = "0" ]; then
592 %userremove sshd
593fi
594
595%post -n openldap-schema-openssh-lpk
596%openldap_schema_register %{schemadir}/openssh-lpk.schema
597%service -q ldap restart
598
599%postun -n openldap-schema-openssh-lpk
600if [ "$1" = "0" ]; then
601 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
602 %service -q ldap restart
603fi
604
605%files
606%defattr(644,root,root,755)
607%doc *.RNG TODO README OVERVIEW CREDITS Change*
608%attr(755,root,root) %{_bindir}/ssh-key*
609%attr(755,root,root) %{_bindir}/ssh-vulnkey*
610%{_mandir}/man1/ssh-key*.1*
611%{_mandir}/man1/ssh-vulnkey*.1*
612%dir %{_sysconfdir}
613%dir %{_libexecdir}
614
615%files clients
616%defattr(644,root,root,755)
617%attr(755,root,root) %{_bindir}/ssh
618%attr(755,root,root) %{_bindir}/slogin
619%attr(755,root,root) %{_bindir}/sftp
620%attr(755,root,root) %{_bindir}/ssh-agent
621%attr(755,root,root) %{_bindir}/ssh-add
622%attr(755,root,root) %{_bindir}/ssh-copy-id
623%attr(755,root,root) %{_bindir}/scp
624%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
625%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
626%{_mandir}/man1/scp.1*
627%{_mandir}/man1/ssh.1*
628%{_mandir}/man1/slogin.1*
629%{_mandir}/man1/sftp.1*
630%{_mandir}/man1/ssh-agent.1*
631%{_mandir}/man1/ssh-add.1*
632%{_mandir}/man1/ssh-copy-id.1*
633%{_mandir}/man5/ssh_config.5*
634%lang(it) %{_mandir}/it/man1/ssh.1*
635%lang(it) %{_mandir}/it/man5/ssh_config.5*
636%lang(pl) %{_mandir}/pl/man1/scp.1*
637%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
638
639# for host-based auth (suid required for accessing private host key)
640#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
641#%{_mandir}/man8/ssh-keysign.8*
642
643%files clients-agent-profile_d
644%defattr(644,root,root,755)
645%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
646%attr(755,root,root) /etc/profile.d/ssh-agent.sh
647
648%files clients-agent-xinitrc
649%defattr(644,root,root,755)
650%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
651
652%files server
653%defattr(644,root,root,755)
654%attr(755,root,root) %{_sbindir}/sshd
655%attr(755,root,root) %{_libexecdir}/sftp-server
656%attr(755,root,root) %{_libexecdir}/ssh-keysign
657%{_mandir}/man8/sshd.8*
658%{_mandir}/man8/sftp-server.8*
659%{_mandir}/man8/ssh-keysign.8*
660%{_mandir}/man5/sshd_config.5*
661%{_mandir}/man5/moduli.5*
662%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
663%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
664%attr(640,root,root) %{_sysconfdir}/moduli
665%attr(754,root,root) /etc/rc.d/init.d/sshd
666%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
667%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
668
669%if %{with gnome} || %{with gtk}
670%files gnome-askpass
671%defattr(644,root,root,755)
672%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
673%dir %{_libexecdir}/ssh
674%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
675%attr(755,root,root) %{_libexecdir}/ssh-askpass
676%endif
677
678%if %{with ldap}
679%files -n openldap-schema-openssh-lpk
680%defattr(644,root,root,755)
681%{schemadir}/openssh-lpk.schema
682%endif
This page took 0.027535 seconds and 4 git commands to generate.