]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
sshd_config: add sample for CheckHostIP no in Host *.local
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# TODO:
2# - add trigger to enable this:
3# * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4# new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5#
6# Conditional build:
7%bcond_without audit # sshd audit support
8%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
9%bcond_without gtk # without GTK+ (2.x)
10%bcond_without ldap # with ldap support
11%bcond_without libedit # without libedit (editline/history support in sftp client)
12%bcond_without kerberos5 # without kerberos5 support
13%bcond_without selinux # build without SELinux support
14%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15%bcond_without tests
16
17# gtk2-based gnome-askpass means no gnome1-based
18%{?with_gtk:%undefine with_gnome}
19
20%if "%{pld_release}" == "ac"
21%define pam_ver 0.79.0
22%else
23%define pam_ver 1:1.1.5-5
24%endif
25Summary: OpenSSH free Secure Shell (SSH) implementation
26Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
27Summary(es.UTF-8): Implementación libre de SSH
28Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
29Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
30Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
31Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
32Summary(pt_BR.UTF-8): Implementação livre do SSH
33Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
34Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
35Name: openssh
36Version: 6.3p1
37Release: 1
38Epoch: 2
39License: BSD
40Group: Applications/Networking
41Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
42# Source0-md5: 225e75c9856f76011966013163784038
43Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
44# Source1-md5: 66943d481cc422512b537bcc2c7400d1
45Source2: %{name}d.init
46Source3: %{name}d.pamd
47Source4: %{name}.sysconfig
48Source5: ssh-agent.sh
49Source6: ssh-agent.conf
50Source7: %{name}-lpk.schema
51Source8: %{name}d.upstart
52Source9: sshd.service
53Source10: sshd-keygen
54Source11: sshd.socket
55Source12: sshd@.service
56Patch0: %{name}-no_libnsl.patch
57Patch2: %{name}-pam_misc.patch
58Patch3: %{name}-sigpipe.patch
59# http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
60Patch4: %{name}-5.9p1-ldap.patch
61Patch5: %{name}-5.9p1-ldap-fixes.patch
62Patch8: ldap.conf.patch
63Patch6: %{name}-config.patch
64
65# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
66# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
67Patch9: %{name}-5.2p1-hpn13v6.diff
68Patch10: %{name}-include.patch
69Patch11: %{name}-chroot.patch
70# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
71Patch12: %{name}-blacklist.diff
72Patch13: %{name}-kuserok.patch
73Patch14: %{name}-bind.patch
74Patch15: %{name}-disable_ldap.patch
75URL: http://www.openssh.com/portable.html
76BuildRequires: %{__perl}
77%{?with_tests:BuildRequires: %{name}-server}
78%{?with_audit:BuildRequires: audit-libs-devel}
79BuildRequires: autoconf >= 2.50
80BuildRequires: automake
81%{?with_gnome:BuildRequires: gnome-libs-devel}
82%{?with_gtk:BuildRequires: gtk+2-devel}
83%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
84%{?with_libedit:BuildRequires: libedit-devel}
85%{?with_selinux:BuildRequires: libselinux-devel}
86BuildRequires: libwrap-devel
87%{?with_ldap:BuildRequires: openldap-devel}
88BuildRequires: openssl-devel >= 0.9.7d
89BuildRequires: pam-devel
90%{?with_gtk:BuildRequires: pkgconfig}
91BuildRequires: rpm >= 4.4.9-56
92BuildRequires: rpmbuild(macros) >= 1.627
93BuildRequires: sed >= 4.0
94BuildRequires: zlib-devel >= 1.2.3
95Requires: zlib >= 1.2.3
96%if "%{pld_release}" == "ac"
97Requires: filesystem >= 2.0-1
98Requires: pam >= 0.79.0
99%else
100Requires: filesystem >= 3.0-11
101Requires: pam >= %{pam_ver}
102Suggests: openssh-blacklist
103Suggests: xorg-app-xauth
104%endif
105Obsoletes: ssh
106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108%define _sysconfdir /etc/ssh
109%define _libexecdir %{_libdir}/%{name}
110%define _privsepdir /usr/share/empty
111%define schemadir /usr/share/openldap/schema
112
113%description
114Ssh (Secure Shell) a program for logging into a remote machine and for
115executing commands in a remote machine. It is intended to replace
116rlogin and rsh, and provide secure encrypted communications between
117two untrusted hosts over an insecure network. X11 connections and
118arbitrary TCP/IP ports can also be forwarded over the secure channel.
119
120OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
121it up to date in terms of security and features, as well as removing
122all patented algorithms to seperate libraries (OpenSSL).
123
124This package includes the core files necessary for both the OpenSSH
125client and server. To make this package useful, you should also
126install openssh-clients, openssh-server, or both.
127
128%if %{with hpn}
129This release includes High Performance SSH/SCP patches from
130http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
131increase throughput on fast connections with high RTT (20-150 msec).
132See the website for '-w' values for your connection and /proc/sys TCP
133values. BTW. in a LAN you have got generally RTT < 1 msec.
134%endif
135
136%description -l de.UTF-8
137OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
138ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
139verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
140über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
141andere TCP/IP Ports können ebenso über den sicheren Channel
142weitergeleitet werden.
143
144%description -l es.UTF-8
145SSH es un programa para accesar y ejecutar órdenes en computadores
146remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
147seguro entre dos servidores en una red insegura. Conexiones X11 y
148puertas TCP/IP arbitrárias también pueden ser usadas por el canal
149seguro.
150
151OpenSSH es el resultado del trabajo del equipo de OpenBSD para
152continuar la última versión gratuita de SSH, actualizándolo en
153términos de seguridad y recursos,así también eliminando todos los
154algoritmos patentados y colocándolos en bibliotecas separadas
155(OpenSSL).
156
157Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
158también el paquete openssh-clients u openssh-server o ambos.
159
160%description -l fr.UTF-8
161OpenSSH (Secure Shell) fournit un accès à un système distant. Il
162remplace telnet, rlogin, rexec et rsh, tout en assurant des
163communications cryptées securisées entre deux hôtes non fiabilisés sur
164un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
165arbitraires peuvent également être transmis sur le canal sécurisé.
166
167%description -l it.UTF-8
168OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
169Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
170sicure e crittate tra due host non fidati su una rete non sicura. Le
171connessioni X11 ad una porta TCP/IP arbitraria possono essere
172inoltrate attraverso un canale sicuro.
173
174%description -l pl.UTF-8
175Ssh (Secure Shell) to program służący do logowania się na zdalną
176maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
177zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
178pomiędzy dwoma hostami.
179
180Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
181klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
182co najmniej jeden z pakietów: openssh-clients lub openssh-server.
183
184%if %{with hpn}
185Ta wersja zawiera łaty z projektu High Performance SSH/SCP
186http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
187zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
188RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
189danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
190TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
191%endif
192
193%description -l pt.UTF-8
194OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
195telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
196cifradas entre duas máquinas sem confiança mútua sobre uma rede
197insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
198reenviados pelo canal seguro.
199
200%description -l pt_BR.UTF-8
201SSH é um programa para acessar e executar comandos em máquinas
202remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
203seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
204TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
205
206OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
207última versão gratuita do SSH, atualizando-o em termos de segurança e
208recursos, assim como removendo todos os algoritmos patenteados e
209colocando-os em bibliotecas separadas (OpenSSL).
210
211Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
212também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
213
214%description -l ru.UTF-8
215Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
216машину и для выполнения команд на удаленной машине. Она предназначена
217для замены rlogin и rsh и обеспечивает безопасную шифрованную
218коммуникацию между двумя хостами в сети, являющейся небезопасной.
219Соединения X11 и любые порты TCP/IP могут также быть проведены через
220безопасный канал.
221
222OpenSSH - это переделка командой разработчиков OpenBSD последней
223свободной версии SSH, доведенная до современного состояния в терминах
224уровня безопасности и поддерживаемых возможностей. Все патентованные
225алгоритмы вынесены в отдельные библиотеки (OpenSSL).
226
227Этот пакет содержит файлы, необходимые как для клиента, так и для
228сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
229openssh-server, или оба пакета.
230
231%description -l uk.UTF-8
232Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
233машини та для виконання команд на віддаленій машині. Вона призначена
234для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
235між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
236довільні порти TCP/IP можуть також бути проведені через безпечний
237канал.
238
239OpenSSH - це переробка командою розробників OpenBSD останньої вільної
240версії SSH, доведена до сучасного стану в термінах рівня безпеки та
241підтримуваних можливостей. Всі патентовані алгоритми винесені до
242окремих бібліотек (OpenSSL).
243
244Цей пакет містить файли, необхідні як для клієнта, так і для сервера
245OpenSSH. Вам потрібно буде ще встановити openssh-clients,
246openssh-server, чи обидва пакети.
247
248%package clients
249Summary: OpenSSH Secure Shell protocol clients
250Summary(es.UTF-8): Clientes de OpenSSH
251Summary(pl.UTF-8): Klienci protokołu Secure Shell
252Summary(pt_BR.UTF-8): Clientes do OpenSSH
253Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
254Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
255Group: Applications/Networking
256Requires: %{name}
257Provides: ssh-clients
258Obsoletes: ssh-clients
259%requires_eq_to openssl openssl-devel
260
261%description clients
262Ssh (Secure Shell) a program for logging into a remote machine and for
263executing commands in a remote machine. It is intended to replace
264rlogin and rsh, and provide secure encrypted communications between
265two untrusted hosts over an insecure network. X11 connections and
266arbitrary TCP/IP ports can also be forwarded over the secure channel.
267
268OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
269it up to date in terms of security and features, as well as removing
270all patented algorithms to seperate libraries (OpenSSL).
271
272This package includes the clients necessary to make encrypted
273connections to SSH servers.
274
275%description clients -l es.UTF-8
276Este paquete incluye los clientes que se necesitan para hacer
277conexiones codificadas con servidores SSH.
278
279%description clients -l pl.UTF-8
280Ssh (Secure Shell) to program służący do logowania się na zdalną
281maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
282zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
283pomiędzy dwoma hostami.
284
285Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
286
287%description clients -l pt_BR.UTF-8
288Esse pacote inclui os clientes necessários para fazer conexões
289encriptadas com servidores SSH.
290
291%description clients -l ru.UTF-8
292Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
293машину и для выполнения команд на удаленной машине.
294
295Этот пакет содержит программы-клиенты, необходимые для установления
296зашифрованных соединений с серверами SSH.
297
298%description clients -l uk.UTF-8
299Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
300машини та для виконання команд на віддаленій машині.
301
302Цей пакет містить програми-клієнти, необхідні для встановлення
303зашифрованих з'єднань з серверами SSH.
304
305%package clients-agent-profile_d
306Summary: OpenSSH Secure Shell agent init script
307Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
308Group: Applications/Networking
309Requires: %{name}-clients = %{epoch}:%{version}-%{release}
310
311%description clients-agent-profile_d
312profile.d scripts for starting SSH agent.
313
314%description clients-agent-profile_d -l pl.UTF-8
315Skrypty profile.d do uruchamiania agenta SSH.
316
317%package clients-agent-xinitrc
318Summary: OpenSSH Secure Shell agent init script
319Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
320Group: Applications/Networking
321Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
322Requires: xinitrc
323
324%description clients-agent-xinitrc
325xinitrc scripts for starting SSH agent.
326
327%description clients-agent-xinitrc -l pl.UTF-8
328Skrypty xinitrc do uruchamiania agenta SSH.
329
330%package server
331Summary: OpenSSH Secure Shell protocol server (sshd)
332Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
333Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
334Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
335Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
336Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
337Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
338Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
339Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
340Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
341Group: Networking/Daemons
342Requires(post): /sbin/chkconfig
343Requires(post): grep
344Requires(post,preun): /sbin/chkconfig
345Requires(postun): /usr/sbin/userdel
346Requires(pre): /bin/id
347Requires(pre): /usr/sbin/useradd
348Requires(post,preun,postun): systemd-units >= 38
349Requires: %{name} = %{epoch}:%{version}-%{release}
350# remove in 6.0, kept for flawless upgrade
351%{?with_ldap:Requires: %{name}-server-ldap = %{epoch}:%{version}-%{release}}
352Requires: pam >= %{pam_ver}
353Requires: rc-scripts >= 0.4.3.0
354Requires: systemd-units >= 38
355Requires: util-linux
356Suggests: /bin/login
357Suggests: xorg-app-xauth
358Provides: ssh-server
359Provides: user(sshd)
360%requires_eq_to openssl openssl-devel
361
362%description server
363Ssh (Secure Shell) a program for logging into a remote machine and for
364executing commands in a remote machine. It is intended to replace
365rlogin and rsh, and provide secure encrypted communications between
366two untrusted hosts over an insecure network. X11 connections and
367arbitrary TCP/IP ports can also be forwarded over the secure channel.
368
369OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
370it up to date in terms of security and features, as well as removing
371all patented algorithms to seperate libraries (OpenSSL).
372
373This package contains the secure shell daemon. The sshd is the server
374part of the secure shell protocol and allows ssh clients to connect to
375your host.
376
377%description server -l de.UTF-8
378Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
379
380%description server -l es.UTF-8
381Este paquete contiene el servidor SSH. sshd es la parte servidor del
382protocolo secure shell y permite que clientes ssh se conecten a su
383servidor.
384
385%description server -l fr.UTF-8
386Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
387
388%description server -l it.UTF-8
389Questo pacchetto installa sshd, il server di OpenSSH.
390
391%description server -l pl.UTF-8
392Ssh (Secure Shell) to program służący do logowania się na zdalną
393maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
394zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
395pomiędzy dwoma hostami.
396
397Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
398ssh).
399
400%description server -l pt.UTF-8
401Este pacote intala o sshd, o servidor do OpenSSH.
402
403%description server -l pt_BR.UTF-8
404Esse pacote contém o servidor SSH. O sshd é a parte servidor do
405protocolo secure shell e permite que clientes ssh se conectem ao seu
406host.
407
408%description server -l ru.UTF-8
409Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
410машину и для выполнения команд на удаленной машине.
411
412Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
413часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
414вашим хостом.
415
416%description server -l uk.UTF-8
417Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
418машини та для виконання команд на віддаленій машині.
419
420Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
421частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
422з вашим хостом.
423
424%package server-ldap
425Summary: A LDAP support for open source SSH server daemon
426Summary(pl.UTF-8): Wsparcie LDAP dla serwera OpenSSH
427Group: Daemons
428Requires: %{name} = %{epoch}:%{version}-%{release}
429
430%description server-ldap
431OpenSSH LDAP backend is a way how to distribute the authorized tokens
432among the servers in the network.
433
434%description server-ldap -l pl.UTF-8
435Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
436tokenów między serwerami w sieci.
437
438%package server-upstart
439Summary: Upstart job description for OpenSSH server
440Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
441Group: Daemons
442Requires: %{name}-server = %{epoch}:%{version}-%{release}
443Requires: upstart >= 0.6
444Conflicts: syslog-ng < 3.2.4-1
445
446%description server-upstart
447Upstart job description for OpenSSH.
448
449%description server-upstart -l pl.UTF-8
450Opis zadania Upstart dla OpenSSH.
451
452%package gnome-askpass
453Summary: OpenSSH GNOME passphrase dialog
454Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
455Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
456Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
457Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
458Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
459Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
460Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
461Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
462Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
463Group: Applications/Networking
464Requires: %{name} = %{epoch}:%{version}-%{release}
465Obsoletes: openssh-askpass
466Obsoletes: ssh-askpass
467Obsoletes: ssh-extras
468
469%description gnome-askpass
470Ssh (Secure Shell) a program for logging into a remote machine and for
471executing commands in a remote machine. It is intended to replace
472rlogin and rsh, and provide secure encrypted communications between
473two untrusted hosts over an insecure network. X11 connections and
474arbitrary TCP/IP ports can also be forwarded over the secure channel.
475
476OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
477it up to date in terms of security and features, as well as removing
478all patented algorithms to seperate libraries (OpenSSL).
479
480This package contains the GNOME passphrase dialog.
481
482%description gnome-askpass -l es.UTF-8
483Este paquete contiene un programa que abre una caja de diálogo para
484entrada de passphrase en GNOME.
485
486%description gnome-askpass -l pl.UTF-8
487Ssh (Secure Shell) to program służący do logowania się na zdalną
488maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
489zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
490pomiędzy dwoma hostami.
491
492Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
493
494%description gnome-askpass -l pt_BR.UTF-8
495Esse pacote contém um programa que abre uma caixa de diálogo para
496entrada de passphrase no GNOME.
497
498%description gnome-askpass -l ru.UTF-8
499Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
500машину и для выполнения команд на удаленной машине.
501
502Этот пакет содержит диалог ввода ключевой фразы для использования под
503GNOME.
504
505%description gnome-askpass -l uk.UTF-8
506Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
507машини та для виконання команд на віддаленій машині.
508
509Цей пакет містить діалог вводу ключової фрази для використання під
510GNOME.
511
512%package -n openldap-schema-openssh-lpk
513Summary: OpenSSH LDAP Public Key schema
514Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
515Group: Networking/Daemons
516Requires(post,postun): sed >= 4.0
517Requires: openldap-servers
518%if "%{_rpmversion}" >= "5"
519BuildArch: noarch
520%endif
521
522%description -n openldap-schema-openssh-lpk
523This package contains OpenSSH LDAP Public Key schema for openldap.
524
525%description -n openldap-schema-openssh-lpk -l pl.UTF-8
526Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
527openldap-a.
528
529%prep
530%setup -q
531%patch0 -p1
532%patch2 -p1
533%patch3 -p1
534%patch4 -p1
535%patch5 -p1
536%patch8 -p1
537%patch6 -p1
538
539%{?with_hpn:%patch9 -p1}
540%patch10 -p1
541%patch11 -p1
542%patch12 -p1
543%patch13 -p1
544%patch14 -p1
545%{!?with_ldap:%patch15 -p1}
546
547%if "%{pld_release}" == "ac"
548# fix for missing x11.pc
549%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
550%endif
551
552# hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
553sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
554
555grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
556%{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
557
558%build
559cp /usr/share/automake/config.sub .
560%{__aclocal}
561%{__autoconf}
562%{__autoheader}
563CPPFLAGS="-DCHROOT"
564%configure \
565 PERL=%{__perl} \
566 --disable-strip \
567 --enable-utmpx \
568 --enable-wtmpx \
569 --with-4in6 \
570 %{?with_audit:--with-audit=linux} \
571 --with-ipaddr-display \
572 %{?with_kerberos5:--with-kerberos5=/usr} \
573 --with-ldap%{!?with_ldap:=no} \
574 %{?with_libedit:--with-libedit} \
575 --with-mantype=man \
576 --with-md5-passwords \
577 --with-pam \
578 --with-pid-dir=%{_localstatedir}/run \
579 --with-privsep-path=%{_privsepdir} \
580 --with-sandbox=seccomp_filter \
581 %{?with_selinux:--with-selinux} \
582 --with-tcp-wrappers \
583%if "%{pld_release}" == "ac"
584 --with-xauth=/usr/X11R6/bin/xauth
585%else
586 --with-xauth=%{_bindir}/xauth
587%endif
588
589echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
590
591%{__make}
592
593%{?with_tests:%{__make} tests}
594
595cd contrib
596%if %{with gnome}
597%{__make} gnome-ssh-askpass1 \
598 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
599%endif
600%if %{with gtk}
601%{__make} gnome-ssh-askpass2 \
602 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
603%endif
604
605%install
606rm -rf $RPM_BUILD_ROOT
607install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
608 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
609install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
610
611%{__make} install \
612 DESTDIR=$RPM_BUILD_ROOT
613
614bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
615
616cp -p %{SOURCE3} sshd.pam
617install -p %{SOURCE2} sshd.init
618
619%if "%{pld_release}" == "ac"
620# not present in ac, no point searching it
621%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
622# openssl on ac does not have OPENSSL_HAS_ECC
623%{__sed} -i -e '/ecdsa/d' sshd.init
624%endif
625
626%if %{without audit}
627# remove recording user's login uid to the process attribute
628%{__sed} -i -e '/pam_loginuid.so/d' sshd.pam
629%endif
630
631install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
632cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
633cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
634cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
635ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
636cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
637cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
638cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
639
640%{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
641cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
642
643cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
644cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
645
646%if %{with gnome}
647install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
648%endif
649%if %{with gtk}
650install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
651%endif
652%if %{with gnome} || %{with gtk}
653cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
654#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
655EOF
656cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
657#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
658EOF
659ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
660%endif
661
662install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
663cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
664
665%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
666echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
667
668touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
669
670cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
671#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
672EOF
673
674%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
675%{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
676
677%clean
678rm -rf $RPM_BUILD_ROOT
679
680%post clients
681%env_update
682
683%postun clients
684%env_update
685
686%post gnome-askpass
687%env_update
688
689%postun gnome-askpass
690%env_update
691
692%pre server
693%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
694
695%post server
696/sbin/chkconfig --add sshd
697%service sshd reload "OpenSSH Daemon"
698NORESTART=1
699%systemd_post sshd.service
700
701%preun server
702if [ "$1" = "0" ]; then
703 %service sshd stop
704 /sbin/chkconfig --del sshd
705fi
706%systemd_preun sshd.service
707
708%postun server
709if [ "$1" = "0" ]; then
710 %userremove sshd
711fi
712%systemd_reload
713
714%triggerpostun server -- %{name}-server < 6.2p1-1
715cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
716sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
717
718%triggerpostun server -- %{name}-server < 2:5.9p1-8
719# lpk.patch to ldap.patch
720if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
721 echo >&2 "Migrating LPK patch to LDAP patch"
722 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
723 %{__sed} -i -e '
724 # disable old configs
725 # just UseLPK/LkpLdapConf supported for now
726 s/^\s*UseLPK/## Obsolete &/
727 s/^\s*Lpk/## Obsolete &/
728 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
729 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
730 ' %{_sysconfdir}/sshd_config
731 if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
732 /bin/systemctl try-restart sshd.service || :
733 else
734 %service -q sshd reload
735 fi
736fi
737%systemd_trigger sshd.service
738if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
739%banner %{name}-server -e << EOF
740!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
741! Native systemd support for sshd has been installed. !
742! Restarting sshd.service with systemctl WILL kill all !
743! active ssh sessions (daemon as such will be started). !
744!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
745EOF
746fi
747
748%post server-upstart
749%upstart_post sshd
750
751%postun server-upstart
752%upstart_postun sshd
753
754%post -n openldap-schema-openssh-lpk
755%openldap_schema_register %{schemadir}/openssh-lpk.schema
756%service -q ldap restart
757
758%postun -n openldap-schema-openssh-lpk
759if [ "$1" = "0" ]; then
760 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
761 %service -q ldap restart
762fi
763
764%files
765%defattr(644,root,root,755)
766%doc TODO README OVERVIEW CREDITS Change*
767%attr(755,root,root) %{_bindir}/ssh-key*
768%attr(755,root,root) %{_bindir}/ssh-vulnkey*
769%{_mandir}/man1/ssh-key*.1*
770%{_mandir}/man1/ssh-vulnkey*.1*
771%dir %{_sysconfdir}
772%dir %{_libexecdir}
773
774%files clients
775%defattr(644,root,root,755)
776%attr(755,root,root) %{_bindir}/ssh
777%attr(755,root,root) %{_bindir}/slogin
778%attr(755,root,root) %{_bindir}/sftp
779%attr(755,root,root) %{_bindir}/ssh-agent
780%attr(755,root,root) %{_bindir}/ssh-add
781%attr(755,root,root) %{_bindir}/ssh-copy-id
782%attr(755,root,root) %{_bindir}/scp
783%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
784%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
785%{_mandir}/man1/scp.1*
786%{_mandir}/man1/ssh.1*
787%{_mandir}/man1/slogin.1*
788%{_mandir}/man1/sftp.1*
789%{_mandir}/man1/ssh-agent.1*
790%{_mandir}/man1/ssh-add.1*
791%{_mandir}/man1/ssh-copy-id.1*
792%{_mandir}/man5/ssh_config.5*
793%lang(it) %{_mandir}/it/man1/ssh.1*
794%lang(it) %{_mandir}/it/man5/ssh_config.5*
795%lang(pl) %{_mandir}/pl/man1/scp.1*
796%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
797
798# for host-based auth (suid required for accessing private host key)
799#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
800#%{_mandir}/man8/ssh-keysign.8*
801
802%files clients-agent-profile_d
803%defattr(644,root,root,755)
804%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
805%attr(755,root,root) /etc/profile.d/ssh-agent.sh
806
807%files clients-agent-xinitrc
808%defattr(644,root,root,755)
809%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
810
811%files server
812%defattr(644,root,root,755)
813%attr(755,root,root) %{_sbindir}/sshd
814%attr(755,root,root) %{_libexecdir}/sftp-server
815%attr(755,root,root) %{_libexecdir}/ssh-keysign
816%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
817%attr(755,root,root) %{_libexecdir}/sshd-keygen
818%{_mandir}/man8/sshd.8*
819%{_mandir}/man8/sftp-server.8*
820%{_mandir}/man8/ssh-keysign.8*
821%{_mandir}/man8/ssh-pkcs11-helper.8*
822%{_mandir}/man5/sshd_config.5*
823%{_mandir}/man5/moduli.5*
824%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
825%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
826%attr(640,root,root) %{_sysconfdir}/moduli
827%attr(754,root,root) /etc/rc.d/init.d/sshd
828%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
829%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
830%{systemdunitdir}/sshd.service
831%{systemdunitdir}/sshd.socket
832%{systemdunitdir}/sshd@.service
833
834%if %{with ldap}
835%files server-ldap
836%defattr(644,root,root,755)
837%doc HOWTO.ldap-keys ldap.conf
838%attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
839%attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
840%{_mandir}/man5/ssh-ldap.conf.5*
841%{_mandir}/man8/ssh-ldap-helper.8*
842%endif
843
844%if %{with gnome} || %{with gtk}
845%files gnome-askpass
846%defattr(644,root,root,755)
847%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
848%dir %{_libexecdir}/ssh
849%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
850%attr(755,root,root) %{_libexecdir}/ssh-askpass
851%endif
852
853%if %{with ldap}
854%files -n openldap-schema-openssh-lpk
855%defattr(644,root,root,755)
856%{schemadir}/openssh-lpk.schema
857%endif
858
859%if "%{pld_release}" != "ti"
860%files server-upstart
861%defattr(644,root,root,755)
862%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
863%endif
This page took 0.043886 seconds and 4 git commands to generate.