]> git.pld-linux.org Git - packages/openscad.git/commitdiff
- up to 2019.01-RC2 auto/th/openscad-2019.01-0.RC2.1
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 19 Apr 2019 14:05:01 +0000 (16:05 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 19 Apr 2019 14:05:01 +0000 (16:05 +0200)
localedir.patch [new file with mode: 0644]
openscad-polyclipping.patch
openscad.spec

diff --git a/localedir.patch b/localedir.patch
new file mode 100644 (file)
index 0000000..3d42b74
--- /dev/null
@@ -0,0 +1,21 @@
+--- openscad-2019.01-RC2/src/openscad.cc~      2019-01-28 20:47:07.000000000 +0100
++++ openscad-2019.01-RC2/src/openscad.cc       2019-04-19 15:35:44.398250089 +0200
+@@ -144,17 +144,10 @@
+  * files.
+  */
+ void localization_init() {
+-      fs::path po_dir(PlatformUtils::resourcePath("locale"));
+-      std::string locale_path(po_dir.string());
+-
+-      if (fs::is_directory(locale_path)) {
+               setlocale(LC_ALL, "");
+-              bindtextdomain("openscad", locale_path.c_str());
++              bindtextdomain("openscad", "/usr/share/locale");
+               bind_textdomain_codeset("openscad", "UTF-8");
+               textdomain("openscad");
+-      } else {
+-              PRINT("Could not initialize localization.");
+-      }
+ }
+ Camera get_camera(const po::variables_map &vm)
index e876dbafef56ec3b0556eb90c96b78c3bb347491..d7d41d6cc2f3298f85ff4b3f8d0592fc4479244a 100644 (file)
@@ -6,8 +6,8 @@ index a2eefe6..20b1864 100644
             src/LibraryInfoDialog.cc
  
  # ClipperLib
--SOURCES += src/polyclipping/clipper.cpp
--HEADERS += src/polyclipping/clipper.hpp
+-SOURCES += src/ext/polyclipping/clipper.cpp
+-HEADERS += src/ext/polyclipping/clipper.hpp
 +LIBS += -lpolyclipping
  
  # libtess2
@@ -19,37 +19,19 @@ index 0dc7cd0..c98cda0 100644
 @@ -1,6 +1,6 @@
  #pragma once
  
--#include "polyclipping/clipper.hpp"
+-#include "ext/polyclipping/clipper.hpp"
 +#include <polyclipping/clipper.hpp>
  #include "Polygon2d.h"
  
  namespace ClipperUtils {
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index 93658a0..a852ef6 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -705,7 +705,6 @@ set(COMMON_SOURCES
-   ../src/GeometryCache.cc 
-   ../src/clipper-utils.cc 
-   ../src/Tree.cc
--  ../src/polyclipping/clipper.cpp
-   ../src/libtess2/Source/bucketalloc.c
-   ../src/libtess2/Source/dict.c
-   ../src/libtess2/Source/geom.c
-@@ -786,14 +785,14 @@ target_link_libraries(csgtexttest tests-nocgal ${GLEW_LIBRARY} ${OPENCSG_LIBRARY
- #
- add_executable(cgalcachetest cgalcachetest.cc)
- set_target_properties(cgalcachetest PROPERTIES COMPILE_FLAGS "-DENABLE_CGAL ${CGAL_CXX_FLAGS_INIT}")
--target_link_libraries(cgalcachetest tests-cgal ${GLEW_LIBRARY} ${OPENCSG_LIBRARY} ${APP_SERVICES_LIBRARY})
-+target_link_libraries(cgalcachetest tests-cgal -lpolyclipping ${GLEW_LIBRARY} ${OPENCSG_LIBRARY} ${APP_SERVICES_LIBRARY})
+--- openscad-openscad-2019.01-RC4/src/libsvg/shape.h~  2019-03-17 02:57:25.000000000 +0100
++++ openscad-openscad-2019.01-RC4/src/libsvg/shape.h   2019-04-19 14:37:29.511178262 +0200
+@@ -34,7 +34,7 @@
+ #include <Eigen/Geometry>
  
- #
- # openscad no-qt
- #
- add_executable(openscad_nogui ../src/openscad.cc)
- set_target_properties(openscad_nogui PROPERTIES COMPILE_FLAGS "-fno-strict-aliasing -DEIGEN_DONT_ALIGN ${ENABLE_OPENCSG_FLAG} -DENABLE_CGAL ${CGAL_CXX_FLAGS_INIT}")
--target_link_libraries(openscad_nogui tests-offscreen tests-cgal ${GLEW_LIBRARY} ${OPENCSG_LIBRARY} ${APP_SERVICES_LIBRARY})
-+target_link_libraries(openscad_nogui tests-offscreen tests-cgal -lX11 -lpolyclipping ${GLEW_LIBRARY} ${OPENCSG_LIBRARY} ${APP_SERVICES_LIBRARY})
+ #include "util.h"
+-#include "ext/polyclipping/clipper.hpp"
++#include <polyclipping/clipper.hpp>
+ namespace libsvg {
  
- # also run translation compilation to verify the files are without syntax errors
- add_custom_target(locale_files ALL COMMAND ${CMAKE_SOURCE_DIR}/../scripts/translation-make.sh)
index fd5fbd44b12fcbc5f67e0d66e74a527ee052e7d4..bf8a4300dc083c9361beca67ca99560797a5734c 100644 (file)
@@ -1,24 +1,37 @@
 #
 # Conditional build:
-%bcond_with    tests           # build with tests
+%bcond_without tests           # build with tests
 %bcond_with    qt5
 
 %define        qtver   %{?with_qt5:5}%{!?with_qt5:4}
 
-%define        upversion 2015.03-3
+%define        _rc     RC2
+%define        upversion %{version}-%{_rc}
 Summary:       The Programmers Solid 3D CAD Modeller
 Name:          openscad
-Version:       2015.03.3
-Release:       2
+Version:       2019.01
+Release:       0.%{_rc}.1
 # COPYING contains a linking exception for CGAL
 # Appdata file is CC0
 # Examples are CC0
 License:       GPLv2 with exceptions and CC0
 Group:         Applications/Engineering
 Source0:       http://files.openscad.org/%{name}-%{upversion}.src.tar.gz
-# Source0-md5: a498a218a247468eee140ccc44c73afa
+# Source0-md5: a850bd071b8dd47cfcb833a6bd3044c4
 Patch0:                %{name}-polyclipping.patch
+Patch1:                localedir.patch
 URL:           http://www.openscad.org/
+%if %{with qt5}
+BuildRequires: Qt5Network-devel
+BuildRequires: Qt5Concurrent-devel
+BuildRequires: Qt5Multimedia-devel
+BuildRequires: Qt5DBus-devel
+BuildRequires: Qt5PrintSupport-devel
+%else
+BuildRequires: QtNetwork-devel
+BuildRequires: QtMultimedia-devel
+BuildRequires: QtDBus-devel
+%endif
 BuildRequires: CGAL-devel >= 3.6
 BuildRequires: ImageMagick
 BuildRequires: Mesa-dri-driver-swrast
@@ -137,60 +150,54 @@ expect some API changes, however many things are already working.
 %prep
 %setup -qn %{name}-%{upversion}
 %patch0 -p1
+%patch1 -p1
 
 # use system package
-rm -r src/polyclipping
+rm -r src/ext/polyclipping
 
 %build
 qmake-qt%{qtver} \
        PREFIX=%{_prefix}
 %{__make}
 
-# tests
+%if %{with tests}
 cd tests
 install -d build
 cd build
 %cmake ..
 %{__make}
+cd ..
+ctest
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} -j1 install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-rm -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
-
-:> %{name}.lang
-# TODO: fix this to find the files
-#%find_lang %{name}
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
 
-rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
-rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
-rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
 
-%if %{with tests}
-cd tests
-ctest
-cd ..
-%endif
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README.md RELEASE_NOTES
+%doc README.md RELEASE_NOTES.md
 %attr(755,root,root) %{_bindir}/%{name}
-%{_datadir}/appdata/*.xml
+%{_datadir}/metainfo/*.xml
 %{_desktopdir}/%{name}.desktop
 %{_pixmapsdir}/%{name}.png
 %{_datadir}/mime/packages/%{name}.xml
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/examples
 %{_datadir}/%{name}/color-schemes
-%dir %{_datadir}/%{name}/locale
-# drop when find_lang is fixed
-%{_datadir}/%{name}/locale/*
 %dir %{_datadir}/%{name}/libraries
 %{_mandir}/man1/*
 
This page took 0.158985 seconds and 4 git commands to generate.