]> git.pld-linux.org Git - packages/openscad.git/blob - openscad.spec
71bc2b838f0252b744cccfc16ae9bf3096923c16
[packages/openscad.git] / openscad.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build with tests
4
5 Summary:        The Programmers Solid 3D CAD Modeller
6 Name:           openscad
7 Version:        2019.05
8 Release:        1
9 # COPYING contains a linking exception for CGAL
10 # Appdata file is CC0
11 # Examples are CC0
12 License:        GPLv2 with exceptions and CC0
13 Group:          Applications/Engineering
14 Source0:        http://files.openscad.org/%{name}-%{version}.src.tar.gz
15 # Source0-md5:  2b63e249d56e2eba62ed5b042e1d82bc
16 Patch0:         %{name}-polyclipping.patch
17 Patch1:         localedir.patch
18 URL:            http://www.openscad.org/
19 BuildRequires:  Qt5Network-devel
20 BuildRequires:  Qt5Concurrent-devel
21 BuildRequires:  Qt5Multimedia-devel
22 BuildRequires:  Qt5DBus-devel
23 BuildRequires:  Qt5PrintSupport-devel
24 BuildRequires:  CGAL-devel >= 3.6
25 BuildRequires:  ImageMagick
26 BuildRequires:  Mesa-dri-driver-swrast
27 BuildRequires:  bison >= 2.4
28 BuildRequires:  boost-devel >= 1.35
29 BuildRequires:  desktop-file-utils
30 BuildRequires:  double-conversion-devel
31 BuildRequires:  eigen3
32 BuildRequires:  flex >= 2.5.35
33 BuildRequires:  fontconfig-devel >= 2.10
34 BuildRequires:  freetype-devel >= 2.4
35 BuildRequires:  gettext
36 BuildRequires:  glew-devel >= 1.6
37 BuildRequires:  glib2-devel
38 BuildRequires:  gmp-devel >= 5.0.0
39 BuildRequires:  harfbuzz-devel >= 0.9.19
40 BuildRequires:  lib3mf-devel >= 1.8.1
41 BuildRequires:  libzip-devel
42 BuildRequires:  libxml2-devel
43 BuildRequires:  mpfr-devel >= 3.0.0
44 BuildRequires:  opencsg-devel >= 1.3.2
45 BuildRequires:  pkgconfig
46 BuildRequires:  polyclipping-devel >= 6.1.3
47 BuildRequires:  procps
48 BuildRequires:  python
49 BuildRequires:  qscintilla2-qt5-devel >= 2.11.2
50 BuildRequires:  qt5-build
51 BuildRequires:  xorg-xserver-Xvfb
52 Requires:       font(liberationmono)
53 Requires:       font(liberationsans)
54 Requires:       font(liberationserif)
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 ### LICENSES:
58
59 ##  LGPLv2+:
60 #   2Dshapes.scad
61 #   3d_triangle.scad
62 #   fonts.scad
63 #   gridbeam.scad
64 #   hardware.scad
65 #   libtriangles.scad
66 #   multiply.scad
67 #   shapes.scad
68 #   screw.scad
69
70 ##  LGPLv2:
71 #   gears.scad
72 #   involute_gears.scad
73 #   servos.scad
74 #   transformations.scad
75 #   triangles.scad
76 #   unregular_shapes.scad
77 #   bitmap/letter_necklace.scad
78
79 ##  LGPLv3+:
80 #   teardrop.scad
81
82 ##  GPLv3 or LGPLv2:
83 #   motors.scad
84 #   nuts_and_bolts.scad
85
86
87 ##  GPLv3+ or LGPLv2:
88 #   metric_fastners.scad
89 #   regular_shapes.scad
90
91 ##  CC-BY-SA or LGPLv2+:
92 #   bearing.scad
93 #   materials.scad
94 #   stepper.scad
95 #   utilities.scad
96
97 ##  CC-BY-SA or LGPLv2:
98 #   units.scad
99
100 ##  CC-BY:
101 #   polyholes.scad
102 #   bitmap/alphabet_block.scad
103 #   bitmap/bitmap.scad
104 #   bitmap/height_map.scad
105 #   bitmap/name_tag.scad
106
107 ## BSD
108 #   boxes.scad
109
110 ## MIT
111 #   constants.scad
112 #   curves.scad
113 #   math.scad
114
115 ## Public Domain
116 #   lego_compatibility.scad
117 #   trochoids.scad
118
119 ###############################################
120
121 %description
122 OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
123 free software for creating 3D models (such as the famous application
124 Blender) it does not focus on the artistic aspects of 3D modeling but
125 instead on the CAD aspects. Thus it might be the application you are
126 looking for when you are planning to create 3D models of machine parts
127 but pretty sure is not what you are looking for when you are more
128 interested in creating computer-animated movies.
129
130 %package MCAD
131 Summary:        OpenSCAD Parametric CAD Library
132 License:        LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
133 URL:            https://www.github.com/openscad/MCAD
134 Requires:       %{name} = %{version}-%{release}
135 %if "%{_rpmversion}" >= "5"
136 BuildArch:      noarch
137 %endif
138
139 %description    MCAD
140 This library contains components commonly used in designing and
141 moching up mechanical designs. It is currently unfinished and you can
142 expect some API changes, however many things are already working.
143
144 %prep
145 %setup -q
146 %patch0 -p1
147 %patch1 -p1
148
149 # use system package
150 %{__rm} -r src/ext/polyclipping
151
152 %build
153 qmake-qt5 \
154         PREFIX=%{_prefix}
155 %{__make}
156
157 %if %{with tests}
158 mkdir -p tests/build
159 cd tests/build
160 %cmake ../
161 %{__make}
162 %{__make} -j1 test
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 %{__make} install \
168         INSTALL_ROOT=$RPM_BUILD_ROOT
169
170 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
171 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
172 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
173 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
174
175 %{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
176
177 %find_lang %{name}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files -f %{name}.lang
183 %defattr(644,root,root,755)
184 %doc README.md RELEASE_NOTES.md
185 %attr(755,root,root) %{_bindir}/%{name}
186 %{_datadir}/metainfo/*.xml
187 %{_desktopdir}/%{name}.desktop
188 %{_pixmapsdir}/%{name}.png
189 %{_datadir}/mime/packages/%{name}.xml
190 %dir %{_datadir}/%{name}
191 %{_datadir}/%{name}/examples
192 %{_datadir}/%{name}/color-schemes
193 %dir %{_datadir}/%{name}/libraries
194 %{_mandir}/man1/*
195
196 %files MCAD
197 %defattr(644,root,root,755)
198 %doc libraries/MCAD/README.markdown libraries/MCAD/TODO
199 %{_datadir}/%{name}/libraries/MCAD
This page took 0.049687 seconds and 2 git commands to generate.