]> git.pld-linux.org Git - packages/openscad.git/blob - openscad.spec
- rel 1
[packages/openscad.git] / openscad.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build with tests
4
5 Summary:        The Programmers Solid 3D CAD Modeller
6 Name:           openscad
7 Version:        2019.05
8 Release:        1
9 # COPYING contains a linking exception for CGAL
10 # Appdata file is CC0
11 # Examples are CC0
12 License:        GPLv2 with exceptions and CC0
13 Group:          Applications/Engineering
14 Source0:        http://files.openscad.org/%{name}-%{version}.src.tar.gz
15 # Source0-md5:  2b63e249d56e2eba62ed5b042e1d82bc
16 Patch0:         %{name}-polyclipping.patch
17 Patch1:         localedir.patch
18 URL:            http://www.openscad.org/
19 BuildRequires:  Qt5Network-devel
20 BuildRequires:  Qt5Concurrent-devel
21 BuildRequires:  Qt5Multimedia-devel
22 BuildRequires:  Qt5DBus-devel
23 BuildRequires:  Qt5PrintSupport-devel
24 BuildRequires:  CGAL-devel >= 3.6
25 BuildRequires:  ImageMagick
26 BuildRequires:  Mesa-dri-driver-swrast
27 BuildRequires:  bison >= 2.4
28 BuildRequires:  boost-devel >= 1.35
29 BuildRequires:  desktop-file-utils
30 BuildRequires:  eigen3
31 BuildRequires:  flex >= 2.5.35
32 BuildRequires:  fontconfig-devel >= 2.10
33 BuildRequires:  freetype-devel >= 2.4
34 BuildRequires:  gettext
35 BuildRequires:  glew-devel >= 1.6
36 BuildRequires:  glib2-devel
37 BuildRequires:  gmp-devel >= 5.0.0
38 BuildRequires:  harfbuzz-devel >= 0.9.19
39 BuildRequires:  lib3mf-devel >= 1.8.1
40 BuildRequires:  libzip-devel
41 BuildRequires:  libxml2-devel
42 BuildRequires:  mpfr-devel >= 3.0.0
43 BuildRequires:  opencsg-devel >= 1.3.2
44 BuildRequires:  pkgconfig
45 BuildRequires:  polyclipping-devel >= 6.1.3
46 BuildRequires:  procps
47 BuildRequires:  python
48 BuildRequires:  qscintilla2-qt5-devel
49 BuildRequires:  qt5-build
50 BuildRequires:  xorg-xserver-Xvfb
51 Requires:       font(liberationmono)
52 Requires:       font(liberationsans)
53 Requires:       font(liberationserif)
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 ### LICENSES:
57
58 ##  LGPLv2+:
59 #   2Dshapes.scad
60 #   3d_triangle.scad
61 #   fonts.scad
62 #   gridbeam.scad
63 #   hardware.scad
64 #   libtriangles.scad
65 #   multiply.scad
66 #   shapes.scad
67 #   screw.scad
68
69 ##  LGPLv2:
70 #   gears.scad
71 #   involute_gears.scad
72 #   servos.scad
73 #   transformations.scad
74 #   triangles.scad
75 #   unregular_shapes.scad
76 #   bitmap/letter_necklace.scad
77
78 ##  LGPLv3+:
79 #   teardrop.scad
80
81 ##  GPLv3 or LGPLv2:
82 #   motors.scad
83 #   nuts_and_bolts.scad
84
85
86 ##  GPLv3+ or LGPLv2:
87 #   metric_fastners.scad
88 #   regular_shapes.scad
89
90 ##  CC-BY-SA or LGPLv2+:
91 #   bearing.scad
92 #   materials.scad
93 #   stepper.scad
94 #   utilities.scad
95
96 ##  CC-BY-SA or LGPLv2:
97 #   units.scad
98
99 ##  CC-BY:
100 #   polyholes.scad
101 #   bitmap/alphabet_block.scad
102 #   bitmap/bitmap.scad
103 #   bitmap/height_map.scad
104 #   bitmap/name_tag.scad
105
106 ## BSD
107 #   boxes.scad
108
109 ## MIT
110 #   constants.scad
111 #   curves.scad
112 #   math.scad
113
114 ## Public Domain
115 #   lego_compatibility.scad
116 #   trochoids.scad
117
118 ###############################################
119
120 %description
121 OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
122 free software for creating 3D models (such as the famous application
123 Blender) it does not focus on the artistic aspects of 3D modeling but
124 instead on the CAD aspects. Thus it might be the application you are
125 looking for when you are planning to create 3D models of machine parts
126 but pretty sure is not what you are looking for when you are more
127 interested in creating computer-animated movies.
128
129 %package MCAD
130 Summary:        OpenSCAD Parametric CAD Library
131 License:        LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
132 URL:            https://www.github.com/openscad/MCAD
133 Requires:       %{name} = %{version}-%{release}
134 %if "%{_rpmversion}" >= "5"
135 BuildArch:      noarch
136 %endif
137
138 %description    MCAD
139 This library contains components commonly used in designing and
140 moching up mechanical designs. It is currently unfinished and you can
141 expect some API changes, however many things are already working.
142
143 %prep
144 %setup -q
145 %patch0 -p1
146 %patch1 -p1
147
148 # use system package
149 %{__rm} -r src/ext/polyclipping
150
151 %build
152 qmake-qt5 \
153         PREFIX=%{_prefix}
154 %{__make}
155
156 %if %{with tests}
157 mkdir -p tests/build
158 cd tests/build
159 %cmake ../
160 %{__make}
161 %{__make} -j1 test
162 %endif
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166 %{__make} install \
167         INSTALL_ROOT=$RPM_BUILD_ROOT
168
169 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
170 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
171 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
172 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
173
174 %{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
175
176 %find_lang %{name}
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %files -f %{name}.lang
182 %defattr(644,root,root,755)
183 %doc README.md RELEASE_NOTES.md
184 %attr(755,root,root) %{_bindir}/%{name}
185 %{_datadir}/metainfo/*.xml
186 %{_desktopdir}/%{name}.desktop
187 %{_pixmapsdir}/%{name}.png
188 %{_datadir}/mime/packages/%{name}.xml
189 %dir %{_datadir}/%{name}
190 %{_datadir}/%{name}/examples
191 %{_datadir}/%{name}/color-schemes
192 %dir %{_datadir}/%{name}/libraries
193 %{_mandir}/man1/*
194
195 %files MCAD
196 %defattr(644,root,root,755)
197 %doc libraries/MCAD/README.markdown libraries/MCAD/TODO
198 %{_datadir}/%{name}/libraries/MCAD
This page took 0.058925 seconds and 3 git commands to generate.