]> git.pld-linux.org Git - packages/openscad.git/blob - openscad.spec
- release 3 (by relup.sh)
[packages/openscad.git] / openscad.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build with tests
4
5 %ifnarch %{x8664}
6 %undefine       with_tests
7 %endif
8 Summary:        The Programmers Solid 3D CAD Modeller
9 Name:           openscad
10 Version:        2019.05
11 Release:        3
12 # COPYING contains a linking exception for CGAL
13 # Appdata file is CC0
14 # Examples are CC0
15 License:        GPLv2 with exceptions and CC0
16 Group:          Applications/Engineering
17 Source0:        http://files.openscad.org/%{name}-%{version}.src.tar.gz
18 # Source0-md5:  2b63e249d56e2eba62ed5b042e1d82bc
19 Patch0:         %{name}-polyclipping.patch
20 Patch1:         localedir.patch
21 URL:            http://www.openscad.org/
22 BuildRequires:  Qt5Network-devel
23 BuildRequires:  Qt5Concurrent-devel
24 BuildRequires:  Qt5Multimedia-devel
25 BuildRequires:  Qt5DBus-devel
26 BuildRequires:  Qt5PrintSupport-devel
27 BuildRequires:  CGAL-devel >= 3.6
28 BuildRequires:  ImageMagick
29 BuildRequires:  Mesa-dri-driver-swrast
30 BuildRequires:  bison >= 2.4
31 BuildRequires:  boost-devel >= 1.35
32 BuildRequires:  desktop-file-utils
33 BuildRequires:  double-conversion-devel
34 BuildRequires:  eigen3
35 BuildRequires:  flex >= 2.5.35
36 BuildRequires:  fontconfig-devel >= 2.10
37 BuildRequires:  freetype-devel >= 2.4
38 BuildRequires:  gettext
39 BuildRequires:  glew-devel >= 1.6
40 BuildRequires:  glib2-devel
41 BuildRequires:  gmp-devel >= 5.0.0
42 BuildRequires:  harfbuzz-devel >= 0.9.19
43 BuildRequires:  lib3mf-devel >= 1.8.1
44 BuildRequires:  libzip-devel
45 BuildRequires:  libxml2-devel
46 BuildRequires:  mpfr-devel >= 3.0.0
47 BuildRequires:  opencsg-devel >= 1.3.2
48 BuildRequires:  pkgconfig
49 BuildRequires:  polyclipping-devel >= 6.1.3
50 BuildRequires:  procps
51 BuildRequires:  python
52 BuildRequires:  qscintilla2-qt5-devel >= 2.11.2
53 BuildRequires:  qt5-build
54 BuildRequires:  xorg-xserver-Xvfb
55 Requires:       font(liberationmono)
56 Requires:       font(liberationsans)
57 Requires:       font(liberationserif)
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 ### LICENSES:
61
62 ##  LGPLv2+:
63 #   2Dshapes.scad
64 #   3d_triangle.scad
65 #   fonts.scad
66 #   gridbeam.scad
67 #   hardware.scad
68 #   libtriangles.scad
69 #   multiply.scad
70 #   shapes.scad
71 #   screw.scad
72
73 ##  LGPLv2:
74 #   gears.scad
75 #   involute_gears.scad
76 #   servos.scad
77 #   transformations.scad
78 #   triangles.scad
79 #   unregular_shapes.scad
80 #   bitmap/letter_necklace.scad
81
82 ##  LGPLv3+:
83 #   teardrop.scad
84
85 ##  GPLv3 or LGPLv2:
86 #   motors.scad
87 #   nuts_and_bolts.scad
88
89
90 ##  GPLv3+ or LGPLv2:
91 #   metric_fastners.scad
92 #   regular_shapes.scad
93
94 ##  CC-BY-SA or LGPLv2+:
95 #   bearing.scad
96 #   materials.scad
97 #   stepper.scad
98 #   utilities.scad
99
100 ##  CC-BY-SA or LGPLv2:
101 #   units.scad
102
103 ##  CC-BY:
104 #   polyholes.scad
105 #   bitmap/alphabet_block.scad
106 #   bitmap/bitmap.scad
107 #   bitmap/height_map.scad
108 #   bitmap/name_tag.scad
109
110 ## BSD
111 #   boxes.scad
112
113 ## MIT
114 #   constants.scad
115 #   curves.scad
116 #   math.scad
117
118 ## Public Domain
119 #   lego_compatibility.scad
120 #   trochoids.scad
121
122 ###############################################
123
124 %description
125 OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
126 free software for creating 3D models (such as the famous application
127 Blender) it does not focus on the artistic aspects of 3D modeling but
128 instead on the CAD aspects. Thus it might be the application you are
129 looking for when you are planning to create 3D models of machine parts
130 but pretty sure is not what you are looking for when you are more
131 interested in creating computer-animated movies.
132
133 %package MCAD
134 Summary:        OpenSCAD Parametric CAD Library
135 License:        LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
136 URL:            https://www.github.com/openscad/MCAD
137 Requires:       %{name} = %{version}-%{release}
138 %if "%{_rpmversion}" >= "5"
139 BuildArch:      noarch
140 %endif
141
142 %description    MCAD
143 This library contains components commonly used in designing and
144 moching up mechanical designs. It is currently unfinished and you can
145 expect some API changes, however many things are already working.
146
147 %prep
148 %setup -q
149 %patch0 -p1
150 %patch1 -p1
151
152 # use system package
153 %{__rm} -r src/ext/polyclipping
154
155 %build
156 qmake-qt5 \
157         PREFIX=%{_prefix}
158 %{__make}
159
160 %if %{with tests}
161 mkdir -p tests/build
162 cd tests/build
163 %cmake ../
164 %{__make}
165 %{__make} -j1 test
166 %endif
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 %{__make} install \
171         INSTALL_ROOT=$RPM_BUILD_ROOT
172
173 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
174 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
175 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
176 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
177
178 %{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
179
180 %find_lang %{name}
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %files -f %{name}.lang
186 %defattr(644,root,root,755)
187 %doc README.md RELEASE_NOTES.md
188 %attr(755,root,root) %{_bindir}/%{name}
189 %{_datadir}/metainfo/*.xml
190 %{_desktopdir}/%{name}.desktop
191 %{_pixmapsdir}/%{name}.png
192 %{_datadir}/mime/packages/%{name}.xml
193 %dir %{_datadir}/%{name}
194 %{_datadir}/%{name}/examples
195 %{_datadir}/%{name}/color-schemes
196 %dir %{_datadir}/%{name}/libraries
197 %{_mandir}/man1/*
198
199 %files MCAD
200 %defattr(644,root,root,755)
201 %doc libraries/MCAD/README.markdown libraries/MCAD/TODO
202 %{_datadir}/%{name}/libraries/MCAD
This page took 0.088945 seconds and 3 git commands to generate.