]> git.pld-linux.org Git - packages/openscad.git/blame - openscad.spec
- BR double-conversion-devel
[packages/openscad.git] / openscad.spec
CommitLineData
cd307a29
ER
1#
2# Conditional build:
35570a78 3%bcond_without tests # build with tests
cd307a29 4
cd307a29 5Summary: The Programmers Solid 3D CAD Modeller
a4cd6760 6Name: openscad
9ef24798 7Version: 2019.05
3b02408e 8Release: 1
a4cd6760
AM
9# COPYING contains a linking exception for CGAL
10# Appdata file is CC0
11# Examples are CC0
12License: GPLv2 with exceptions and CC0
13Group: Applications/Engineering
9ef24798
JR
14Source0: http://files.openscad.org/%{name}-%{version}.src.tar.gz
15# Source0-md5: 2b63e249d56e2eba62ed5b042e1d82bc
a4cd6760 16Patch0: %{name}-polyclipping.patch
35570a78 17Patch1: localedir.patch
cd307a29 18URL: http://www.openscad.org/
35570a78
JR
19BuildRequires: Qt5Network-devel
20BuildRequires: Qt5Concurrent-devel
21BuildRequires: Qt5Multimedia-devel
22BuildRequires: Qt5DBus-devel
23BuildRequires: Qt5PrintSupport-devel
a4cd6760
AM
24BuildRequires: CGAL-devel >= 3.6
25BuildRequires: ImageMagick
26BuildRequires: Mesa-dri-driver-swrast
27BuildRequires: bison >= 2.4
28BuildRequires: boost-devel >= 1.35
29BuildRequires: desktop-file-utils
aff0f9ea 30BuildRequires: double-conversion-devel
a4cd6760
AM
31BuildRequires: eigen3
32BuildRequires: flex >= 2.5.35
33BuildRequires: fontconfig-devel >= 2.10
34BuildRequires: freetype-devel >= 2.4
35BuildRequires: gettext
36BuildRequires: glew-devel >= 1.6
37BuildRequires: glib2-devel
38BuildRequires: gmp-devel >= 5.0.0
39BuildRequires: harfbuzz-devel >= 0.9.19
a7d7666a
JR
40BuildRequires: lib3mf-devel >= 1.8.1
41BuildRequires: libzip-devel
42BuildRequires: libxml2-devel
a4cd6760
AM
43BuildRequires: mpfr-devel >= 3.0.0
44BuildRequires: opencsg-devel >= 1.3.2
a7d7666a 45BuildRequires: pkgconfig
a4cd6760
AM
46BuildRequires: polyclipping-devel >= 6.1.3
47BuildRequires: procps
48BuildRequires: python
a4514540 49BuildRequires: qscintilla2-qt5-devel >= 2.11.2
a7d7666a 50BuildRequires: qt5-build
a4cd6760
AM
51BuildRequires: xorg-xserver-Xvfb
52Requires: font(liberationmono)
53Requires: font(liberationsans)
54Requires: font(liberationserif)
cd307a29
ER
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57### LICENSES:
58
59## LGPLv2+:
60# 2Dshapes.scad
61# 3d_triangle.scad
62# fonts.scad
63# gridbeam.scad
64# hardware.scad
65# libtriangles.scad
66# multiply.scad
67# shapes.scad
68# screw.scad
69
70## LGPLv2:
71# gears.scad
72# involute_gears.scad
73# servos.scad
74# transformations.scad
75# triangles.scad
76# unregular_shapes.scad
77# bitmap/letter_necklace.scad
78
79## LGPLv3+:
80# teardrop.scad
81
82## GPLv3 or LGPLv2:
83# motors.scad
84# nuts_and_bolts.scad
85
86
87## GPLv3+ or LGPLv2:
88# metric_fastners.scad
89# regular_shapes.scad
90
91## CC-BY-SA or LGPLv2+:
92# bearing.scad
93# materials.scad
94# stepper.scad
95# utilities.scad
96
97## CC-BY-SA or LGPLv2:
98# units.scad
99
100## CC-BY:
101# polyholes.scad
102# bitmap/alphabet_block.scad
103# bitmap/bitmap.scad
104# bitmap/height_map.scad
105# bitmap/name_tag.scad
106
107## BSD
108# boxes.scad
109
110## MIT
111# constants.scad
112# curves.scad
113# math.scad
114
115## Public Domain
116# lego_compatibility.scad
117# trochoids.scad
118
119###############################################
a4cd6760
AM
120
121%description
122OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
123free software for creating 3D models (such as the famous application
124Blender) it does not focus on the artistic aspects of 3D modeling but
125instead on the CAD aspects. Thus it might be the application you are
126looking for when you are planning to create 3D models of machine parts
127but pretty sure is not what you are looking for when you are more
128interested in creating computer-animated movies.
129
cd307a29 130%package MCAD
a4cd6760
AM
131Summary: OpenSCAD Parametric CAD Library
132License: LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
133URL: https://www.github.com/openscad/MCAD
134Requires: %{name} = %{version}-%{release}
2d0b2699 135%if "%{_rpmversion}" >= "5"
a4cd6760 136BuildArch: noarch
2d0b2699 137%endif
a4cd6760
AM
138
139%description MCAD
140This library contains components commonly used in designing and
141moching up mechanical designs. It is currently unfinished and you can
142expect some API changes, however many things are already working.
143
a4cd6760 144%prep
9ef24798 145%setup -q
a4cd6760 146%patch0 -p1
35570a78 147%patch1 -p1
a4cd6760 148
2d0b2699 149# use system package
a7d7666a 150%{__rm} -r src/ext/polyclipping
a4cd6760
AM
151
152%build
a7d7666a 153qmake-qt5 \
a4cd6760
AM
154 PREFIX=%{_prefix}
155%{__make}
156
35570a78 157%if %{with tests}
a7d7666a
JR
158mkdir -p tests/build
159cd tests/build
160%cmake ../
a4cd6760 161%{__make}
a7d7666a 162%{__make} -j1 test
35570a78 163%endif
a4cd6760
AM
164
165%install
166rm -rf $RPM_BUILD_ROOT
a7d7666a 167%{__make} install \
a4cd6760
AM
168 INSTALL_ROOT=$RPM_BUILD_ROOT
169
35570a78
JR
170%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
171%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
172%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
173%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
a4cd6760 174
35570a78 175%{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
a4cd6760 176
35570a78 177%find_lang %{name}
a4cd6760 178
2d0b2699
ER
179%clean
180rm -rf $RPM_BUILD_ROOT
181
a4cd6760
AM
182%files -f %{name}.lang
183%defattr(644,root,root,755)
35570a78 184%doc README.md RELEASE_NOTES.md
a4cd6760 185%attr(755,root,root) %{_bindir}/%{name}
35570a78 186%{_datadir}/metainfo/*.xml
a4cd6760
AM
187%{_desktopdir}/%{name}.desktop
188%{_pixmapsdir}/%{name}.png
189%{_datadir}/mime/packages/%{name}.xml
190%dir %{_datadir}/%{name}
191%{_datadir}/%{name}/examples
192%{_datadir}/%{name}/color-schemes
a4cd6760
AM
193%dir %{_datadir}/%{name}/libraries
194%{_mandir}/man1/*
195
196%files MCAD
197%defattr(644,root,root,755)
198%doc libraries/MCAD/README.markdown libraries/MCAD/TODO
199%{_datadir}/%{name}/libraries/MCAD
This page took 0.108601 seconds and 4 git commands to generate.