]> git.pld-linux.org Git - packages/openscad.git/blame - openscad.spec
- BR qscintilla from a non-broken package
[packages/openscad.git] / openscad.spec
CommitLineData
cd307a29
ER
1#
2# Conditional build:
35570a78 3%bcond_without tests # build with tests
cd307a29 4
cd307a29 5Summary: The Programmers Solid 3D CAD Modeller
a4cd6760 6Name: openscad
9ef24798 7Version: 2019.05
3b02408e 8Release: 1
a4cd6760
AM
9# COPYING contains a linking exception for CGAL
10# Appdata file is CC0
11# Examples are CC0
12License: GPLv2 with exceptions and CC0
13Group: Applications/Engineering
9ef24798
JR
14Source0: http://files.openscad.org/%{name}-%{version}.src.tar.gz
15# Source0-md5: 2b63e249d56e2eba62ed5b042e1d82bc
a4cd6760 16Patch0: %{name}-polyclipping.patch
35570a78 17Patch1: localedir.patch
cd307a29 18URL: http://www.openscad.org/
35570a78
JR
19BuildRequires: Qt5Network-devel
20BuildRequires: Qt5Concurrent-devel
21BuildRequires: Qt5Multimedia-devel
22BuildRequires: Qt5DBus-devel
23BuildRequires: Qt5PrintSupport-devel
a4cd6760
AM
24BuildRequires: CGAL-devel >= 3.6
25BuildRequires: ImageMagick
26BuildRequires: Mesa-dri-driver-swrast
27BuildRequires: bison >= 2.4
28BuildRequires: boost-devel >= 1.35
29BuildRequires: desktop-file-utils
30BuildRequires: eigen3
31BuildRequires: flex >= 2.5.35
32BuildRequires: fontconfig-devel >= 2.10
33BuildRequires: freetype-devel >= 2.4
34BuildRequires: gettext
35BuildRequires: glew-devel >= 1.6
36BuildRequires: glib2-devel
37BuildRequires: gmp-devel >= 5.0.0
38BuildRequires: harfbuzz-devel >= 0.9.19
a7d7666a
JR
39BuildRequires: lib3mf-devel >= 1.8.1
40BuildRequires: libzip-devel
41BuildRequires: libxml2-devel
a4cd6760
AM
42BuildRequires: mpfr-devel >= 3.0.0
43BuildRequires: opencsg-devel >= 1.3.2
a7d7666a 44BuildRequires: pkgconfig
a4cd6760
AM
45BuildRequires: polyclipping-devel >= 6.1.3
46BuildRequires: procps
47BuildRequires: python
a4514540 48BuildRequires: qscintilla2-qt5-devel >= 2.11.2
a7d7666a 49BuildRequires: qt5-build
a4cd6760
AM
50BuildRequires: xorg-xserver-Xvfb
51Requires: font(liberationmono)
52Requires: font(liberationsans)
53Requires: font(liberationserif)
cd307a29
ER
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56### LICENSES:
57
58## LGPLv2+:
59# 2Dshapes.scad
60# 3d_triangle.scad
61# fonts.scad
62# gridbeam.scad
63# hardware.scad
64# libtriangles.scad
65# multiply.scad
66# shapes.scad
67# screw.scad
68
69## LGPLv2:
70# gears.scad
71# involute_gears.scad
72# servos.scad
73# transformations.scad
74# triangles.scad
75# unregular_shapes.scad
76# bitmap/letter_necklace.scad
77
78## LGPLv3+:
79# teardrop.scad
80
81## GPLv3 or LGPLv2:
82# motors.scad
83# nuts_and_bolts.scad
84
85
86## GPLv3+ or LGPLv2:
87# metric_fastners.scad
88# regular_shapes.scad
89
90## CC-BY-SA or LGPLv2+:
91# bearing.scad
92# materials.scad
93# stepper.scad
94# utilities.scad
95
96## CC-BY-SA or LGPLv2:
97# units.scad
98
99## CC-BY:
100# polyholes.scad
101# bitmap/alphabet_block.scad
102# bitmap/bitmap.scad
103# bitmap/height_map.scad
104# bitmap/name_tag.scad
105
106## BSD
107# boxes.scad
108
109## MIT
110# constants.scad
111# curves.scad
112# math.scad
113
114## Public Domain
115# lego_compatibility.scad
116# trochoids.scad
117
118###############################################
a4cd6760
AM
119
120%description
121OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
122free software for creating 3D models (such as the famous application
123Blender) it does not focus on the artistic aspects of 3D modeling but
124instead on the CAD aspects. Thus it might be the application you are
125looking for when you are planning to create 3D models of machine parts
126but pretty sure is not what you are looking for when you are more
127interested in creating computer-animated movies.
128
cd307a29 129%package MCAD
a4cd6760
AM
130Summary: OpenSCAD Parametric CAD Library
131License: LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
132URL: https://www.github.com/openscad/MCAD
133Requires: %{name} = %{version}-%{release}
2d0b2699 134%if "%{_rpmversion}" >= "5"
a4cd6760 135BuildArch: noarch
2d0b2699 136%endif
a4cd6760
AM
137
138%description MCAD
139This library contains components commonly used in designing and
140moching up mechanical designs. It is currently unfinished and you can
141expect some API changes, however many things are already working.
142
a4cd6760 143%prep
9ef24798 144%setup -q
a4cd6760 145%patch0 -p1
35570a78 146%patch1 -p1
a4cd6760 147
2d0b2699 148# use system package
a7d7666a 149%{__rm} -r src/ext/polyclipping
a4cd6760
AM
150
151%build
a7d7666a 152qmake-qt5 \
a4cd6760
AM
153 PREFIX=%{_prefix}
154%{__make}
155
35570a78 156%if %{with tests}
a7d7666a
JR
157mkdir -p tests/build
158cd tests/build
159%cmake ../
a4cd6760 160%{__make}
a7d7666a 161%{__make} -j1 test
35570a78 162%endif
a4cd6760
AM
163
164%install
165rm -rf $RPM_BUILD_ROOT
a7d7666a 166%{__make} install \
a4cd6760
AM
167 INSTALL_ROOT=$RPM_BUILD_ROOT
168
35570a78
JR
169%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
170%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
171%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
172%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
a4cd6760 173
35570a78 174%{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
a4cd6760 175
35570a78 176%find_lang %{name}
a4cd6760 177
2d0b2699
ER
178%clean
179rm -rf $RPM_BUILD_ROOT
180
a4cd6760
AM
181%files -f %{name}.lang
182%defattr(644,root,root,755)
35570a78 183%doc README.md RELEASE_NOTES.md
a4cd6760 184%attr(755,root,root) %{_bindir}/%{name}
35570a78 185%{_datadir}/metainfo/*.xml
a4cd6760
AM
186%{_desktopdir}/%{name}.desktop
187%{_pixmapsdir}/%{name}.png
188%{_datadir}/mime/packages/%{name}.xml
189%dir %{_datadir}/%{name}
190%{_datadir}/%{name}/examples
191%{_datadir}/%{name}/color-schemes
a4cd6760
AM
192%dir %{_datadir}/%{name}/libraries
193%{_mandir}/man1/*
194
195%files MCAD
196%defattr(644,root,root,755)
197%doc libraries/MCAD/README.markdown libraries/MCAD/TODO
198%{_datadir}/%{name}/libraries/MCAD
This page took 0.115225 seconds and 4 git commands to generate.