]> git.pld-linux.org Git - packages/openscad.git/blame - openscad.spec
- does not build with qt4, switch to qt5
[packages/openscad.git] / openscad.spec
CommitLineData
cd307a29
ER
1#
2# Conditional build:
35570a78 3%bcond_without tests # build with tests
7c812244 4%bcond_without qt5
9d3a487c
AM
5
6%define qtver %{?with_qt5:5}%{!?with_qt5:4}
cd307a29 7
cd307a29 8Summary: The Programmers Solid 3D CAD Modeller
a4cd6760 9Name: openscad
9ef24798
JR
10Version: 2019.05
11Release: 0.1
a4cd6760
AM
12# COPYING contains a linking exception for CGAL
13# Appdata file is CC0
14# Examples are CC0
15License: GPLv2 with exceptions and CC0
16Group: Applications/Engineering
9ef24798
JR
17Source0: http://files.openscad.org/%{name}-%{version}.src.tar.gz
18# Source0-md5: 2b63e249d56e2eba62ed5b042e1d82bc
a4cd6760 19Patch0: %{name}-polyclipping.patch
35570a78 20Patch1: localedir.patch
cd307a29 21URL: http://www.openscad.org/
35570a78
JR
22%if %{with qt5}
23BuildRequires: Qt5Network-devel
24BuildRequires: Qt5Concurrent-devel
25BuildRequires: Qt5Multimedia-devel
26BuildRequires: Qt5DBus-devel
27BuildRequires: Qt5PrintSupport-devel
28%else
29BuildRequires: QtNetwork-devel
30BuildRequires: QtMultimedia-devel
31BuildRequires: QtDBus-devel
32%endif
a4cd6760
AM
33BuildRequires: CGAL-devel >= 3.6
34BuildRequires: ImageMagick
35BuildRequires: Mesa-dri-driver-swrast
36BuildRequires: bison >= 2.4
37BuildRequires: boost-devel >= 1.35
38BuildRequires: desktop-file-utils
39BuildRequires: eigen3
40BuildRequires: flex >= 2.5.35
41BuildRequires: fontconfig-devel >= 2.10
42BuildRequires: freetype-devel >= 2.4
43BuildRequires: gettext
44BuildRequires: glew-devel >= 1.6
45BuildRequires: glib2-devel
46BuildRequires: gmp-devel >= 5.0.0
47BuildRequires: harfbuzz-devel >= 0.9.19
48BuildRequires: mpfr-devel >= 3.0.0
49BuildRequires: opencsg-devel >= 1.3.2
50BuildRequires: polyclipping-devel >= 6.1.3
51BuildRequires: procps
52BuildRequires: python
9d3a487c
AM
53BuildRequires: qscintilla2-qt%{qtver}-devel
54BuildRequires: qt%{qtver}-build >= 4.4
a4cd6760
AM
55BuildRequires: xorg-xserver-Xvfb
56Requires: font(liberationmono)
57Requires: font(liberationsans)
58Requires: font(liberationserif)
cd307a29
ER
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61### LICENSES:
62
63## LGPLv2+:
64# 2Dshapes.scad
65# 3d_triangle.scad
66# fonts.scad
67# gridbeam.scad
68# hardware.scad
69# libtriangles.scad
70# multiply.scad
71# shapes.scad
72# screw.scad
73
74## LGPLv2:
75# gears.scad
76# involute_gears.scad
77# servos.scad
78# transformations.scad
79# triangles.scad
80# unregular_shapes.scad
81# bitmap/letter_necklace.scad
82
83## LGPLv3+:
84# teardrop.scad
85
86## GPLv3 or LGPLv2:
87# motors.scad
88# nuts_and_bolts.scad
89
90
91## GPLv3+ or LGPLv2:
92# metric_fastners.scad
93# regular_shapes.scad
94
95## CC-BY-SA or LGPLv2+:
96# bearing.scad
97# materials.scad
98# stepper.scad
99# utilities.scad
100
101## CC-BY-SA or LGPLv2:
102# units.scad
103
104## CC-BY:
105# polyholes.scad
106# bitmap/alphabet_block.scad
107# bitmap/bitmap.scad
108# bitmap/height_map.scad
109# bitmap/name_tag.scad
110
111## BSD
112# boxes.scad
113
114## MIT
115# constants.scad
116# curves.scad
117# math.scad
118
119## Public Domain
120# lego_compatibility.scad
121# trochoids.scad
122
123###############################################
a4cd6760
AM
124
125%description
126OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
127free software for creating 3D models (such as the famous application
128Blender) it does not focus on the artistic aspects of 3D modeling but
129instead on the CAD aspects. Thus it might be the application you are
130looking for when you are planning to create 3D models of machine parts
131but pretty sure is not what you are looking for when you are more
132interested in creating computer-animated movies.
133
cd307a29 134%package MCAD
a4cd6760
AM
135Summary: OpenSCAD Parametric CAD Library
136License: LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
137URL: https://www.github.com/openscad/MCAD
138Requires: %{name} = %{version}-%{release}
2d0b2699 139%if "%{_rpmversion}" >= "5"
a4cd6760 140BuildArch: noarch
2d0b2699 141%endif
a4cd6760
AM
142
143%description MCAD
144This library contains components commonly used in designing and
145moching up mechanical designs. It is currently unfinished and you can
146expect some API changes, however many things are already working.
147
a4cd6760 148%prep
9ef24798 149%setup -q
a4cd6760 150%patch0 -p1
35570a78 151%patch1 -p1
a4cd6760 152
2d0b2699 153# use system package
35570a78 154rm -r src/ext/polyclipping
a4cd6760
AM
155
156%build
9d3a487c 157qmake-qt%{qtver} \
a4cd6760
AM
158 PREFIX=%{_prefix}
159%{__make}
160
35570a78 161%if %{with tests}
a4cd6760
AM
162cd tests
163install -d build
164cd build
2d0b2699 165%cmake ..
a4cd6760 166%{__make}
35570a78
JR
167cd ..
168ctest
169%endif
a4cd6760
AM
170
171%install
172rm -rf $RPM_BUILD_ROOT
a4cd6760
AM
173%{__make} -j1 install \
174 INSTALL_ROOT=$RPM_BUILD_ROOT
175
35570a78
JR
176%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
177%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
178%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
179%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
a4cd6760 180
35570a78 181%{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
a4cd6760 182
35570a78 183%find_lang %{name}
a4cd6760 184
2d0b2699
ER
185%clean
186rm -rf $RPM_BUILD_ROOT
187
a4cd6760
AM
188%files -f %{name}.lang
189%defattr(644,root,root,755)
35570a78 190%doc README.md RELEASE_NOTES.md
a4cd6760 191%attr(755,root,root) %{_bindir}/%{name}
35570a78 192%{_datadir}/metainfo/*.xml
a4cd6760
AM
193%{_desktopdir}/%{name}.desktop
194%{_pixmapsdir}/%{name}.png
195%{_datadir}/mime/packages/%{name}.xml
196%dir %{_datadir}/%{name}
197%{_datadir}/%{name}/examples
198%{_datadir}/%{name}/color-schemes
a4cd6760
AM
199%dir %{_datadir}/%{name}/libraries
200%{_mandir}/man1/*
201
202%files MCAD
203%defattr(644,root,root,755)
204%doc libraries/MCAD/README.markdown libraries/MCAD/TODO
205%{_datadir}/%{name}/libraries/MCAD
This page took 0.117115 seconds and 4 git commands to generate.