]> git.pld-linux.org Git - packages/openscad.git/blame - openscad.spec
- leave tests only on x8664, other builders have problems running the suite
[packages/openscad.git] / openscad.spec
CommitLineData
cd307a29
ER
1#
2# Conditional build:
35570a78 3%bcond_without tests # build with tests
cd307a29 4
40cc174f
JR
5%ifnarch %{x8664}
6%undefine with_tests
7%endif
cd307a29 8Summary: The Programmers Solid 3D CAD Modeller
a4cd6760 9Name: openscad
9ef24798 10Version: 2019.05
3b02408e 11Release: 1
a4cd6760
AM
12# COPYING contains a linking exception for CGAL
13# Appdata file is CC0
14# Examples are CC0
15License: GPLv2 with exceptions and CC0
16Group: Applications/Engineering
9ef24798
JR
17Source0: http://files.openscad.org/%{name}-%{version}.src.tar.gz
18# Source0-md5: 2b63e249d56e2eba62ed5b042e1d82bc
a4cd6760 19Patch0: %{name}-polyclipping.patch
35570a78 20Patch1: localedir.patch
cd307a29 21URL: http://www.openscad.org/
35570a78
JR
22BuildRequires: Qt5Network-devel
23BuildRequires: Qt5Concurrent-devel
24BuildRequires: Qt5Multimedia-devel
25BuildRequires: Qt5DBus-devel
26BuildRequires: Qt5PrintSupport-devel
a4cd6760
AM
27BuildRequires: CGAL-devel >= 3.6
28BuildRequires: ImageMagick
29BuildRequires: Mesa-dri-driver-swrast
30BuildRequires: bison >= 2.4
31BuildRequires: boost-devel >= 1.35
32BuildRequires: desktop-file-utils
aff0f9ea 33BuildRequires: double-conversion-devel
a4cd6760
AM
34BuildRequires: eigen3
35BuildRequires: flex >= 2.5.35
36BuildRequires: fontconfig-devel >= 2.10
37BuildRequires: freetype-devel >= 2.4
38BuildRequires: gettext
39BuildRequires: glew-devel >= 1.6
40BuildRequires: glib2-devel
41BuildRequires: gmp-devel >= 5.0.0
42BuildRequires: harfbuzz-devel >= 0.9.19
a7d7666a
JR
43BuildRequires: lib3mf-devel >= 1.8.1
44BuildRequires: libzip-devel
45BuildRequires: libxml2-devel
a4cd6760
AM
46BuildRequires: mpfr-devel >= 3.0.0
47BuildRequires: opencsg-devel >= 1.3.2
a7d7666a 48BuildRequires: pkgconfig
a4cd6760
AM
49BuildRequires: polyclipping-devel >= 6.1.3
50BuildRequires: procps
51BuildRequires: python
a4514540 52BuildRequires: qscintilla2-qt5-devel >= 2.11.2
a7d7666a 53BuildRequires: qt5-build
a4cd6760
AM
54BuildRequires: xorg-xserver-Xvfb
55Requires: font(liberationmono)
56Requires: font(liberationsans)
57Requires: font(liberationserif)
cd307a29
ER
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60### LICENSES:
61
62## LGPLv2+:
63# 2Dshapes.scad
64# 3d_triangle.scad
65# fonts.scad
66# gridbeam.scad
67# hardware.scad
68# libtriangles.scad
69# multiply.scad
70# shapes.scad
71# screw.scad
72
73## LGPLv2:
74# gears.scad
75# involute_gears.scad
76# servos.scad
77# transformations.scad
78# triangles.scad
79# unregular_shapes.scad
80# bitmap/letter_necklace.scad
81
82## LGPLv3+:
83# teardrop.scad
84
85## GPLv3 or LGPLv2:
86# motors.scad
87# nuts_and_bolts.scad
88
89
90## GPLv3+ or LGPLv2:
91# metric_fastners.scad
92# regular_shapes.scad
93
94## CC-BY-SA or LGPLv2+:
95# bearing.scad
96# materials.scad
97# stepper.scad
98# utilities.scad
99
100## CC-BY-SA or LGPLv2:
101# units.scad
102
103## CC-BY:
104# polyholes.scad
105# bitmap/alphabet_block.scad
106# bitmap/bitmap.scad
107# bitmap/height_map.scad
108# bitmap/name_tag.scad
109
110## BSD
111# boxes.scad
112
113## MIT
114# constants.scad
115# curves.scad
116# math.scad
117
118## Public Domain
119# lego_compatibility.scad
120# trochoids.scad
121
122###############################################
a4cd6760
AM
123
124%description
125OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
126free software for creating 3D models (such as the famous application
127Blender) it does not focus on the artistic aspects of 3D modeling but
128instead on the CAD aspects. Thus it might be the application you are
129looking for when you are planning to create 3D models of machine parts
130but pretty sure is not what you are looking for when you are more
131interested in creating computer-animated movies.
132
cd307a29 133%package MCAD
a4cd6760
AM
134Summary: OpenSCAD Parametric CAD Library
135License: LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
136URL: https://www.github.com/openscad/MCAD
137Requires: %{name} = %{version}-%{release}
2d0b2699 138%if "%{_rpmversion}" >= "5"
a4cd6760 139BuildArch: noarch
2d0b2699 140%endif
a4cd6760
AM
141
142%description MCAD
143This library contains components commonly used in designing and
144moching up mechanical designs. It is currently unfinished and you can
145expect some API changes, however many things are already working.
146
a4cd6760 147%prep
9ef24798 148%setup -q
a4cd6760 149%patch0 -p1
35570a78 150%patch1 -p1
a4cd6760 151
2d0b2699 152# use system package
a7d7666a 153%{__rm} -r src/ext/polyclipping
a4cd6760
AM
154
155%build
a7d7666a 156qmake-qt5 \
a4cd6760
AM
157 PREFIX=%{_prefix}
158%{__make}
159
35570a78 160%if %{with tests}
a7d7666a
JR
161mkdir -p tests/build
162cd tests/build
163%cmake ../
a4cd6760 164%{__make}
a7d7666a 165%{__make} -j1 test
35570a78 166%endif
a4cd6760
AM
167
168%install
169rm -rf $RPM_BUILD_ROOT
a7d7666a 170%{__make} install \
a4cd6760
AM
171 INSTALL_ROOT=$RPM_BUILD_ROOT
172
35570a78
JR
173%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
174%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
175%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
176%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
a4cd6760 177
35570a78 178%{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
a4cd6760 179
35570a78 180%find_lang %{name}
a4cd6760 181
2d0b2699
ER
182%clean
183rm -rf $RPM_BUILD_ROOT
184
a4cd6760
AM
185%files -f %{name}.lang
186%defattr(644,root,root,755)
35570a78 187%doc README.md RELEASE_NOTES.md
a4cd6760 188%attr(755,root,root) %{_bindir}/%{name}
35570a78 189%{_datadir}/metainfo/*.xml
a4cd6760
AM
190%{_desktopdir}/%{name}.desktop
191%{_pixmapsdir}/%{name}.png
192%{_datadir}/mime/packages/%{name}.xml
193%dir %{_datadir}/%{name}
194%{_datadir}/%{name}/examples
195%{_datadir}/%{name}/color-schemes
a4cd6760
AM
196%dir %{_datadir}/%{name}/libraries
197%{_mandir}/man1/*
198
199%files MCAD
200%defattr(644,root,root,755)
201%doc libraries/MCAD/README.markdown libraries/MCAD/TODO
202%{_datadir}/%{name}/libraries/MCAD
This page took 0.099268 seconds and 4 git commands to generate.